SUNWgnome-media.spec revision 20897
10139N/A#
10139N/A# spec file for packages SUNWgnome-media
10139N/A#
16171N/A# includes module(s): gst, gst-plugins-base, gst-plugins-good
10139N/A#
10139N/A# Copyright 2009, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner yippi
15322N/A#
10139N/A%include Solaris.inc
16490N/A
10139N/A%ifarch amd64 sparcv9
10139N/A%include arch64.inc
10139N/A%use gst64 = gst.spec
10139N/A%use gst_plugins_base64 = gst-plugins-base.spec
16231N/A%use gst_plugins_good64 = gst-plugins-good.spec
10139N/A%endif
10139N/A
10139N/A%include base.inc
10139N/A%use gst = gst.spec
10139N/A%use gst_plugins_base = gst-plugins-base.spec
10139N/A%use gst_plugins_good = gst-plugins-good.spec
10139N/A
10139N/A%define gst_minmaj %(echo %{gst.version} | cut -f1,2 -d.)
10139N/A
10139N/AName: SUNWgnome-media
10139N/AIPS_package_name: library/audio/gstreamer
10139N/AMeta(info.classification): %{classification_prefix}:System/Multimedia Libraries
10139N/ASummary: GNOME streaming media framework
10139N/AVersion: %{gst.version}
10139N/ASource: %{name}-manpages-0.1.tar.gz
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ALicense: LGPL v2, LGPL v2.1, GPL v2, BSD, MIT, Public Domain
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10139N/A
10139N/ARequires: library/desktop/gobject/gobject-introspection
10139N/ARequires: runtime/perl-512
10139N/ARequires: runtime/python-26
10139N/ARequires: service/gnome/desktop-cache
10139N/ARequires: system/hal
10139N/A
10139N/ABuildRequires: codec/flac
10139N/ABuildRequires: codec/libtheora
10139N/ABuildRequires: codec/ogg-vorbis
10139N/ABuildRequires: codec/speex
10139N/ABuildRequires: developer/parser/bison
10139N/ABuildRequires: gnome/config/gconf
10139N/ABuildRequires: gnome/gnome-audio
10139N/ABuildRequires: image/library/libjpeg
10139N/ABuildRequires: image/library/libpng
10139N/ABuildRequires: library/desktop/libvisual
10139N/ABuildRequires: library/aalib
10139N/ABuildRequires: library/audio/pulseaudio
16172N/ABuildRequires: library/desktop/gtk2
10139N/ABuildRequires: library/desktop/pango
10139N/ABuildRequires: library/gnome/gnome-keyring
10139N/ABuildRequires: library/gnome/gnome-libs
10139N/ABuildRequires: library/gnome/gnome-vfs
10139N/ABuildRequires: library/liboil
10139N/ABuildRequires: library/libsoup
10139N/ABuildRequires: library/libxml2
10139N/ABuildRequires: library/musicbrainz/libdiscid
10139N/ABuildRequires: library/musicbrainz/libmusicbrainz
10139N/ABuildRequires: library/python-2/python-extra-26
10139N/ABuildRequires: library/zlib
15576N/ABuildRequires: media/cdrtools
10139N/ABuildRequires: runtime/perl-512
10139N/ABuildRequires: runtime/python-26
10139N/ABuildRequires: system/header
10139N/ABuildRequires: system/library/math
10139N/ABuildRequires: text/gawk
10139N/ABuildRequires: text/gnu-grep
10139N/ABuildRequires: text/gnu-sed
10139N/ABuildRequires: x11/library/libx11
10139N/ABuildRequires: x11/library/libxext
10139N/ABuildRequires: x11/library/libxv
10139N/ABuildRequires: x11/server/xorg
10139N/A
16039N/A%package root
10139N/ASummary: %{summary} - / filesystem
16039N/ASUNW_BaseDir: /
16039N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10139N/A
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ARequires: %{name}
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A
10139N/A%ifarch amd64 sparcv9
10139N/Amkdir %name-%version/%_arch64
10139N/A%gst64.prep -d %name-%version/%_arch64
10139N/A%gst_plugins_base64.prep -d %name-%version/%_arch64
10139N/A%gst_plugins_good64.prep -d %name-%version/%_arch64
10139N/A%endif
10139N/A
10139N/Amkdir %name-%version/%{base_arch}
10139N/A%gst.prep -d %name-%version/%{base_arch}
10139N/A%gst_plugins_base.prep -d %name-%version/%{base_arch}
10139N/A%gst_plugins_good.prep -d %name-%version/%{base_arch}
10139N/A
10139N/Acd %{_builddir}/%name-%version
10139N/Agzcat %SOURCE0 | tar xf -
10139N/A
16490N/A%build
16490N/A# There seems to be an issue with the version of libtool that GStreamer is
16368N/A# now using. The libtool script uses the echo and RM variables but does not
16368N/A# define them, so setting them here addresses this.
16171N/Aexport echo="/usr/bin/echo"
16368N/Aexport RM="/usr/bin/rm"
16171N/A
16368N/Aexport ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
16368N/A
16039N/A# The taglib gst-plugins-good plugin does not build without setting this since
16039N/A# AC_PROG_PATH does not work with CXX set to the full-path of the C++ compiler.
15754N/A# So, overriding the setting fixes this.
15754N/A#
15576N/Aexport HAVE_CXX=yes
16368N/A
16368N/A%ifarch amd64 sparcv9
16368N/Aexport CXXFLAGS="%cxx_optflags64"
16368N/A
15470N/Aexport CFLAGS="%optflags64 -I/usr/sfw/include -DANSICPP"
15470N/Aexport RPM_OPT_FLAGS="$CFLAGS"
15470N/Aexport PKG_CONFIG_PATH="%{_pkg_config_path64}"
15448N/A
16368N/A%gst64.build -d %name-%version/%_arch64
15428N/A
15428N/Aexport CFLAGS="%optflags64 -I/usr/sfw/include -I/usr/X11/include -DANSICPP"
14484N/Aexport LDFLAGS="%{_ldflags} -lresolv"
14484N/Aexport PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{_arch64}/gstreamer-%{gst.version}/pkgconfig:%{_pkg_config_path64}"
14213N/A
14213N/A%gst_plugins_base64.build -d %name-%version/%_arch64
13780N/A
13780N/Aunset LDFLAGS
13343N/A
13343N/Aexport CFLAGS="%optflags64 -I/usr/sfw/include -DANSICPP"
12875N/Aexport PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{_arch64}/gstreamer-%{gst.version}/pkgconfig:%{_builddir}/%name-%version/%{_arch64}/gst-plugins-base-%{gst_plugins_base.version}/pkgconfig:%{_pkg_config_path64}"
12875N/A
12875N/A# The taglib library is not in Solaris, but the spec-file in SFE does not
12875N/A# provide 64-bit libraries, so avoid building it with 64-bit to avoid build
12875N/A# failing if it is installed.
12584N/A#
12584N/Aexport GST_EXTRA_CONFIG="--disable-taglib"
12153N/A
12153N/A%gst_plugins_good64.build -d %name-%version/%_arch64
12072N/A
12072N/Aexport GST_EXTRA_CONFIG=""
12022N/A%endif
12022N/A
12020N/Aexport CXXFLAGS="%cxx_optflags"
12020N/A
11874N/Aexport CFLAGS="%optflags -I/usr/sfw/include -DANSICPP"
11874N/Aexport RPM_OPT_FLAGS="$CFLAGS"
11874N/Aexport PKG_CONFIG_PATH="%{_pkg_config_path}"
11260N/A
12022N/A%gst.build -d %name-%version/%{base_arch}
11260N/A
10979N/Aexport CFLAGS="%optflags -I/usr/sfw/include -I/usr/X11/include -DANSICPP"
10979N/Aexport LDFLAGS="%_ldflags -lresolv"
10972N/Aexport PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{base_arch}/gstreamer-%{gst.version}/pkgconfig:%{_pkg_config_path}"
10972N/A
10818N/A%gst_plugins_base.build -d %name-%version/%{base_arch}
10818N/A
10698N/Aunset LDFLAGS
10698N/A
10698N/Aexport CFLAGS="%optflags -I/usr/sfw/include -DANSICPP"
10689N/Aexport PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{base_arch}/gstreamer-%{gst.version}/pkgconfig:%{_builddir}/%name-%version/%{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/pkgconfig:%{_pkg_config_path}"
10689N/A
10689N/A%gst_plugins_good.build -d %name-%version/%{base_arch}
10689N/A
10552N/A%install
10552N/A# There seems to be an issue with the version of libtool that GStreamer is
10540N/A# now using. The libtool script uses the echo and RM variables but does not
10540N/A# define them, so setting them here addresses this.
10516N/Aexport echo="/usr/bin/echo"
10516N/Aexport RM="/usr/bin/rm"
10471N/A
10471N/Arm -rf $RPM_BUILD_ROOT
10462N/A
10462N/A%ifarch amd64 sparcv9
10410N/A# Rebuilding the gobject-introspection files requires resetting.
10410N/Aexport PKG_CONFIG_PATH="%{_pkg_config_path64}"
10285N/Aexport CFLAGS="%optflags64 -DANSICPP"
10285N/A
10179N/A%gst64.install -d %name-%version/%_arch64
10179N/A%gst_plugins_base64.install -d %name-%version/%_arch64
10139N/A%gst_plugins_good64.install -d %name-%version/%_arch64
10139N/A
10139N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/gstreamer-%{gst_minmaj}/tools
10139N/Acd $RPM_BUILD_ROOT%{_bindir}/%{_arch64}
10139N/Afor prog in gst-feedback gst-inspect gst-launch gst-typefind \
10139N/A gst-xmlinspect gst-xmllaunch; do
10139N/A mv $prog-%{gst_minmaj} ../../lib/%{_arch64}/gstreamer-%{gst_minmaj}/tools
10139N/A rm -f $prog
10139N/A ln -s ../../lib/%{_arch64}/gstreamer-%{gst_minmaj}/tools/$prog-%{gst_minmaj} $prog
10139N/Adone
10139N/A
10139N/Aperl -pi -e 's,^toolsdir=.*,toolsdir=\${exec_prefix}/%{_arch64}/lib/gstreamer-%{gst_minmaj}/tools,' $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/pkgconfig/gstreamer-%{gst_minmaj}.pc
10139N/A%endif
10139N/A
10139N/Acd %{_builddir}
10139N/A
10139N/A# Rebuilding the gobject-introspection files requires resetting.
10139N/Aexport PKG_CONFIG_PATH="%{_pkg_config_path}"
10139N/Aexport CFLAGS="%optflags -DANSICPP"
16368N/A
10139N/A%gst.install -d %name-%version/%{base_arch}
10139N/A%gst_plugins_base.install -d %name-%version/%{base_arch}
10139N/A%gst_plugins_good.install -d %name-%version/%{base_arch}
10139N/A
10139N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_minmaj}/tools
10139N/Acd $RPM_BUILD_ROOT%{_bindir}
10139N/Afor prog in gst-feedback gst-inspect gst-launch gst-typefind \
10139N/A gst-xmlinspect gst-xmllaunch; do
10139N/A mv $prog-%{gst_minmaj} ../lib/gstreamer-%{gst_minmaj}/tools
10139N/A rm -f $prog
10139N/A ln -s ../lib/gstreamer-%{gst_minmaj}/tools/$prog-%{gst_minmaj} $prog
10139N/Adone
10139N/A
10139N/Aperl -pi -e 's,^toolsdir=.*,toolsdir=\${exec_prefix}/lib/gstreamer-%{gst_minmaj}/tools,' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gstreamer-%{gst_minmaj}.pc
10139N/A
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/Achmod 755 $RPM_BUILD_ROOT%{_mandir}/man1/*.1
10139N/Achmod 755 $RPM_BUILD_ROOT%{_mandir}/man3/*.3
10139N/Achmod 755 $RPM_BUILD_ROOT%{_mandir}/man5/*.5
10139N/A
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/doc
10139N/A
10139N/A# RBAC related
10139N/Amkdir -p $RPM_BUILD_ROOT/etc/security/prof_attr.d
10139N/A
10139N/A# prof_attr(4)
10139N/Acat >> $RPM_BUILD_ROOT/etc/security/prof_attr.d/library-audio-gstreamer <<EOF
10139N/ADesktop Removable Media User:RO::Access removable media for desktop user:
10139N/AConsole User:RO:::profiles=Desktop Removable Media User
10139N/AEOF
10139N/A
10139N/A%if %{!?_without_gtk_doc:0}%{?_without_gtk_doc:1}
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
10139N/A%endif
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
16368N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
16368N/A%restart_fmri gconf-cache
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/gst*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/libgst*.so*
10139N/A%{_libdir}/gstreamer-%{gst_minmaj}/lib*.so*
10139N/A%{_libdir}/gstreamer-%{gst_minmaj}/tools
10139N/A%{_libdir}/gstreamer-%{gst_minmaj}/gst-plugin-scanner
10139N/A%{_libdir}/girepository-1.0/*
10139N/A%ifarch amd64 sparcv9
10139N/A%dir %attr(0755, root, bin) %{_bindir}/%{_arch64}
16368N/A%{_bindir}/%{_arch64}/gst*
10139N/A%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
10139N/A%{_libdir}/%{_arch64}/libgst*.so*
10139N/A%{_libdir}/%{_arch64}/gstreamer-%{gst_minmaj}/lib*.so*
10139N/A%{_libdir}/%{_arch64}/gstreamer-%{gst_minmaj}/tools
10139N/A%{_libdir}/%{_arch64}/gstreamer-%{gst_minmaj}/gst-plugin-scanner
10139N/A%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}/girepository-1.0
10139N/A%{_libdir}/%{_arch64}/girepository-1.0/*
10139N/A%endif
10139N/A%dir %attr (0755, root, sys) %{_datadir}
16368N/A%doc %{base_arch}/gstreamer-%{gst.version}/AUTHORS
10139N/A%doc %{base_arch}/gstreamer-%{gst.version}/README
10139N/A%doc(bzip2) %{base_arch}/gstreamer-%{gst.version}/COPYING
16368N/A%doc(bzip2) %{base_arch}/gstreamer-%{gst.version}/NEWS
10139N/A%doc(bzip2) %{base_arch}/gstreamer-%{gst.version}/ChangeLog
10139N/A%doc(bzip2) %{base_arch}/gstreamer-%{gst.version}/common/ChangeLog
10139N/A%doc %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/AUTHORS
16368N/A%doc %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/README
16368N/A%doc(bzip2) %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/COPYING
10139N/A%doc(bzip2) %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/COPYING.LIB
16368N/A%doc(bzip2) %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/NEWS
10139N/A%doc(bzip2) %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/ChangeLog
10139N/A%doc(bzip2) %{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/common/ChangeLog
10139N/A%doc %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/AUTHORS
10139N/A%doc %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/README
10139N/A%doc(bzip2) %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/COPYING
16368N/A%doc(bzip2) %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/NEWS
16368N/A%doc(bzip2) %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/ChangeLog
10139N/A%doc(bzip2) %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/common/ChangeLog
10139N/A%doc(bzip2) %{base_arch}/gst-plugins-good-%{gst_plugins_good.version}/docs/random/ChangeLog-0.8
16368N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A%{_datadir}/gir-1.0/*.gir
10139N/A%dir %attr (0755, root, other) %{_datadir}/gstreamer-0.10
16368N/A%{_datadir}/gstreamer-0.10/*
10139N/A%dir %attr (0755, root, other)
10139N/A%dir %attr(0755, root, bin) %{_mandir}
16368N/A%dir %attr(0755, root, bin) %{_mandir}/man1
10139N/A%dir %attr(0755, root, bin) %{_mandir}/man5
16368N/A%{_mandir}/man1/gst*
10139N/A%{_mandir}/man5/*
16368N/A
10139N/A%files root
16368N/A%defattr (-, root, sys)
10139N/A%attr (0755, root, sys) %dir %{_sysconfdir}
16368N/A%{_sysconfdir}/gconf/schemas/gstreamer-%{gst_minmaj}.schemas
16368N/A%attr (0755, root, sys) %dir /etc/security
10139N/A%attr (0755, root, sys) %dir /etc/security/prof_attr.d
16368N/A%ips_tag(restart_fmri=svc:/system/rbac:default) %attr (0444, root, sys) /etc/security/prof_attr.d/*
10139N/A
10139N/A%files devel
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
16368N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
16368N/A%ifarch amd64 sparcv9
10139N/A%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
10139N/A%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
10139N/A%{_libdir}/%{_arch64}/pkgconfig/*
10139N/A%endif
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/gstreamer-%{gst_minmaj}/gst
16368N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/aclocal
10139N/A%{_datadir}/aclocal/*
10139N/A%if %{!?_without_gtk_doc:1}%{?_without_gtk_doc:0}
10139N/A%{_datadir}/gtk-doc
10139N/A%endif
16368N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/man3
16368N/A%{_mandir}/man3/*
16368N/A
10139N/A%files l10n
16368N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
16368N/A%attr (-, root, other) %{_datadir}/locale
10139N/A
16368N/A%changelog
10139N/A* Fri Feb 17 2012 - brian.cameron@oracle.com
16368N/A- Now build with vfs and soup 64-bit plug-ins.
16368N/A* Wed Apr 06 2011 - brian.cameron@oracle.com
10139N/A- Add "RO" to prof_attr config.
10139N/A* Thu Apr 15 2010 - christian.kelly@oracle.com
10139N/A- Re-enable dependency on liboil.
10139N/A* Thu Feb 11 2010 - brian.cameron@sun.com
16368N/A- Fix packaging after bumping GStreamer to 0.10.26.
10139N/A* Fri Jan 15 2009 - lin.ma@sun.com
16368N/A- Move the definition of 'Desktop Removable Media User' from
SUNWgnome-cd-burner to here - doo 13911.
* Mon May 18 2009 - dave.lin@sun.com
- Comment out the line 'Requires: SUNWmkcd' until we work out the bug CR6840919.
* Fri Apr 3 2009 - laca@sun.com
- use desktop-cache instead of postrun
* Fri Feb 20 2009 - brian.cameron@sun.com
- Update packaging as needed for gst-plugins-good 0.10.14.
* Fri Sep 12 2008 - brian.cameron@sun.com
- Add new copyright files.
* Wed Jun 18 2008 - damien.carbery@sun.com
- Add Build/Requires SUNWlibsoup/-devel after check-deps.pl run.
* Wed May 07 2008 - damien.carbery@sun.com
- Remove PERL5LIB setting as it is not necessary.
* Tue Apr 01 2008 - brian.cameron@sun.com
- Add SUNW_Copyright.
* Thu Jan 3 2008 - laca@sun.com
- use gconf-install.script instead of an inline script
* Fri Sep 28 2007 - laca@sun.com
- delete SUNWxwrtl dep
* Thu Aug 02 2007 - damien.carbery@sun.com
- Add -lresolv to LDFLAGS for gst-plugins-base for hstrerror function.
* Thu Aug 02 2007 - damien.carbery@sun.com
- Delete gtk-doc files in %install when built using --without-gtk-doc. The root
cause is in the gst/gst-plugins modules but this fix works for now.
* Tue Jun 26 2007 - irene.huang@sun.com
- remove libcdio as dependency
* Fri Oct 20 2006 - damien.carbery@sun.com
- Remove SUNWhalh BuildRequires because header files are in SUNWhea in snv_51.
* Mon Sep 18 2006 - Brian.Cameron@sun.com
- Add SUNWhalh BuildRequires.
* Mon Sep 04 2006 - Matt.Keenan@sun.com
- New Manpage tarball
* Thu Aug 24 2006 - brian.cameron@sun.com
- Remove pointless libgstgetbits.3, libgstdataprotocol.3 manpage and move
libgstreamer-0.8.3 manpage to libgstreamer-0.10.3.
* Tue Aug 22 2006 - brian.cameron@sun.com
- Remove gst-md5sum man page since this is no longer a part of GStreamer.
* Mon Aug 14 2006 - damien.carbery@sun.com
- Add Build/Requires SUNWhal after check-deps.pl run.
* Fri Jul 14 2006 - laca@sun.com
- update %post/%postun/etc scripts to support diskless client setup,
part of 6448317
* Thu Jun 29 2006 - laca@sun.com
- update postrun scripts
* Fri Jun 23 2006 - christopher.hanna@sun.com
- Removed all of the 0.8 version manpages and the following
manpages which are no longer needed:
gst-complete, gst-compprep, gst-launch-ext, gst-register
* Wed Jun 14 2006 - brian.cameron@sun.com
- Changes from bumping to new versions of modules.
* Sun Jun 11 2006 - laca@sun.com
- change group from other to bin/sys
* Thu Jun 1 2006 - laca@sun.com
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - laca@sun.com
- merge -share pkg(s) into the base pkg(s)
- add the versioned binaries back in %{_libdir}/gstreamer-0.10/tools
otherwise gnome-media (SUNWgnome-media-apps) fails
* Tue Mar 28 2006 - brian.cameron@sun.com
- Added libcdio dependency.
* Mon Feb 20 2006 - damien.carbery@sun.com
- Complete update of Build/Requires after running check-deps.pl script.
* Fri Feb 17 2006 - damien.carbery@sun.com
- Update Build/Requires after running check-deps.pl script.
* Tue Jan 24 2006 - damien.carbery@sun.com
- Add Build/Requires SUNWliboil/-devel as required by liboil.
* Fri Jan 19 2006 - brian.cameron@sun.com
- Bump to GStreamer 0.10.
* Tue Nov 29 2005 - laca@sun.com
- remove javahelp stuff
* Mon Nov 07 2005 - brian.cameron@sun.com
- Fix spec file so it builds xvimagesink. This requires adding
/usr/X11/lib to LDFLAGS and /usr/X11/include to CFLAGS when building
gst-plugins. xvimagesink is faster than ximagesink since it uses
the XVideo Xserver extension, so its nice to have. This only works
when using the Xorg Xserver, so users who are using Xsun will need
to continue using the ximagesink plugin for video output.
* Tue Sep 27 2005 - laca@sun.com
- add python build dep for gstreamer-plugins gtk docs (mangle-tmpl.py)
* Mon Sep 12 2005 - laca@sun.com
- remove unpackaged files
* Fri Aug 12 2005 - balamurali.viswanathan@wipro.com
- Add dependency of SUNWflac
* Tue Jul 26 2005 - balamurali.viswanathan@wipro.com
- Add dependency of SUNWspeex and SUNWlibtheora
* Mon Jul 11 2005 - balamurali.viswanathan@wipro.com
- Add BuildRequires: SUNWmusicbrainz
* Wed Jun 01 2005 - brian.cameron@sun.com
- remove nautilus-media since it no longer works with nautilus. Nautilus
no longer supports extensions like nautilus-media. Remove gnome-media
since it needs to be split into a separate package. This is because
gnome-panel requires gstreamer and gnome-media requires gnome-panel.
* Tue Feb 22 2005 - brian.cameron@sun.com
- moved l10n package to last built since it tends to fail on re-install.
* Fri Jan 28 2005 - matt.keenan@sun.com
- #6222302 : Remove gstreamer properties from yelp TOC
* Tue Nov 23 2004 - damien.carbery@sun.com
- Fix 6197917: Restore files 'lost' when SUNWgnome-media packages reorganised
to restore 'lost' Gnome 2.0 packages. Reviewed by Laca.
* Fri Nov 12 2004 - laca@sun.com
- Use the original GNOME 2.0 packaging structure: add SUNWgnome-cd*
SUNWgnome-freedb-libs* and SUNWgnome-sound-recorder*
* Thu Oct 21 2004 - laca@sun.com
- change registry.xml to volatile, fixes 6180895
* Thu Oct 14 2004 - brian.cameron@sun.com
- Added gst-launch-ext* man pages.
* Wed Oct 06 2004 - vinay.mandyakoppal@wipro.com
- Added code to install javahelp documents.
Fixes  bugs #5096655,5096658.
* Mon Oct 04 2004 - matt.keenan@sun.com
- Added javahelp files for share package #5108690
* Sat Oct 02 2004 - laca@sun.com
- added %pkgbuild_postprocess
* Mon Sep 27 2004 - arvind.samptur@wipro.com
- Get GNOME_Media_CDDBSlave2.server to be installed
* Fri Sep 24 2004 - brian.cameron
- Added %post section so that programs that use GStreamer will work
properly. The timestamp of the registry file must be later than
the libraries for programs to work.
* Thu Sep 09 2004 - matt.keenan@sun.com
- Added a heap of manpages
* Thu Aug 26 2004 - Brian.Cameron@sun.com
- Now package gtk-docs.
* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
- Added l10n javahelp entry in l10n pkg files
* Tue Aug 24 2004 - laca@sun.com
- move l10n files to the l10n package
* Fri Aug 20 2004 brian.cameron@sun.com
- No longer package Nautilus_View server files since they aren't being
installed by the nautilus-media.spec file.
* Mon Aug 16 2004 shirley.woo@sun.com
- change .../sman1/*.1 permissions to 0755 for Solaris integration error
* Thu Jul 29 2004 brian.cameron@sun.com
- Fixed setting of PKG_CONFIG_PATH and CPPFLAGS so that they work when
gstreamer and gst-plugins have different version #'s.
* Sat Jun 26 2004 shirley.woo@sun.com
- Changed install location to /usr/...
* Mon Jun 07 2004 - brian.cameron@sun.com
- Added ogg/vorbis dependancy. Now including registry.xml.
* Wed Jun 02 2004 - brian.cameron@sun.com
- Removed SUNWgnome-pilot-link dependancy which was wrong.
* Wed Jun 2 2004 - takao.fujiwara@sun.com
- Added %{_datadir}/locale to install l10n messages
* Wed May 26 2004 - brian.cameron@sun.com
- Fixed CFLAGS so that Kpic flag gets properly recognized, allowing
gstreamer to actually work in addition to just compiling.
* Tue May 25 2004 - brian.cameron@sun.com
- Updated dependencies to include SUNWgnome-file-mgr.
* Wed May 12 2004 - brian.cameron@sun.com
- Add nautilus-media. Made changes so that this works with
gstreamer and gst-plugins 0.8.1.
* Sun Mar 28 2004 - brian.cameron@sun.com
- Corrected PKG_CONFIG_PATH so it will find gst-plugins properly.
* Fri Mar 26 2004 - laca@sun.com
- buildrequires CBEbison instead of SUNWbison
* Wed Mar 24 2004 - brian.cameron@sun.com
- Added SGML man page integration
* Thu Feb 26 2004 - niall.power@sun.com
- Initial spec-file created