#
# spec file for packages SUNWgnome-media
#
# includes module(s): gst, gst-plugins-base, gst-plugins-good
#
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
#
Version: %{gst.version}
SUNW_BaseDir: %{_basedir}
# GStreamer has some configure tests that are hardcoded to use the gcc
# compiler, so the build will fail if it is not present.
SUNW_BaseDir: /
SUNW_BaseDir: %{_basedir}
%prep
# Set default sinks and source plugins to use.
export GST_DEFAULTS_EXTRA_CONFIG="\
--with-default-audiosrc=autoaudiosrc \
--with-default-audiosink=autoaudiosink \
--with-default-videosink=autovideosink"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
# The taglib gst-plugins-good plugin does not build without setting this since
# AC_PROG_PATH does not work with CXX set to the full-path of the C++ compiler.
# So, overriding the setting fixes this.
#
export CXXFLAGS="%cxx_optflags64"
export RPM_OPT_FLAGS="$CFLAGS"
export PKG_CONFIG_PATH="%{_pkg_config_path64}"
export LDFLAGS="%{_ldflags} -lresolv"
export PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{_arch64}/gstreamer-%{gst.version}/pkgconfig:%{_pkg_config_path64}"
unset LDFLAGS
export PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{_arch64}/gstreamer-%{gst.version}/pkgconfig:%{_builddir}/%name-%version/%{_arch64}/gst-plugins-base-%{gst_plugins_base.version}/pkgconfig:%{_pkg_config_path64}"
# The taglib library is not in Solaris, but the spec-file in SFE does not
# provide 64-bit libraries, so avoid building it with 64-bit to avoid build
# failing if it is installed.
#
export GST_EXTRA_CONFIG="$GST_DEFAULTS_EXTRA_CONFIG --disable-taglib"
export CXXFLAGS="%cxx_optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export PKG_CONFIG_PATH="%{_pkg_config_path}"
export LDFLAGS="%_ldflags -lresolv"
export PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{base_arch}/gstreamer-%{gst.version}/pkgconfig:%{_pkg_config_path}"
unset LDFLAGS
export PKG_CONFIG_PATH="%{_builddir}/%name-%version/%{base_arch}/gstreamer-%{gst.version}/pkgconfig:%{_builddir}/%name-%version/%{base_arch}/gst-plugins-base-%{gst_plugins_base.version}/pkgconfig:%{_pkg_config_path}"
# Rebuilding the gobject-introspection files requires resetting.
export PKG_CONFIG_PATH="%{_pkg_config_path64}"
export CFLAGS="%optflags64 -DANSICPP"
done
perl -pi -e 's,^toolsdir=.*,toolsdir=\${exec_prefix}/%{_arch64}/lib/gstreamer-%{gst_minmaj}/tools,' $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/pkgconfig/gstreamer-%{gst_minmaj}.pc
cd %{_builddir}
# Rebuilding the gobject-introspection files requires resetting.
export PKG_CONFIG_PATH="%{_pkg_config_path}"
export CFLAGS="%optflags -DANSICPP"
cd $RPM_BUILD_ROOT%{_bindir}
done
perl -pi -e 's,^toolsdir=.*,toolsdir=\${exec_prefix}/lib/gstreamer-%{gst_minmaj}/tools,' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gstreamer-%{gst_minmaj}.pc
# RBAC related
# prof_attr(4)
Desktop Removable Media User:RO::Access removable media for desktop user:
Console User:RO:::profiles=Desktop Removable Media User
EOF
%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
%post
- #6222302 : Remove gstreamer properties from yelp TOC
installed by the nautilus-media.spec file.
* Mon Aug 16 2004 shirley.woo@sun.com
- change .../sman1/*.1 permissions to 0755 for Solaris integration error
* Thu Jul 29 2004 brian.cameron@sun.com
- Fixed setting of PKG_CONFIG_PATH and CPPFLAGS so that they work when
gstreamer and gst-plugins have different version #'s.