#
# spec file for package SUNWgnome-calculator
#
# includes module(s): gcalctool
#
# Copyright 2010 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner laca
#
%include Solaris.inc
%use gcalctool = gcalctool.spec
Name: SUNWgnome-calculator
IPS_package_name: desktop/calculator/gcalctool
Meta(info.classification): %{classification_prefix}:Applications/Accessories
Summary: GNOME calculator utility
Version: %{gcalctool.version}
Source: %{name}-manpages-0.1.tar.gz
SUNW_BaseDir: %{_basedir}
SUNW_Copyright: %{name}.copyright
License: %{gcalctool.license}
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
%include desktop-incorporation.inc
Requires: SUNWlibglade
Requires: SUNWgnome-calculator-root
Requires: SUNWgnome-libs
Requires: SUNWgnome-config
Requires: SUNWlibms
BuildRequires: SUNWlibglade-devel
BuildRequires: SUNWgnome-config-devel
Requires: SUNWdesktop-cache
BuildRequires: SUNWgnome-doc-utils
%package l10n
Summary: %{summary} - l10n files
Requires: %{name}
%package root
Summary: %{summary} - / filesystem
SUNW_BaseDir: /
%include default-depend.inc
%include desktop-incorporation.inc
%prep
rm -rf %name-%version
mkdir %name-%version
%gcalctool.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -
%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"
%gcalctool.build -d %name-%version
%install
rm -rf $RPM_BUILD_ROOT
%gcalctool.install -d %name-%version
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_datadir}/gnome/help/*/.help.copyright
rmdir $RPM_BUILD_ROOT%{_datadir}/gnome/help/[a-z][a-z]
rmdir $RPM_BUILD_ROOT%{_datadir}/gnome/help/[a-z][a-z]_*
%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
%clean
rm -rf $RPM_BUILD_ROOT
%post
%restart_fmri desktop-mime-cache gconf-cache
%postun
%restart_fmri desktop-mime-cache
%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%{_datadir}/gcalctool
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/*/C
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/gnome
%attr (-, root, other) %{_datadir}/locale
%{_datadir}/gnome/help/*/[a-z]*
%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/gcalctool.schemas
%changelog
* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
- Updated BuildRequires to fit SourceJuicer.
* Fri Apr 3 2009 - laca@sun.com
- use desktop-cache instead of postrun
* Thu Jan 3 2008 - laca@sun.com
- use gconf-install.script instead of an inline script
* Wed Oct 31 2007 - damien.carbery@sun.com
- Add %{_datadir}/gcalctool to %files.
* Fri Sep 21 2007 - brian.cameron@sunc.om
- Re-add the desktop file back into the packaging. It wasn't getting
built before because we weren't calling the proper autotools.
* Thu Aug 16 2007 - damien.carbery@sun.com
- Remove %files line because dir not installed.
* Tue Apr 24 2007 - laca@sun.com
- s/0755/-/ in defattr so that files are not made all executable
* Fri Sep 01 2006 - Matt.Keenan@sun.com
- New Manpage tarball
* Sat Aug 12 2006 - laca@sun.com
- delete some unnecessary env variables
* Fri Jul 14 2006 - laca@sun.com
- update %post/%postun/etc scripts to support diskless client setup,
part of 6448317
* Thu Jun 29 2006 - laca@sun.com
- update postrun scripts
* Sun Jun 11 2006 - laca@sun.com
- change group from other to bin/sys
* Thu May 25 2006 - laca@sun.com
- use post/preun scripts to install schemas into the merged gconf files
* Tue May 09 2006 - laca@sun.com
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - damien.carbery@sun.com
- Update Build/Requires after running check-deps.pl script.
* Sat Dec 3 2005 - laca@sun.com
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - laca@sun.com
- remove javahelp stuff
* Fri Oct 28 2005 - damien.carbery@sun.com
- Remove more l10n files for non-l10n build.
* Tue May 25 2005 - brian.cameron@sun.com
- Bump to 2.10.0, fix packaging.
* Sat Oct 02 2004 - laca@sun.com
- added %pkgbuild_postprocess
* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
- Updated files sect to extracted l10n help into l10n pkg
- s/SUNWpl5u/SUNWperl584usr/
* Mon Aug 23 2004 - laca@sun.com
- s/SUNWpl5u/SUNWperl584usr/
* Wed Aug 18 2004 damien.carbery@sun.com
- Change manpage perms for Solaris integration.
* Sat Jun 26 2004 shirley.woo@sun.com
- Changed install location to /usr/...
* Wed Jun 2 2004 - takao.fujiwara@sun.com
- Added %{_datadir}/locale to install l10n messages
* Thu May 06 2004 - brian.cameron@sun.com
- Removed %{_sysconfdir}/gconf from share package since
it is already included in root.
* Wed Mar 24 2004 - brian.cameron@sun.com
- Added SGML man page integration
* Mon Mar 01 2004 - laca@sun.com
- define PERL5LIB
* Mon Feb 23 2004 - niall.power@sun.com
- add a *-root package and install schemas
- fix up dependencies