rules revision b32ffdb7bf463438d3ca07e4089957284c9908c7
99N/A# Copyright (C) 2006-2008 Sun Microsystems, Inc. 99N/A# This file is part of VirtualBox Open Source Edition (OSE), as 99N/A# you can redistribute it and/or modify it under the terms of the GNU 99N/A# General Public License as published by the Free Software Foundation, 99N/A# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE 99N/A# distribution. VirtualBox OSE is distributed in the hope that it will 99N/A# be useful, but WITHOUT ANY WARRANTY of any kind. 99N/A#export DH_VERBOSE=1 99N/A# possible overrides: 99N/A# OSE=1 force VBOX_OSE 99N/A# NOPARALLEL=1 compile with -j1 99N/A# LINUX=<dir> compile vboxdrv against Linux found in <dir> 99N/A# DEBUG=1 debug build 3746N/A# NOSUBVER=1 disable generation of the sub-version field (which is 3746N/A# either the subversion rev [if available] or the build date) 99N/A# NOMODS=1 don't build any module 99N/A# NOQT=1 don't build the Qt GUI 99N/A# HEADLESS=1 build the headless version 99N/A# STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso 3353N/A# Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead 3353N/A# Ubuntu gutsy: gcc-4.1 does not work for the webservices, use gcc-4.2 instead # Build modules for every kernel we find in /lib/modules/* # Build architecture-dependent files here. -e
's|%VERPKG%|$(verpkg)|g' \
-e
's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g' \
-e
's|%PACKAGE%|virtualbox|g' \
if [
"$(debrel)" =
"_Ubuntu_dapper" -o
"$(debrel)" =
"_Debian_sarge" ];
then \
# manually strip our R0/GC modules, dh_strip cannot handle them