rules revision 80b853528b74d686eebf9331ee762891d0038f06
#
# Copyright (C) 2006-2008 Sun Microsystems, Inc.
#
# This file is part of VirtualBox Open Source Edition (OSE), as
# available from http://www.virtualbox.org. This file is free software;
# General Public License as published by the Free Software Foundation,
# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
# distribution. VirtualBox OSE is distributed in the hope that it will
# be useful, but WITHOUT ANY WARRANTY of any kind.
#
#export DH_VERBOSE=1
export DH_COMPAT=4
# possible overrides:
# OSE=1 force VBOX_OSE
# NOPARALLEL=1 compile with -j1
# LINUX=<dir> compile vboxdrv against Linux found in <dir>
# VERBOSE=1 verbose build
# DEBUG=1 debug build
# NOSUBVER=1 disable generation of the sub-version field (which is
# either the subversion rev [if available] or the build date)
# NODOCS=1 don't build docs, use precompiled UserManual.pdf and
# VirtualBox.chm from $HOME
# NOMODS=1 don't build any module
# NOQT=1 don't build the Qt GUI
# HEADLESS=1 build the headless version
# STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso
arch := $(shell dpkg --print-architecture)
ose := 1
ver := $(VBOX_VERSION_STRING)
else
else
debrel := $(if $(shell which lsb_release),_$(shell lsb_release -si)_$(shell lsb_release -sc),unknown)
# Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead
# Ubuntu gutsy: gcc-4.1 does not work for the webservices, use gcc-4.2 instead
$(debcfgs) \
$(debcfgs) \
fi; \
done
else
# Build architecture-dependent files here.
dh_clean -k
sed \
-e 's|%VERPKG%|$(verpkg)|g' \
if [ -f $(archdir)/vboxwebsrv ]; then \
fi
fi
install -D -g 0 -o 0 -m 0644 \
install -D -g 0 -o 0 -m 0644 \
done)
else
dh_link \
sed \
-e 's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g' \
-e 's|%PACKAGE%|virtualbox|g' \
dh_strip --keep-debug --exclude=libVBoxQtCore.so.4 --exclude=libVBoxQtGui.so.4 --exclude=libVBoxQtNetwork.so.4 --exclude=libqtaccessiblewidgets.so
for f in \
$$f \
done
dh_gencontrol -- \