rules revision 37a84692e27b34ed2141b208bf3ab7f9f90bb422
#
# Copyright (C) 2006-2008 Sun Microsystems, Inc.
#
# This file is part of VirtualBox Open Source Edition (OSE), as
# available from http://www.virtualbox.org. This file is free software;
# General Public License as published by the Free Software Foundation,
# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
# distribution. VirtualBox OSE is distributed in the hope that it will
# be useful, but WITHOUT ANY WARRANTY of any kind.
#
#export DH_VERBOSE=1
export DH_COMPAT=4
# possible overrides:
# OSE=1 force VBOX_OSE
# NOPARALLEL=1 compile with -j1 (-j2 is default)
# LINUX=<dir> compile vboxdrv against Linux found in <dir>
# VERBOSE=1 verbose build
# DEBUG=1 debug build
# NOSUBVER=1 disable generation of the sub-version field (which is
# either the subversion rev [if available] or the build date)
# NODOCS=1 don't build docs, use precompiled UserManual.pdf and
# VirtualBox.chm from $HOME
# NOMODS=1 don't build any module
# HEADLESS=1 build the headless version
# STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso
arch := $(shell dpkg --print-architecture)
ose := 1
ver := $(VBOX_VERSION_STRING)
else
else
# Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead
$(shell test $(gccvmaj) -eq 4 -a $(gccvmin) -gt 2 -o $(gccvmaj) -gt 4 && echo "yes"),--with-gcc=gcc-4.2 --with-g++=g++-4.2,) $(if \
$(debdocs) \
$(debdocs) \
fi; \
done
else
# Build architecture-dependent files here.
dh_clean -k
VBoxHeadless; do \
install -D -g 0 -o 0 -m 0644 \
else
dh_link \
sed -e 's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g; s|%PACKAGE%|virtualbox-ose|g;' \
sed -e 's|%NOLSB%|$(if $(filter _Debian_sarge,$(debrel)),yes,)|g;' \
for f in \
$$f \
done
dh_gencontrol -- \