rules revision 27efd9329f6a90f7cacf840031e5305f98975960
# Copyright (C) 2006-2008 Sun Microsystems, Inc. # This file is part of VirtualBox Open Source Edition (OSE), as # you can redistribute it and/or modify it under the terms of the GNU # General Public License as published by the Free Software Foundation, # in version 2 as it comes in the "COPYING" file of the VirtualBox OSE # distribution. VirtualBox OSE is distributed in the hope that it will # be useful, but WITHOUT ANY WARRANTY of any kind. # NOPARALLEL=1 compile with -j1 (-j2 is default) # LINUX=<dir> compile vboxdrv against Linux found in <dir> # VERBOSE=1 verbose build # NOSUBVER=1 disable generation of the sub-version field (which is # either the subversion rev [if available] or the build date) # NOMODS=1 don't build any module # HEADLESS=1 build the headless version # STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso # Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead # Build modules for every kernel we find in /lib/modules/* # Build architecture-dependent files here. sed -e
's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g; s|%PACKAGE%|virtualbox-ose|g;' \
sed -e
's|%NOLSB%|$(if $(filter _Debian_sarge,$(debrel)),yes,)|g;' \
if [
"$(debrel)" =
"_Ubuntu_dapper" -o
"$(debrel)" =
"_Debian_sarge" ];
then \
# manually strip our R0/GC modules, dh_strip cannot handle them