rules revision 1c2c968fd241148110002d75b2c0fdeddc211e14
0N/A# Copyright (C) 2006-2008 Sun Microsystems, Inc. 0N/A# This file is part of VirtualBox Open Source Edition (OSE), as 0N/A# you can redistribute it and/or modify it under the terms of the GNU 0N/A# General Public License as published by the Free Software Foundation, 0N/A# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE 0N/A# distribution. VirtualBox OSE is distributed in the hope that it will 0N/A# be useful, but WITHOUT ANY WARRANTY of any kind. 0N/A# possible overrides: 0N/A# OSE=1 force VBOX_OSE 0N/A# NOPARALLEL=1 compile with -j1 (-j2 is default) 0N/A# LINUX=<dir> compile vboxdrv against Linux found in <dir> 0N/A# VERBOSE=1 verbose build 0N/A# DEBUG=1 debug build 0N/A# NOSUBVER=1 disable generation of the sub-version field (which is 0N/A# either the subversion rev [if available] or the build date) # NOMODS=1 don't build any module # HEADLESS=1 build the headless version # STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso # Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead # Build modules for every kernel we find in /lib/modules/* # Build architecture-dependent files here. sed -e
's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g; s|%PACKAGE%|virtualbox-ose|g;' \
sed -e
's|%NOLSB%|$(if $(filter _Debian_sarge,$(debrel)),yes,)|g;' \
if [
"$(debrel)" =
"_Ubuntu_dapper" -o
"$(debrel)" =
"_Debian_sarge" ];
then \
# manually strip our R0/GC modules, dh_strip cannot handle them