rules revision 0b1397fff8b368cf5c2f3d8f5b312ed00114977d
#export DH_VERBOSE=1
export DH_COMPAT=4
# possible overrides:
# OSE=1 force VBOX_OSE
# NOPARALLEL=1 compile with -j1 (-j2 is default)
# LINUX=<dir> compile vboxdrv against Linux found in <dir>
# VERBOSE=1 verbose build
# DEBUG=1 debug build
# NOSUBVER=1 disable generation of the sub-version field (which is
# either the subversion rev [if available] or the build date)
# NODOCS=1 don't build docs, use precompiled UserManual.pdf and
# VirtualBox.chm from $HOME
# NOMODS=1 don't build any module
# HEADLESS=1 build the headless version
# STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso
arch := $(shell dpkg --print-architecture)
ver := $(VBOX_VERSION_STRING)
else
else
# Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead
done
else
# Build architecture-dependent files here.
dh_clean -k
install -D -g 0 -o 0 -m 0644 \
else
dh_link \
sed -e 's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g;' \
sed -e 's|%NOLSB%|$(if $(filter _Debian_sarge,$(debrel)),yes,)|g;' \