rules revision 61ad2dd000a26df2101176cc74bd531bb18020de
#
# Copyright (C) 2006-2009 Sun Microsystems, Inc.
#
# This file is part of VirtualBox Open Source Edition (OSE), as
# available from http://www.virtualbox.org. This file is free software;
# General Public License as published by the Free Software Foundation,
# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
# distribution. VirtualBox OSE is distributed in the hope that it will
# be useful, but WITHOUT ANY WARRANTY of any kind.
#
#export DH_VERBOSE=1
export DH_COMPAT=4
# possible overrides:
# OSE=1 force VBOX_OSE
# NOPARALLEL=1 compile with -j1
# LINUX=<dir> compile vboxdrv against Linux found in <dir>
# VERBOSE=1 verbose build
# DEBUG=1 debug build
# NOSUBVER=1 disable generation of the sub-version field (which is
# either the subversion rev [if available] or the build date)
# NODOCS=1 don't build docs, use precompiled UserManual.pdf and
# VirtualBox.chm from $HOME
# NOMODS=1 don't build any module
# NOQT=1 don't build the Qt GUI
# HEADLESS=1 build the headless version
# NOWEBSVC=1 don't build the webservice API, default for OSE
# STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso
pkgdir := ..
arch := $(shell dpkg --print-architecture)
ose := 1
ver := $(VBOX_VERSION_STRING)
else
else
debrel := $(if $(shell which lsb_release),_$(shell lsb_release -si)_$(shell lsb_release -sc),unknown)
# Locations of custom built Qt libraries (see below)
# Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead
# Ubuntu gutsy: gcc-4.1 does not work for the webservices, use gcc-4.2 instead
$(filter _Debian_etch _Ubuntu_dapper _Ubuntu_edgy _Ubuntu_feisty,$(debrel)),--with-qt4-dir=$(qtstdc6)) $(if \
$(filter _Debian_sarge _Ubuntu_dapper _Ubuntu_edgy _xandros4.1 _ucs1.3,$(debrel)),--disable-pulse,) $(if \
$(debcfgs) \
$(debcfgs) \
fi; \
done
else
# Build architecture-dependent files here.
dh_clean -k
sed \
-e 's|%VERPKG%|$(verpkg)|g' \
install -D -g 0 -o 0 -m 0644 \
install -D -g 0 -o 0 -m 0644 \
install -D -g 0 -o 0 -m 0644 \
done)
else
dh_link \
sed \
-e 's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g' \
-e 's|%PACKAGE%|virtualbox|g' \
dh_strip --keep-debug --exclude=libQtCoreVBox.so.4 --exclude=libQtGuiVBox.so.4 --exclude=libQtNetworkVBox.so.4 --exclude=libqtaccessiblewidgets.so
for f in \
$$f \
done
dh_gencontrol -- \