udev.spec revision 8481f8ce2bd2b19ebcf3cb96ac6825093f626b0f
# if we want to build against the included version of klibc or not.
# 0 - do not use klibc
# 1 - use klibc
# Watch out for where the linux symlink is in the klibc part of the tarball,
# it probably is not where you want it to be.
# if we want to have logging support in or not.
# 0 - no logging support
# 1 - logging support
# Note, it is not recommend if you use klibc to enable logging.
# if we want to build DBUS support in or not.
# 0 - no DBUS support
# 1 - DBUS support
# if we want to build SELinux support in or not.
# 0 - no SELinux support
# 1 - SELinux support
# if we want to enable debugging support in udev. If it is enabled, lots of
# stuff will get sent to the debug syslog.
# 0 - debugging disabled
# 1 - debugging enabled
# if we want to use the LSB version of the init script or the Redhat one
# 1 - use LSB: etc/init.d/udev.init.LSB
# if we want to build the scsi_id "extra" package or not
# 0 - do not build the package
# 1 - build it
Release: 1
%prep
%setup -q
%if %{klibc}
USE_KLIBC=true \
%if %{log}
USE_LOG=true \
%else
USE_LOG=false \
%if %{dbus}
USE_DBUS=true \
%else
USE_DBUS=false \
%if %{selinux}
USE_SELINUX=true \
%else
USE_SELINUX=false \
%if %{debug}
DEBUG=true \
%else
DEBUG=false \
EXTRAS=" \
%if %{scsi_id}
%endif
"
%if %{dbus}
USE_DBUS=true \
%else
USE_DBUS=false \
%if %{selinux}
USE_SELINUX=true \
%else
USE_SELINUX=false \
%if %{lsb}
USE_LSB=true \
%else
USE_LSB=false \
EXTRAS=" \
%if %{scsi_id}
%endif
"
%post
if [ $1 = 0 ]; then
fi
%if %{dbus}
%if %{scsi_id}
- add udevtest to list of files
- more Red Hat sync ups.
* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
- add some changes from the latest Fedora udev release.
* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
- add udevsend, and udevd to the files
- add ability to build udevd with glibc after the rest is build with klibc
* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
- added udevinfo to rpm
- added URL to spec file