18861N/A#
18861N/A# spec file for package SUNWtransmission
18861N/A#
18861N/A# Copyright 2010 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
20129N/A%define owner jouby
18861N/A
18861N/A%include Solaris.inc
18861N/A
18861N/A%define OSR 9428:1.x
18861N/A
18861N/A%define source_name transmission
18861N/A
18861N/AName: SUNWtransmission
18861N/AIPS_package_name: desktop/torrent/transmission
18861N/AMeta(info.classification): %{classification_prefix}:Applications/Internet
18861N/ASummary: GTK and console BitTorrent client
18861N/AVersion: 1.93
18861N/ASource: http://download.m0k.org/transmission/files/transmission-%{version}.tar.bz2
18861N/A
18861N/AURL: http://transmission.m0k.org/
18861N/ASUNW_BaseDir: %{_basedir}
18861N/ASUNW_Copyright: %{name}.copyright
19078N/ALicense: GPL v2, LGPL v2.1, MIT, BSD, Public Domain
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ASource1: %{name}-manpages-0.1.tar.gz
18861N/A
18861N/A# date:2009-06-22 owner:elaine type:branding
18861N/APatch1: transmission-01-set-noevports.diff
18861N/A# date:2010-05-03 owner:yippi type:branding
18861N/APatch2: transmission-02-desktop.diff
18861N/A
18861N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
18861N/ABuildRequires: SUNWgtk2-devel
18861N/ABuildRequires: SUNWopenssl-include
18861N/ABuildRequires: SUNWgnome-panel-devel
18861N/ABuildRequires: SUNWdbus-glib-devel
18861N/ARequires: SUNWgtk2
18861N/ARequires: SUNWopenssl-libraries
18861N/ARequires: SUNWcurl
18861N/ARequires: SUNWgnome-panel
18861N/ARequires: SUNWdbus-glib
18861N/A%if %option_with_gnu_iconv
18861N/ARequires: SUNWgnu-libiconv
18861N/ARequires: SUNWgnu-gettext
18861N/A%else
18861N/ARequires: SUNWuiu8
18861N/A%endif
18861N/A
18861N/A%package l10n
18861N/ASummary: %{summary} - l10n files
18861N/ARequires: %{name}
18861N/A
18861N/A%prep
18861N/A%setup -q -c -n %{name}-%{version}
18861N/Acd %{_builddir}/%name-%version
18861N/Agzcat %SOURCE1 | tar xf -
18861N/Acd %{source_name}-%{version}
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/A
18861N/A%build
18861N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Aexport CFLAGS="%optflags -mt -xc99 -D__EXTENSIONS__"
18861N/A%if %option_with_gnu_iconv
18861N/Aexport CFLAGS="$CFLAGS -I/usr/gnu/include -L/usr/gnu/lib -R/usr/gnu/lib -lintl"
18861N/Aexport CXXFLAGS="$CXXFLAGS -I/usr/gnu/include -L/usr/gnu/lib -R/usr/gnu/lib -lintl"
18861N/A%endif
18861N/A
18861N/Acd %{source_name}-%{version}
18861N/A
18861N/Aexport LDFLAGS="%_ldflags"
18861N/Aexport ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
18861N/A
18861N/A./configure --prefix=%{_prefix} \
18861N/A --datadir=%{_datadir} \
18861N/A --mandir=%{_mandir} \
18861N/A --disable-wx \
18861N/A --program-prefix=""
18861N/A
18861N/Amake -j$CPUS
18861N/A
18861N/A%install
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/Acd %{source_name}-%{version}
18861N/Amake DESTDIR=$RPM_BUILD_ROOT install
18861N/A
18861N/A#install man page
18861N/Arm -r $RPM_BUILD_ROOT%{_mandir}
18861N/Acd %{_builddir}/%name-%version/sun-manpages
18861N/Amake install DESTDIR=$RPM_BUILD_ROOT
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%files
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755, root, bin) %{_bindir}
18861N/A%{_bindir}/*
18861N/A%dir %attr (0755, root, bin) %{_mandir}/man1
18861N/A%{_mandir}/man1/*
18861N/A%dir %attr (-, root, sys) %{_datadir}
18861N/A%dir %attr (0755, root, other) %{_datadir}/applications
18861N/A%{_datadir}/applications/*
18861N/A%dir %attr (0755, root, other) %{_datadir}/pixmaps
18861N/A%{_datadir}/pixmaps/*
18861N/A%dir %attr (0755, root, other) %{_datadir}/%{source_name}
18861N/A%{_datadir}/%{source_name}/*
18861N/A%dir %attr (0755, root, other) %{_datadir}/icons
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
18861N/A%{_datadir}/icons/hicolor/16x16/apps/transmission.png
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
18861N/A%{_datadir}/icons/hicolor/22x22/apps/transmission.png
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
18861N/A%{_datadir}/icons/hicolor/24x24/apps/transmission.png
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
18861N/A%{_datadir}/icons/hicolor/32x32/apps/transmission.png
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
18861N/A%{_datadir}/icons/hicolor/48x48/apps/transmission.png
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
18861N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
18861N/A%{_datadir}/icons/hicolor/scalable/apps/transmission.svg
18861N/A
18861N/A%files l10n
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755, root, sys) %{_datadir}
18861N/A%attr (-, root, other) %{_datadir}/locale
18861N/A
18861N/A%changelog
18861N/A* Mon May 03 2010 - brian.cameron@oracle.com
18861N/A- Add patch transmission-02-desktop.diff to fix doo bug #6861.
18861N/A* Mon May 03 2010 - brian.cameron@oracle.com
18861N/A- Bump to 1.93.
18861N/A* Fri Mar 26 2010 - brian.lu@sun.com
18861N/A- Bump to 1.92
18861N/A* Mon Feb 22 2010 - brian.lu@sun.com
18861N/A- Bump to 1.91
18861N/A* Thu Jan 28 2010 - brian.cameron@sun.com
18861N/A- Bump to 1.83.
18861N/A* Wed Jan 27 2010 - brian.cameron@sun.com
18861N/A- Bump to 1.82.
18861N/A* Mon Jan 19 2010 - brian.lu@sun.com
18861N/A- Bump to 1.77.
18861N/A* Mon Jul 27 2009 - elaine.xiong@sun.com
18861N/A- Bump to 1.73.
18861N/A* Mon Jun 22 2009 - elaine.xiong@sun.com
18861N/A- Bump to 1.72. Add a branding patch to disable evports since libevent has
18861N/A troubles with evports that is the default poll mechanism used on Solaris).
18861N/A* Fri May 22 2009 - elaine.xiong@sun.com
18861N/A- Bump to 1.61. Remove upstream patch. Add -xc99 flag to CFLAGS.
18861N/A* Thu Mar 05 2009 - brian.cameron@sun.com
18861N/A- Change SUNWdbus-bindings to SUNWdbus-glib.
18861N/A* Thu Feb 19 2009 - elaine.xiong@sun.com
18861N/A- Bump to 1.50 and add a patch to fix build problems.
18861N/A* Tue Feb 10 2009 - halton.huo@sun.com
18861N/A- Add depend to SUNWgnome-panel and SUNWdbus-bindings to
18861N/A fix issue #7 for CR6753371
18861N/A* Mon Jan 19 2009 - elaine.xiong@sun.com
18861N/A- Bump to 1.4.2 and disable unsupported wxWidgets client.
18861N/A* Mon Nov 17 2008 - elaine.xiong@sun.com
18861N/A- Bump to 1.40.
18861N/A* Mon Sep 15 2008 - elaine.xiong@sun.com
18861N/A- Bump to 1.33.
18861N/A* Tue Aug 12 2008 - elaine.xiong@sun.com
18861N/A- Bump to 1.32 and remove upstream patches.
18861N/A* Tue Aug 05 2008 - elaine.xiong@sun.com
18861N/A- Add new manpages into the package.
18861N/A* Sat Aug 02 2008 - elaine.xiong@sun.com
18861N/A- Temporarily disable new manpages.
18861N/A* Tue Jul 29 2008 - takao.fujiwara@sun.com
18861N/A- Add transmission-02-g11n-i18n-ui.diff. CR 6729782
18861N/A* Mon Jul 28 2008 - elaine.xiong@sun.com
18861N/A- Copy from SFEtransmission.spec and rename to SUNWtransmission.
18861N/A* Wed Jun 25 2008 - darren.kenny@sun.com
18861N/A- Bump to 1.2.2 and remove upstream patch for compiler. Add patch for solaris
18861N/A getgateway implementation.
18861N/A* Tue May 27 2008 - trisk@acm.jhu.edu
18861N/A- Add SUNWcurl dependency
18861N/A* Sat May 24 2008 - trisk@acm.jhu.edu
18861N/A- Bump to 1.21, drop patch2
18861N/A* Sun Mar 02 2008 - trisk@acm.jhu.edu
18861N/A- Bump to 1.06, add patch2 (fixed upstream)
18861N/A* Tue Feb 26 2008 - markwright@internode.on.net
18861N/A- Bump to 1.05, bump patch1, add icons.
18861N/A* Thu Nov 22 2007 - daymobrew@users.sourceforge.net
18861N/A- Enable building on Indiana systems.
18861N/A* Thu Nov 01 2007 - trisk@acm.jhu.edu
18861N/A- Bump to 0.91, replace patch1
18861N/A* Mon Sep 10 2007 - trisk@acm.jhu.edu
18861N/A- Bump to 0.82
18861N/A* Thu Sep 6 2007 - Petr Sobotka sobotkap@centum.cz
18861N/A- Fix typo in changelog
18861N/A* Wed Aug 29 2007 - trisk@acm.jhu.edu
18861N/A- Bump to 0.81, add workaround for broken tarball
18861N/A* Mon Aug 20 2007 - trisk@acm.jhu.edu
18861N/A- Clean up, allow building with Studio
18861N/A* Sun Aug 19 2007 - Petr Sobotka sobotkap@centrum.cz
18861N/A- Initial spec
18861N/A
19452N/A
19769N/A