18861N/A#
18861N/A# spec file for package terminator
18861N/A#
20890N/A# Copyright (c) 2010, 2012, Oracle and/or its affiliates. All rights reserved.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A%define owner kevmca
18861N/A#
18861N/A
18861N/A%include Solaris.inc
18861N/A
18861N/A%define OSR 9644:0.9
18861N/A
18861N/A%define python_version 2.6
18861N/A
18861N/AName: SUNWterminator
18861N/AIPS_package_name: terminal/terminator
18861N/AMeta(info.classification): %{classification_prefix}:Applications/System Utilities
18861N/ALicense: GPLv2
19067N/AVersion: 0.95
18861N/ASummary: Multiple GNOME terminals in one window
18861N/ASource: http://launchpad.net/terminator/trunk/%{version}/+download/terminator_%{version}.tar.gz
18861N/A# date:2009-02-19 owner:mattman type:branding
18861N/APatch1: terminator-01-manpages.diff
18861N/APatch2: terminator-02-py26.diff
18861N/AURL: http://www.tenshu.net/terminator/
18861N/ASUNW_Basedir: %{_basedir}
18861N/ASUNW_Copyright: %{name}.copyright
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/A
18861N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
20890N/ABuildRequires: runtime/python-26
20890N/ABuildRequires: library/python-2/setuptools-26
20890N/ARequires: library/python-2/pygtk2-26
20890N/ARequires: service/gnome/desktop-cache
20890N/ARequires: runtime/python-26
20890N/ARequires: library/gnome/gnome-libs
18861N/A
18861N/A%description
18861N/AThis is a project to produce an efficient way of filling a
18861N/Alarge area of screen space with terminals. This is done by
18861N/Asplitting the window into a resizeable grid of terminals. As
18861N/Asuch, you can produce a very flexible arrangements of terminals
18861N/Afor different tasks.
18861N/A
18861N/A%package l10n
18861N/ASummary: %{summary} - l10n files
18861N/A
18861N/A%prep
18861N/A%setup -q -c -n terminator-%{version}
18861N/Acd terminator-%{version}
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/Arm po/ru_RU.po
18861N/A
18861N/A%build
18861N/Aexport PYTHON="/usr/bin/python%{python_version}"
18861N/Acd terminator-%{version}
18861N/Apython%{python_version} setup.py build
18861N/A
18861N/A%install
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/Acd terminator-%{version}
18861N/Apython%{python_version} setup.py install --root=$RPM_BUILD_ROOT
18861N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
18861N/A
18861N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{python_version}/site-packages \
18861N/A $RPM_BUILD_ROOT%{_libdir}/python%{python_version}/vendor-packages
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A#%post
18861N/A#%restart_fmri icon-cache desktop-mime-cache
18861N/A
18861N/A#%postun
18861N/A#%restart_fmri icon-cache desktop-mime-cache
18861N/A
18861N/A%files
18861N/A%defattr(-, root, bin)
18861N/A%dir %attr (0755, root, bin) %{_bindir}
18861N/A%{_bindir}/*
18861N/A%dir %attr (0755, root, bin) %{_libdir}
18861N/A%{_libdir}/*
18861N/A%dir %attr(0755, root, sys) %{_datadir}
18861N/A%dir %attr(0755, root, other) %{_datadir}/applications
18861N/A%{_datadir}/applications/*
18861N/A%dir %attr(0755, root, other) %{_datadir}/pixmaps
18861N/A%{_datadir}/pixmaps/*
18861N/A%dir %attr(0755, root, other) %{_datadir}/icons
18861N/A%attr(-, root, other) %{_datadir}/icons/*
18861N/A%dir %attr (0755, root, bin) %{_mandir}/man1
18861N/A%{_mandir}/man1/*
18861N/A%dir %attr (0755, root, bin) %{_mandir}/man5
18861N/A%{_mandir}/man5/*
18861N/A
18861N/A%files l10n
18861N/A%defattr(-, root, bin)
18861N/A%dir %attr (0755, root, sys) %{_datadir}
18861N/A%dir %attr (0755, root, other) %{_datadir}/locale
18861N/A%attr(-, root, other) %{_datadir}/locale/*
18861N/A
18861N/A%changelog
20890N/A* Fri Feb 10 2012 - padraig.obriain@oracle.com
20890N/A- Update Requires and BuildRequires to be IPS package names.
19067N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
19067N/A- Bump to 0.95.
18861N/A* Tue May 25 2010 - brian.cameron@oracle.com
18861N/A- Bump to 0.93.
18861N/A* Tue May 04 2010 - harry.fu@sun.com
18861N/A- Bypass ru_RU translations at the moment.
18861N/A* Thu Apr 15 2010 - brian.cameron@sun.com
18861N/A- Bump to 0.92.
18861N/A* Wed Jan 27 2010 - brian.cameron@sun.com
18861N/A- Bump to 0.14.
18861N/A* Mon Dec 07 2009 - yuntong.jin@sun.com
18861N/A- use python2.6 in script explicitly.
18861N/A* Mon Nov 09 2009 - ke.wang@sun.com
18861N/A- Change dependency from SUNWPython to SUNWPython26.
18861N/A* Fri Oct 02 2009 - brian.cameron@sun.com
18861N/A- Now build with Python 2.6. Terminator no longer works with Python 2.4.
18861N/A See CR #6885253.
18861N/A* Wed Aug 12 2009 - christian.kelly@sun.com
18861N/A- Bump to 0.13.
18861N/A- Remove terminator-02-interpreters.diff, upstream.
18861N/A* Fri May 29 2009 - kevin.mcareavey@sun.com
18861N/A- Add patch to fix python path.
18861N/A* Wed Apr 22 2009 - kevin.mcareavey@sun.com
18861N/A- Bump to 0.12.
18861N/A* Fri Apr 3 2009 - laca@sun.com
18861N/A- use desktop-cache instead of postrun.
18861N/A* Thu Feb 19 2009 - matt.keenan@sun.com
18861N/A- Add manpages patch for Attributes and ARC case comments.
18861N/A* Thu Sep 11 2008 - kevin.mcareavey@sun.com
18861N/A- Add %doc to %files for copyright.
18861N/A* Fri Aug 8 2008 - kevin.mcareavey@sun.com
18861N/A- Updated Summary and %description.
18861N/A* Tue Aug 5 2008 - kevin.mcareavey@sun.com
18861N/A- Initial version.
18861N/A
19441N/A
19758N/A