SUNWpython26-coherence.spec revision 19730
10139N/A#
10139N/A# spec file for package SUNWpython26-coherence
10139N/A#
12198N/A# includes module(s): coherence
10139N/A#
10139N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
17185N/A# package are under the same license as the package itself.
10139N/A#
17178N/A# bugdb: http://coherence.beebits.net/ticket/$bugid
17178N/A%define owner jouby
17178N/A#
10139N/A
10139N/A%include Solaris.inc
10139N/A
10139N/A%define pythonver 2.6
17120N/A%define src_url http://coherence.beebits.net/download
10139N/A%define src_name Coherence
10139N/A
10139N/A%use coherence = coherence.spec
10139N/A
16834N/AName: SUNWpython26-coherence
10139N/AIPS_package_name: library/python-2/coherence-26
10139N/AMeta(info.classification): %{classification_prefix}:Development/Python
10139N/ASummary: DLNA/UPnP framework for the digital living
10139N/AURL: %{coherence.url}
10139N/ASUNW_Copyright: SUNWpython26-coherence.copyright
10142N/ALicense: MIT
10142N/AVersion: %{coherence.version}
12773N/ASource1: coherence.xml
12773N/ASource2: coherence.conf
12773N/ASource3: coherence
10139N/ASource4: %{name}-manpages-0.1.tar.gz
10139N/APatch1: coherence-01-youtubedl.diff
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
13269N/A%include gnome-consolidation.inc
13269N/ARequires: SUNWPython26
13868N/ARequires: SUNWpython26-twisted
14258N/ARequires: SUNWpython26-zope-interface
15166N/ABuildRequires: SUNWPython26-devel
15166N/ABuildRequires: SUNWpython26-setuptools
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
10139N/A%include gnome-consolidation.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir -p %name-%version
10139N/A%coherence.prep -d %name-%version
10139N/Acd %{_builddir}/%name-%version
10139N/Agzcat %{SOURCE4} | tar xf -
10139N/A
10139N/A%patch1 -p1
10139N/A
10139N/A%build
10139N/Aexport PYTHON="/usr/bin/python%{pythonver}"
10139N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/Aexport PYCC_CC="$CC"
10139N/Aexport PYCC_CXX="$CXX"
10139N/A%coherence.build -d %name-%version
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%coherence.install -d %name-%version
10139N/A
10139N/A# install man page
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A# Install SMF related files.
10139N/Amkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/svc/manifest/application
10139N/Amkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/coherence
10139N/Amkdir -p $RPM_BUILD_ROOT/lib/svc/method
10139N/A
10139N/Ainstall -c -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_localstatedir}/svc/manifest/application/
11461N/Ainstall -c -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_localstatedir}/coherence/
10139N/Ainstall -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT/lib/svc/method/
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
11461N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10142N/A%if %(test -f /usr/sadm/install/scripts/i.manifest && echo 0 || echo 1)
10139N/A%iclass manifest -f i.manifest
10139N/A%endif
13269N/A
11959N/A%actions
10139N/Agroup gid=52 groupname=upnp
10139N/Auser gcos-field="UPnP Server Reserved UID" group=upnp home-dir=/var/coherence login-shell=/bin/ksh password=NP uid=52 username=upnp
13653N/A
15166N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%doc(bzip2) -d Coherence-%version LICENCE NEWS ChangeLog
10139N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A%dir %attr (0755, root, bin) %{_datadir}/dbus-1
10139N/A%dir %attr (0755, root, bin) %{_datadir}/dbus-1/services
10139N/A%{_datadir}/dbus-1/services/org.Coherence.service
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/python%{pythonver}/vendor-packages
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
10139N/A
16174N/A%files root
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_localstatedir}
12773N/A%dir %attr (0755, root, sys) %{_localstatedir}/svc
12773N/A%dir %attr (0755, root, sys) %{_localstatedir}/svc/manifest
12773N/A%dir %attr (0755, root, sys) %{_localstatedir}/svc/manifest/application
12773N/A%class(manifest) %attr (0444, root, sys) %{_localstatedir}/svc/manifest/application/coherence.xml
12773N/A%attr (0555, root, bin) /lib/svc/method/coherence
16632N/A%dir %attr (0755, upnp, upnp) %{_localstatedir}/coherence
10139N/A%attr (0644, upnp, upnp) %{_localstatedir}/coherence/coherence.conf
10139N/A
10139N/A%changelog
10139N/A* Wen Jan 01 2010 - yuntong.jin@sun.com
10139N/A- Bump to 0.6.6.2, del upstream patch: coherence-01-appletrailers-storage.diff
10139N/A* Thu Dec 03 2009 - yuntong.jin@sun.com
10139N/A- Add dependency
10139N/A* Wen Dec 02 2009 - yuntong.jin@sun.com
10139N/A- Fixed appletrailer backend is broken issue
10139N/A* Wen Oct 21 2009 - yuntong.jin@sun.com
10139N/A- Fixed doo bug 11433
10139N/A* Tue Sep 29 2009 - dave.lin@sun.com
10139N/A- Fixed file attribute issue.
10139N/A* Fri Sep 17 2009 - brian.lu@sun.com
10139N/A- Add support to ship org.Coherence.service fil
10139N/A* Thu Aug 27 2009 - yuntong.jin@sun.com
10139N/A- change owner to jouby, add license info
10139N/A* Fri Mar 06 2009 - alfred.peng@sun.com
10139N/A- Create SFEpython24-coherence.spec and coherence.spec to replace
10139N/A SFEcoherence.spec.
10139N/A* Mon Mar 02 2009 - alfred.peng@sun.com
10139N/A- Bump to 0.6.2. Remove the upstream patch path-blank.diff.
11461N/A* Mon Feb 16 2009 - alfred.peng@sun.com
10139N/A- Add patch path-blank.diff to fix packaging problem.
11461N/A Bump to 0.6.0.
10142N/A* Thu Oct 09 2008 - jijun.yu@sun.com
10139N/A- Initial version.
10139N/A
10139N/A
10139N/A