18861N/A#
18861N/A# spec file for package SUNWpython26-coherence
18861N/A#
18861N/A# includes module(s): coherence
18861N/A#
20890N/A# Copyright (c) 2009, 2012, Oracle and/or its affiliates. All rights reserved.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A# bugdb: http://coherence.beebits.net/ticket/$bugid
18861N/A%define owner jouby
18861N/A#
18861N/A
18861N/A%include Solaris.inc
18861N/A
18861N/A%define pythonver 2.6
18861N/A%define src_url http://coherence.beebits.net/download
18861N/A%define src_name Coherence
18861N/A
18861N/A%use coherence = coherence.spec
18861N/A
18861N/AName: SUNWpython26-coherence
18861N/AIPS_package_name: library/python-2/coherence-26
18861N/AMeta(info.classification): %{classification_prefix}:Development/Python
18861N/ASummary: DLNA/UPnP framework for the digital living
18861N/AURL: %{coherence.url}
19092N/ASUNW_Copyright: SUNWpython26-coherence.copyright
18861N/ALicense: MIT
18861N/AVersion: %{coherence.version}
18861N/ASource1: coherence.xml
18861N/ASource2: coherence.conf
18861N/ASource3: coherence
18861N/ASource4: %{name}-manpages-0.1.tar.gz
18861N/APatch1: coherence-01-youtubedl.diff
18861N/ASUNW_BaseDir: %{_basedir}
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/A
18861N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
20890N/ARequires: runtime/python-26
20857N/ARequires: library/python-2/python-twisted-26
20890N/ARequires: library/python-2/python-zope-interface-26
20890N/ABuildRequires: runtime/python-26
20890N/ABuildRequires: library/python-2/setuptools-26
18861N/A
18861N/A%package root
18861N/ASummary: %{summary} - / filesystem
18861N/ASUNW_BaseDir: /
18861N/A
18861N/A%prep
18861N/Arm -rf %name-%version
18861N/Amkdir -p %name-%version
18861N/A%coherence.prep -d %name-%version
18861N/Acd %{_builddir}/%name-%version
18861N/Agzcat %{SOURCE4} | tar xf -
18861N/A
18861N/A%patch1 -p1
18861N/A
18861N/A%build
18861N/Aexport PYTHON="/usr/bin/python%{pythonver}"
18861N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
18861N/Aexport RPM_OPT_FLAGS="$CFLAGS"
18861N/Aexport LDFLAGS="%_ldflags"
18861N/Aexport PYCC_CC="$CC"
18861N/Aexport PYCC_CXX="$CXX"
18861N/A%coherence.build -d %name-%version
18861N/A
18861N/A%install
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A%coherence.install -d %name-%version
18861N/A
18861N/A# install man page
18861N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
18861N/Acd %{_builddir}/%name-%version/sun-manpages
18861N/Amake install DESTDIR=$RPM_BUILD_ROOT
18861N/A
18861N/A# Install SMF related files.
20071N/Amkdir -p $RPM_BUILD_ROOT/lib/svc/manifest/application
18861N/Amkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/coherence
18861N/Amkdir -p $RPM_BUILD_ROOT/lib/svc/method
18861N/A
20071N/Ainstall -c -m 644 %{SOURCE1} $RPM_BUILD_ROOT/lib/svc/manifest/application/
18861N/Ainstall -c -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_localstatedir}/coherence/
18861N/Ainstall -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT/lib/svc/method/
18861N/A
18861N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%if %(test -f /usr/sadm/install/scripts/i.manifest && echo 0 || echo 1)
18861N/A%iclass manifest -f i.manifest
18861N/A%endif
18861N/A
19142N/A%actions
19142N/Agroup gid=52 groupname=upnp
19142N/Auser gcos-field="UPnP Server Reserved UID" group=upnp home-dir=/var/coherence login-shell=/bin/ksh password=NP uid=52 username=upnp
19142N/A
18861N/A%files
18861N/A%defattr (-, root, bin)
18861N/A%doc(bzip2) -d Coherence-%version LICENCE NEWS ChangeLog
18861N/A%dir %attr (0755, root, other) %{_datadir}/doc
18861N/A%dir %attr (0755, root, bin) %{_datadir}/dbus-1
18861N/A%dir %attr (0755, root, bin) %{_datadir}/dbus-1/services
18861N/A%{_datadir}/dbus-1/services/org.Coherence.service
18861N/A%dir %attr (0755, root, bin) %{_bindir}
18861N/A%{_bindir}/*
18861N/A%dir %attr (0755, root, bin) %{_libdir}
18861N/A%{_libdir}/python%{pythonver}/vendor-packages
18861N/A%dir %attr (0755, root, sys) %{_datadir}
18861N/A%dir %attr(0755, root, bin) %{_mandir}
18861N/A%dir %attr(0755, root, bin) %{_mandir}/*
18861N/A%{_mandir}/*/*
18861N/A
18861N/A%files root
18861N/A%defattr (-, root, bin)
20071N/A/lib/svc/method/coherence
20071N/A%dir %attr (0755, root, sys) /lib/svc/manifest
20071N/A%dir %attr (0755, root, sys) /lib/svc/manifest/application
20076N/A%class(manifest) %attr (0444, root, sys) /lib/svc/manifest/application/coherence.xml
18861N/A%dir %attr (0755, root, sys) %{_localstatedir}
18861N/A%dir %attr (0755, upnp, upnp) %{_localstatedir}/coherence
18861N/A%attr (0644, upnp, upnp) %{_localstatedir}/coherence/coherence.conf
18861N/A
18861N/A%changelog
20890N/A* Fri Feb 10 2012 - padraig.obriain@oracle.com
20890N/A- Update Requires and BuildRequires to be IPS package names.
18861N/A* Wen Jan 01 2010 - yuntong.jin@sun.com
18861N/A- Bump to 0.6.6.2, del upstream patch: coherence-01-appletrailers-storage.diff
18861N/A* Thu Dec 03 2009 - yuntong.jin@sun.com
18861N/A- Add dependency
18861N/A* Wen Dec 02 2009 - yuntong.jin@sun.com
18861N/A- Fixed appletrailer backend is broken issue
18861N/A* Wen Oct 21 2009 - yuntong.jin@sun.com
18861N/A- Fixed doo bug 11433
18861N/A* Tue Sep 29 2009 - dave.lin@sun.com
18861N/A- Fixed file attribute issue.
18861N/A* Fri Sep 17 2009 - brian.lu@sun.com
18861N/A- Add support to ship org.Coherence.service fil
18861N/A* Thu Aug 27 2009 - yuntong.jin@sun.com
18861N/A- change owner to jouby, add license info
18861N/A* Fri Mar 06 2009 - alfred.peng@sun.com
18861N/A- Create SFEpython24-coherence.spec and coherence.spec to replace
18861N/A SFEcoherence.spec.
18861N/A* Mon Mar 02 2009 - alfred.peng@sun.com
18861N/A- Bump to 0.6.2. Remove the upstream patch path-blank.diff.
18861N/A* Mon Feb 16 2009 - alfred.peng@sun.com
18861N/A- Add patch path-blank.diff to fix packaging problem.
18861N/A Bump to 0.6.0.
18861N/A* Thu Oct 09 2008 - jijun.yu@sun.com
18861N/A- Initial version.
19413N/A
19730N/A