SUNWpyorbit26.spec revision 19997
10139N/A#
10139N/A# spec file for package SUNWpyorbit26 aka library/python-2/pyorbit-26
10139N/A#
12219N/A# includes module(s): pyorbit
10139N/A#
10139N/A# Copyright (c) 2005,2011, Oracle and/or its affiliates. All rights reserved.
10139N/A#
17185N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
17176N/A#
17176N/A%define owner laca
17176N/A#
10139N/A%include Solaris.inc
10139N/A%define pythonver 2.6
15291N/A%define python_version %{pythonver}
10139N/A
10615N/A%use pyorbit = pyorbit.spec
17866N/A
18091N/AName: SUNWpyorbit26
10139N/AIPS_package_name: library/python-2/pyorbit-26
10139N/AMeta(info.classification): %{classification_prefix}:Development/Python
10139N/ASummary: Python 2.6 bindings for ORBit
10139N/AVersion: %{pyorbit.version}
17866N/ASUNW_BaseDir: %{_basedir}
10794N/ASUNW_Copyright: %{name}.copyright
10139N/ALicense: %{pyorbit.license}
10794N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12773N/A
12773N/A%include default-depend.inc
12773N/A%include gnome-consolidation.inc
10794N/ARequires: SUNWgnome-component
10139N/ARequires: SUNWPython26
10640N/ABuildRequires: SUNWPython26-devel
17989N/ABuildRequires: SUNWgnome-component-devel
10820N/ABuildRequires: SUNWpython26-setuptools
16105N/ABuildRequires: SUNWgsed
10820N/A
16769N/A%package devel
16769N/ASummary: %{summary} - development files
10861N/ASUNW_BaseDir: %{_basedir}
13306N/A%include default-depend.inc
17481N/A%include gnome-consolidation.inc
17481N/ARequires: %name
13379N/ARequires: SUNWPython26
13379N/A
15219N/A%prep
14420N/Arm -rf %name-%version
14503N/Amkdir %name-%version
14503N/A%pyorbit.prep -d %name-%version
16472N/A
16434N/A%build
16472N/APKG_CONFIG_DISABLE_UNINSTALLED=
16442N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
16690N/A
16690N/Aexport PYTHON="/usr/bin/python2.6"
18091N/Aexport CPPFLAGS="-I/usr/xpg4/include -I/usr/include/python%{pythonver}"
18091N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/Aexport PYCC_CC="$CC"
10139N/Aexport PYCC_CXX="$CXX"
10139N/A
10139N/A%pyorbit.build -d %name-%version
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%pyorbit.install -d %name-%version
10139N/A
10139N/A# move to vendor-packages
10139N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
10139N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10139N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
10139N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
10139N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
10139N/Afi
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/python?.?/vendor-packages
17891N/A
17891N/A%files devel
10139N/A%defattr(-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A
17891N/A%changelog
17891N/A* Fri Feb 4 2010 - laszlo.peter@oracle.com
10139N/A- created, based on SUNWgnome-python26-libs.spec
10139N/A* Wed Sep 23 2009 - brian.cameron@sun.com
10139N/A- Use PKG_CONFIG_TOP_BUILD_DIR environment variable when building pygtk and
10139N/A pygtksourceview, so that pkg-config expands $(top_builddir), otherwise
10139N/A pygobject pkg-config variables do not expand nicely and the build fails.
10139N/A* Sat Jun 20 2009 - christian.kelly@sun.com
10139N/A- Minor pkg'ing fix.
10139N/A* Wed Mar 25 2009 - li.yuan@sun.com
10139N/A- Move pyspi from SUNWgnome-python-libs to SUNWgnome-a11y-libs.
10139N/A* Mon Feb 2 2009 - laca@sun.com
10139N/A- created, based on SUNWgnome-python25-libs.spec
10139N/A* Tue Nov 25 2008 - laca@sun.com
10139N/A- get rid of SUNWgnome-python-libs-common because there are no files
10139N/A that we can share between 2.4 and 2.5.
10139N/A* Mon Nov 24 2008 - laca@sun.com
10139N/A- created, based on SUNWPython-extra.spec
10139N/A* Wed Sep 17 2008 - laca@sun.com
10139N/A- set PYTHON to python2.4 (instead of just python) to make sure the
10139N/A right version is used for the build
10139N/A* Tue Aug 12 2008 - damien.carbery@sun.com
10139N/A- Add %{_libdir}/libpyglib-2.0.so* to %files.
10139N/A* Mon Aug 11 2008 - damien.carbery@sun.com
10139N/A- Move site-packages to vendor-packages here because pygobject 2.15.2 borked
10139N/A when vendor-packages was specified by pyexecdir and pythondir in make
10139N/A install.
10139N/A* Tue Oct 16 2007 - damien.carbery@sun.com
10139N/A- Remove unnecessary environment variable settings.
10139N/A* Mon Oct 8 2007 - damien.carbery@sun.com
10139N/A- Add SUNWgnome-gtksourceview dependency as it is required to by
10139N/A pygtksourceview.
10139N/A* Sun Oct 7 2007 - damien.carbery@sun.com
10139N/A- Add pygtksourceview as it is required to build python bindings in gedit.
10794N/A* Fri Sep 28 2007 - laca@sun.com
12754N/A- delete some unnecessary env vars
10139N/A* Fri Aug 31 2007 - damien.carbery@sun.com
10139N/A- Remove pygtksourceview.spec. It is still not building and isn't required.
10139N/A* Thu Jul 05 2007 - damien.carbery@sun.com
11087N/A- Add pygtksourceview.spec, but disable it because it is not building yet.
11087N/A* Tue Jan 9 2007 - laca@sun.com
17866N/A- define PYCC_CC and PYCC_CXX to override what the configure script sets
16769N/A in CC/CXX
13306N/A* Mon Aug 28 2006 - damien.carbery@sun.com
17866N/A- Fix typo in PKG_CONFIG_PATH data (s/=/-/).
13379N/A* Sun Jun 11 2006 - laca@sun.com
15449N/A- change group from other to bin/sys
17866N/A* Fri May 12 2006 - damien.carbery@sun.com
17866N/A- Small update to dependency list after check-deps.pl run.
16690N/A* Thu May 11 2006 - brian.cameron@sun.com
18091N/A- Move pygtk-demo to demo directory.
16998N/A* Wed Apr 5 2006 - damien.carbery@sun.com
10139N/A- Add pygobject. It has been moved from pygtk2.
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Complete update of Build/Requires after running check-deps.pl script.
17891N/A* Fri Feb 17 2006 - damien.carbery@sun.com
17891N/A- Update Build/Requires after running check-deps.pl script.
17891N/A* Mon Jan 09 2006 - damien.carbery@sun.com
10139N/A- Add gnome-vfs module.
10139N/A* Thu Oct 27 2005 - laca@sun.com
10139N/A- add pygtk2
10139N/A* Tue Sep 20 2005 - laca@sun.com
10139N/A- move to /usr as Python was also moved there
17891N/A* Thu Sep 01 2005 - damien.carbery@sun.com
10139N/A- Remove unused pygtk2 references.
17891N/A* Wed Aug 30 2005 - damien.carbery@sun.com
17891N/A- Add Build/Requires for SUNWgnome-file-mgr (nautilus) and SUNWgnome-print
17891N/A (libgnomeprint/libgnomeprintui) so that those submodules will be built.
17891N/A* Mon Aug 29 2005 - rich.burridge@sun.com
17891N/A- Adjusted to put files under /usr/sfw
10139N/A* Thu Aug 25 2005 - rich.burridge@sun.com
17891N/A- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
11344N/A* Mon Aug 22 2005 - rich.burridge@sun.com
11344N/A- Adjustments needed to make the package proto maps equivalent to what gets
11344N/A installed via "make install"
11344N/A* Thu Aug 11 2005 - rich.burridge@sun.com
11344N/A- initial version
10139N/A
11994N/A
11994N/A
12773N/A