SUNWpygtksourceview26.spec revision 20857
10139N/A#
10139N/A# spec file for package SUNWpygtksourceview26 aka
10139N/A# library/python-2/pygtksourceview-26
10139N/A#
10139N/A# includes module(s): pygtksourceview
10139N/A#
12173N/A# Copyright (c) 2005, 2011, Oracle and/or its affiliates. All rights reserved.
10139N/A#
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
17185N/A#
10139N/A%define owner laca
10139N/A#
10139N/A%include Solaris.inc
10139N/A%define pythonver 2.6
10139N/A%define python_version %{pythonver}
18688N/A
18688N/A%use pygtksourceview = pygtksourceview.spec
10139N/A
19013N/AName: SUNWpygtksourceview26
10139N/AIPS_package_name: library/python-2/pygtksourceview2-26
12695N/AMeta(info.classification): %{classification_prefix}:Development/Python
19140N/ASummary: Python 2.6 bindings for the gtksourceview library
10139N/AVersion: %{pygtksourceview.version}
13685N/ASUNW_BaseDir: %{_basedir}
13685N/ASUNW_Copyright: %{name}.copyright
10139N/ALicense: %{pygtksourceview.license}
19142N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
16401N/A
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10139N/ARequires: SUNWPython26
10139N/ARequires: SUNWpygobject26
10139N/ARequires: SUNWgnome-gtksourceview
20239N/ABuildRequires: SUNWPython26-devel
16401N/ABuildRequires: SUNWpygobject26-devel
10139N/ABuildRequires: SUNWpygtk2-26-devel
10139N/ABuildRequires: SUNWgnome-gtksourceview-devel
10139N/ABuildRequires: SUNWpython26-setuptools
10139N/ABuildRequires: SUNWgsed
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
19142N/ARequires: %name
10139N/ARequires: SUNWPython26
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
19126N/Amkdir %name-%version
10139N/A%pygtksourceview.prep -d %name-%version
19126N/A
10139N/A%build
19142N/APKG_CONFIG_DISABLE_UNINSTALLED=
10139N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
10139N/A
10139N/Aexport PYTHON="/usr/bin/python2.6"
10139N/Aexport CPPFLAGS="-I/usr/xpg4/include -I/usr/include/python%{pythonver}"
10139N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags"
13685N/Aexport PYCC_CC="$CC"
13685N/Aexport PYCC_CXX="$CXX"
10139N/A
10139N/A%pygtksourceview.build -d %name-%version
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%pygtksourceview.install -d %name-%version
12173N/A
10139N/A# move to vendor-packages
10139N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
10139N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10139N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
10139N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
10139N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
10139N/Afi
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/python?.?/vendor-packages
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
13685N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
13685N/A%{_libdir}/pkgconfig/*
13685N/A%dir %attr (0755, root, sys) %{_datadir}
13685N/A%{_datadir}/*
10139N/A
10139N/A%changelog
10139N/A* Fri Feb 4 2010 - laszlo.peter@oracle.com
10139N/A- created, based on SUNWgnome-python26-libs.spec
10139N/A* Wed Sep 23 2009 - brian.cameron@sun.com
14371N/A- Use PKG_CONFIG_TOP_BUILD_DIR environment variable when building pygtk and
14371N/A pygtksourceview, so that pkg-config expands $(top_builddir), otherwise
14371N/A pygobject pkg-config variables do not expand nicely and the build fails.
10139N/A* Sat Jun 20 2009 - christian.kelly@sun.com
10139N/A- Minor pkg'ing fix.
10139N/A* Wed Mar 25 2009 - li.yuan@sun.com
13685N/A- Move pyspi from SUNWgnome-python-libs to SUNWgnome-a11y-libs.
13685N/A* Mon Feb 2 2009 - laca@sun.com
13685N/A- created, based on SUNWgnome-python25-libs.spec
10139N/A* Tue Nov 25 2008 - laca@sun.com
10139N/A- get rid of SUNWgnome-python-libs-common because there are no files
10139N/A that we can share between 2.4 and 2.5.
10139N/A* Mon Nov 24 2008 - laca@sun.com
10139N/A- created, based on SUNWPython-extra.spec
10139N/A* Wed Sep 17 2008 - laca@sun.com
10139N/A- set PYTHON to python2.4 (instead of just python) to make sure the
10139N/A right version is used for the build
10139N/A* Tue Aug 12 2008 - damien.carbery@sun.com
10139N/A- Add %{_libdir}/libpyglib-2.0.so* to %files.
10139N/A* Mon Aug 11 2008 - damien.carbery@sun.com
10139N/A- Move site-packages to vendor-packages here because pygobject 2.15.2 borked
10139N/A when vendor-packages was specified by pyexecdir and pythondir in make
10139N/A install.
10139N/A* Tue Oct 16 2007 - damien.carbery@sun.com
10139N/A- Remove unnecessary environment variable settings.
10139N/A* Mon Oct 8 2007 - damien.carbery@sun.com
10139N/A- Add SUNWgnome-gtksourceview dependency as it is required to by
10139N/A pygtksourceview.
17286N/A* Sun Oct 7 2007 - damien.carbery@sun.com
17286N/A- Add pygtksourceview as it is required to build python bindings in gedit.
16228N/A* Fri Sep 28 2007 - laca@sun.com
16228N/A- delete some unnecessary env vars
14372N/A* Fri Aug 31 2007 - damien.carbery@sun.com
14372N/A- Remove pygtksourceview.spec. It is still not building and isn't required.
13685N/A* Thu Jul 05 2007 - damien.carbery@sun.com
13685N/A- Add pygtksourceview.spec, but disable it because it is not building yet.
12173N/A* Tue Jan 9 2007 - laca@sun.com
12173N/A- define PYCC_CC and PYCC_CXX to override what the configure script sets
11311N/A in CC/CXX
11311N/A* Mon Aug 28 2006 - damien.carbery@sun.com
10139N/A- Fix typo in PKG_CONFIG_PATH data (s/=/-/).
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Fri May 12 2006 - damien.carbery@sun.com
10139N/A- Small update to dependency list after check-deps.pl run.
10139N/A* Thu May 11 2006 - brian.cameron@sun.com
10139N/A- Move pygtk-demo to demo directory.
10139N/A* Wed Apr 5 2006 - damien.carbery@sun.com
10139N/A- Add pygobject. It has been moved from pygtk2.
16401N/A* Mon Feb 20 2006 - damien.carbery@sun.com
19346N/A- Complete update of Build/Requires after running check-deps.pl script.
19663N/A* Fri Feb 17 2006 - damien.carbery@sun.com
- Update Build/Requires after running check-deps.pl script.
* Mon Jan 09 2006 - damien.carbery@sun.com
- Add gnome-vfs module.
* Thu Oct 27 2005 - laca@sun.com
- add pygtk2
* Tue Sep 20 2005 - laca@sun.com
- move to /usr as Python was also moved there
* Thu Sep 01 2005 - damien.carbery@sun.com
- Remove unused pygtk2 references.
* Wed Aug 30 2005 - damien.carbery@sun.com
- Add Build/Requires for SUNWgnome-file-mgr (nautilus) and SUNWgnome-print
(libgnomeprint/libgnomeprintui) so that those submodules will be built.
* Mon Aug 29 2005 - rich.burridge@sun.com
- Adjusted to put files under /usr/sfw
* Thu Aug 25 2005 - rich.burridge@sun.com
- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
* Mon Aug 22 2005 - rich.burridge@sun.com
- Adjustments needed to make the package proto maps equivalent to what gets
installed via "make install"
* Thu Aug 11 2005 - rich.burridge@sun.com
- initial version