19997N/A#
19997N/A# spec file for package SUNWpygtk2-26 aka library/python-2/gtk2-26
19997N/A#
19997N/A# includes module(s): pygtk2
19997N/A#
20890N/A# Copyright (c) 2005, 2012, Oracle and/or its affiliates. All rights reserved.
19997N/A#
19997N/A# This file and all modifications and additions to the pristine
19997N/A# package are under the same license as the package itself.
19997N/A#
19997N/A%define owner laca
19997N/A#
19997N/A%include Solaris.inc
19997N/A%define pythonver 2.6
19997N/A%define python_version %{pythonver}
19997N/A
19997N/A%use pygtk2 = pygtk2.spec
19997N/A
19997N/AName: SUNWpygtk2-26
19997N/AIPS_package_name: library/python-2/pygtk2-26
19997N/AMeta(info.classification): %{classification_prefix}:Development/Python
19997N/ASummary: Python 2.6 bindings for the Gtk+ library
19997N/AVersion: %{pygtk2.version}
19997N/ASUNW_BaseDir: %{_basedir}
19997N/ASUNW_Copyright: %{name}.copyright
19997N/ALicense: %{pygtk2.license}
19997N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
19997N/A
19997N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
20890N/ARequires: library/desktop/gtk2
20890N/ARequires: runtime/python-26
19997N/A# for numpy
20893N/ARequires: library/python-2/python-extra-26
20893N/ARequires: library/python-2/pygobject-26
20892N/ARequires: library/python-2/pycairo-26
20890N/ARequires: library/desktop/libglade
20890N/ABuildRequires: library/desktop/gtk2
20890N/ABuildRequires: runtime/python-26
20890N/ABuildRequires: library/python-2/python-extra-26
20890N/ABuildRequires: library/python-2/setuptools-26
20890N/ABuildRequires: library/python-2/pygobject-26
20890N/ABuildRequires: library/python-2/pycairo-26
20890N/ABuildRequires: library/desktop/libglade
20890N/ABuildRequires: text/gnu-sed
19997N/A
19997N/A%package devel
19997N/ASummary: %{summary} - development files
19997N/ASUNW_BaseDir: %{_basedir}
19997N/A
19997N/A%prep
19997N/Arm -rf %name-%version
19997N/Amkdir %name-%version
19997N/A%pygtk2.prep -d %name-%version
19997N/A
19997N/A%build
19997N/APKG_CONFIG_DISABLE_UNINSTALLED=
19997N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
19997N/A
19997N/Aexport PYTHON="/usr/bin/python2.6"
19997N/Aexport CPPFLAGS="-I/usr/xpg4/include -I/usr/include/python%{pythonver}"
19997N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
19997N/Aexport RPM_OPT_FLAGS="$CFLAGS"
19997N/Aexport LDFLAGS="%_ldflags"
19997N/Aexport PYCC_CC="$CC"
19997N/Aexport PYCC_CXX="$CXX"
19997N/A
19997N/A%pygtk2.build -d %name-%version
19997N/A
19997N/A%install
19997N/Arm -rf $RPM_BUILD_ROOT
19997N/A%pygtk2.install -d %name-%version
19997N/A
19997N/A# move to vendor-packages
19997N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
19997N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
19997N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
19997N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
19997N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
19997N/Afi
19997N/A
19997N/A# Move demo to demo directory.
19997N/A#
19997N/Ainstall -d $RPM_BUILD_ROOT%{_prefix}/demo/jds/bin
19997N/Amv $RPM_BUILD_ROOT%{_bindir}/pygtk-demo $RPM_BUILD_ROOT%{_prefix}/demo/jds/bin/pygtk-demo-2.6
19997N/A
19997N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
19997N/A
19997N/A%clean
19997N/Arm -rf $RPM_BUILD_ROOT
19997N/A
19997N/A%files
19997N/A%defattr(-, root, bin)
19997N/A%dir %attr (0755, root, bin) %{_libdir}
19997N/A%{_libdir}/python?.?/vendor-packages
19997N/A%dir %attr (0755, root, bin) %{_bindir}
19997N/A%{_bindir}/*
19997N/A
19997N/A%files devel
19997N/A%defattr(-, root, bin)
19997N/A%dir %attr (0755, root, bin) %{_includedir}
19997N/A%{_includedir}/*
19997N/A%dir %attr (0755, root, bin) %{_libdir}
19997N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
19997N/A%{_libdir}/pkgconfig/*
19997N/A%{_libdir}/pygtk
19997N/A%dir %attr (0755, root, sys) %{_datadir}
19997N/A%{_datadir}/*
19997N/A%dir %attr (0755, root, bin) %dir %{_prefix}/demo
19997N/A%dir %attr (0755, root, bin) %dir %{_prefix}/demo/jds
19997N/A%dir %attr (0755, root, bin) %dir %{_prefix}/demo/jds/bin
19997N/A%{_prefix}/demo/jds/bin/pygtk-demo-2.6
19997N/A
19997N/A%changelog
20890N/A* Fri Feb 10 2012 - padraig.obriain@oracle.com
20890N/A- Update Requires and BuildRequires to be IPS package names.
19997N/A* Fri Feb 4 2010 - laszlo.peter@oracle.com
19997N/A- created, based on SUNWgnome-python26-libs.spec
19997N/A* Wed Sep 23 2009 - brian.cameron@sun.com
19997N/A- Use PKG_CONFIG_TOP_BUILD_DIR environment variable when building pygtk and
19997N/A pygtksourceview, so that pkg-config expands $(top_builddir), otherwise
19997N/A pygobject pkg-config variables do not expand nicely and the build fails.
19997N/A* Sat Jun 20 2009 - christian.kelly@sun.com
19997N/A- Minor pkg'ing fix.
19997N/A* Wed Mar 25 2009 - li.yuan@sun.com
19997N/A- Move pyspi from SUNWgnome-python-libs to SUNWgnome-a11y-libs.
19997N/A* Mon Feb 2 2009 - laca@sun.com
19997N/A- created, based on SUNWgnome-python25-libs.spec
19997N/A* Tue Nov 25 2008 - laca@sun.com
19997N/A- get rid of SUNWgnome-python-libs-common because there are no files
19997N/A that we can share between 2.4 and 2.5.
19997N/A* Mon Nov 24 2008 - laca@sun.com
19997N/A- created, based on SUNWPython-extra.spec
19997N/A* Wed Sep 17 2008 - laca@sun.com
19997N/A- set PYTHON to python2.4 (instead of just python) to make sure the
19997N/A right version is used for the build
19997N/A* Tue Aug 12 2008 - damien.carbery@sun.com
19997N/A- Add %{_libdir}/libpyglib-2.0.so* to %files.
19997N/A* Mon Aug 11 2008 - damien.carbery@sun.com
19997N/A- Move site-packages to vendor-packages here because pygobject 2.15.2 borked
19997N/A when vendor-packages was specified by pyexecdir and pythondir in make
19997N/A install.
19997N/A* Tue Oct 16 2007 - damien.carbery@sun.com
19997N/A- Remove unnecessary environment variable settings.
19997N/A* Mon Oct 8 2007 - damien.carbery@sun.com
19997N/A- Add SUNWgnome-gtksourceview dependency as it is required to by
19997N/A pygtksourceview.
19997N/A* Sun Oct 7 2007 - damien.carbery@sun.com
19997N/A- Add pygtksourceview as it is required to build python bindings in gedit.
19997N/A* Fri Sep 28 2007 - laca@sun.com
19997N/A- delete some unnecessary env vars
19997N/A* Fri Aug 31 2007 - damien.carbery@sun.com
19997N/A- Remove pygtksourceview.spec. It is still not building and isn't required.
19997N/A* Thu Jul 05 2007 - damien.carbery@sun.com
19997N/A- Add pygtksourceview.spec, but disable it because it is not building yet.
19997N/A* Tue Jan 9 2007 - laca@sun.com
19997N/A- define PYCC_CC and PYCC_CXX to override what the configure script sets
19997N/A in CC/CXX
19997N/A* Mon Aug 28 2006 - damien.carbery@sun.com
19997N/A- Fix typo in PKG_CONFIG_PATH data (s/=/-/).
19997N/A* Sun Jun 11 2006 - laca@sun.com
19997N/A- change group from other to bin/sys
19997N/A* Fri May 12 2006 - damien.carbery@sun.com
19997N/A- Small update to dependency list after check-deps.pl run.
19997N/A* Thu May 11 2006 - brian.cameron@sun.com
19997N/A- Move pygtk-demo to demo directory.
19997N/A* Wed Apr 5 2006 - damien.carbery@sun.com
19997N/A- Add pygobject. It has been moved from pygtk2.
19997N/A* Mon Feb 20 2006 - damien.carbery@sun.com
19997N/A- Complete update of Build/Requires after running check-deps.pl script.
19997N/A* Fri Feb 17 2006 - damien.carbery@sun.com
19997N/A- Update Build/Requires after running check-deps.pl script.
19997N/A* Mon Jan 09 2006 - damien.carbery@sun.com
19997N/A- Add gnome-vfs module.
19997N/A* Thu Oct 27 2005 - laca@sun.com
19997N/A- add pygtk2
19997N/A* Tue Sep 20 2005 - laca@sun.com
19997N/A- move to /usr as Python was also moved there
19997N/A* Thu Sep 01 2005 - damien.carbery@sun.com
19997N/A- Remove unused pygtk2 references.
19997N/A* Wed Aug 30 2005 - damien.carbery@sun.com
19997N/A- Add Build/Requires for SUNWgnome-file-mgr (nautilus) and SUNWgnome-print
19997N/A (libgnomeprint/libgnomeprintui) so that those submodules will be built.
19997N/A* Mon Aug 29 2005 - rich.burridge@sun.com
19997N/A- Adjusted to put files under /usr/sfw
19997N/A* Thu Aug 25 2005 - rich.burridge@sun.com
19997N/A- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
19997N/A* Mon Aug 22 2005 - rich.burridge@sun.com
19997N/A- Adjustments needed to make the package proto maps equivalent to what gets
19997N/A installed via "make install"
19997N/A* Thu Aug 11 2005 - rich.burridge@sun.com
19997N/A- initial version
19997N/A
19997N/A
19997N/A