SUNWpygobject26.spec revision 20857
10139N/A#
10139N/A# spec file for package SUNWpygobject26 aka library/python-2/pygobject-26
10139N/A#
12147N/A# includes module(s): pygobject
10139N/A#
10139N/A# Copyright (c) 2005, 2011, Oracle and/or its affiliates. All rights reserved.
10139N/A#
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner laca
10139N/A#
13497N/A%include Solaris.inc
10139N/A%define pythonver 2.6
10139N/A%define python_version %{pythonver}
10139N/A
10139N/A%use pygobject = pygobject.spec
13400N/A
10139N/AName: SUNWpygobject26
10139N/AIPS_package_name: library/python-2/pygobject-26
10139N/AMeta(info.classification): %{classification_prefix}:Development/Python
10139N/ASummary: Python 2.6 bindings for the GObject library
10139N/AVersion: %{pygobject.version}
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ALicense: %{pygobject.license}
10491N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10491N/A
10491N/A%include default-depend.inc
10491N/A%include gnome-incorporation.inc
12088N/ARequires: SUNWPython26
10139N/ABuildRequires: SUNWglib2
12088N/ABuildRequires: SUNWPython26-devel
10139N/ABuildRequires: SUNWglib2-devel
12088N/ABuildRequires: SUNWgsed
12176N/ABuildRequires: SUNWpython26-setuptools
12196N/ABuildRequires: SUNWgtk-doc
12306N/A
12368N/A%package devel
13088N/ASummary: %{summary} - development files
13278N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10139N/ARequires: %name
10139N/ARequires: SUNWPython26
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%pygobject.prep -d %name-%version
10139N/A
10139N/A%build
10139N/APKG_CONFIG_DISABLE_UNINSTALLED=
10139N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
10139N/A
10139N/Aexport PYTHON="/usr/bin/python2.6"
10139N/Aexport CPPFLAGS="-I/usr/xpg4/include -I/usr/include/python%{pythonver}"
10139N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/Aexport PYCC_CC="$CC"
10139N/Aexport PYCC_CXX="$CXX"
10139N/A
10139N/A%pygobject.build -d %name-%version
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%pygobject.install -d %name-%version
10139N/A
10139N/A# move to vendor-packages
10139N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
10139N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10139N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
10139N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
10139N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
10139N/Afi
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
12819N/A
12288N/A%clean
13278N/Arm -rf $RPM_BUILD_ROOT
10139N/A
11330N/A%files
11330N/A%defattr(-, root, bin)
11330N/A%dir %attr (0755, root, bin) %{_libdir}
11330N/A%{_libdir}/python?.?/vendor-packages
11330N/A%{_libdir}/libpyglib-2.0-python2.6.so*
11330N/A%dir %attr (0755, root, bin) %{_bindir}
11330N/A%{_bindir}/*
11330N/A
11330N/A%files devel
10139N/A%defattr(-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%{_datadir}/*
10139N/A
10139N/A%changelog
10139N/A* Fri Feb 4 2010 - laszlo.peter@oracle.com
10139N/A- created, based on SUNWgnome-python26-libs.spec
11314N/A* Wed Sep 23 2009 - brian.cameron@sun.com
11314N/A- Use PKG_CONFIG_TOP_BUILD_DIR environment variable when building pygtk and
11314N/A pygtksourceview, so that pkg-config expands $(top_builddir), otherwise
11320N/A pygobject pkg-config variables do not expand nicely and the build fails.
11314N/A* Sat Jun 20 2009 - christian.kelly@sun.com
11314N/A- Minor pkg'ing fix.
10139N/A* Wed Mar 25 2009 - li.yuan@sun.com
10139N/A- Move pyspi from SUNWgnome-python-libs to SUNWgnome-a11y-libs.
10139N/A* Mon Feb 2 2009 - laca@sun.com
10139N/A- created, based on SUNWgnome-python25-libs.spec
10139N/A* Tue Nov 25 2008 - laca@sun.com
10139N/A- get rid of SUNWgnome-python-libs-common because there are no files
10318N/A that we can share between 2.4 and 2.5.
10318N/A* Mon Nov 24 2008 - laca@sun.com
10318N/A- created, based on SUNWPython-extra.spec
10318N/A* Wed Sep 17 2008 - laca@sun.com
10318N/A- set PYTHON to python2.4 (instead of just python) to make sure the
10318N/A right version is used for the build
10318N/A* Tue Aug 12 2008 - damien.carbery@sun.com
10139N/A- Add %{_libdir}/libpyglib-2.0.so* to %files.
12140N/A* Mon Aug 11 2008 - damien.carbery@sun.com
11314N/A- Move site-packages to vendor-packages here because pygobject 2.15.2 borked
10139N/A when vendor-packages was specified by pyexecdir and pythondir in make
10139N/A install.
10139N/A* Tue Oct 16 2007 - damien.carbery@sun.com
10139N/A- Remove unnecessary environment variable settings.
10139N/A* Mon Oct 8 2007 - damien.carbery@sun.com
10139N/A- Add SUNWgnome-gtksourceview dependency as it is required to by
10139N/A pygtksourceview.
10139N/A* Sun Oct 7 2007 - damien.carbery@sun.com
10139N/A- Add pygtksourceview as it is required to build python bindings in gedit.
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- delete some unnecessary env vars
10139N/A* Fri Aug 31 2007 - damien.carbery@sun.com
10139N/A- Remove pygtksourceview.spec. It is still not building and isn't required.
10139N/A* Thu Jul 05 2007 - damien.carbery@sun.com
10139N/A- Add pygtksourceview.spec, but disable it because it is not building yet.
10139N/A* Tue Jan 9 2007 - laca@sun.com
10139N/A- define PYCC_CC and PYCC_CXX to override what the configure script sets
10139N/A in CC/CXX
10139N/A* Mon Aug 28 2006 - damien.carbery@sun.com
10139N/A- Fix typo in PKG_CONFIG_PATH data (s/=/-/).
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Fri May 12 2006 - damien.carbery@sun.com
10139N/A- Small update to dependency list after check-deps.pl run.
10139N/A* Thu May 11 2006 - brian.cameron@sun.com
10139N/A- Move pygtk-demo to demo directory.
10139N/A* Wed Apr 5 2006 - damien.carbery@sun.com
10139N/A- Add pygobject. It has been moved from pygtk2.
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Complete update of Build/Requires after running check-deps.pl script.
10139N/A* Fri Feb 17 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Mon Jan 09 2006 - damien.carbery@sun.com
10139N/A- Add gnome-vfs module.
10139N/A* Thu Oct 27 2005 - laca@sun.com
10139N/A- add pygtk2
10139N/A* Tue Sep 20 2005 - laca@sun.com
10139N/A- move to /usr as Python was also moved there
10139N/A* Thu Sep 01 2005 - damien.carbery@sun.com
10139N/A- Remove unused pygtk2 references.
13497N/A* Wed Aug 30 2005 - damien.carbery@sun.com
13497N/A- Add Build/Requires for SUNWgnome-file-mgr (nautilus) and SUNWgnome-print
13400N/A (libgnomeprint/libgnomeprintui) so that those submodules will be built.
13400N/A* Mon Aug 29 2005 - rich.burridge@sun.com
13278N/A- Adjusted to put files under /usr/sfw
13278N/A* Thu Aug 25 2005 - rich.burridge@sun.com
13278N/A- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
13109N/A* Mon Aug 22 2005 - rich.burridge@sun.com
13109N/A- Adjustments needed to make the package proto maps equivalent to what gets
13088N/A installed via "make install"
13088N/A* Thu Aug 11 2005 - rich.burridge@sun.com
13088N/A- initial version
13088N/A
13055N/A
13055N/A
12819N/A