10139N/A#
10139N/A# spec file for package SUNWjdsrm
10139N/A#
10139N/A# includes module(s): SUNWjdsver.spec
10139N/A#
10139N/A# Copyright (c) 2004 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner laca
10139N/A#
10139N/A# DO NOT REMOVE NEXT LINE
10139N/A# PACKAGE NOT ARC REVIEWED BY SUN JDS TEAM
10139N/A#
10139N/A%include Solaris.inc
10139N/A
10139N/A%use jdsver = SunDesktopVersion.spec
10139N/A
10139N/AName: SUNWjdsrm
10139N/ASummary: Java Desktop System upgrade package remove
10139N/A# Note: increment the nano version in case of a respin.
10139N/A# New builds should start with a 0
10139N/A# 110 means integrated into solaris 11.0
10139N/AVersion: %{jdsver.prodRelMajor}.%{jdsver.prodBuild}.0
10139N/ASUNW_Category: JDS,system,%{jds_version}
10139N/ASUNW_BaseDir: /
12790N/ASUNW_Copyright: %{name}.copyright
19140N/ALicense: %{jdsver.license}
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20857N/A%include gnome-incorporation.inc
10139N/A%include default-depend.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A
10139N/A
10139N/A%post
10139N/A#
10139N/A# JDS clean up for packages with non-standard package version strings
10139N/A# Note: Any pkg using SUNWjdsrm to remove a previous version,
10139N/A# Must add SUNWjdsrm to it's package depend file to ensure the
10139N/A# removal of the previous version before the addition of the
10139N/A# new version.
10139N/A#
10139N/APKG="SUNWglow SUNWjai-imageio SUNWjmf SUNWjmfmp3 SUNWjdsver SUNWjpeg SUNWjpegx SUNWtiff SUNWtiffx"
10139N/Acat > /tmp/admin.dflt.$$ << EOF
10139N/Amail=
10139N/Ainstance=overwrite
10139N/Apartial=nocheck
10139N/Arunlevel=nocheck
10139N/Aidepend=nocheck
10139N/Ardepend=nocheck
10139N/Aspace=nocheck
10139N/Asetuid=nocheck
10139N/Aconflict=nocheck
10139N/Aaction=nocheck
10139N/Abasedir=default
10139N/AEOF
10139N/A
10139N/AREM_SCRIPT=/tmp/pkgremoval.$PKGINST.$$
10139N/Aecho "PATH=/usr/sadm/bin:$PATH" > $REM_SCRIPT
10139N/Ado_pkgrm() {
10139N/A echo "sleep 3" >> $REM_SCRIPT
10139N/A echo "echo Now removing old instance of $1" >> $REM_SCRIPT
10139N/A eval echo `gettext SUNW_INSTALL_LIBSVC 'Removing package $1:'`
10139N/A if [ -n "${PKG_INSTALL_ROOT}" ]; then
10139N/A if [ -f ${PKG_INSTALL_ROOT}/var/sadm/pkg/$i/install/preremove ]; then
10139N/A sed -e 's: /usr: ${PKG_INSTALL_ROOT}/usr:' ${PKG_INSTALL_ROOT}/var/sadm/pkg/$i/install/preremove > /tmp/$i.pkgremove.$$
10139N/A cp /tmp/$i.pkgremove.$$ ${PKG_INSTALL_ROOT}/var/sadm/pkg/$i/install/preremove
10139N/A rm /tmp/$i.pkgremove.$$
10139N/A fi
10139N/A echo "pkgrm -M -R ${PKG_INSTALL_ROOT} -a /tmp/admin.dflt.$$ -n $1" >> $REM_SCRIPT
10139N/A else
10139N/A echo "pkgrm -M -a /tmp/admin.dflt.$$ -n $1" >> $REM_SCRIPT
10139N/A fi
10139N/A}
10139N/A
10139N/Afor i in $PKG
10139N/Ado
10139N/A if [ -n "${PKG_INSTALL_ROOT}" ]; then
10139N/A (pkgparam -R ${PKG_INSTALL_ROOT} $i VERSION | egrep -v '^[0-9.]+$|^[0-9.]+,REV=[0-9.]+$') > /dev/null 2>&1
10139N/A else
10139N/A (pkgparam $i VERSION | egrep -v '^[0-9.]+$|^[0-9.]+,REV=[0-9.]+$') > /dev/null 2>&1
10139N/A fi
10139N/A exist=$?
10139N/A if [ $exist -eq 0 ] ; then
10139N/A do_pkgrm $i
10139N/A fi
10139N/Adone
10139N/A
10139N/Aif [ -f $REM_SCRIPT ]; then
10139N/A sh $REM_SCRIPT &
10139N/Afi
10139N/A
10139N/Aexit 0
10139N/A
10139N/A
10139N/A%changelog
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Thu May 25 2006 - shirley.woo@sun.com
10139N/A- Updated package version string to remove "110" from the VERSION.
10139N/A This makes it consistent with SUNWjdsver.
10139N/A* Tue Nov 05 2004 - shirley.woo@sun.com
10139N/A- Bug 4810847 & 6185753: Initial Creation
19320N/A
19637N/A