12606N/A#
12606N/A# spec file for package SUNWgobby
18951N/A#
12606N/A# Copyright 2010 Sun Microsystems, Inc.
12606N/A# This file and all modifications and additions to the pristine
12606N/A# package are under the same license as the package itself.
12606N/A#
17185N/A%define owner kevmca
12606N/A#
18644N/A
17182N/A%include Solaris.inc
12606N/A
12606N/A%define OSR 9643:0.4
12747N/A
12747N/AName: SUNWgobby
18951N/AIPS_package_name: editor/gobby
12606N/AMeta(info.classification): %{classification_prefix}:Development/Editors,%{classification_prefix}:System/Text Tools
12606N/ALicense: GPLv2
19939N/ASummary: A collaborative text editor
18688N/AVersion: 0.4.12
12606N/ASource: http://releases.0x539.de/gobby/gobby-%{version}.tar.gz
18970N/ASource1: l10n-configure.sh
19013N/A# owner:trisk date:2007-8-17 type:bug
12645N/APatch1: gobby-01-prototype.diff
19934N/A# owner:trisk date:2007-8-17 type:bug
20096N/APatch2: gobby-02-const.diff
20127N/A# owner:trisk date:2007-8-17 type:bug
20829N/APatch3: gobby-03-auto_ptr.diff
12773N/A# owner:mattman date:2009-02-27 type:branding
12606N/APatch8: gobby-08-manpage.diff
12771N/ASUNW_Basedir: %{_basedir}
12606N/ASUNW_Copyright: %{name}.copyright
12606N/AURL: http://gobby.0x539.de/
12606N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20857N/A
16401N/A%include default-depend.inc
12606N/A%include desktop-incorporation.inc
12606N/ARequires: SUNWgtk2
18993N/ARequires: SUNWgnutls
20348N/ARequires: SUNWobby
20857N/ARequires: SUNWgnome-gtksourceview
17266N/ARequires: SUNWgnome-libs
17266N/ARequires: SUNWlibxmlpp
17266N/ARequires: SUNWgtkmm
12606N/ARequires: SUNWdesktop-cache
12606N/ABuildRequires: SUNWgtk2-devel
12606N/ABuildRequires: SUNWgnutls-devel
12606N/ABuildRequires: SUNWobby-devel
12606N/ABuildRequires: SUNWgnome-gtksourceview-devel
12606N/ABuildRequires: SUNWgnome-libs-devel
12606N/ABuildRequires: SUNWlibxmlpp-devel
12606N/ABuildRequires: SUNWgtkmm-devel
19934N/A
20096N/A%package l10n
20127N/ASummary: %{summary} - l10n files
20829N/ARequires: %{name}
19934N/A
12606N/A%description
12606N/AGobby is a free collaborative editor. This means that it
12606N/Aprovides you with the possibility to edit files simultaneously
12606N/Awith other users over a network. It supports multiple
12645N/Adocuments in one session and a multi-user chat. The platforms
12773N/Aon which you could use Gobby are so far Microsoft Windows,
12773N/ALinux, Mac OS X and other Unix-like ones. Developed with the
12773N/AGtk+ toolkit it integrates nicely into the GNOME desktop
12606N/Aenvironment if you want it to.
12606N/A
12606N/A%prep
12606N/A%setup -q -n gobby-%version
12606N/Abash %SOURCE1 --enable-sun-linguas
12606N/A
12606N/A%patch1 -p1
12606N/A%patch2 -p1
12606N/A%patch3 -p1
12606N/A%patch8 -p1
12606N/A
12606N/A%build
12606N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12606N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20096N/A CPUS=1
20096N/Afi
20096N/A
20096N/A# compiler seems to run out of space when running on a 24-core system
20096N/Aif [ $CPUS -gt 4 ]; then
20096N/A CPUS=4
20096N/Afi
20096N/A
20096N/ACXXFLAGS="-xO2"
20096N/Aexport LDFLAGS="%_ldflags"
20096N/A
20096N/A%if %cc_is_gcc
20096N/A%else
20096N/Aexport CXX="${CXX} -norunpath"
20096N/A%endif
20096N/A
20096N/Aintltoolize --copy --force --automake
12606N/A
12606N/Abash -x %SOURCE1 --enable-copyright
12606N/A
12606N/Aaclocal -I m4
12606N/Aautoconf
12606N/Aautomake -a --copy --force
12606N/A./configure --prefix=%{_prefix} --mandir=%{_mandir} \
12606N/A --libdir=%{_libdir} \
12606N/A --libexecdir=%{_libexecdir} \
12606N/A --sysconfdir=%{_sysconfdir} \
12606N/A --with-gnome
12606N/A
12606N/Amake -j$CPUS
13825N/A
20096N/A%install
20096N/Arm -rf $RPM_BUILD_ROOT
20096N/Amake install DESTDIR=$RPM_BUILD_ROOT
12606N/A
12606N/A%clean
12606N/Arm -rf $RPM_BUILD_ROOT
12606N/A
12606N/A%post
12606N/A%restart_fmri icon-cache desktop-mime-cache
13056N/A
20115N/A%postun
20127N/A%restart_fmri desktop-mime-cache
20127N/A
20127N/A%files
20127N/A%doc AUTHORS
20115N/A%doc(bzip2) COPYING NEWS ChangeLog README
20114N/A%dir %attr (0755, root, sys) %{_datadir}
20096N/A%dir %attr (0755, root, other) %{_datadir}/doc
20096N/A%defattr (-, root, bin)
20096N/A%dir %attr (0755, root, bin) %{_bindir}
18951N/A%{_bindir}/*
18951N/A%dir %attr (0755, root, other) %{_datadir}/applications
18951N/A%{_datadir}/applications/*
18951N/A%dir %attr (0755, root, other) %{_datadir}/icons
13825N/A%attr (0755, root, other) %{_datadir}/icons/*
13825N/A%{_datadir}/gobby
13056N/A%dir %attr(0755, root, bin) %{_mandir}
13056N/A%dir %attr(0755, root, bin) %{_mandir}/man1
12606N/A%{_mandir}/man1/*
13015N/A
13015N/A%files l10n
13015N/A%defattr (-, root, bin)
13015N/A%dir %attr (0755, root, sys) %{_datadir}
12645N/A%attr (-, root, other) %{_datadir}/locale
12645N/A
12645N/A%changelog
12645N/A* Wed Jan 27 2010 - brian.cameron@sun.com
12643N/A- Bump to 0.4.12.
12643N/A* Fri Apr 3 2009 - laca@sun.com
12643N/A- use desktop-cache instead of postrun.
12606N/A* Tue Mar 3 2009 - kevin.mcareavey@sun.com
12606N/A- Bump to 0.4.10.
12606N/A* Fri Feb 27 2009 - matt.keenan@sun.com
12606N/A- Add manpage patch for Attributes and ARC Comment.
12606N/A* Mon Dec 22 2008 - takao.fujiwara@sun.com
12606N/A- Add gobby-06-g11n-desktop.diff for desktop.in
12606N/A- Add gobby-07-g11n-po.diff for upstreamed translations.
12606N/A* Fri Nov 28 2008 - takao.fujiwara@sun.com
12606N/A- Add gobby-04-g11n-encoding.diff to support the current encoding.
12606N/A- Add gobby-05-g11n-filename.diff to show the status on none UTF-8 locales.
12606N/A* Tue Sep 23 2008 - dave.lin@sun.com
12606N/A- Set attribute to %{_datadir} in base & l10n pkg.
12606N/A* Fri Sep 19 2008 - kevin.mcareavey@sun.com
12606N/A- Changed %doc files to bzip2.
12606N/A- Changed %post and %postun to use scripts.
12606N/A* Thu Sep 18 2008 - kevin.mcareavey@sun.com
12606N/A- Cleanup for spec-files-other integration.
12606N/A* Wed Nov 14 2007 - daymobrew@users.sourceforge.net
12606N/A- Add l10n package.
12606N/A* Mon Sep 17 2007 - trisk@acm.jhu.edu
12606N/A- Bump to 0.4.5.
12606N/A* Fri Aug 17 2007 - trisk@acm.jhu.edu
12606N/A- Initial version.
12606N/A