SUNWgnu-findutils.spec revision 20190
10139N/A#
10139N/A# spec file for package SUNWgnu-findutils
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
16307N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner gheet
10139N/A#
17820N/A
10139N/A%include Solaris.inc
10139N/A
10139N/A%define OSR 9641:4.2.32
10139N/A
10139N/A%define _gnudir %{_basedir}/gnu
10139N/A%define _gnubin %{_gnudir}/bin
19095N/A%define _gnudata %{_gnudir}/share
18688N/A%define _gnuman %{_gnudata}/man
18688N/A
10139N/A# Do NOT bump past 4.2.31. Later versions are GPLv3 and this needs to be
19013N/A# reviewed and approved before we can release with the newer license.
10139N/A
10139N/AName: SUNWgnu-findutils
12700N/AIPS_package_name: file/gnu-findutils
10139N/AMeta(info.classification): %{classification_prefix}:Applications/System Utilities
20857N/ALicense: GPLv2
10139N/AVendor: www.gnu.org/software/findutils
16401N/ASummary: GNU utilities find and xargs
10139N/AVersion: 4.2.31
10139N/ASource: http://ftp.gnu.org/pub/gnu/findutils/findutils-%{version}.tar.gz
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A# owner:mattman date:2009-02-27 type:branding
10139N/APatch1: gnu-findutils-01-manpages.diff
10139N/A%endif
10139N/AURL: http://www.gnu.org/software/findutils/
10139N/ASUNW_BaseDir: %{_basedir}
16307N/ASUNW_Copyright: %{name}.copyright
16401N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A%include default-depend.inc
18850N/A%include gnome-consolidation.inc
10139N/A
10139N/A%if %build_l10n
10139N/A%package l10n
10139N/AIPS_package_name: file/gnu-findutils/l10n
10139N/ASummary: %{summary} - l10n files
10139N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_dto_il10n_basedir}
10139N/A%include default-depend.inc
10139N/ARequires: %{name}
10139N/A%endif
10139N/A
10139N/A%description
10139N/AThe GNU Find Utilities are the basic directory searching utilities of
10139N/Athe GNU operating system. These programs are typically used in
10139N/Aconjunction with other programs to provide modular and powerful
10139N/Adirectory search and file locating capabilities to other commands. The
10139N/Atools supplied with this package are: find - search for files in a
10139N/Adirectory hierarchy and xargs - build and execute command lines from standard input.
10139N/A
12175N/A%prep
10139N/A%setup -q -n findutils-%version
10139N/A%if %build_l10n
12175N/A%patch1 -p1
10139N/A%endif
10139N/A
10139N/A%build
10139N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport CFLAGS="%optflags"
10139N/A
10139N/A%if %build_l10n
10139N/Ash %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A./configure --disable-leaf-optimisation \
10139N/A --prefix=%{_gnudir} \
10139N/A --mandir=%{_gnuman} \
10139N/A --infodir=%{_gnudata}/info \
16307N/A --libexecdir=%{_gnudir}/lib
10139N/A
10139N/Amake -j$CPUS
16307N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Armdir $RPM_BUILD_ROOT%{_gnudir}%{_localstatedir}
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnudir}/lib/charset.alias
10139N/A
10139N/A#remove unused files
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnudir}/lib
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnudata}/info/dir
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnubin}/locate
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/glocate.1
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnubin}/updatedb
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/gupdatedb.1
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man5
10139N/A
10139N/A#create links in gnu dir
10139N/Acd $RPM_BUILD_ROOT
10139N/Ainstall -m 755 -d usr/bin
14247N/A
14247N/Aln -s ../gnu/bin/find usr/bin/gfind
14247N/Aln -s ../gnu/bin/xargs usr/bin/gxargs
10139N/Ainstall -m 755 -d usr/share/man/man1
10139N/Aln -s ../../../gnu/share/man/man1/find.1 usr/share/man/man1/gfind.1
10139N/Aln -s ../../../gnu/share/man/man1/xargs.1 usr/share/man/man1/gxargs.1
10139N/A
10139N/A%if %build_l10n
10139N/A%else
10139N/A# REMOVE l10n FILES
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnudata}/locale
16162N/A%endif
10139N/A
10139N/A%clean
10522N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%doc COPYING AUTHORS NEWS ChangeLog README THANKS
10139N/A%dir %attr (0755, root, other) %{_datadir}/doc
18850N/A%defattr (-, root, bin)
18850N/A%dir %attr (0755, root, bin) %{_bindir}
16307N/A%{_bindir}/*
16307N/A%dir %attr (0755, root, sys) %{_datadir}
16162N/A%{_gnudata}/info
16162N/A%{_mandir}
14247N/A%dir %attr (0755, root, bin) %{_gnubin}
14247N/A%{_gnubin}/*
12175N/A%dir %attr (0755, root, sys) %{_gnudata}
12175N/A%{_gnuman}
12175N/A
12175N/A%if %build_l10n
12112N/A%files l10n
12112N/A%defattr (-, root, bin)
10522N/A%dir %attr (0755, root, sys) %{_gnudata}
10522N/A%dir %attr (-, root, bin) %{_gnudata}/locale
10336N/A%{_gnudata}/locale/*
10336N/A%endif
10336N/A
10139N/A%changelog
10139N/A* Thu Apr 07 2011 - ghee.teo@oracle.com
10139N/A- Fixes bugster#7031707.
10139N/A* Tue Aug 25 2009 - brian.cameron@sun.com
10139N/A- Rever to 4.2.31. Newer versions are GPLv3.
10139N/A* Tue Aug 25 2009 - brian.cameron@sun.com
10139N/A- Bump to 4.2.33.
10139N/A* Fri Feb 27 2009 - matt.keenan@sun.com
10139N/A- Add manpage patch for Attributes and ARC Comment
10139N/A* Thu Sep 11 2008 - kevin.mcareavey@sun.com
10139N/A- Add %doc to %files for copyright
10139N/A* Fri Aug 15 2008 - kevin.mcareavey@sun.com
10139N/A- Cleanup for spec-files-other integration
10139N/A- Rollback to 4.2.31 for GPLv2
10139N/A- Create links in gnu directory
10139N/A- Remove unused files
10139N/A* Thu Feb 21 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 4.2.33
10139N/A* Thu Nov 15 2007 - daymobrew@users.sourceforge.net
10139N/A- Correct path to charset.alias file.
10139N/A* Sun Oct 14 2007 - laca@sun.com
10139N/A- fix l10n installation
10139N/A* Tue Sep 18 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 4.2.31
10139N/A* Sun Sep 24 2006 - Eric Boutilier
10139N/A- Initial spec
10139N/A
10139N/A
10139N/A