SUNWgnu-findutils.spec revision 20179
10139N/A#
10139N/A# spec file for package SUNWgnu-findutils
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner gheet
10139N/A#
17185N/A
10139N/A%include Solaris.inc
10139N/A
10374N/A%define OSR 9641:4.2.32
10374N/A
10374N/A%define _gnudir %{_basedir}/gnu
10374N/A%define _gnubin %{_gnudir}/bin
10374N/A%define _gnudata %{_gnudir}/share
10374N/A%define _gnuman %{_gnudata}/man
10374N/A
10139N/A# Do NOT bump past 4.2.31. Later versions are GPLv3 and this needs to be
10139N/A# reviewed and approved before we can release with the newer license.
10139N/A
19093N/AName: SUNWgnu-findutils
18688N/AIPS_package_name: file/gnu-findutils
18688N/AMeta(info.classification): %{classification_prefix}:Applications/System Utilities
10139N/ALicense: GPLv2
10139N/AVendor: www.gnu.org/software/findutils
10139N/ASummary: GNU utilities find and xargs
12673N/AVersion: 4.2.31
10139N/ASource: http://ftp.gnu.org/pub/gnu/findutils/findutils-%{version}.tar.gz
10139N/A%if %build_l10n
20857N/ASource1: l10n-configure.sh
20857N/A# owner:mattman date:2009-02-27 type:branding
10139N/APatch1: gnu-findutils-01-manpages.diff
10139N/A%endif
13710N/AURL: http://www.gnu.org/software/findutils/
13710N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A%include default-depend.inc
10139N/A%include gnome-consolidation.inc
20857N/A
10139N/A%if %build_l10n
10139N/A%package l10n
10139N/AIPS_package_name: file/gnu-findutils/l10n
10139N/ASummary: %{summary} - l10n files
10139N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_dto_il10n_basedir}
10374N/A%include default-depend.inc
10374N/ARequires: %{name}
10374N/A%endif
10374N/A
10374N/A%description
10374N/AThe GNU Find Utilities are the basic directory searching utilities of
10374N/Athe GNU operating system. These programs are typically used in
10139N/Aconjunction with other programs to provide modular and powerful
13710N/Adirectory search and file locating capabilities to other commands. The
13710N/Atools supplied with this package are: find - search for files in a
13710N/Adirectory hierarchy and xargs - build and execute command lines from standard input.
13710N/A
13710N/A%prep
10139N/A%setup -q -n findutils-%version
10374N/A%if %build_l10n
10374N/A%patch1 -p1
10374N/A%endif
10374N/A
10374N/A%build
10139N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10374N/A CPUS=1
10374N/Afi
10374N/A
16029N/Aexport CFLAGS="%optflags"
10374N/A
10374N/A%if %build_l10n
10374N/Ash %SOURCE1 --enable-copyright
13357N/A%endif
13357N/A./configure --disable-leaf-optimisation \
16029N/A --prefix=%{_gnudir} \
10139N/A --mandir=%{_gnuman} \
13710N/A --infodir=%{_gnudata}/info \
13710N/A --libexecdir=%{_gnudir}/lib
13710N/A
10139N/Amake -j$CPUS
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
14344N/Armdir $RPM_BUILD_ROOT%{_gnudir}%{_localstatedir}
14344N/Arm -rf $RPM_BUILD_ROOT%{_gnudir}/lib/charset.alias
14344N/A
14344N/A#remove unused files
14341N/Arm -rf $RPM_BUILD_ROOT%{_gnudir}/lib
14341N/Arm -rf $RPM_BUILD_ROOT%{_gnudata}/info/dir
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnubin}/locate
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/glocate.1
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnubin}/updatedb
10374N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/gupdatedb.1
10374N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man5
10374N/A
10139N/A#create links in gnu dir
13710N/Acd $RPM_BUILD_ROOT
13710N/Ainstall -m 755 -d usr/bin
13710N/A
13710N/Aln -s ../gnu/bin/find usr/bin/gfind
13710N/Aln -s ../gnu/bin/xargs usr/bin/gxargs
13710N/Ainstall -m 755 -d usr/share/man/man1
13710N/Aln -s ../../../gnu/share/man/man1/find.1 usr/share/man/man1/gfind.1
10139N/Aln -s ../../../gnu/share/man/man1/xargs.1 usr/share/man/man1/gxargs.1
10139N/A
10139N/A%if %build_l10n
10139N/A%else
10139N/A# REMOVE l10n FILES
10139N/Arm -rf $RPM_BUILD_ROOT%{_gnudata}/locale
10139N/A%endif
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
16029N/A%files
16029N/A%doc COPYING AUTHORS NEWS ChangeLog README THANKS
14341N/A%dir %attr (0755, root, other) %{_datadir}/doc
14341N/A%defattr (-, root, bin)
13710N/A%dir %attr (0755, root, bin) %{_bindir}
13710N/A%{_bindir}/*
13357N/A%dir %attr (0755, root, sys) %{_datadir}
13357N/A%{_gnudata}/info
13357N/A%{_mandir}
10374N/A%dir %attr (0755, root, bin) %{_gnubin}
10374N/A%{_gnubin}/*
10139N/A%dir %attr (0755, root, sys) %{_gnudata}
10139N/A%{_gnuman}
10139N/A
10139N/A%if %build_l10n
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_gnudata}
10139N/A%attr (-, root, other) %{_gnudata}/locale
10139N/A%{_gnudata}/locale/*
10139N/A%endif
10139N/A
10139N/A%changelog
10139N/A* Thu Apr 07 2011 - ghee.teo@oracle.com
10139N/A- Fixes bugster#7031707.
10139N/A* Tue Aug 25 2009 - brian.cameron@sun.com
10139N/A- Rever to 4.2.31. Newer versions are GPLv3.
10139N/A* Tue Aug 25 2009 - brian.cameron@sun.com
10139N/A- Bump to 4.2.33.
10139N/A* Fri Feb 27 2009 - matt.keenan@sun.com
10139N/A- Add manpage patch for Attributes and ARC Comment
10139N/A* Thu Sep 11 2008 - kevin.mcareavey@sun.com
10139N/A- Add %doc to %files for copyright
10139N/A* Fri Aug 15 2008 - kevin.mcareavey@sun.com
10139N/A- Cleanup for spec-files-other integration
19336N/A- Rollback to 4.2.31 for GPLv2
19653N/A- Create links in gnu directory
- Remove unused files
* Thu Feb 21 2008 - nonsea@users.sourceforge.net
- Bump to 4.2.33
* Thu Nov 15 2007 - daymobrew@users.sourceforge.net
- Correct path to charset.alias file.
* Sun Oct 14 2007 - laca@sun.com
- fix l10n installation
* Tue Sep 18 2007 - nonsea@users.sourceforge.net
- Bump to 4.2.31
* Sun Sep 24 2006 - Eric Boutilier
- Initial spec