SUNWgnu-findutils.spec revision 19611
12248N/A#
12251N/A# spec file for package SUNWgnu-findutils
12248N/A#
12248N/A# Copyright (c) 2008 Sun Microsystems, Inc.
12248N/A# This file and all modifications and additions to the pristine
12248N/A# package are under the same license as the package itself.
12248N/A#
17835N/A%define owner kevmca
17835N/A#
12248N/A
17178N/A%include Solaris.inc
18603N/A
17178N/A%define OSR 9641:4.2.32
12248N/A
12248N/A%define _gnudir %{_basedir}/gnu
12248N/A%define _gnubin %{_gnudir}/bin
12248N/A%define _gnudata %{_gnudir}/share
18544N/A%define _gnuman %{_gnudata}/man
12248N/A
12248N/A# Do NOT bump past 4.2.31. Later versions are GPLv3 and this needs to be
18615N/A# reviewed and approved before we can release with the newer license.
12248N/A
18544N/AName: SUNWgnu-findutils
12773N/AIPS_package_name: file/gnu-findutils
12773N/AMeta(info.classification): %{classification_prefix}:Applications/System Utilities
12773N/ALicense: GPLv2
12248N/AVendor: www.gnu.org/software/findutils
12248N/ASummary: GNU utilities find and xargs
12248N/AVersion: 4.2.31
12248N/ASource: http://ftp.gnu.org/pub/gnu/findutils/findutils-%{version}.tar.gz
15622N/A%if %build_l10n
15338N/ASource1: l10n-configure.sh
12248N/A# owner:mattman date:2009-02-27 type:branding
12248N/APatch1: gnu-findutils-01-manpages.diff
12248N/A%endif
12248N/AURL: http://www.gnu.org/software/findutils/
12248N/ASUNW_BaseDir: %{_basedir}
12248N/ASUNW_Copyright: %{name}.copyright
12254N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12361N/A%include default-depend.inc
14531N/A
14429N/A%if %build_l10n
14472N/A%package l10n
14472N/AIPS_package_name: file/gnu-findutils/l10n
16384N/ASummary: %{summary} - l10n files
16372N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_dto_il10n_basedir}
16972N/A%include default-depend.inc
18320N/ARequires: %{name}
18595N/A%endif
18595N/A
12248N/A%description
12248N/AThe GNU Find Utilities are the basic directory searching utilities of
12248N/Athe GNU operating system. These programs are typically used in
12248N/Aconjunction with other programs to provide modular and powerful
12248N/Adirectory search and file locating capabilities to other commands. The
12248N/Atools supplied with this package are: find - search for files in a
12248N/Adirectory hierarchy and xargs - build and execute command lines from standard input.
12248N/A
12248N/A%prep
12248N/A%setup -q -n findutils-%version
12248N/A%if %build_l10n
12248N/A%patch1 -p1
12248N/A%endif
12248N/A
12248N/A%build
12248N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12248N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12248N/A CPUS=1
12248N/Afi
12248N/A
12248N/Aexport CFLAGS="%optflags"
12248N/A
12248N/A%if %build_l10n
12248N/Ash %SOURCE1 --enable-copyright
12248N/A%endif
12248N/A./configure --prefix=%{_basedir} \
12248N/A --program-prefix=g \
12248N/A --mandir=%{_mandir} \
12248N/A --infodir=%{_datadir}/info \
12248N/A --libexecdir=%{_libexecdir}
12248N/A
12248N/Amake -j$CPUS
12248N/A
12248N/A%install
12248N/Arm -rf $RPM_BUILD_ROOT
12248N/A
12248N/Amake install DESTDIR=$RPM_BUILD_ROOT
12248N/Armdir $RPM_BUILD_ROOT%{_basedir}%{_localstatedir}
12248N/Arm -rf $RPM_BUILD_ROOT%{_basedir}/lib/charset.alias
12248N/A
12248N/A#remove unused files
12248N/Arm -rf $RPM_BUILD_ROOT%{_libdir}
12248N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
12248N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/glocate
12248N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/glocate.1
12248N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/gupdatedb
12248N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/gupdatedb.1
12248N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man5
12248N/A
12248N/A#create links in gnu dir
12248N/Amkdir -p $RPM_BUILD_ROOT%{_gnubin}
12248N/Aln -s ../../bin/gfind $RPM_BUILD_ROOT%{_gnubin}/find
12248N/Aln -s ../../bin/gxargs $RPM_BUILD_ROOT%{_gnubin}/xargs
12248N/Amkdir -p $RPM_BUILD_ROOT%{_gnuman}/man1
12248N/Aln -s ../../../../share/man/man1/gfind.1 $RPM_BUILD_ROOT%{_gnuman}/man1/find.1
12248N/Aln -s ../../../../share/man/man1/gxargs.1 $RPM_BUILD_ROOT%{_gnuman}/man1/xargs.1
12248N/A
12248N/A%if %build_l10n
12248N/A%else
12248N/A# REMOVE l10n FILES
12248N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
13941N/A%endif
12293N/A
12397N/A%clean
14472N/Arm -rf $RPM_BUILD_ROOT
16270N/A
16384N/A%files
18596N/A%doc COPYING AUTHORS NEWS ChangeLog README THANKS
12293N/A%dir %attr (0755, root, other) %{_datadir}/doc
12263N/A%defattr (-, root, bin)
12263N/A%dir %attr (0755, root, bin) %{_bindir}
12330N/A%{_bindir}/*
12248N/A%dir %attr (0755, root, sys) %{_datadir}
12248N/A%{_datadir}/info
12248N/A%{_mandir}
12248N/A%dir %attr (0755, root, bin) %{_gnubin}
12248N/A%{_gnubin}/*
12248N/A%dir %attr (0755, root, sys) %{_gnudata}
12248N/A%{_gnuman}
12248N/A
12248N/A%if %build_l10n
12248N/A%files l10n
12248N/A%defattr (-, root, bin)
12248N/A%dir %attr (0755, root, sys) %{_datadir}
12248N/A%attr (-, root, other) %{_datadir}/locale
12248N/A%endif
12248N/A
12248N/A%changelog
12248N/A* Tue Aug 25 2009 - brian.cameron@sun.com
12248N/A- Rever to 4.2.31. Newer versions are GPLv3.
12248N/A* Tue Aug 25 2009 - brian.cameron@sun.com
12248N/A- Bump to 4.2.33.
12248N/A* Fri Feb 27 2009 - matt.keenan@sun.com
12773N/A- Add manpage patch for Attributes and ARC Comment
12773N/A* Thu Sep 11 2008 - kevin.mcareavey@sun.com
12773N/A- Add %doc to %files for copyright
12773N/A* Fri Aug 15 2008 - kevin.mcareavey@sun.com
12773N/A- Cleanup for spec-files-other integration
12248N/A- Rollback to 4.2.31 for GPLv2
12248N/A- Create links in gnu directory
12248N/A- Remove unused files
12248N/A* Thu Feb 21 2008 - nonsea@users.sourceforge.net
12248N/A- Bump to 4.2.33
12248N/A* Thu Nov 15 2007 - daymobrew@users.sourceforge.net
12248N/A- Correct path to charset.alias file.
12248N/A* Sun Oct 14 2007 - laca@sun.com
12248N/A- fix l10n installation
12248N/A* Tue Sep 18 2007 - nonsea@users.sourceforge.net
12248N/A- Bump to 4.2.31
12248N/A* Sun Sep 24 2006 - Eric Boutilier
12248N/A- Initial spec
12248N/A
12248N/A
12248N/A