SUNWgnu-findutils.spec revision 19294
10139N/A#
10139N/A# spec file for package SUNWgnu-findutils
10139N/A#
16880N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner kevmca
10139N/A#
16880N/A
17178N/A%include Solaris.inc
17178N/A
10139N/A%define OSR 9641:4.2.32
16880N/A
10139N/A%define _gnudir %{_basedir}/gnu
17806N/A%define _gnubin %{_gnudir}/bin
12578N/A%define _gnudata %{_gnudir}/share
10139N/A%define _gnuman %{_gnudata}/man
10139N/A
10139N/A# Do NOT bump past 4.2.31. Later versions are GPLv3 and this needs to be
17724N/A# reviewed and approved before we can release with the newer license.
17797N/A
17797N/AName: SUNWgnu-findutils
17797N/AIPS_package_name: file/gnu-findutils
16880N/AMeta(info.classification): %{classification_prefix}:Applications/System Utilities
17733N/ALicense: GPLv2
17797N/AVendor: www.gnu.org/software/findutils
17753N/ASummary: GNU utilities find and xargs
16880N/AVersion: 4.2.31
17089N/ASource: http://ftp.gnu.org/pub/gnu/findutils/findutils-%{version}.tar.gz
17797N/A%if %build_l10n
16880N/ASource1: l10n-configure.sh
16880N/A# owner:mattman date:2009-02-27 type:branding
16880N/APatch1: gnu-findutils-01-manpages.diff
17797N/A%endif
16880N/AURL: http://www.gnu.org/software/findutils/
16880N/ASUNW_BaseDir: %{_basedir}
16880N/ASUNW_Copyright: %{name}.copyright
17733N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
16880N/A%include default-depend.inc
17089N/A
17073N/A%if %build_l10n
17089N/A%package l10n
17733N/AIPS_package_name: file/gnu-findutils/l10n
17074N/ASummary: %{summary} - l10n files
17089N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_dto_il10n_basedir}
17733N/A%include default-depend.inc
17733N/ARequires: %{name}
17222N/A%endif
17725N/A
17247N/A%description
17725N/AThe GNU Find Utilities are the basic directory searching utilities of
17753N/Athe GNU operating system. These programs are typically used in
17753N/Aconjunction with other programs to provide modular and powerful
17753N/Adirectory search and file locating capabilities to other commands. The
17753N/Atools supplied with this package are: find - search for files in a
17753N/Adirectory hierarchy and xargs - build and execute command lines from standard input.
17753N/A
17753N/A%prep
17753N/A%setup -q -n findutils-%version
17753N/A%if %build_l10n
17402N/A%patch1 -p1
17753N/A%endif
17806N/A
17535N/A%build
17806N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17546N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17806N/A CPUS=1
17733N/Afi
17733N/A
17629N/Aexport CFLAGS="%optflags"
17806N/A
17733N/A%if %build_l10n
17672N/Ash %SOURCE1 --enable-copyright
17806N/A%endif
17858N/A./configure --prefix=%{_basedir} \
17858N/A --program-prefix=g \
17858N/A --mandir=%{_mandir} \
17858N/A --infodir=%{_datadir}/info \
17873N/A --libexecdir=%{_libexecdir}
17873N/A
17884N/Amake -j$CPUS
17884N/A
17884N/A%install
17957N/Arm -rf $RPM_BUILD_ROOT
17957N/A
17957N/Amake install DESTDIR=$RPM_BUILD_ROOT
17957N/Armdir $RPM_BUILD_ROOT%{_basedir}%{_localstatedir}
17968N/Arm -rf $RPM_BUILD_ROOT%{_basedir}/lib/charset.alias
17968N/A
16880N/A#remove unused files
10139N/Arm -rf $RPM_BUILD_ROOT%{_libdir}
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
10139N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/glocate
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/glocate.1
12274N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/gupdatedb
12274N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/gupdatedb.1
12274N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man5
12274N/A
10139N/A#create links in gnu dir
10139N/Amkdir -p $RPM_BUILD_ROOT%{_gnubin}
10139N/Aln -s ../../bin/gfind $RPM_BUILD_ROOT%{_gnubin}/find
10139N/Aln -s ../../bin/gxargs $RPM_BUILD_ROOT%{_gnubin}/xargs
11002N/Amkdir -p $RPM_BUILD_ROOT%{_gnuman}/man1
13025N/Aln -s ../../../../share/man/man1/gfind.1 $RPM_BUILD_ROOT%{_gnuman}/man1/find.1
17693N/Aln -s ../../../../share/man/man1/gxargs.1 $RPM_BUILD_ROOT%{_gnuman}/man1/xargs.1
17693N/A
17693N/A%if %build_l10n
17693N/A%else
17693N/A# REMOVE l10n FILES
17725N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
17693N/A%endif
17693N/A
17725N/A%clean
17693N/Arm -rf $RPM_BUILD_ROOT
17693N/A
17693N/A%files
17858N/A%doc COPYING AUTHORS NEWS ChangeLog README THANKS
17858N/A%dir %attr (0755, root, other) %{_datadir}/doc
17873N/A%defattr (-, root, bin)
17884N/A%dir %attr (0755, root, bin) %{_bindir}
17957N/A%{_bindir}/*
17957N/A%dir %attr (0755, root, sys) %{_datadir}
17968N/A%{_datadir}/info
10139N/A%{_mandir}
10139N/A%dir %attr (0755, root, bin) %{_gnubin}
10139N/A%{_gnubin}/*
10139N/A%dir %attr (0755, root, sys) %{_gnudata}
10139N/A%{_gnuman}
10139N/A
10139N/A%if %build_l10n
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%attr (-, root, other) %{_datadir}/locale
10139N/A%endif
10139N/A
16880N/A%changelog
16880N/A* Tue Aug 25 2009 - brian.cameron@sun.com
16880N/A- Rever to 4.2.31. Newer versions are GPLv3.
16880N/A* Tue Aug 25 2009 - brian.cameron@sun.com
16880N/A- Bump to 4.2.33.
16880N/A* Fri Feb 27 2009 - matt.keenan@sun.com
10139N/A- Add manpage patch for Attributes and ARC Comment
16880N/A* Thu Sep 11 2008 - kevin.mcareavey@sun.com
16880N/A- Add %doc to %files for copyright
10139N/A* Fri Aug 15 2008 - kevin.mcareavey@sun.com
10139N/A- Cleanup for spec-files-other integration
10139N/A- Rollback to 4.2.31 for GPLv2
16880N/A- Create links in gnu directory
16880N/A- Remove unused files
10139N/A* Thu Feb 21 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 4.2.33
16880N/A* Thu Nov 15 2007 - daymobrew@users.sourceforge.net
11155N/A- Correct path to charset.alias file.
16880N/A* Sun Oct 14 2007 - laca@sun.com
16880N/A- fix l10n installation
17249N/A* Tue Sep 18 2007 - nonsea@users.sourceforge.net
17249N/A- Bump to 4.2.31
10139N/A* Sun Sep 24 2006 - Eric Boutilier
10139N/A- Initial spec
10139N/A
10139N/A