SUNWgnu-findutils.spec revision 18861
10139N/A#
10139N/A# spec file for package SUNWgnu-findutils
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner kevmca
10139N/A#
10139N/A
10139N/A%include Solaris.inc
10139N/A
10139N/A%define OSR 9641:4.2.32
10723N/A
10624N/A%define _gnudir %{_basedir}/gnu
10139N/A%define _gnubin %{_gnudir}/bin
10139N/A%define _gnudata %{_gnudir}/share
10139N/A%define _gnuman %{_gnudata}/man
10709N/A
10142N/A# Do NOT bump past 4.2.31. Later versions are GPLv3 and this needs to be
10139N/A# reviewed and approved before we can release with the newer license.
10610N/A
10776N/AName: SUNWgnu-findutils
10776N/AIPS_package_name: file/gnu-findutils
10139N/AMeta(info.classification): %{classification_prefix}:Applications/System Utilities
10139N/ALicense: GPLv2
10139N/AVendor: www.gnu.org/software/findutils
10139N/ASummary: GNU utilities find and xargs
10139N/AVersion: 4.2.31
10139N/ASource: http://ftp.gnu.org/pub/gnu/findutils/findutils-%{version}.tar.gz
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A# owner:mattman date:2009-02-27 type:branding
10139N/APatch1: gnu-findutils-01-manpages.diff
10139N/A%endif
10139N/AURL: http://www.gnu.org/software/findutils/
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A%include default-depend.inc
10139N/A
10139N/A%if %build_l10n
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/ARequires: %{name}
10139N/A%endif
10139N/A
10139N/A%description
10139N/AThe GNU Find Utilities are the basic directory searching utilities of
10139N/Athe GNU operating system. These programs are typically used in
10139N/Aconjunction with other programs to provide modular and powerful
10139N/Adirectory search and file locating capabilities to other commands. The
10139N/Atools supplied with this package are: find - search for files in a
10139N/Adirectory hierarchy and xargs - build and execute command lines from standard input.
10139N/A
10139N/A%prep
10139N/A%setup -q -n findutils-%version
10139N/A%if %build_l10n
10139N/A%patch1 -p1
10139N/A%endif
10139N/A
10139N/A%build
10139N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport CFLAGS="%optflags"
10139N/A
10139N/A%if %build_l10n
10139N/Ash %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A./configure --prefix=%{_basedir} \
10139N/A --program-prefix=g \
10139N/A --mandir=%{_mandir} \
10139N/A --infodir=%{_datadir}/info \
10139N/A --libexecdir=%{_libexecdir}
10139N/A
10139N/Amake -j$CPUS
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Armdir $RPM_BUILD_ROOT%{_basedir}%{_localstatedir}
10142N/Arm -rf $RPM_BUILD_ROOT%{_basedir}/lib/charset.alias
10139N/A
10139N/A#remove unused files
10139N/Arm -rf $RPM_BUILD_ROOT%{_libdir}
10776N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
10139N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/glocate
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/glocate.1
10139N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/gupdatedb
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man1/gupdatedb.1
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/man5
10139N/A
10139N/A#create links in gnu dir
10139N/Amkdir -p $RPM_BUILD_ROOT%{_gnubin}
10139N/Aln -s ../../bin/gfind $RPM_BUILD_ROOT%{_gnubin}/find
10139N/Aln -s ../../bin/gxargs $RPM_BUILD_ROOT%{_gnubin}/xargs
10139N/Amkdir -p $RPM_BUILD_ROOT%{_gnuman}/man1
10139N/Aln -s ../../../../share/man/man1/gfind.1 $RPM_BUILD_ROOT%{_gnuman}/man1/find.1
10139N/Aln -s ../../../../share/man/man1/gxargs.1 $RPM_BUILD_ROOT%{_gnuman}/man1/xargs.1
10139N/A
10139N/A%if %build_l10n
10139N/A%else
10139N/A# REMOVE l10n FILES
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
10139N/A%endif
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10617N/A%files
10139N/A%doc COPYING AUTHORS NEWS ChangeLog README THANKS
10139N/A%dir %attr (0755, root, other) %{_datadir}/doc
10617N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%{_datadir}/info
10139N/A%{_mandir}
10139N/A%dir %attr (0755, root, bin) %{_gnubin}
10139N/A%{_gnubin}/*
10139N/A%dir %attr (0755, root, sys) %{_gnudata}
10139N/A%{_gnuman}
10139N/A
10139N/A%if %build_l10n
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%attr (-, root, other) %{_datadir}/locale
10139N/A%endif
10139N/A
10139N/A%changelog
10617N/A* Tue Aug 25 2009 - brian.cameron@sun.com
10139N/A- Rever to 4.2.31. Newer versions are GPLv3.
10139N/A* Tue Aug 25 2009 - brian.cameron@sun.com
10139N/A- Bump to 4.2.33.
10139N/A* Fri Feb 27 2009 - matt.keenan@sun.com
10139N/A- Add manpage patch for Attributes and ARC Comment
10139N/A* Thu Sep 11 2008 - kevin.mcareavey@sun.com
10139N/A- Add %doc to %files for copyright
10139N/A* Fri Aug 15 2008 - kevin.mcareavey@sun.com
10139N/A- Cleanup for spec-files-other integration
10139N/A- Rollback to 4.2.31 for GPLv2
10139N/A- Create links in gnu directory
10139N/A- Remove unused files
10139N/A* Thu Feb 21 2008 - nonsea@users.sourceforge.net
10248N/A- Bump to 4.2.33
10248N/A* Thu Nov 15 2007 - daymobrew@users.sourceforge.net
10139N/A- Correct path to charset.alias file.
10139N/A* Sun Oct 14 2007 - laca@sun.com
10139N/A- fix l10n installation
10139N/A* Tue Sep 18 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 4.2.31
10139N/A* Sun Sep 24 2006 - Eric Boutilier
10139N/A- Initial spec
10139N/A