SUNWgnome-remote-desktop.spec revision 20857
10139N/A#
10139N/A# spec file for package SUNWgnome-remote-desktop
10139N/A#
12147N/A# includes module(s): vino, realvnc-java-client
10139N/A#
10139N/A# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner wangke
10139N/A#
10139N/A%include Solaris.inc
12147N/A
10139N/A%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
10139N/A%use vino = vino.spec
10139N/A%if %option_with_java
10139N/A%use rjc = realvnc-java-client.spec
12082N/A%endif
10977N/A
11066N/AName: SUNWgnome-remote-desktop
10139N/ALicense: GPL v2
10139N/ASummary: GNOME remote desktop
10139N/AVersion: %{vino.version}
10139N/ASUNW_Pkg: SUNWgnome-remote-desktop
10139N/AIPS_package_name: gnome/gnome-remote-desktop
10139N/AMeta(info.classification): %{classification_prefix}:System/X11
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ASource1: %{name}-manpages-0.1.tar.gz
10139N/A
10139N/A%include default-depend.inc
10139N/A%include desktop-incorporation.inc
10139N/ARequires: SUNWlibglade
10139N/ARequires: SUNWgnome-libs
10139N/ARequires: SUNWgnome-component
10139N/ARequires: SUNWgnome-config
10139N/ARequires: SUNWgnutls
10139N/ARequires: SUNWjpg
10139N/ARequires: SUNWlibgcrypt
10139N/ARequires: SUNWzlib
10139N/ARequires: SUNWdesktop-cache
10139N/ARequires: SUNWgnome-panel
10139N/ARequires: SUNWavahi-bridge-dsd
10139N/ARequires: SUNWlibunique
10139N/ARequires: %{name}-root
10139N/ABuildRequires: SUNWlibglade-devel
10139N/ABuildRequires: SUNWgnome-component-devel
10139N/ABuildRequires: SUNWgnome-config-devel
10139N/ABuildRequires: SUNWgnutls-devel
10139N/ABuildRequires: SUNWjpg-devel
10139N/ABuildRequires: SUNWlibgcrypt-devel
10139N/ABuildRequires: SUNWgnome-libs-devel
10139N/ABuildRequires: SUNWgnome-panel-devel
10139N/ABuildRequires: SUNWavahi-bridge-dsd-devel
10139N/ABuildRequires: SUNWlibunique-devel
10139N/ABuildRequires: SUNWj6dev
10139N/A
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ARequires: %{name}
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
11191N/A%include desktop-incorporation.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%vino.prep -d %name-%version
10139N/A%if %option_with_java
10139N/A%rjc.prep -d %name-%version
10139N/A%endif
10139N/Acd %{_builddir}/%name-%version
10139N/Agzcat %SOURCE1 | tar xf -
10139N/A
10139N/A%build
10139N/A# There seems to be an issue with the version of libtool that GStreamer is
10139N/A# now using. The libtool script uses the echo and RM variables but does not
10139N/A# define them, so setting them here addresses this.
10139N/Aexport echo="/usr/bin/echo"
10139N/Aexport RM="/usr/bin/rm"
10139N/A
10139N/Aexport PKG_CONFIG_PATH=%{_pkg_config_path}
10139N/Aexport CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"
10139N/A
10139N/A%vino.build -d %name-%version
11204N/A
10139N/Aunset echo
10139N/Aunset RM
10139N/A
10139N/A%if %option_with_java
10139N/A%rjc.build -d %name-%version
10139N/A%endif
10139N/A
10139N/A%install
10139N/A# There seems to be an issue with the version of libtool that GStreamer is
10139N/A# now using. The libtool script uses the echo and RM variables but does not
10139N/A# define them, so setting them here addresses this.
10139N/Aexport echo="/usr/bin/echo"
10139N/Aexport RM="/usr/bin/rm"
10139N/A
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%vino.install -d %name-%version
10139N/A
10139N/Aunset echo
10139N/Aunset RM
10139N/A
10139N/A%if %option_with_java
10139N/A# install vnc client
10139N/Acd %{name}-%{version}
10139N/Acd vnc-*javasrc/java
10139N/Ainstall --mode=0755 vncviewer.jar $RPM_BUILD_ROOT%{_datadir}/vino/vino-client.jar
10139N/Ainstall --mode=0755 vino-client.html $RPM_BUILD_ROOT%{_datadir}/vino/vino-client.html
10139N/A%endif
10139N/A
10139N/A# install man page
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
12147N/A
12147N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}
12147N/A
12082N/A%clean
12082N/Arm -rf $RPM_BUILD_ROOT
12082N/A
12147N/A%post
12071N/A%restart_fmri desktop-mime-cache icon-cache gconf-cache
12071N/A
12071N/A%postun
11989N/A%restart_fmri desktop-mime-cache
11989N/A
11989N/A%files
11416N/A%doc vino-%{vino.version}/AUTHORS
11417N/A%doc vino-%{vino.version}/README
11416N/A%doc(bzip2) vino-%{vino.version}/COPYING
11257N/A%doc(bzip2) vino-%{vino.version}/NEWS
11257N/A%doc(bzip2) vino-%{vino.version}/ChangeLog
11257N/A%doc(bzip2) vino-%{vino.version}/po/ChangeLog
11234N/A%doc(bzip2) vnc-%{rjc.tarball_version}-javasrc/java/LICENCE.TXT
11234N/A%doc(bzip2) vnc-%{rjc.tarball_version}-javasrc/java/README
11234N/A%dir %attr (0755, root, other) %{_datadir}/doc
11257N/A%defattr (-, root, bin)
11191N/A%dir %attr (0755, root, bin) %{_bindir}
11191N/A%{_bindir}/*
11191N/A%dir %attr (0755, root, bin) %{_libdir}
11191N/A%{_libdir}/vino-server
11191N/A%dir %attr (0755, root, sys) %{_datadir}
11085N/A%{_datadir}/vino
11085N/A%dir %attr (0755, root, other) %{_datadir}/applications
11085N/A%{_datadir}/applications/*
11066N/A%dir %attr(0755, root, bin) %{_mandir}
11066N/A%dir %attr(0755, root, bin) %{_mandir}/*
11066N/A%{_mandir}/*/*
11066N/A%{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.Vino.service
10977N/A
10977N/A
10977N/A%files l10n
10977N/A%defattr (-, root, bin)
10975N/A%dir %attr (0755, root, sys) %{_datadir}
10975N/A%attr (-, root, other) %{_datadir}/locale
10975N/A
10972N/A%files root
10972N/A%defattr (-, root, sys)
10972N/A%attr (0755, root, sys) %dir %{_sysconfdir}
10909N/A%{_sysconfdir}/gconf/schemas/vino-server.schemas
10909N/A%{_sysconfdir}/xdg/autostart/vino-server.desktop
10909N/A
10909N/A%changelog
10821N/A* Wed Mar 31 2010 - halton.huo@sun.com
10821N/A- Add %SUNW_Pkg %IPS_package_name
10821N/A* Mon Jul 27 2009 - christian.kelly@sun.com
10810N/A- Minor change to %files.
10810N/A* Fri Apr 3 2009 - laca@sun.com
10810N/A- use desktop-cache instead of postrun
10645N/A* Sat Jan 24 2009 - halton.huo@sun.com
10645N/A- Update %files, move autostart/vino-server.desktop to -root pkg.
10645N/A* Sat Jan 24 2009 - halton.huo@sun.com
10645N/A- Add Requires to libunique package
10435N/A* Wed Nov 05 2008 - halton.huo@sun.com
10435N/A- Add po/ChangeLog to %files
10435N/A* Wed Sep 10 2008 - halton.huo@sun.com
10371N/A- Add %doc to %files for new copyright
10371N/A* Thu Aug 07 2008 - halton.huo@sun.com
10371N/A- Add %{_datadir}/gnome/autostart for new gnome-session change.
10270N/A* Thu Mar 27 2008 - halton.huo@sun.com
10271N/A- Add copyright file
10270N/A* Thu Jan 3 2008 - laca@sun.com
10200N/A- use gconf-install.script instead of an inline script
10200N/A* Fri Nov 02 2007 - halton.huo@sun.com
10200N/A- Remove vncviewer wrapper since C version of vncviewer will be added.
10139N/A* Fri Nov 02 2007 - halton.huo@sun.com
10139N/A- Add SUNWavahi-bridge-dsd to Requires
10139N/A- Add SUNWavahi-bridge-dsd-devel to BuildRequires
10139N/A* Wed Oct 31 2007 - damien.carbery@sun.com
10139N/A- Remove %{_datadir}/icons from %files as it is not installed.
10139N/A* Thu Oct 11 2007 - halton.huo@sun.com
10139N/A- Use desktop-database-install.script for %post
10139N/A and desktop-database-uninstall.script for %postun
10139N/A* Thu Oct 11 2007 - halton.huo@sun.com
10139N/A- change the inline postinstall script to an include
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- disable building the java client when --without-java is used
10139N/A- delete unneeded env variables
10139N/A* Tue Jul 31 2007 - halton.huo@sun.com
10139N/A- Add Requires: SUNWgnome-panel and BuildRequires: SUNWgnome-panel-devel
10139N/A because vino-server now depend on libnotify, fix bugster #6585037.
10139N/A* Tue Jul 10 2007 - halton.huo@sun.com
10139N/A- Use $prefix/share/vino for data in favor of $prefix/share/gnome/vino,
10139N/A refer bugzilla #436460.
10139N/A* Fri Jun 22 2007 - halton.huo@sun.com
10139N/A- Use realvnc-java-client.spec generate vino-client.jar and vino-client.html
10139N/A- Add script wrapper /usr/bin/vncviewer for vino-client.jar
10139N/A* Tue Apr 24 2007 - laca@sun.com
10139N/A- s/0755/-/ in defattr so that files are not made all executable
10139N/A* Wed Nov 08 2006 - halton.huo@sun.com
10139N/A- Add manpage section to fix bug, bugster #6489749
10139N/A* Fri Spe 22 2006 - dermot.mccluskey@sun.com
10139N/A- temporarily comment out manpage sections as source tarball does not exist
10139N/A* Mon Sept 11 2006 - steven.zhang@sun.com
10139N/A- update to add vnc client support with server
10139N/A- update to add manpage
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- change datadir/icons permissions back to root:other since it's a stable
10139N/A interface and wasn't supposed to be changed
10139N/A* Fri Jul 14 2006 - laca@sun.com
10139N/A- update %post/%postun/etc scripts to support diskless client setup,
10139N/A part of 6448317
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- update postrun scripts
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Fri Jun 2 2006 - laca@sun.com
10139N/A- use post/preun scripts to install schemas into the merged gconf files
10139N/A* Thu May 11 2006 - halton.huo@sun.com
10139N/A- Merge -share pkg(s) into the base pkg(s).
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Complete update of Build/Requires after running check-deps.pl script.
10139N/A* Fri Feb 17 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Sat Dec 3 2005 - laca@sun.com
10139N/A- add %post script that runs update-desktop-database
10139N/A* Fri Sep 30 2005 - damien.carbery@sun.com
10139N/A- Add applications and icons dirs under %{_datadir}.
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Mon Aug 23 2004 - laca@sun.com
10139N/A- s/SUNWpl5u/SUNWperl584usr/
10139N/A* Thu Jun 23 2004 - shirley.woo@sun.com
10139N/A- more changes for change install location to /usr/lib and /usr/bin
10139N/A* Tue Jun 22 2004 - shirley.woo@sun.com
10139N/A- changed install location to /usr/lib and /usr/bin
10139N/A* Wed Jun 2 2004 - takao.fujiwara@sun.com
10139N/A- Added %{_datadir}/locale to install l10n messages
10139N/A* Fri May 07 2004 - brian.cameron@sun.com
10139N/A- Removed locale/C from "%files share" since it doesn't
10139N/A exist.
10139N/A* Thu Apr 15 2004 - brian.cameron@sun.com
10139N/A- Created
10139N/A
10139N/A
10139N/A
10139N/A