10139N/A#
10139N/A# spec file for package SUNWgnome-remote-desktop
10139N/A#
10848N/A# includes module(s): vino, realvnc-java-client
10139N/A#
20904N/A# Copyright (c) 2004, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
19107N/A%define owner wangke
10139N/A#
10139N/A%include Solaris.inc
10139N/A
10139N/A%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
10139N/A%use vino = vino.spec
11314N/A%if %option_with_java
10848N/A%use rjc = realvnc-java-client.spec
11314N/A%endif
10139N/A
10139N/AName: SUNWgnome-remote-desktop
19107N/ALicense: GPL v2
10139N/ASummary: GNOME remote desktop
18537N/AVersion: %{vino.version}
18537N/ASUNW_Pkg: SUNWgnome-remote-desktop
18537N/AIPS_package_name: gnome/gnome-remote-desktop
18688N/AMeta(info.classification): %{classification_prefix}:System/X11
10139N/ASUNW_BaseDir: %{_basedir}
12664N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12664N/ASource1: %{name}-manpages-0.1.tar.gz
10139N/A
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
16401N/ARequires: SUNWlibglade
10139N/ARequires: SUNWgnome-libs
10139N/ARequires: SUNWgnome-component
10139N/ARequires: SUNWgnome-config
10139N/ARequires: SUNWgnutls
10139N/ARequires: SUNWjpg
10139N/ARequires: SUNWlibgcrypt
10139N/ARequires: SUNWzlib
16307N/ARequires: SUNWdesktop-cache
10975N/ARequires: SUNWgnome-panel
11848N/ARequires: SUNWavahi-bridge-dsd
15724N/ARequires: SUNWlibunique
16307N/ARequires: %{name}-root
16401N/ABuildRequires: SUNWlibglade-devel
10139N/ABuildRequires: SUNWgnome-component-devel
10139N/ABuildRequires: SUNWgnome-config-devel
10139N/ABuildRequires: SUNWgnutls-devel
10139N/ABuildRequires: SUNWjpg-devel
10139N/ABuildRequires: SUNWlibgcrypt-devel
10139N/ABuildRequires: SUNWgnome-libs-devel
10975N/ABuildRequires: SUNWgnome-panel-devel
11848N/ABuildRequires: SUNWavahi-bridge-dsd-devel
15724N/ABuildRequires: SUNWlibunique-devel
20197N/ABuildRequires: SUNWj6dev
10139N/A
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ARequires: %{name}
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%vino.prep -d %name-%version
11314N/A%if %option_with_java
10848N/A%rjc.prep -d %name-%version
11314N/A%endif
10139N/Acd %{_builddir}/%name-%version
10848N/Agzcat %SOURCE1 | tar xf -
10139N/A
10139N/A%build
10139N/Aexport PKG_CONFIG_PATH=%{_pkg_config_path}
10139N/Aexport CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"
10139N/A
10139N/A%vino.build -d %name-%version
20332N/A
11317N/A%if %option_with_java
10848N/A%rjc.build -d %name-%version
11317N/A%endif
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%vino.install -d %name-%version
20332N/A
11314N/A%if %option_with_java
10139N/A# install vnc client
10848N/Acd %{name}-%{version}
10848N/Acd vnc-*javasrc/java
10914N/Ainstall --mode=0755 vncviewer.jar $RPM_BUILD_ROOT%{_datadir}/vino/vino-client.jar
10914N/Ainstall --mode=0755 vino-client.html $RPM_BUILD_ROOT%{_datadir}/vino/vino-client.html
11314N/A%endif
10139N/A
10139N/A# install man page
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
16307N/A%restart_fmri desktop-mime-cache icon-cache gconf-cache
10139N/A
10139N/A%postun
16307N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A%files
14221N/A%doc vino-%{vino.version}/AUTHORS
14225N/A%doc vino-%{vino.version}/README
14221N/A%doc(bzip2) vino-%{vino.version}/COPYING
14225N/A%doc(bzip2) vino-%{vino.version}/NEWS
14221N/A%doc(bzip2) vino-%{vino.version}/ChangeLog
15308N/A%doc(bzip2) vino-%{vino.version}/po/ChangeLog
14221N/A%doc(bzip2) vnc-%{rjc.tarball_version}-javasrc/java/LICENCE.TXT
14221N/A%doc(bzip2) vnc-%{rjc.tarball_version}-javasrc/java/README
14221N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/vino-server
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10914N/A%{_datadir}/vino
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%{_datadir}/applications/*
10139N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
20332N/A%{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.Vino.service
20332N/A
10139N/A
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%attr (-, root, other) %{_datadir}/locale
10139N/A
10139N/A%files root
10522N/A%defattr (-, root, sys)
10139N/A%attr (0755, root, sys) %dir %{_sysconfdir}
10139N/A%{_sysconfdir}/gconf/schemas/vino-server.schemas
15857N/A%{_sysconfdir}/xdg/autostart/vino-server.desktop
10139N/A
10139N/A%changelog
20904N/A* Fri May 04 2012 - brian.cameron@oracle.com
20904N/A- Now use newer autotools.
18537N/A* Wed Mar 31 2010 - halton.huo@sun.com
18537N/A- Add %SUNW_Pkg %IPS_package_name
16884N/A* Mon Jul 27 2009 - christian.kelly@sun.com
16884N/A- Minor change to %files.
16307N/A* Fri Apr 3 2009 - laca@sun.com
16307N/A- use desktop-cache instead of postrun
15724N/A* Sat Jan 24 2009 - halton.huo@sun.com
15857N/A- Update %files, move autostart/vino-server.desktop to -root pkg.
15857N/A* Sat Jan 24 2009 - halton.huo@sun.com
15724N/A- Add Requires to libunique package
15308N/A* Wed Nov 05 2008 - halton.huo@sun.com
15308N/A- Add po/ChangeLog to %files
14221N/A* Wed Sep 10 2008 - halton.huo@sun.com
14221N/A- Add %doc to %files for new copyright
13807N/A* Thu Aug 07 2008 - halton.huo@sun.com
13807N/A- Add %{_datadir}/gnome/autostart for new gnome-session change.
12664N/A* Thu Mar 27 2008 - halton.huo@sun.com
12664N/A- Add copyright file
12112N/A* Thu Jan 3 2008 - laca@sun.com
12112N/A- use gconf-install.script instead of an inline script
11848N/A* Fri Nov 02 2007 - halton.huo@sun.com
11849N/A- Remove vncviewer wrapper since C version of vncviewer will be added.
11849N/A* Fri Nov 02 2007 - halton.huo@sun.com
11848N/A- Add SUNWavahi-bridge-dsd to Requires
11848N/A- Add SUNWavahi-bridge-dsd-devel to BuildRequires
11830N/A* Wed Oct 31 2007 - damien.carbery@sun.com
11830N/A- Remove %{_datadir}/icons from %files as it is not installed.
11381N/A* Thu Oct 11 2007 - halton.huo@sun.com
11386N/A- Use desktop-database-install.script for %post
11386N/A and desktop-database-uninstall.script for %postun
11386N/A* Thu Oct 11 2007 - halton.huo@sun.com
11381N/A- change the inline postinstall script to an include
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- disable building the java client when --without-java is used
11314N/A- delete unneeded env variables
10975N/A* Tue Jul 31 2007 - halton.huo@sun.com
10975N/A- Add Requires: SUNWgnome-panel and BuildRequires: SUNWgnome-panel-devel
10975N/A because vino-server now depend on libnotify, fix bugster #6585037.
10914N/A* Tue Jul 10 2007 - halton.huo@sun.com
10914N/A- Use $prefix/share/vino for data in favor of $prefix/share/gnome/vino,
10914N/A refer bugzilla #436460.
10848N/A* Fri Jun 22 2007 - halton.huo@sun.com
10848N/A- Use realvnc-java-client.spec generate vino-client.jar and vino-client.html
10848N/A- Add script wrapper /usr/bin/vncviewer for vino-client.jar
10522N/A* Tue Apr 24 2007 - laca@sun.com
10522N/A- s/0755/-/ in defattr so that files are not made all executable
10139N/A* Wed Nov 08 2006 - halton.huo@sun.com
10139N/A- Add manpage section to fix bug, bugster #6489749
10139N/A* Fri Spe 22 2006 - dermot.mccluskey@sun.com
10139N/A- temporarily comment out manpage sections as source tarball does not exist
10139N/A* Mon Sept 11 2006 - steven.zhang@sun.com
10139N/A- update to add vnc client support with server
10139N/A- update to add manpage
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- change datadir/icons permissions back to root:other since it's a stable
10139N/A interface and wasn't supposed to be changed
10139N/A* Fri Jul 14 2006 - laca@sun.com
10139N/A- update %post/%postun/etc scripts to support diskless client setup,
10139N/A part of 6448317
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- update postrun scripts
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Fri Jun 2 2006 - laca@sun.com
10139N/A- use post/preun scripts to install schemas into the merged gconf files
10139N/A* Thu May 11 2006 - halton.huo@sun.com
10139N/A- Merge -share pkg(s) into the base pkg(s).
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Complete update of Build/Requires after running check-deps.pl script.
10139N/A* Fri Feb 17 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Sat Dec 3 2005 - laca@sun.com
10139N/A- add %post script that runs update-desktop-database
10139N/A* Fri Sep 30 2005 - damien.carbery@sun.com
10139N/A- Add applications and icons dirs under %{_datadir}.
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Mon Aug 23 2004 - laca@sun.com
10139N/A- s/SUNWpl5u/SUNWperl584usr/
10139N/A* Thu Jun 23 2004 - shirley.woo@sun.com
10139N/A- more changes for change install location to /usr/lib and /usr/bin
10139N/A* Tue Jun 22 2004 - shirley.woo@sun.com
10139N/A- changed install location to /usr/lib and /usr/bin
10139N/A* Wed Jun 2 2004 - takao.fujiwara@sun.com
10139N/A- Added %{_datadir}/locale to install l10n messages
10139N/A* Fri May 07 2004 - brian.cameron@sun.com
10139N/A- Removed locale/C from "%files share" since it doesn't
10139N/A exist.
10139N/A* Thu Apr 15 2004 - brian.cameron@sun.com
10139N/A- Created
16401N/A