SUNWgnome-python26.spec revision 20857
10292N/A#
10292N/A# spec file for package SUNWgnome-python26 aka library/python-2/gnome-python-26
10292N/A#
18540N/A# includes module(s): gnome-python
10292N/A#
10292N/A# Copyright (c) 2005, 2011, Oracle and/or its affiliates. All rights reserved.
10292N/A#
10292N/A# This file and all modifications and additions to the pristine
10292N/A# package are under the same license as the package itself.
17185N/A#
12666N/A%define owner laca
10292N/A#
10292N/A%include Solaris.inc
10292N/A%define pythonver 2.6
10292N/A%define python_version %{pythonver}
10292N/A
10292N/A%use gnome_python = gnome-python.spec
19013N/A
10320N/AName: SUNWgnome-python26
18540N/AIPS_package_name: library/python-2/python-gnome-26
18540N/AMeta(info.classification): %{classification_prefix}:Development/Python
18688N/ASummary: Python 2.6 support libraries for GNOME
10292N/AVersion: %{gnome_python.version}
12666N/ASUNW_BaseDir: %{_basedir}
19092N/ASUNW_Copyright: %{name}.copyright
10292N/ALicense: %{gnome_python.license}
10292N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10292N/A
19142N/A%include default-depend.inc
16401N/A%include gnome-incorporation.inc
10309N/ARequires: SUNWlibgnomecanvas
13059N/ARequires: SUNWgnome-component
16307N/ARequires: SUNWgnome-config
16307N/ARequires: SUNWgnome-vfs
16401N/ARequires: SUNWlibgnomecanvas
10309N/ARequires: SUNWgnome-libs
13059N/ARequires: SUNWPython26-extra
19142N/ARequires: SUNWPython26
10292N/ARequires: SUNWpygobject26
10292N/ARequires: SUNWpygtk2-26
10292N/ARequires: SUNWpyorbit26
10292N/ABuildRequires: SUNWlibgnomecanvas-devel
10292N/ABuildRequires: SUNWPython26-devel
19142N/ABuildRequires: SUNWgnome-config-devel
10292N/ABuildRequires: SUNWgnome-vfs-devel
10292N/ABuildRequires: SUNWlibpopt-devel
10292N/ABuildRequires: SUNWgnome-libs-devel
10292N/ABuildRequires: SUNWgnome-file-mgr-devel
10292N/ABuildRequires: SUNWPython26-extra
19142N/ABuildRequires: SUNWgnome-component-devel
10292N/ABuildRequires: SUNWgnome-config-devel
16401N/ABuildRequires: SUNWgnome-gtksourceview-devel
10292N/ABuildRequires: SUNWpython26-setuptools
10292N/ABuildRequires: SUNWgtk-doc
10292N/ABuildRequires: SUNWgsed
19126N/A
10292N/A%package devel
19126N/ASummary: %{summary} - development files
10292N/ASUNW_BaseDir: %{_basedir}
19142N/A%include default-depend.inc
10292N/A%include gnome-incorporation.inc
10292N/ARequires: %name
10292N/ARequires: SUNWPython26
10292N/A
10292N/A%prep
10292N/Arm -rf %name-%version
10292N/Amkdir %name-%version
10292N/A%gnome_python.prep -d %name-%version
10320N/A
10292N/A%build
10292N/APKG_CONFIG_DISABLE_UNINSTALLED=
13011N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
10292N/A
13011N/Aexport PYTHON="/usr/bin/python2.6"
10292N/Aexport CPPFLAGS="-I/usr/xpg4/include -I/usr/include/python%{pythonver}"
10292N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
10292N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10292N/Aexport LDFLAGS="%_ldflags"
13011N/Aexport PYCC_CC="$CC"
10292N/Aexport PYCC_CXX="$CXX"
10292N/A
10292N/A%gnome_python.build -d %name-%version
10292N/A
10292N/A%install
10320N/Arm -rf $RPM_BUILD_ROOT
10320N/A%gnome_python.install -d %name-%version
10320N/A
10292N/A# move to vendor-packages
10292N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
10292N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10292N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
10292N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
10292N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
10292N/Afi
10292N/A
10292N/A# avoid conflict with 2.4:
10292N/Amv $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so \
16307N/A $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod-2.6.so
16307N/A
10292N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10292N/A
10292N/A%clean
10292N/Arm -rf $RPM_BUILD_ROOT
10292N/A
10292N/A%files
10292N/A%defattr(-, root, bin)
10292N/A%dir %attr (0755, root, bin) %{_libdir}
10292N/A%{_libdir}/python?.?/vendor-packages
14364N/A%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod-2.6.so
14364N/A
14364N/A%files devel
10292N/A%defattr(-, root, bin)
10292N/A%dir %attr (0755, root, bin) %{_includedir}
14418N/A%{_includedir}/*
14418N/A%dir %attr (0755, root, bin) %{_libdir}
14418N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
14418N/A%{_libdir}/pkgconfig/*
14418N/A%dir %attr (0755, root, sys) %{_datadir}
14418N/A%{_datadir}/*
14418N/A
14418N/A%changelog
14418N/A* Fri Feb 4 2010 - laszlo.peter@oracle.com
14418N/A- created, based on SUNWgnome-python26-libs.spec
14418N/A* Wed Sep 23 2009 - brian.cameron@sun.com
14418N/A- Use PKG_CONFIG_TOP_BUILD_DIR environment variable when building pygtk and
14418N/A pygtksourceview, so that pkg-config expands $(top_builddir), otherwise
14418N/A pygobject pkg-config variables do not expand nicely and the build fails.
14418N/A* Sat Jun 20 2009 - christian.kelly@sun.com
14418N/A- Minor pkg'ing fix.
14418N/A* Wed Mar 25 2009 - li.yuan@sun.com
14418N/A- Move pyspi from SUNWgnome-python-libs to SUNWgnome-a11y-libs.
14418N/A* Mon Feb 2 2009 - laca@sun.com
14418N/A- created, based on SUNWgnome-python25-libs.spec
10292N/A* Tue Nov 25 2008 - laca@sun.com
10292N/A- get rid of SUNWgnome-python-libs-common because there are no files
10320N/A that we can share between 2.4 and 2.5.
10292N/A* Mon Nov 24 2008 - laca@sun.com
10292N/A- created, based on SUNWPython-extra.spec
10522N/A* Wed Sep 17 2008 - laca@sun.com
10292N/A- set PYTHON to python2.4 (instead of just python) to make sure the
10292N/A right version is used for the build
10292N/A* Tue Aug 12 2008 - damien.carbery@sun.com
10292N/A- Add %{_libdir}/libpyglib-2.0.so* to %files.
10292N/A* Mon Aug 11 2008 - damien.carbery@sun.com
10292N/A- Move site-packages to vendor-packages here because pygobject 2.15.2 borked
10292N/A when vendor-packages was specified by pyexecdir and pythondir in make
10292N/A install.
10292N/A* Tue Oct 16 2007 - damien.carbery@sun.com
10292N/A- Remove unnecessary environment variable settings.
10292N/A* Mon Oct 8 2007 - damien.carbery@sun.com
10292N/A- Add SUNWgnome-gtksourceview dependency as it is required to by
10292N/A pygtksourceview.
10292N/A* Sun Oct 7 2007 - damien.carbery@sun.com
10292N/A- Add pygtksourceview as it is required to build python bindings in gedit.
10292N/A* Fri Sep 28 2007 - laca@sun.com
10292N/A- delete some unnecessary env vars
10292N/A* Fri Aug 31 2007 - damien.carbery@sun.com
10292N/A- Remove pygtksourceview.spec. It is still not building and isn't required.
13094N/A* Thu Jul 05 2007 - damien.carbery@sun.com
13094N/A- Add pygtksourceview.spec, but disable it because it is not building yet.
13094N/A* Tue Jan 9 2007 - laca@sun.com
13094N/A- define PYCC_CC and PYCC_CXX to override what the configure script sets
13059N/A in CC/CXX
13059N/A* Mon Aug 28 2006 - damien.carbery@sun.com
13011N/A- Fix typo in PKG_CONFIG_PATH data (s/=/-/).
13011N/A* Sun Jun 11 2006 - laca@sun.com
13011N/A- change group from other to bin/sys
12666N/A* Fri May 12 2006 - damien.carbery@sun.com
12666N/A- Small update to dependency list after check-deps.pl run.
12112N/A* Thu May 11 2006 - brian.cameron@sun.com
12112N/A- Move pygtk-demo to demo directory.
11826N/A* Wed Apr 5 2006 - damien.carbery@sun.com
11826N/A- Add pygobject. It has been moved from pygtk2.
10522N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10524N/A- Complete update of Build/Requires after running check-deps.pl script.
10524N/A* Fri Feb 17 2006 - damien.carbery@sun.com
10524N/A- Update Build/Requires after running check-deps.pl script.
10524N/A* Mon Jan 09 2006 - damien.carbery@sun.com
10522N/A- Add gnome-vfs module.
10320N/A* Thu Oct 27 2005 - laca@sun.com
10320N/A- add pygtk2
10309N/A* Tue Sep 20 2005 - laca@sun.com
10309N/A- move to /usr as Python was also moved there
10309N/A* Thu Sep 01 2005 - damien.carbery@sun.com
10292N/A- Remove unused pygtk2 references.
10292N/A* Wed Aug 30 2005 - damien.carbery@sun.com
16401N/A- Add Build/Requires for SUNWgnome-file-mgr (nautilus) and SUNWgnome-print
19235N/A (libgnomeprint/libgnomeprintui) so that those submodules will be built.
* Mon Aug 29 2005 - rich.burridge@sun.com
- Adjusted to put files under /usr/sfw
* Thu Aug 25 2005 - rich.burridge@sun.com
- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
* Mon Aug 22 2005 - rich.burridge@sun.com
- Adjustments needed to make the package proto maps equivalent to what gets
installed via "make install"
* Thu Aug 11 2005 - rich.burridge@sun.com
- initial version