SUNWgnome-python26.spec revision 19997
10139N/A#
10139N/A# spec file for package SUNWgnome-python26 aka library/python-2/gnome-python-26
10139N/A#
12147N/A# includes module(s): gnome-python
10139N/A#
10139N/A# Copyright (c) 2005,2011, Oracle and/or its affiliates. All rights reserved.
10139N/A#
15830N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
15291N/A%define owner laca
10139N/A#
15759N/A%include Solaris.inc
10139N/A%define pythonver 2.6
10139N/A%define python_version %{pythonver}
10139N/A
15298N/A%use gnome_python = gnome-python.spec
10139N/A
15319N/AName: SUNWgnome-python26
12773N/AIPS_package_name: library/python-2/gnome-python-26
15298N/AMeta(info.classification): %{classification_prefix}:Development/Python
12773N/ASummary: Python 2.6 support libraries for GNOME
15370N/AVersion: %{gnome_python.version}
15370N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ALicense: %{gnome_python.license}
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
10139N/A%include gnome-consolidation.inc
10139N/ARequires: SUNWlibgnomecanvas
10139N/ARequires: SUNWgnome-component
10139N/ARequires: SUNWgnome-config
10139N/ARequires: SUNWgnome-vfs
10139N/ARequires: SUNWlibgnomecanvas
10139N/ARequires: SUNWgnome-libs
10139N/ARequires: SUNWPython26-extra
10139N/ARequires: SUNWPython26
10139N/ARequires: SUNWpygobject26
10139N/ARequires: SUNWpygtk2-26
10139N/ARequires: SUNWpyorbit26
10139N/ABuildRequires: SUNWlibgnomecanvas-devel
10139N/ABuildRequires: SUNWPython26-devel
10139N/ABuildRequires: SUNWgnome-config-devel
10139N/ABuildRequires: SUNWgnome-vfs-devel
10139N/ABuildRequires: SUNWlibpopt-devel
10139N/ABuildRequires: SUNWgnome-libs-devel
10139N/ABuildRequires: SUNWgnome-file-mgr-devel
10139N/ABuildRequires: SUNWPython26-extra
10139N/ABuildRequires: SUNWgnome-component-devel
10139N/ABuildRequires: SUNWgnome-config-devel
10139N/ABuildRequires: SUNWgnome-gtksourceview-devel
10139N/ABuildRequires: SUNWpython26-setuptools
10139N/ABuildRequires: SUNWgtk-doc
10139N/ABuildRequires: SUNWgsed
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/A%include gnome-consolidation.inc
10139N/ARequires: %name
10139N/ARequires: SUNWPython26
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%gnome_python.prep -d %name-%version
10139N/A
15370N/A%build
10139N/APKG_CONFIG_DISABLE_UNINSTALLED=
10139N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
10139N/A
10139N/Aexport PYTHON="/usr/bin/python2.6"
10139N/Aexport CPPFLAGS="-I/usr/xpg4/include -I/usr/include/python%{pythonver}"
10139N/Aexport CFLAGS="%optflags -I/usr/xpg4/include -I%{_includedir} -I/usr/include/python%{pythonver}"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/Aexport PYCC_CC="$CC"
10139N/Aexport PYCC_CXX="$CXX"
10139N/A
10139N/A%gnome_python.build -d %name-%version
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
12773N/A%gnome_python.install -d %name-%version
12773N/A
12773N/A# move to vendor-packages
12773N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
12773N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10139N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
10139N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
10139N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
10139N/Afi
10139N/A
12379N/A# avoid conflict with 2.4:
10139N/Amv $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so \
10139N/A $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod-2.6.so
10139N/A
11204N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/python?.?/vendor-packages
15298N/A%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod-2.6.so
15298N/A
15298N/A%files devel
15298N/A%defattr(-, root, bin)
15298N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
12889N/A%dir %attr (0755, root, bin) %{_libdir}
12889N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
12889N/A%{_libdir}/pkgconfig/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%{_datadir}/*
10139N/A
10139N/A%changelog
10139N/A* Fri Feb 4 2010 - laszlo.peter@oracle.com
10139N/A- created, based on SUNWgnome-python26-libs.spec
10139N/A* Wed Sep 23 2009 - brian.cameron@sun.com
10139N/A- Use PKG_CONFIG_TOP_BUILD_DIR environment variable when building pygtk and
10139N/A pygtksourceview, so that pkg-config expands $(top_builddir), otherwise
10139N/A pygobject pkg-config variables do not expand nicely and the build fails.
10139N/A* Sat Jun 20 2009 - christian.kelly@sun.com
10139N/A- Minor pkg'ing fix.
10139N/A* Wed Mar 25 2009 - li.yuan@sun.com
10139N/A- Move pyspi from SUNWgnome-python-libs to SUNWgnome-a11y-libs.
10139N/A* Mon Feb 2 2009 - laca@sun.com
10139N/A- created, based on SUNWgnome-python25-libs.spec
10139N/A* Tue Nov 25 2008 - laca@sun.com
10139N/A- get rid of SUNWgnome-python-libs-common because there are no files
10139N/A that we can share between 2.4 and 2.5.
10139N/A* Mon Nov 24 2008 - laca@sun.com
10139N/A- created, based on SUNWPython-extra.spec
15830N/A* Wed Sep 17 2008 - laca@sun.com
15830N/A- set PYTHON to python2.4 (instead of just python) to make sure the
15759N/A right version is used for the build
15759N/A* Tue Aug 12 2008 - damien.carbery@sun.com
15692N/A- Add %{_libdir}/libpyglib-2.0.so* to %files.
15692N/A* Mon Aug 11 2008 - damien.carbery@sun.com
15692N/A- Move site-packages to vendor-packages here because pygobject 2.15.2 borked
15637N/A when vendor-packages was specified by pyexecdir and pythondir in make
15637N/A install.
15637N/A* Tue Oct 16 2007 - damien.carbery@sun.com
15515N/A- Remove unnecessary environment variable settings.
15515N/A* Mon Oct 8 2007 - damien.carbery@sun.com
15515N/A- Add SUNWgnome-gtksourceview dependency as it is required to by
15515N/A pygtksourceview.
15478N/A* Sun Oct 7 2007 - damien.carbery@sun.com
15478N/A- Add pygtksourceview as it is required to build python bindings in gedit.
15478N/A* Fri Sep 28 2007 - laca@sun.com
15424N/A- delete some unnecessary env vars
15424N/A* Fri Aug 31 2007 - damien.carbery@sun.com
15370N/A- Remove pygtksourceview.spec. It is still not building and isn't required.
15370N/A* Thu Jul 05 2007 - damien.carbery@sun.com
15319N/A- Add pygtksourceview.spec, but disable it because it is not building yet.
15319N/A* Tue Jan 9 2007 - laca@sun.com
15298N/A- define PYCC_CC and PYCC_CXX to override what the configure script sets
15298N/A in CC/CXX
15298N/A* Mon Aug 28 2006 - damien.carbery@sun.com
15291N/A- Fix typo in PKG_CONFIG_PATH data (s/=/-/).
15291N/A* Sun Jun 11 2006 - laca@sun.com
15219N/A- change group from other to bin/sys
15219N/A* Fri May 12 2006 - damien.carbery@sun.com
14457N/A- Small update to dependency list after check-deps.pl run.
14457N/A* Thu May 11 2006 - brian.cameron@sun.com
14185N/A- Move pygtk-demo to demo directory.
14185N/A* Wed Apr 5 2006 - damien.carbery@sun.com
14188N/A- Add pygobject. It has been moved from pygtk2.
14163N/A* Mon Feb 20 2006 - damien.carbery@sun.com
14163N/A- Complete update of Build/Requires after running check-deps.pl script.
14163N/A* Fri Feb 17 2006 - damien.carbery@sun.com
14015N/A- Update Build/Requires after running check-deps.pl script.
14015N/A* Mon Jan 09 2006 - damien.carbery@sun.com
13908N/A- Add gnome-vfs module.
13908N/A* Thu Oct 27 2005 - laca@sun.com
13908N/A- add pygtk2
13889N/A* Tue Sep 20 2005 - laca@sun.com
13889N/A- move to /usr as Python was also moved there
13889N/A* Thu Sep 01 2005 - damien.carbery@sun.com
13758N/A- Remove unused pygtk2 references.
13767N/A* Wed Aug 30 2005 - damien.carbery@sun.com
13767N/A- Add Build/Requires for SUNWgnome-file-mgr (nautilus) and SUNWgnome-print
13767N/A (libgnomeprint/libgnomeprintui) so that those submodules will be built.
13767N/A* Mon Aug 29 2005 - rich.burridge@sun.com
13758N/A- Adjusted to put files under /usr/sfw
13758N/A* Thu Aug 25 2005 - rich.burridge@sun.com
13624N/A- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
13624N/A* Mon Aug 22 2005 - rich.burridge@sun.com
13624N/A- Adjustments needed to make the package proto maps equivalent to what gets
13439N/A installed via "make install"
13439N/A* Thu Aug 11 2005 - rich.burridge@sun.com
13624N/A- initial version
12889N/A
12889N/A
13624N/A
12379N/A