20898N/A#
20898N/A# spec file for packages SUNWgnome-media, SUNWgnome-sound-recorder
20898N/A#
20898N/A# includes module(s): gnome-media
20898N/A#
20898N/A# Copyright (c) 2009, 2012, Oracle and/or its affiliates. All rights reserved.
20898N/A# This file and all modifications and additions to the pristine
20898N/A# package are under the same license as the package itself.
20898N/A#
20898N/A%define owner yippi
20898N/A#
20898N/A%include Solaris.inc
20898N/A
20898N/A%use gmedia = gnome-media.spec
20898N/A
20898N/AName: SUNWgnome-media-apps
20898N/AIPS_package_name: gnome/media/gnome-media
20898N/AMeta(info.classification): %{classification_prefix}:Applications/Sound and Video
20898N/ASummary: GNOME media components
20898N/AVersion: %{gmedia.version}
20898N/ASource: %{name}-manpages-0.1.tar.gz
20898N/ASUNW_BaseDir: %{_basedir}
20898N/ASUNW_Copyright: %{name}.copyright
20898N/ALicense: %{gmedia.license}
20898N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20898N/A
20898N/A%include default-depend.inc
20898N/A%include gnome-incorporation.inc
20898N/ABuildRequires: developer/parser/bison
20898N/ABuildRequires: runtime/python-26
20901N/ABuildRequires: library/audio/pulseaudio
20898N/ABuildRequires: library/desktop/xdg/libcanberra
20898N/ABuildRequires: gnome/gnome-audio
20898N/ABuildRequires: desktop/cd-burning/brasero
20898N/ABuildRequires: library/gnome/gnome-component
20898N/ABuildRequires: gnome/config/gconf
20898N/ABuildRequires: library/gnome/gnome-libs
20898N/ABuildRequires: library/audio/gstreamer
20898N/ABuildRequires: library/gnome/gnome-vfs
20898N/ABuildRequires: developer/gnome/gnome-doc-utils
20901N/ABuildRequires: library/gc
20901N/ABuildRequires: library/json-c
20901N/ABuildRequires: library/libsndfile
20898N/ARequires: library/desktop/libglade
20898N/ARequires: library/desktop/xdg/libcanberra
20898N/ARequires: system/library/math
20898N/ARequires: service/gnome/desktop-cache
20898N/ARequires: desktop/cd-burning/brasero
20898N/ARequires: gnome/config/gconf
20898N/ARequires: library/gnome/gnome-libs
20898N/ARequires: library/audio/gstreamer
20898N/ARequires: library/gnome/gnome-vfs
20898N/ARequires: developer/ui-designer/glade
20898N/A
20898N/A%package root
20898N/ASummary: %{summary} - / filesystem
20898N/ASUNW_BaseDir: /
20898N/A%include default-depend.inc
20898N/A%include gnome-incorporation.inc
20898N/A
20898N/A%package l10n
20898N/ASummary: %{summary} - l10n files
20898N/A
20898N/A%package devel
20898N/ASummary: %{summary} - development files
20898N/ASUNW_BaseDir: %{_basedir}
20898N/A%include default-depend.inc
20898N/A%include gnome-incorporation.inc
20898N/A
20898N/A%package -n SUNWgnome-sound-recorder
20898N/AIPS_package_name: gnome/media/sound-recorder
20898N/AMeta(info.classification): %{classification_prefix}:Applications/Sound and Video
20898N/ASummary: GNOME sound recording utilities
20898N/ASUNW_BaseDir: %{_basedir}
20898N/A%include default-depend.inc
20898N/A%include gnome-incorporation.inc
20898N/ARequires: library/desktop/gtk2
20898N/ARequires: library/gnome/gnome-libs
20898N/ARequires: gnome/gnome-audio
20898N/ARequires: gnome/config/gconf
20898N/ARequires: library/audio/gstreamer
20898N/ARequires: library/gnome/gnome-vfs
20898N/ARequires: service/gnome/desktop-cache
20898N/A
20898N/A%package -n SUNWgnome-sound-recorder-root
20898N/ASummary: GNOME sound recording utilities - / filesystem
20898N/AIPS_package_name: gnome/media/sound-recorder
20898N/ASUNW_BaseDir: /
20898N/A%include default-depend.inc
20898N/A%include gnome-incorporation.inc
20898N/A
20898N/A%prep
20898N/Arm -rf %name-%version
20898N/Amkdir %name-%version
20898N/A%gmedia.prep -d %name-%version
20898N/Acd %{_builddir}/%name-%version
20898N/Agzcat %SOURCE0 | tar xf -
20898N/A
20898N/A%build
20898N/A# Note that including __STDC_VERSION n CFLAGS for gnome-media breaks the S9
20898N/A# build for gstreamer, gst-plugins, and gnome-media, so not including for them.
20898N/A#
20898N/Aexport CFLAGS="%optflags -I/usr/sfw/include -DANSICPP"
20898N/Aexport RPM_OPT_FLAGS="$CFLAGS"
20898N/Aexport ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
20898N/Aexport LDFLAGS="%_ldflags"
20898N/A
20898N/A%gmedia.build -d %name-%version
20898N/A
20898N/A%install
20898N/Arm -rf $RPM_BUILD_ROOT
20898N/A%gmedia.install -d %name-%version
20898N/A
20898N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
20898N/Acd %{_builddir}/%name-%version/sun-manpages
20898N/Amake install DESTDIR=$RPM_BUILD_ROOT
20898N/A
20898N/Achmod 0644 $RPM_BUILD_ROOT%{_mandir}/man1/*.1
20898N/A
20898N/A# Remove .la and .a file as we don't ship them.
20898N/Afind $RPM_BUILD_ROOT -name "*.la" -exec rm {} \;
20898N/Afind $RPM_BUILD_ROOT -name "*.a" -exec rm {} \;
20898N/A
20898N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
20898N/A
20898N/A# process doc files
20898N/Acd %{_builddir}/%name-%version/gnome-media-%{gmedia.version}
20898N/A# Use bzip2 -k option since the original files are needed when packaging
20898N/A# the main SUNWgnome-media package.
20898N/Abzip2 -k COPYING COPYING-DOCS COPYING.grecord ChangeLog.pre-2-26 grecord/ChangeLog.pre-2-26 grecord/doc/ChangeLog po/ChangeLog NEWS grecord/NEWS
20898N/A
20898N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/SUNWgnome-sound-recorder
20898N/Atar cf - AUTHORS grecord/AUTHORS grecord/icons/AUTHORS README grecord/README COPYING.bz2 COPYING-DOCS.bz2 COPYING.grecord.bz2 ChangeLog-pre-2-26.bz2 po/ChangeLog.bz2 grecord/ChangeLog.bz2 grecord/doc/ChangeLog.bz2 NEWS.bz2 grecord/NEWS.bz2 | ( cd $RPM_BUILD_ROOT%{_datadir}/doc/SUNWgnome-sound-recorder; tar xf - )
20898N/A
20898N/A%clean
20898N/Arm -rf $RPM_BUILD_ROOT
20898N/A
20898N/A%post -n SUNWgnome-sound-recorder
20898N/A%restart_fmri desktop-mime-cache icon-cache gconf-cache
20898N/A
20898N/A%postun -n SUNWgnome-sound-recorder
20898N/A%restart_fmri desktop-mime-cache
20898N/A
20898N/A%post
20898N/A%restart_fmri desktop-mime-cache icon-cache gconf-cache
20898N/A
20898N/A%postun
20898N/A%restart_fmri desktop-mime-cache
20898N/A
20898N/A%files
20898N/A%defattr (-, root, bin)
20898N/A%dir %attr (0755, root, bin) %{_bindir}
20898N/A%{_bindir}/gnome-audio-profiles-properties
20898N/A%{_bindir}/gnome-volume-control
20898N/A%{_bindir}/gstreamer-properties
20898N/A%dir %attr (0755, root, bin) %{_libdir}
20898N/A%{_libdir}/libgnome-media*.so*
20898N/A#%{_libdir}/libglade/2.0/lib*.so*
20898N/A%dir %attr (0755, root, sys) %{_datadir}
20898N/A%dir %attr (0755, root, other) %{_datadir}/applications
20898N/A%{_datadir}/applications/gstreamer-properties.desktop
20898N/A%{_datadir}/applications/gnome-volume-control.desktop
20898N/A%doc gnome-media-%{gmedia.version}/AUTHORS
20898N/A%doc gnome-media-%{gmedia.version}/README
20898N/A%doc gnome-media-%{gmedia.version}/profiles/README
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/COPYING
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/COPYING-DOCS
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/COPYING.gst-mixer
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/COPYING.profiles
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/NEWS
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/ChangeLog.pre-2-26
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/gst-mixer/doc/ChangeLog
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/gstreamer-properties/help/ChangeLog
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/profiles/help/ChangeLog
20898N/A%doc(bzip2) gnome-media-%{gmedia.version}/po/ChangeLog
20898N/A%dir %attr (0755, root, other) %{_datadir}/doc
20898N/A%dir %attr (0755, root, other) %{_datadir}/gnome
20898N/A%{_datadir}/gnome/help/gnome-volume-control/C
20898N/A%{_datadir}/gnome/help/gstreamer-properties/C
20898N/A%{_datadir}/gnome-media
20898N/A%{_datadir}/gstreamer-properties
20898N/A%dir %attr (-, root, other) %{_datadir}/icons
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/devices
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/status
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
20898N/A%{_datadir}/icons/hicolor/16x16/devices/gvc-3d-sound.png
20898N/A%{_datadir}/icons/hicolor/16x16/devices/gvc-headphones.png
20898N/A%{_datadir}/icons/hicolor/16x16/devices/gvc-line-in.png
20898N/A%{_datadir}/icons/hicolor/16x16/devices/gvc-tone.png
20898N/A%{_datadir}/icons/hicolor/16x16/status/audio-input-microphone-muted.png
20898N/A%{_datadir}/icons/hicolor/48x48/apps/gstreamer-properties.png
20898N/A%dir %attr (0755, root, bin) %{_datadir}/sounds
20898N/A%{_datadir}/sounds/*
20898N/A%{_datadir}/omf/gstreamer-properties/gstreamer-properties-C.omf
20898N/A%{_datadir}/omf/gnome-volume-control/gnome-volume-control-C.omf
20898N/A%dir %attr(0755, root, bin) %{_mandir}
20898N/A%dir %attr(0755, root, bin) %{_mandir}/man1
20898N/A%dir %attr(0755, root, bin) %{_mandir}/man3
20898N/A%{_mandir}/man1/gnome-audio-profiles-properties.1
20898N/A%{_mandir}/man1/gnome-volume-control.1
20898N/A%{_mandir}/man1/gst*
20898N/A%{_mandir}/man3/*
20898N/A%{_datadir}/omf/gnome-audio-profiles/gnome-audio-profiles-C.omf
20898N/A%{_datadir}/gnome/help/gnome-audio-profiles/C/legal.xml
20898N/A%{_datadir}/gnome/help/gnome-audio-profiles/C/figures/gnome-audio-profiles-profiles-window.png
20898N/A%{_datadir}/gnome/help/gnome-audio-profiles/C/figures/gnome-audio-profiles-profile-window.png
20898N/A%{_datadir}/gnome/help/gnome-audio-profiles/C/gnome-audio-profiles.xml
20898N/A%{_datadir}/glade3/catalogs/gnome-media-profiles.xml
20898N/A%{_libdir}/glade3/modules/libgnome-media-profiles.so
20898N/A
20898N/A%files -n SUNWgnome-sound-recorder
20898N/A%defattr (-, root, bin)
20898N/A%dir %attr (0755, root, bin) %{_bindir}
20898N/A%{_bindir}/gnome-sound-recorder
20898N/A%dir %attr (0755, root, sys) %{_datadir}
20898N/A%dir %attr (0755, root, other) %{_datadir}/applications
20898N/A%{_datadir}/applications/gnome-sound-recorder.desktop
20898N/A%doc %{_datadir}/doc/SUNWgnome-sound-recorder
20898N/A%dir %attr (0755, root, other) %{_datadir}/doc
20898N/A%dir %attr (0755, root, other) %{_datadir}/gnome
20898N/A%{_datadir}/gnome/help/gnome-sound-recorder/C
20898N/A%{_datadir}/gnome-sound-recorder
20898N/A%dir %attr (-, root, other) %{_datadir}/icons
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
20898N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
20898N/A%{_datadir}/icons/hicolor/16x16/apps/gnome-sound-recorder.png
20898N/A%{_datadir}/icons/hicolor/22x22/apps/gnome-sound-recorder.png
20898N/A%{_datadir}/icons/hicolor/24x24/apps/gnome-sound-recorder.png
20898N/A%{_datadir}/icons/hicolor/32x32/apps/gnome-sound-recorder.png
20898N/A%{_datadir}/icons/hicolor/48x48/apps/gnome-sound-recorder.png
20898N/A%{_datadir}/icons/hicolor/scalable/apps/gnome-sound-recorder.svg
20898N/A%{_datadir}/omf/gnome-sound-recorder/gnome-sound-recorder-C.omf
20898N/A%dir %attr(0755, root, bin) %{_mandir}
20898N/A%dir %attr(0755, root, bin) %{_mandir}/man1
20898N/A%{_mandir}/man1/gnome-sound-recorder.1
20898N/A
20898N/A%files l10n
20898N/A%defattr (-, root, bin)
20898N/A%dir %attr (0755, root, sys) %{_datadir}
20898N/A%dir %attr (0755, root, other) %{_datadir}/gnome
20898N/A%attr (-, root, other) %{_datadir}/locale
20898N/A%{_datadir}/gnome/help/*/[a-z]*
20898N/A%{_datadir}/omf/*/*-[a-z][a-z].omf
20898N/A%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z][A-Z].omf
20898N/A
20898N/A%files root
20898N/A%defattr (-, root, sys)
20898N/A%attr (0755, root, sys) %dir %{_sysconfdir}
20898N/A%{_sysconfdir}/gconf/schemas/gnome-audio-profiles.schemas
20898N/A%{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas
20898N/A
20898N/A%files -n SUNWgnome-sound-recorder-root
20898N/A%defattr (-, root, sys)
20898N/A%attr (0755, root, sys) %dir %{_sysconfdir}
20898N/A%{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas
20898N/A
20898N/A%files devel
20898N/A%defattr (-, root, bin)
20898N/A%dir %attr (0755, root, bin) %{_libdir}
20898N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
20898N/A%{_libdir}/pkgconfig/*
20898N/A%dir %attr (0755, root, bin) %{_includedir}
20898N/A%{_includedir}/gnome-media/profiles
20898N/A%dir %attr (0755, root, sys) %{_datadir}
20898N/A
20898N/A%changelog
20898N/A* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
20898N/A- Updated BuildRequires to fit SourceJuicer.
20898N/A* Sun Mar 21 2010 - christian.kelly@sun.com
20898N/A- Add Requires SUNWgnome-ui-designer.
20898N/A* Tue Jan 05 2010 - dave.lin@sun.com
20898N/A- Changed the dependency from CBEbison to SUNWbison.
20898N/A* Thu Jul 30 2009 - brian.cameron@sun.com
20898N/A- Fix up packaging after bumping to 2.27.5.
20898N/A* Fri Jul 24 2009 - christian.kelly@sun.com
20898N/A- Fix up pkg'ing.
20898N/A* Fri Apr 17 2009 - brian.cameron@sun.com
20898N/A- Add SUNWlibcanberra as a dependency. It is needed for the "Sound Theme" tab
20898N/A to be built into gnome-volume-control.
20898N/A* Fri Apr 3 2009 - laca@sun.com
20898N/A- use desktop-cache instead of postrun
20898N/A* ???
20898N/A- Uncomment the line "%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z][A-Z].omf"
20898N/A in %file l10n as the file is available in 2.26.0.
20898N/A* Fri Sep 26 2008 - brian.cameron@sun.com
20898N/A- Now that the GPLv3 mixup is fixed, add new copyright files.
20898N/A* Tue Jun 03 2008 - brian.cameron@sun.com
20898N/A- Packaging changes related to bumping to 2.23. No longer ship
20898N/A cddb code or vumeter since these are no longer supported upstream.
20898N/A Remove support for building with gnome-cd since this is also
20898N/A no longer supported upstream. Removes SUNWgnome-freedb-libs/-root.
20898N/A* Wed May 07 2008 - damien.carbery@sun.com
20898N/A- Remove PERL5LIB setting as it is not necessary.
20898N/A* Wed Apr 02 2008 - brian.cameron@sun.com
20898N/A- Add SUNW_Copyright.
20898N/A* Wed Mar 12 2008 - damien.carbery@sun.com
20898N/A- Update %files for new tarball.
20898N/A* Thu Jan 3 2008 - laca@sun.com
20898N/A- use gconf-install.script instead of an inline script
20898N/A* Mon Oct 8 2007 - damien.carbery@sun.com
20898N/A- Remove some icons from base package because they are already in
20898N/A SUNWgnome-sound-recorder. Fixes 6613798.
20898N/A* Wed Sep 19 2007 - damien.carbery@sun.com
20898N/A- Update %files for 2.20.0 tarball - remove omf files and move png files.
20898N/A* Wed Sep 05 2007 - damien.carbery@sun.com
20898N/A- Remove references to SUNWgnome-a11y-base-libs as its contents have been
20898N/A moved to SUNWgnome-base-libs.
20898N/A* Wed Jan 24 2007 - brian.cameron@sun.com
20898N/A- Change %with_cd to %build_with_gnome_cd with suggestions from Laca.
20898N/A* Tue Jan 23 2007 - brian.cameron@sun.com
20898N/A- Add %with_cd logic so it is easier to build with gnome-cd if desired.
20898N/A* Mon Oct 16 2006 - damien.carbery@sun.com
20898N/A- Remove the '-rf' from the 'rm *.la *.a' lines so that any changes to the
20898N/A module source will be seen as a build error and action can be taken.
20898N/A* Mon Sep 04 2006 - Matt.Keenan@sun.com
20898N/A- New Manpage tarball
20898N/A* Mon Aug 21 2006 - damien.carbery@sun.com
20898N/A- Fix l10n package - C locale omf file was in base and l10n package.
20898N/A* Fri Jul 14 2006 - laca@sun.com
20898N/A- update %post/%postun/etc scripts to support diskless client setup,
20898N/A part of 6448317
20898N/A* Thu Jun 29 2006 - laca@sun.com
20898N/A- update postrun scripts
20898N/A* Sun Jun 11 2006 - laca@sun.com
20898N/A- change group from other to bin/sys
20898N/A* Fri Jun 2 2006 - laca@sun.com
20898N/A- use post/preun scripts to install schemas into the merged gconf files
20898N/A* Thu May 04 2006 - laca@sun.com
20898N/A- merge -share pkg(s) into the base pkg(s)
20898N/A* Tue Mar 28 2006 - brian.cameron@sun.com
20898N/A- Removed SUNWgnome-cd, since now using sound-juicer.
20898N/A* Tue Feb 21 2006 - damien.carbery@sun.com
20898N/A- Just a few more dependencies for SUNWgnome-cd.
20898N/A* Mon Feb 20 2006 - damien.carbery@sun.com
20898N/A- Complete update of Build/Requires after running check-deps.pl script.
20898N/A* Fri Feb 17 2006 - damien.carbery@sun.com
20898N/A- Update Build/Requires after running check-deps.pl script.
20898N/A* Fri Jan 20 2006 - brian.cameron@sun.com
20898N/A- Do not package gstreamer gconf files since GStreamer already installs
20898N/A its own.
20898N/A* Sat Dec 3 2005 - laca@sun.com
20898N/A- add %post script that runs update-desktop-database
20898N/A* Tue Nov 29 2005 - laca@sun.com
20898N/A- remove javahelp stuff
20898N/A* Fri Sep 30 2005 - brian.cameron@sun.com
20898N/A- Fix l10n packaging.
20898N/A* Thu Sep 22 2005 - brian.cameron@sun.com
20898N/A- Build gnome-cd again since sound-juicer doesn't build on Solaris.
20898N/A* Wed Sep 21 2005 - brian.cameron@sun.com
20898N/A- Fix packaging.
20898N/A* Tue Jul 12 2005 - balamurali.viswanathan@wipro.com
20898N/A- Don't build gnome-cd and remove nautilus-cd-burner dependency
20898N/A* Tue Jul 12 2005 - balamurali.viswanathan@wipro.com
20898N/A- Add nautilus-cd-burner dependency
20898N/A* Thu Jul 07 2005 - balamurali.viswanathan@wipro.com
20898N/A- Initial spec-file created
20898N/A
20898N/A
20898N/A