SUNWgnome-img-editor.spec revision 18688
10139N/A#
10139N/A# spec file for package SUNWgnome-img-editor
10139N/A#
12144N/A# includes module(s): gimp
10139N/A#
10139N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner leon.sha
10139N/A#
10139N/A%include Solaris.inc
12071N/A%define pythonver 2.6
10139N/A
10139N/A%use gimp = gimp.spec
10139N/A%use gimphdr = gimp-hdr.spec
10139N/AName: SUNWgnome-img-editor
11819N/AIPS_package_name: image/editor/gimp
12108N/AMeta(info.classification): %{classification_prefix}:Applications/Graphics and Imaging
12145N/ASummary: The Gimp image editor
10139N/AVersion: %{default_pkg_version}
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
10139N/ARequires: SUNWlibart
10139N/ARequires: SUNWgtk2
10139N/ARequires: SUNWgnome-libs
10139N/ARequires: SUNWgnome-python-libs
10139N/ARequires: SUNWgnome-pdf-viewer
10139N/ARequires: SUNWlibms
10139N/ARequires: SUNWTiff
10139N/ARequires: SUNWfontconfig
10139N/ARequires: SUNWfreetype2
10139N/ARequires: SUNWgnome-vfs
10139N/ARequires: SUNWjpg
10139N/ARequires: SUNWlibexif
10139N/ARequires: SUNWlibrsvg
10139N/ARequires: SUNWpng
10139N/ARequires: SUNWzlib
10139N/ARequires: SUNWdesktop-cache
12108N/ARequires: SUNWlcms
12145N/ARequires: SUNWPython26
10139N/ARequires: SUNWgegl
10139N/ARequires: SUNWbabl
10139N/ARequires: SUNWaalib
10139N/ABuildRequires: SUNWgtk2-devel
10139N/ABuildRequires: SUNWTiff-devel
10139N/ABuildRequires: SUNWgnome-vfs-devel
10139N/ABuildRequires: SUNWjpg-devel
10139N/ABuildRequires: SUNWlibexif-devel
10139N/ABuildRequires: SUNWlibrsvg-devel
10139N/ABuildRequires: SUNWpng-devel
10139N/ABuildRequires: SUNWgnome-python-libs-devel
10139N/ABuildRequires: SUNWpython-setuptools
10139N/ABuildRequires: SUNWgnome-pdf-viewer-devel
10139N/ABuildRequires: SUNWgnome-libs-devel
10139N/ABuildRequires: SUNWgnome-python-libs-devel
10139N/ABuildRequires: SUNWlcms
10778N/ABuildRequires: SUNWgegl-devel
10778N/ABuildRequires: SUNWbabl-devel
10139N/ABuildRequires: SUNWaalib
10139N/A%if %build_l10n
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/ARequires: %{name}
10139N/A%endif
10139N/A
11370N/A%package root
12108N/ASummary: %{summary} - / filesystem
12108N/ASUNW_BaseDir: /
12144N/A%include default-depend.inc
12144N/A
11142N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%gimp.prep -d %name-%version
10139N/A%gimphdr.prep -d %name-%version
10139N/A
10139N/A%build
10139N/Aexport CFLAGS="%optflags -I%{_includedir} -KPIC"
10424N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport CPPFLAGS="-I/usr/sfw/include"
10139N/Aexport LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"
10139N/Aexport PATH=$PATH:%{_builddir}/%name-%version/gimp-%{gimp.version}/tools
10139N/Aexport PKG_CONFIG_PATH=%{_builddir}/%name-%version/gimp-%{gimp.version}:/usr/lib/python%{pythonver}/pkgconfig
10139N/Aexport EXTRA_CFLAGS="-I%{_builddir}/%name-%version/gimp-%{gimp.version}/ -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpcolor -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpmath -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimp -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpconfig -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpwidgets"
10139N/Aexport EXTRA_LDFLAGS="-L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpbase/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpcolor/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpmath/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimp/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpconfig/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpwidgets/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpmodule/.libs"
10139N/Aexport PYTHON=/usr/bin/python%{pythonver}
10139N/A
10139N/A%gimp.build -d %name-%version
10139N/A%gimphdr.build -d %name-%version
10139N/A
10139N/A%install
10139N/Aexport PATH=$PATH:%{_builddir}/%name-%version/gimp-%{gimp.version}/tools
10139N/Aexport PKG_CONFIG_PATH=%{_builddir}/%name-%version/gimp-%{gimp.version}:/usr/lib/python%{pythonver}/pkgconfig
10139N/A%gimp.install -d %name-%version
10139N/A%gimphdr.install -d %name-%version
10139N/A
10139N/A%if %build_l10n
10139N/A%else
10139N/A# REMOVE l10n FILES
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
10139N/A%endif
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A%postun
10139N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/lib*.so*
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/environ
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/modules
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/plug-ins
10139N/A%{_libdir}/gimp/%gimp.subver_install/environ/*
10139N/A%{_libdir}/gimp/%gimp.subver_install/modules/lib*.so*
10139N/A%{_libdir}/gimp/%gimp.subver_install/plug-ins/*
10139N/A%{_libdir}/gimp/%gimp.subver_install/interpreters
10139N/A%{_libdir}/gimp/%gimp.subver_install/python
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/gimp
10139N/A%attr (-, root, other) %{_datadir}/icons
10139N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/tinyscheme/COPYING
10139N/A%doc gimp-%{gimp.version}/LICENSE
10139N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/ftx/LICENSE
10139N/A%doc gimp-%{gimp.version}/devel-docs/README
12145N/A%doc gimp-%{gimp.version}/devel-docs/tools/README.shooter
12145N/A%doc gimp-%{gimp.version}/docs/Wilber.xcf.gz.README
12144N/A%doc gimp-%{gimp.version}/app/pdb/README
12144N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/ftx/README
12108N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/tinyscheme/README
12108N/A%doc gimp-%{gimp.version}/plug-ins/flame/README
12108N/A%doc gimp-%{gimp.version}/plug-ins/gradient-flare/README
12071N/A%doc gimp-%{gimp.version}/plug-ins/ifs-compose/README.ifscompose
12071N/A%doc gimp-%{gimp.version}/plug-ins/lighting/README
12022N/A%doc gimp-%{gimp.version}/plug-ins/map-object/README
12022N/A%doc gimp-%{gimp.version}/plug-ins/metadata/README
11922N/A%doc gimp-%{gimp.version}/plug-ins/selection-to-path/README
11922N/A%doc gimp-%{gimp.version}/plug-ins/selection-to-path/README.limn
11819N/A%doc gimp-%{gimp.version}/plug-ins/twain/README
11819N/A%doc(bzip2) gimp-%{gimp.version}/AUTHORS
11416N/A%doc(bzip2) gimp-%{gimp.version}/COPYING
11416N/A%doc(bzip2) gimp-%{gimp.version}/libgimp/COPYING
11370N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/pygimp/COPYING
11370N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog
11370N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-1-0
11256N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-1-2
11256N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-2-0
11172N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-2-2
11175N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-2-4
11136N/A%doc(bzip2) gimp-%{gimp.version}/devel-docs/ChangeLog
11136N/A%doc(bzip2) gimp-%{gimp.version}/po/ChangeLog
11123N/A%doc(bzip2) gimp-%{gimp.version}/po-libgimp/ChangeLog
11123N/A%doc(bzip2) gimp-%{gimp.version}/po-plug-ins/ChangeLog
11083N/A%doc(bzip2) gimp-%{gimp.version}/po-python/ChangeLog
11083N/A%doc(bzip2) gimp-%{gimp.version}/po-script-fu/ChangeLog
11083N/A%doc(bzip2) gimp-%{gimp.version}/po-tips/ChangeLog
11066N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/script-fu/tinyscheme/CHANGES
11071N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/gimpressionist/ChangeLog
11071N/A%doc(bzip2) gimp-%{gimp.version}/NEWS
11066N/A%doc(bzip2) gimp-%{gimp.version}/NEWS.pre-2-0
10972N/A%doc(bzip2) gimp-%{gimp.version}/NEWS.pre-2-2
10972N/A%doc(bzip2) gimp-%{gimp.version}/NEWS.pre-2-4
10972N/A%doc(bzip2) gimp-%{gimp.version}/README
10820N/A%doc(bzip2) gimp-%{gimp.version}/devel-docs/README.gtkdoc
10820N/A%doc(bzip2) gimp-%{gimp.version}/README.i18n
10778N/A%doc(bzip2) gimp-%{gimp.version}/tools/pdbgen/README
10778N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/gfig/README
10778N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/gimpressionist/README
10778N/A%dir %attr (0755, root, other) %{_datadir}/doc
10774N/A
10774N/A%if %build_l10n
10748N/A%files l10n
10748N/A%defattr (-, root, bin)
10666N/A%dir %attr (0755, root, sys) %{_datadir}
10666N/A%attr (-, root, other) %{_datadir}/locale
10650N/A%endif
10650N/A
10596N/A%files root
10596N/A%defattr (-, root, sys)
10580N/A%attr (0755, root, sys) %dir %{_sysconfdir}
10580N/A%{_sysconfdir}/*
10473N/A
10473N/A%files devel
10424N/A%defattr (-, root, bin)
10424N/A%dir %attr (0755, root, bin) %{_includedir}
10424N/A%{_includedir}/*
10346N/A%dir %attr (0755, root, bin) %{_libdir}
10346N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10285N/A%{_libdir}/pkgconfig/*
10285N/A%dir %attr (0755, root, sys) %{_datadir}
10179N/A%dir %attr (0755, root, other) %{_datadir}/aclocal
10187N/A%{_datadir}/aclocal/*
10139N/A%{_datadir}/gtk-doc
10139N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
10139N/A
10139N/A%changelog
10139N/A* Mon Dec 21 2009 - ghee.teo@sun.com
10139N/A- Remove SUNWgnome-print dependency.
10139N/A* Fri Oct 16 2009 - leon.sha@sun.com
10139N/A- Bug 6890513 SUNWgnome-img-editor package dependency on dynamically
10139N/A linked libs not captured.
10139N/A* Mon Sep 07 2009 - dave.lin@sun.com
10139N/A- Change the dependency to python 2.6.
10139N/A* Fri Jul 3 2009 - chris.wang@sun.com
10139N/A- Change PATH to gimp2.66/tools as gimptool-2.0 is installed in
10139N/A this location since 2.6.6
10139N/A* Fri Jun 26 2009 - chris.wang@sun.com
10139N/A- Change owner to leon.sha
10139N/A* Mon Jun 1 2009 - chris.wang@sun.com
10139N/A- Change owner to bewitche
10139N/A* Fri Apr 3 2009 - laca@sun.com
10139N/A- use desktop-cache instead of postrun
10139N/A* Mon Mar 23 2009 - jeff.cai@sun.com
10139N/A- Since /usr/lib/gimp/2.0/plug-ins/colorxhtml.py (SUNWgnome-img-editor)
10139N/A requires /usr/bin/i86/isapython2.4 which is found in SUNWPython, add
10139N/A the dependency.
10139N/A* Tue Feb 24 2009 - laca@sun.com
10139N/A- set PYTHON and PKG_CONFIG_PATH so the correct python version and
10139N/A dependencies are picked up
10139N/A* Tue Sep 16 2008 - matt.keenan@sun.com
10139N/A- Update copyright
10139N/A* Wed May 21 2008 - damien.carbery@sun.com
10139N/A- Add Build/Requires: SUNWlcms after check-deps.pl run.
10139N/A* Fri Jan 11 2008 - laca@sun.com
10139N/A- delete PKG_CONFIG_PATH setting since help was removed
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- delete Nevada X dep
10139N/A* Tue Apr 24 2007 - laca@sun.com
10139N/A- s/0755/-/ in defattr so that files are not made all executable
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- delete some unnecessary env variables
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- change datadir/icons permissions back to root:other since it's a stable
10139N/A interface and wasn't supposed to be changed
10139N/A* Fri Jul 14 2006 - laca@sun.com
10139N/A- update %post/%postun/etc scripts to support diskless client setup,
10139N/A part of 6448317
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- update postrun scripts
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Wed May 10 2006 - laca@sun.com
10139N/A- merge -share pkg(s) into the base pkg(s)
10139N/A* Fri Apr 28 2006 - damien.carbery@sun.com
10139N/A- Fix %files after move to /usr/bin.
10139N/A* Fri Apr 28 2006 - glynn.foster@sun.com
10139N/A- Move into /usr/bin as standard
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Complete update of Build/Requires after running check-deps.pl script.
10139N/A* Thu Feb 16 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Sat Dec 3 2005 - laca@sun.com
10139N/A- add %post script that runs update-desktop-database
10139N/A* Fri Dec 02 2005 - damien.carbery@sun.com
10139N/A- Change SUNWpoppler dependency to SUNWgnome-pdf-viewer as poppler has moved.
10139N/A* Fri Sep 30 2005 - brian.cameron@sun.com
10139N/A- add SUNWpoppler as build requirement.
10139N/A* Tue Sep 20 2005 - laca@sun.com
10139N/A- add unpackaged files to %files
10139N/A* Tue Aug 30 2005 - damien.carbery@sun.com
10139N/A- Add Build/Requires for SUNWgnome-pygtk2.
10139N/A* Fri Jan 21 2005 - damien.carbery@sun.com
10139N/A- Change PKG_CONFIG_PATH to build gimp-help module.
10139N/A* Mon Dec 13 2004 - damien.carbery@sun.com
10139N/A- Move to /usr/sfw to implement ARC decision.
10139N/A* Sun Nov 14 2004 - laca@sun.com
10139N/A- add -KPIC to CFLAGS, because the Makefiles hardcode -fPIC :/
10139N/A* Fri Nov 12 2004 - laca@sun.com
10139N/A- move to /usr/demo/jds
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Wed Sep 01 2004 - shirley.woo@sun.com
10139N/A- Bug 5091588 : man5 files should be in devel-share package
10139N/A* Mon Aug 23 2004 - laca@sun.com
10139N/A- s/SUNWpl5u/SUNWperl584usr/
10139N/A* Fri Aug 20 2004 - damien.carbery@sun.com
10139N/A- Change file paths for new version of Gimp. Use variable from gimp.spec so
10139N/A future version updates will not need a change here.
10139N/A* Tue Jun 22 2004 - shirley.woo@sun.com
10139N/A- changed install location to /usr/lib and /usr/bin
10139N/A* Wed Jun 2 2004 - takao.fujiwara@sun.com
10139N/A- Added %{_datadir}/locale to install l10n messages
10139N/A* Tue May 18 2004 - laca@sun.com
10139N/A- add sfw to LDFLAGS/CPPFLAGS (patch from Shirley)
10139N/A* Fri Mar 26 2004 - brian.cameron@sun.com
10139N/A- Created,
10139N/A
10139N/A