10139N/A#
10139N/A# spec file for package SUNWgnome-img-editor
10139N/A#
10139N/A# includes module(s): gimp
10139N/A#
16307N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner leon.sha
10139N/A#
10139N/A%include Solaris.inc
17240N/A%define pythonver 2.6
10139N/A
10139N/A%use gimp = gimp.spec
13598N/A%use gimphdr = gimp-hdr.spec
10139N/AName: SUNWgnome-img-editor
19958N/ALicense: GPL v3, LGPL v2.1
18688N/AIPS_package_name: image/editor/gimp
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Graphics and Imaging
10139N/ASummary: The Gimp image editor
20056N/AVersion: %{gimp.version}
10139N/ASUNW_BaseDir: %{_basedir}
12856N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
16401N/ARequires: SUNWlibart
16401N/ARequires: SUNWgtk2
10139N/ARequires: SUNWgnome-libs
19997N/ARequires: SUNWpygtk2-26
10139N/ARequires: SUNWgnome-pdf-viewer
10139N/ARequires: SUNWlibms
10139N/ARequires: SUNWTiff
10139N/ARequires: SUNWfontconfig
10139N/ARequires: SUNWfreetype2
10139N/ARequires: SUNWgnome-vfs
10139N/ARequires: SUNWjpg
10139N/ARequires: SUNWlibexif
10139N/ARequires: SUNWlibrsvg
10139N/ARequires: SUNWpng
10139N/ARequires: SUNWzlib
16307N/ARequires: SUNWdesktop-cache
13075N/ARequires: SUNWlcms
17240N/ARequires: SUNWPython26
16575N/ARequires: SUNWgegl
16575N/ARequires: SUNWbabl
17529N/ARequires: SUNWaalib
16401N/ABuildRequires: SUNWgtk2-devel
10139N/ABuildRequires: SUNWTiff-devel
10139N/ABuildRequires: SUNWgnome-vfs-devel
10139N/ABuildRequires: SUNWjpg-devel
10139N/ABuildRequires: SUNWlibexif-devel
10139N/ABuildRequires: SUNWlibrsvg-devel
10139N/ABuildRequires: SUNWpng-devel
19997N/ABuildRequires: SUNWpygtk2-26-devel
18993N/ABuildRequires: SUNWpython26-setuptools
10139N/ABuildRequires: SUNWgnome-pdf-viewer-devel
10139N/ABuildRequires: SUNWgnome-libs-devel
13075N/ABuildRequires: SUNWlcms
16575N/ABuildRequires: SUNWgegl-devel
16575N/ABuildRequires: SUNWbabl-devel
17529N/ABuildRequires: SUNWaalib
20829N/A
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ARequires: %{name}
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%gimp.prep -d %name-%version
13598N/A%gimphdr.prep -d %name-%version
10139N/A
10139N/A%build
10139N/Aexport CFLAGS="%optflags -I%{_includedir} -KPIC"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport CPPFLAGS="-I/usr/sfw/include"
10139N/Aexport LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"
16745N/Aexport PATH=$PATH:%{_builddir}/%name-%version/gimp-%{gimp.version}/tools
15964N/Aexport PKG_CONFIG_PATH=%{_builddir}/%name-%version/gimp-%{gimp.version}:/usr/lib/python%{pythonver}/pkgconfig
13598N/Aexport EXTRA_CFLAGS="-I%{_builddir}/%name-%version/gimp-%{gimp.version}/ -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpcolor -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpmath -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimp -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpconfig -I%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpwidgets"
13598N/Aexport EXTRA_LDFLAGS="-L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpbase/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpcolor/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpmath/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimp/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpconfig/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpwidgets/.libs -L%{_builddir}/%name-%version/gimp-%{gimp.version}/libgimpmodule/.libs"
15964N/Aexport PYTHON=/usr/bin/python%{pythonver}
10139N/A
10139N/A%gimp.build -d %name-%version
13598N/A%gimphdr.build -d %name-%version
10139N/A
10139N/A%install
16745N/Aexport PATH=$PATH:%{_builddir}/%name-%version/gimp-%{gimp.version}/tools
16745N/Aexport PKG_CONFIG_PATH=%{_builddir}/%name-%version/gimp-%{gimp.version}:/usr/lib/python%{pythonver}/pkgconfig
10139N/A%gimp.install -d %name-%version
13598N/A%gimphdr.install -d %name-%version
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
16307N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A%postun
16307N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/lib*.so*
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/environ
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/modules
10139N/A%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/plug-ins
10139N/A%{_libdir}/gimp/%gimp.subver_install/environ/*
10139N/A%{_libdir}/gimp/%gimp.subver_install/modules/lib*.so*
10139N/A%{_libdir}/gimp/%gimp.subver_install/plug-ins/*
10139N/A%{_libdir}/gimp/%gimp.subver_install/interpreters
10139N/A%{_libdir}/gimp/%gimp.subver_install/python
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/gimp
10139N/A%attr (-, root, other) %{_datadir}/icons
14348N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/tinyscheme/COPYING
14348N/A%doc gimp-%{gimp.version}/LICENSE
14348N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/ftx/LICENSE
14348N/A%doc gimp-%{gimp.version}/devel-docs/README
14348N/A%doc gimp-%{gimp.version}/devel-docs/tools/README.shooter
14348N/A%doc gimp-%{gimp.version}/docs/Wilber.xcf.gz.README
14348N/A%doc gimp-%{gimp.version}/app/pdb/README
14348N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/ftx/README
14348N/A%doc gimp-%{gimp.version}/plug-ins/script-fu/tinyscheme/README
14348N/A%doc gimp-%{gimp.version}/plug-ins/flame/README
16575N/A%doc gimp-%{gimp.version}/plug-ins/gradient-flare/README
16575N/A%doc gimp-%{gimp.version}/plug-ins/ifs-compose/README.ifscompose
16575N/A%doc gimp-%{gimp.version}/plug-ins/lighting/README
16575N/A%doc gimp-%{gimp.version}/plug-ins/map-object/README
14348N/A%doc gimp-%{gimp.version}/plug-ins/metadata/README
16575N/A%doc gimp-%{gimp.version}/plug-ins/selection-to-path/README
16575N/A%doc gimp-%{gimp.version}/plug-ins/selection-to-path/README.limn
14348N/A%doc gimp-%{gimp.version}/plug-ins/twain/README
14348N/A%doc(bzip2) gimp-%{gimp.version}/AUTHORS
14348N/A%doc(bzip2) gimp-%{gimp.version}/COPYING
14348N/A%doc(bzip2) gimp-%{gimp.version}/libgimp/COPYING
14348N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/pygimp/COPYING
14348N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-1-0
14348N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-1-2
14348N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-2-0
14348N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-2-2
14348N/A%doc(bzip2) gimp-%{gimp.version}/ChangeLog.pre-2-4
14348N/A%doc(bzip2) gimp-%{gimp.version}/devel-docs/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/po/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/po-libgimp/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/po-plug-ins/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/po-python/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/po-script-fu/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/po-tips/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/script-fu/tinyscheme/CHANGES
14348N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/gimpressionist/ChangeLog
14348N/A%doc(bzip2) gimp-%{gimp.version}/NEWS
14348N/A%doc(bzip2) gimp-%{gimp.version}/NEWS.pre-2-0
14348N/A%doc(bzip2) gimp-%{gimp.version}/NEWS.pre-2-2
14348N/A%doc(bzip2) gimp-%{gimp.version}/NEWS.pre-2-4
14348N/A%doc(bzip2) gimp-%{gimp.version}/README
14348N/A%doc(bzip2) gimp-%{gimp.version}/devel-docs/README.gtkdoc
14348N/A%doc(bzip2) gimp-%{gimp.version}/README.i18n
14348N/A%doc(bzip2) gimp-%{gimp.version}/tools/pdbgen/README
14348N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/gfig/README
14348N/A%doc(bzip2) gimp-%{gimp.version}/plug-ins/gimpressionist/README
14348N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%attr (-, root, other) %{_datadir}/locale
10139N/A
10139N/A%files root
10139N/A%defattr (-, root, sys)
10139N/A%attr (0755, root, sys) %dir %{_sysconfdir}
10139N/A%{_sysconfdir}/*
10139N/A
10139N/A%files devel
10522N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/aclocal
10139N/A%{_datadir}/aclocal/*
10139N/A%{_datadir}/gtk-doc
10139N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
10139N/A
10139N/A%changelog
17967N/A* Mon Dec 21 2009 - ghee.teo@sun.com
17967N/A- Remove SUNWgnome-print dependency.
17529N/A* Fri Oct 16 2009 - leon.sha@sun.com
17529N/A- Bug 6890513 SUNWgnome-img-editor package dependency on dynamically
17529N/A linked libs not captured.
17240N/A* Mon Sep 07 2009 - dave.lin@sun.com
17240N/A- Change the dependency to python 2.6.
16745N/A* Fri Jul 3 2009 - chris.wang@sun.com
16745N/A- Change PATH to gimp2.66/tools as gimptool-2.0 is installed in
16745N/A this location since 2.6.6
16714N/A* Fri Jun 26 2009 - chris.wang@sun.com
16714N/A- Change owner to leon.sha
16714N/A* Mon Jun 1 2009 - chris.wang@sun.com
16575N/A- Change owner to bewitche
16307N/A* Fri Apr 3 2009 - laca@sun.com
16307N/A- use desktop-cache instead of postrun
16224N/A* Mon Mar 23 2009 - jeff.cai@sun.com
16224N/A- Since /usr/lib/gimp/2.0/plug-ins/colorxhtml.py (SUNWgnome-img-editor)
16224N/A requires /usr/bin/i86/isapython2.4 which is found in SUNWPython, add
16224N/A the dependency.
15964N/A* Tue Feb 24 2009 - laca@sun.com
15964N/A- set PYTHON and PKG_CONFIG_PATH so the correct python version and
15964N/A dependencies are picked up
14348N/A* Tue Sep 16 2008 - matt.keenan@sun.com
14348N/A- Update copyright
13075N/A* Wed May 21 2008 - damien.carbery@sun.com
13075N/A- Add Build/Requires: SUNWlcms after check-deps.pl run.
12203N/A* Fri Jan 11 2008 - laca@sun.com
12203N/A- delete PKG_CONFIG_PATH setting since help was removed
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- delete Nevada X dep
10522N/A* Tue Apr 24 2007 - laca@sun.com
10522N/A- s/0755/-/ in defattr so that files are not made all executable
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- delete some unnecessary env variables
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- change datadir/icons permissions back to root:other since it's a stable
10139N/A interface and wasn't supposed to be changed
10139N/A* Fri Jul 14 2006 - laca@sun.com
10139N/A- update %post/%postun/etc scripts to support diskless client setup,
10139N/A part of 6448317
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- update postrun scripts
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Wed May 10 2006 - laca@sun.com
10139N/A- merge -share pkg(s) into the base pkg(s)
10139N/A* Fri Apr 28 2006 - damien.carbery@sun.com
10139N/A- Fix %files after move to /usr/bin.
10139N/A* Fri Apr 28 2006 - glynn.foster@sun.com
10139N/A- Move into /usr/bin as standard
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Complete update of Build/Requires after running check-deps.pl script.
10139N/A* Thu Feb 16 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Sat Dec 3 2005 - laca@sun.com
10139N/A- add %post script that runs update-desktop-database
10139N/A* Fri Dec 02 2005 - damien.carbery@sun.com
10139N/A- Change SUNWpoppler dependency to SUNWgnome-pdf-viewer as poppler has moved.
10139N/A* Fri Sep 30 2005 - brian.cameron@sun.com
10139N/A- add SUNWpoppler as build requirement.
10139N/A* Tue Sep 20 2005 - laca@sun.com
10139N/A- add unpackaged files to %files
10139N/A* Tue Aug 30 2005 - damien.carbery@sun.com
10139N/A- Add Build/Requires for SUNWgnome-pygtk2.
10139N/A* Fri Jan 21 2005 - damien.carbery@sun.com
10139N/A- Change PKG_CONFIG_PATH to build gimp-help module.
10139N/A* Mon Dec 13 2004 - damien.carbery@sun.com
10139N/A- Move to /usr/sfw to implement ARC decision.
10139N/A* Sun Nov 14 2004 - laca@sun.com
10139N/A- add -KPIC to CFLAGS, because the Makefiles hardcode -fPIC :/
10139N/A* Fri Nov 12 2004 - laca@sun.com
10139N/A- move to /usr/demo/jds
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Wed Sep 01 2004 - shirley.woo@sun.com
10139N/A- Bug 5091588 : man5 files should be in devel-share package
10139N/A* Mon Aug 23 2004 - laca@sun.com
10139N/A- s/SUNWpl5u/SUNWperl584usr/
10139N/A* Fri Aug 20 2004 - damien.carbery@sun.com
10139N/A- Change file paths for new version of Gimp. Use variable from gimp.spec so
10139N/A future version updates will not need a change here.
10139N/A* Tue Jun 22 2004 - shirley.woo@sun.com
10139N/A- changed install location to /usr/lib and /usr/bin
10139N/A* Wed Jun 2 2004 - takao.fujiwara@sun.com
10139N/A- Added %{_datadir}/locale to install l10n messages
10139N/A* Tue May 18 2004 - laca@sun.com
10139N/A- add sfw to LDFLAGS/CPPFLAGS (patch from Shirley)
10139N/A* Fri Mar 26 2004 - brian.cameron@sun.com
10139N/A- Created,
16401N/A
19252N/A
19569N/A