SUNWgnome-games.spec revision 18688
12258N/A# spec file for package SUNWgnome-games
12258N/A#
12258N/A# includes module(s): gnome-games, libggz, ggz-client-libs
12412N/A#
12258N/A# Copyright 2009 Sun Microsystems, Inc.
12258N/A# This file and all modifications and additions to the pristine
12258N/A# package are under the same license as the package itself.
15894N/A#
12258N/A%define owner migi
12258N/A#
15153N/A%include Solaris.inc
12258N/A
15293N/A%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
12258N/A%use gnome_games = gnome-games.spec
16080N/A%use libggz = libggz.spec
15839N/A%use ggz_client_libs = ggz-client-libs.spec
12258N/A
12258N/AName: SUNWgnome-games
12258N/AIPS_package_name: games/gnome-games
12258N/AMeta(info.classification): %{classification_prefix}:Applications/Games
12258N/ASummary: GNOME games
16080N/AVersion: %{default_pkg_version}
15153N/ASource: %{name}-manpages-0.1.tar.gz
15153N/ASUNW_BaseDir: %{_basedir}
12258N/ASUNW_Copyright: %{name}.copyright
12258N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12258N/A
12258N/A%include default-depend.inc
12517N/ABuildRequires: SUNWgtk2-devel
12517N/ABuildRequires: SUNWlibrsvg-devel
12258N/ABuildRequires: SUNWPython26-devel
12258N/ABuildRequires: SUNWpython26-setuptools
12258N/ABuildRequires: SUNWgnome-libs-devel
12258N/ABuildRequires: SUNWgnome-vfs-devel
12474N/ABuildRequires: SUNWgnome-config-devel
12258N/ABuildRequires: SUNWgnome-python26-desktop-devel
12258N/ABuildRequires: SUNWlibsdl-devel
12517N/ABuildRequires: SUNWgnome-media-devel
13032N/ARequires: SUNWgtk2
12820N/ARequires: SUNWgnome-libs
15234N/ARequires: SUNWgnome-config
13759N/ARequires: SUNWlibms
13851N/ARequires: SUNWgnome-python26-desktop
13851N/ARequires: SUNWlibrsvg
15234N/ARequires: SUNWPython26
14061N/ARequires: SUNWdesktop-cache
14295N/ARequires: SUNWgnome-media
14295N/ARequires: SUNWclutter
15259N/ARequires: SUNWclutter-gtk
15259N/ARequires: %{name}-root
15260N/A
15260N/A%if %build_l10n
15856N/A%package l10n
15856N/ASummary: %{summary} - l10n files
15856N/ASUNW_BaseDir: %{_basedir}
15856N/A%include default-depend.inc
16080N/ARequires: %{name}
16080N/A%endif
16080N/A
16080N/A%package root
12258N/ASummary: %{summary} - / filesystem
12258N/ASUNW_BaseDir: /
12258N/A%include default-depend.inc
12258N/A
12258N/A%package devel
12258N/ASummary: %{summary} - development files
12258N/ASUNW_BaseDir: %{_basedir}
12258N/A%include default-depend.inc
12258N/ARequires: %{name}
12258N/A
12258N/A%prep
12258N/Arm -rf %name-%version
12258N/Amkdir %name-%version
12258N/A%libggz.prep -d %name-%version
12258N/A%ggz_client_libs.prep -d %name-%version
12258N/A%gnome_games.prep -d %name-%version
12258N/Acd %{_builddir}/%name-%version
12258N/Agzcat %SOURCE0 | tar xf -
12258N/A
12258N/A%build
12258N/A%define libggz_build_dir %{_builddir}/%name-%version/libggz-%{libggz.version}
12258N/A%define ggzclient_build_dir %{_builddir}/%name-%version/ggz-client-libs-%{ggz_client_libs.version}
12258N/A
12258N/Aexport PKG_CONFIG_PATH=%{_pkg_config_path}:/usr/lib/python%{default_python_version}/pkgconfig
12258N/Aexport CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include -xc99 -I%{libggz_build_dir}/src -I%{ggzclient_build_dir}/ggzmod -I%{ggzclient_build_dir}/ggzcore"
12258N/Aexport RPM_OPT_FLAGS="$CFLAGS"
12258N/Aexport LDFLAGS="%_ldflags -lX11 -L/usr/sfw/lib -lexpat -L%{libggz_build_dir}/src/.libs -L%{ggzclient_build_dir}/ggzmod/.libs -L%{ggzclient_build_dir}/ggzcore/.libs"
12258N/Aexport LD_LIBRARY_PATH="%{libggz_build_dir}/src/.libs:%{ggzclient_build_dir}/ggzmod/.libs:%{ggzclient_build_dir}/ggzcore/.libs"
12258N/Aexport PATH="$PATH:"`dirname $CXX`
12258N/Aexport CXX=`basename $CXX`
12258N/Aexport ACLOCAL_FLAGS="-I%{_datadir}/aclocal"
12258N/A
12258N/A# find GNU xgettext
12258N/AIFS=:
12258N/Afor dir in $PATH; do
12258N/A test -x "$dir/xgettext" && \
12258N/A "$dir/xgettext" --version 2>&1 | egrep -s 'GNU gettext' && \
16080N/A XGETTEXT="$dir/xgettext"
15523N/Adone
15153N/Aexport XGETTEXT
15153N/A
15153N/A%libggz.build -d %name-%version
16080N/A%ggz_client_libs.build -d %name-%version
13875N/A%gnome_games.build -d %name-%version
12258N/A
13875N/A%install
13708N/Arm -rf $RPM_BUILD_ROOT
16080N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
16080N/A%libggz.install -d %name-%version
16080N/A%ggz_client_libs.install -d %name-%version
16080N/A%gnome_games.install -d %name-%version
16080N/A
16080N/Arm -rf $RPM_BUILD_ROOT%{_localstatedir}/lib/games
14061N/Armdir $RPM_BUILD_ROOT%{_localstatedir}/lib
14295N/Armdir $RPM_BUILD_ROOT%{_localstatedir}
16080N/A# Delete the include files as we're not delivering a devel package. It's not
15260N/A# useful.
16080N/A#rm -rf $RPM_BUILD_ROOT%{_includedir}
16080N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
16080N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
16080N/A
12258N/A# /etc/ggz.modules is created by gnect game when it finds /usr/bin/ggz-config.
12258N/A# This happens when the module is built but already installed, not on 1st build.
12258N/Aif [ -f $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules ]; then
12258N/A rm $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
12258N/Afi
12258N/A
12258N/Acd %{_builddir}/%name-%version/sun-manpages
12258N/Amake install DESTDIR=$RPM_BUILD_ROOT
12258N/A
12258N/A%if %build_l10n
12258N/A%else
12258N/A# REMOVE l10n FILES*files-list*
12258N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
12258N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/[a-z]*/[a-z]*
12773N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z].omf
12773N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z][A-Z].omf
12773N/Armdir $RPM_BUILD_ROOT%{_datadir}/omf/gnome-games
12258N/A%endif
12258N/A
12258N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}
12258N/A
12258N/A%clean
12258N/Arm -rf $RPM_BUILD_ROOT
12258N/A
12258N/A%post
12258N/A%restart_fmri desktop-mime-cache gconf-cache
12258N/A
16080N/A%postun
12258N/A%restart_fmri desktop-mime-cache
12258N/A
12258N/A%files
12258N/A%doc -d gnome-games-%{gnome_games.version} MAINTAINERS README gnome-sudoku/README gnotski/README gnomine/README gtali/README glchess/README gnotravex/README COPYING COPYING-DOCS AUTHORS gnome-sudoku/AUTHORS glines/AUTHORS gnotski/AUTHORS gnomine/AUTHORS gnect/AUTHORS gtali/AUTHORS gnobots2/AUTHORS gnotravex/AUTHORS gnibbles/AUTHORS iagno/AUTHORS
12258N/A%doc(bzip2) -d gnome-games-%{gnome_games.version} NEWS ChangeLog
16080N/A%doc libggz-%{libggz.version}/AUTHORS
12258N/A%doc libggz-%{libggz.version}/README
12258N/A%doc libggz-%{libggz.version}/README.GGZ
12258N/A%doc libggz-%{libggz.version}/COPYING
12258N/A%doc(bzip2) libggz-%{libggz.version}/ChangeLog
12258N/A%doc(bzip2) libggz-%{libggz.version}/NEWS
12258N/A%doc ggz-client-libs-%{ggz_client_libs.version}/AUTHORS
12258N/A%doc ggz-client-libs-%{ggz_client_libs.version}/README
12258N/A%doc ggz-client-libs-%{ggz_client_libs.version}/README.GGZ
12258N/A%doc ggz-client-libs-%{ggz_client_libs.version}/COPYING
12258N/A%doc(bzip2) ggz-client-libs-%{ggz_client_libs.version}/ChangeLog
12258N/A%doc(bzip2) ggz-client-libs-%{ggz_client_libs.version}/NEWS
12258N/A
12258N/A%defattr (-, root, bin)
12258N/A%dir %attr (0755, root, bin) %{_bindir}
12258N/A%{_bindir}/*
12258N/A
12258N/A%dir %attr (0755, root, bin) %{_libdir}
12258N/A%{_libdir}/gnome-games
12258N/A%{_libdir}/libggz*
12258N/A%{_libdir}/python?.?/vendor-packages
12258N/A
12258N/A%dir %attr (0755, root, sys) %{_datadir}
12258N/A%dir %attr (0755, root, other) %{_datadir}/doc
12258N/A%dir %attr (0755, root, other) %{_datadir}/applications
12258N/A%{_datadir}/applications/*
12258N/A%dir %attr (0755, root, other) %{_datadir}/gnome
16080N/A%{_datadir}/gnome/help/*/C
16080N/A%{_datadir}/glchess
16080N/A%{_datadir}/gnome-games
12258N/A%{_datadir}/gnome-sudoku
12258N/A%attr (-, root, other) %{_datadir}/icons
12258N/A%{_datadir}/desktop-directories
12258N/A%{_datadir}/omf/*/*.omf
12258N/A
12258N/A%dir %attr(0755, root, bin) %{_mandir}
12258N/A%dir %attr(0755, root, bin) %{_mandir}/man1
12258N/A%dir %attr(0755, root, bin) %{_mandir}/man5
12258N/A%{_mandir}/man5/*
12258N/A%dir %attr(0755, root, bin) %{_mandir}/man6
12258N/A%{_mandir}/man6/*
16080N/A%dir %attr(0755, root, bin) %{_mandir}/man7
16080N/A%{_mandir}/man7/*
16080N/A
16080N/A
15856N/A%if %build_l10n
15856N/A%files l10n
15856N/A%defattr (-, root, bin)
15856N/A%dir %attr (0755, root, sys) %{_datadir}
15523N/A%dir %attr (0755, root, other) %{_datadir}/gnome
15523N/A%attr (-, root, other) %{_datadir}/locale
15153N/A%{_datadir}/gnome/help/[a-z]*/[a-z]*
15153N/A%{_datadir}/omf/*/*-[a-z][a-z].omf
14295N/A%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z][A-Z].omf
14295N/A%endif
13851N/A
13851N/A%files root
12517N/A%defattr (-, root, sys)
12517N/A%attr(0755, root, sys) %dir %{_sysconfdir}
12517N/A%{_sysconfdir}/gconf/schemas/*.schemas
12474N/A%{_sysconfdir}/xdg
12474N/A
12457N/A%files devel
12457N/A%defattr (-, root, bin)
12258N/A%dir %attr (0755, root, bin) %dir %{_includedir}
12258N/A%{_includedir}/*
12258N/A%dir %attr (0755, root, sys) %{_datadir}
12258N/A%dir %attr(0755, root, bin) %{_mandir}
12258N/A%dir %attr(0755, root, bin) %{_mandir}/man3
12258N/A%{_mandir}/man3/*
12258N/A
12258N/A%changelog
12258N/A* Thu Apr 22 2010 - christian.kelly@oracle.com
12258N/A- Fix %files.
12258N/A* Mon Mar 22 2010 - christian.kelly@sun.com
12258N/A- Add Requires: SUNWclutter-gtk.
12258N/A* Sat Mar 14 2010 - christian.kelly@sun.com
12258N/A- Add Requires: SUNWclutter.
12258N/A* Mon Nov 02 2009 - Michal.Pryc@Sun.Com
12258N/A- Move deos from Python2.4 to Python2.6.
12258N/A* Mon Jul 27 2009 - christian.kelly@sun.com
- Minor changes to %files.
* Mon Jul 27 2009 - christian.kelly@sun.com
- Correct PKG_CONFIG_PATH again.
* Sun Jul 26 2009 - christian.kelly@sun.com
- Add path to PKG_CONFIG_PATH.
* Fri Apr 3 2009 - laca@sun.com
- use desktop-cache instead of postrun
* Tue Mar 03 2009 - brian.cameron@sun.com
- Remove gnometris again.
* Wed Feb 18 2009 - dave.lin@sun.com
- Removed %doc gnome-games:same-gnome/help/ChangeLog po/ChangeLog which are n/a
in 2.25.91.
* Thu Oct 02 2008 - brian.cameron@sun.com
- Add blackjack and gnometris back to gnome-games.
* Sat Sep 20 2008 - christian.kelly@sun.com
- Set perms on /usr/share/doc.
* Fri Jun 6 2008 - michal.pryc@sun.com
- Added additional manual pages: libggz, libggzmod, libggzcore
* Fri May 30 2008 - damien.carbery@sun.com
- Delete %{_sysconfdir}/ggz.modules in %install. It is only created by gnect
game when it finds /usr/bin/ggz-config. This happens when the module is built
but already installed, not on first build.
* Tue May 13 2008 - damien.carbery@sun.com
- Comment out %{_sysconfdir}/ggz.modules in %files as it's not being installed
this week.
* Sun May 11 2008 - Michal.Pryc@Sun.Com
- Adjusted %files after enabling encryption for libggz
* Mon Mar 24 2008 - patrick.ale@gmail.com
- Add %_datadir/gnome-games/sounds to the package list
* Wed Mar 19 2008 - damien.carbery@sun.com
- Add Build/Requires SUNWgnome-games/-devel as sounds require gstreamer.
* Fri Mar 14 2008 - damien.carbery@sun.com
- Remove 'sounds' dir from %files as it is not installed by 2.22 tarball.
* Sun Mar 09 2008 - damien.carbery@sun.com
- Fix perms for -devel package.
* Thu Mar 06 2008 - Michal.Pryc@Sun.Com
- Moved man packages for headers to the devel package.
* Thu Feb 28 2008 - brian.cameron@sun.com
- Remove ggz-python since it isn't needed. Sorry about the churn.
* Wed Feb 27 2008 - brian.cameron@sun.com
- Add gst-python, since glchess needs it. Rename %{ggzmod_build_dir} to
%{ggzclient_build_dir} since this is more accurate - the module is named
ggz_client_libs. Also add the ggzcore library to LD_LIBRARY_PATH and
LDFLAGS since this is needed by gst-python.
* Mon Feb 18 2008 - Michal.Pryc@Sun.Com
- Update %files for ggz-client-libs patch, which removes ggzwrap manpages
* Fri Feb 15 2008 - damien.carbery@sun.com
- Update %files for new tarball.
* Tue Jan 29 2008 - damien.carbery@sun.com
- Remove empty %{_libdir}/ggz dir.
* Fri Jan 25 2008 - damien.carbery@sun.com
- Add BuildRequires SUNWlibsdl-devel so that the modified sdl.m4 will be
available to configure.
* Sun Jan 20 2008 - patrick.ale@gmail.com
- Rework the XGETTEXT detection.
* Thu Jan 17 2008 - patrick.ale@gmail.com
- Add export XGETTEXT=`which` to pickup GNU getetxt shipped by CBE
* Wed Jan 09 2008 - damien.carbery@sun.com
- Set ACLOCAL_FLAGS to pick up modified intltool.m4.
* Mon Jan 07 2008 - damien.carbery@sun.com
- Update CFLAGS to find ggzcore.h. Update %files. Add devel package but don't
enable it as it is probably not useful.
* Mon Jan 07 2008 - damien.carbery@sun.com
- Add variable to specify location of ggzmod sources (in ggz-client-libs) and
add info to CFLAGS and LDFLAGS.
* Thu Jan 3 2008 - laca@sun.com
- use gconf-install.script instead of an inline script
* Wed Jan 02 2008 - damien.carbery@sun.com
- Add ggz-client-libs module.
- Add variable to specify location of libggz sources. Add info to CFLAGS and
LDFLAGS.
* Tue Dec 18 2007 - damien.carbery@sun.com
- Add libggz module.
* Wed Nov 21 2007 - damien.carbery@sun.com
- Correct non-l10n build.
* Mon Jun 11 2007 - damien.carbery@sun.com
- Update %files to 2.19.6 tarball - add %{_datadir}/gnome-games/gnotski.
* Mon Jun 11 2007 - damien.carbery@sun.com
- Update %files to 2.19.3 tarball.
* Wed Jun 06 2007 - damien.carbery@sun.com
- Add $CXX dir to PATH so that configure can find it. Set $CXX to 'CC', again so
configure can find it (via PATH).
* Fri Mar 23 2007 - damien.carbery@sun.com
- Add en_GB omf files to %files.
* Tue Feb 20 2007 - damien.carbery@sun.com
- Remove %if/%endif with_guile code as aisleriot is no longer built - it is
excluded via a configure option in gnome-games.spec.
* Fri Feb 16 2007 - damien.carbery@sun.com
- Add Build/Requires SUNWgnome-python-desktop/-devel.
* Mon Feb 12 2007 - damien.carbery@sun.com
- aisleriot game is only built when SFEguile is installed. Use %if/%endif to
include its files only when SFEguile is installed.
* Sat Feb 10 2007 - damien.carbery@sun.com
- Add sol-games dir to %files and aisleriot.schemas to %files and %preun root.
* Sun Jan 28 2007 - laca@sun.com
- add -xc99 to CFLAGS
* Tue Jan 09 2007 - damien.carbery@sun.com
- Add glchess.schemas to %preun root and to %files.
* Thu Dec 07 2006 - damien.carbery@sun.com
- Add python libs dir and glchess/gnome-sudoku dirs.
* Fri Nov 24 2006 - damien.carbery@sun.com
- Remove empty %{_libdir}. Remove glchess and gnome-sudoku games as they were
not installed.
* Wed Nov 22 2006 - damien.carbery@sun.com
- 2.17.1 changes - remove gataxx references; add glchess, gnome-sudoku and ggz
games.
* Thu Nov 09 2006 - damien.carbery@sun.com
- Add BuildRequires SUNWgnome-vfs-devel as gnome-libs pc file requires
gnome-vfs.
* Mon Aug 21 2006 - damien.carbery@sun.com
- Fix l10n package - C locale omf file was in base and l10n package.
* Thu Aug 17 2006 - damien.carbery@sun.com
- Change 'icons' line in %files to pick up files.
* Sat Aug 12 2006 - laca@sun.com
- delete some unnecessary env variables
* Sat Aug 12 2006 - laca@sun.com
- change datadir/icons permissions back to root:other since it's a stable
interface and wasn't supposed to be changed
* Fri Jul 14 2006 - laca@sun.com
- update %post/%postun/etc scripts to support diskless client setup,
part of 6448317
* Thu Jun 29 2006 - laca@sun.com
- update postrun scripts
* Mon Jun 26 2006 - laca@sun.com
- move back to /usr, part of CR 6412650
* Sun Jun 11 2006 - laca@sun.com
- change group from other to bin/sys
* Sat Jun 10 2006 - laca@sun.com
- delete -devel pkg: it was empty
* Thu May 25 2006 - laca@sun.com
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - laca@sun.com
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - damien.carbery@sun.com
- Complete update of Build/Requires after running check-deps.pl script.
* Thu Feb 16 2006 - damien.carbery@sun.com
- Update Build/Requires after running check-deps.pl script.
* Fri Jan 06 2006 - damien.carbery@sun.com
- Fix %files for updated file list.
* Sat Dec 3 2005 - laca@sun.com
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - laca@sun.com
- remove javahelp stuff
* Tue Sep 13 2005 - laca@sun.com
- Remove unpackaged files or add to %files
* Thu Jul 28 2005 - damien.carbery@sun.com
- Add SUNWlibrsvg-devel build dependency. Add SUNWlibrsvg runtime dependency.
* Tue May 24 2005 - brian.cameron@sun.com
- Bump to 2.10 and fix packaging.
* Mon Dec 13 2004 - damien.carbery@sun.com
- Move to /usr/sfw to implement ARC decision.
* Fri Nov 12 2004 - laca@sun.com
- move to /usr/demo/jds
* Tue Oct 05 2004 - matt.keenan@sun.com
- Added localized help to l10n package
* Sat Oct 02 2004 - laca@sun.com
- added %pkgbuild_postprocess
* Mon Aug 23 2004 - laca@sun.com
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004 shirley.woo@sun.com
- Changed install location to /usr/...
* Wed Jun 2 2004 - takao.fujiwara@sun.com
- Added %{_datadir}/locale to install l10n messages
* Thu May 27 2004 - damien.carbery@sun.com
- Comment out SUNWcspu lines. Will uncomment when Metropolis branch created.
* Wed May 26 2004 - damien.carbery@sun.com
- Add SUNWcspu (with libucb.so and scandir) to Requires and BuildRequires.
configure was breaking because of its absense.
* Mon May 10 2004 - brian.cameron@sun.com
- Putting back %{_sysconfig}/gconf into packaging which got
accidently simplified away in Laca's last change. Now the
games work again.
* Tue Apr 20 2004 - laca@sun.com
- simlify %files
- add javahelp
* Thu Apr 08 2004 - laca@sun.com
- added missing %defattr
* Fri Mar 26 2004 - brian.cameron@sun.com
- Created,