10139N/A#
10139N/A# spec file for package SUNWgnome-file-mgr
10139N/A#
18582N/A# includes module(s): nautilus, gnome-mount,
10139N/A# gnome-volume-manager
10139N/A#
20904N/A# Copyright (c) 2004, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17642N/A%define owner padraig
10139N/A
10139N/A%include Solaris.inc
10139N/A
10139N/A%define with_hal %(pkginfo -q SUNWhal && echo 1 || echo 0)
10139N/A
10139N/A%use nautilus = nautilus.spec
10139N/A%use open_terminal= nautilus-open-terminal.spec
10139N/A
10139N/A%if %with_hal
10139N/A%use gmount = gnome-mount.spec
10139N/A%endif
10139N/A
10139N/AName: SUNWgnome-file-mgr
18688N/AIPS_package_name: gnome/file-manager/nautilus
18688N/AMeta(info.classification): %{classification_prefix}:Desktop (GNOME)/File Managers
10139N/ASummary: GNOME file manager
20061N/AVersion: %{nautilus.version}
10139N/ASource: %{name}-manpages-0.1.tar.gz
10139N/ASUNW_BaseDir: %{_basedir}
12717N/ASUNW_Copyright: %{name}.copyright
19094N/ALicense: GPL v2, GPL v3
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
20904N/ABuildRequires: developer/gnome/gettext
20904N/ABuildRequires: library/glib2
20904N/ABuildRequires: library/desktop/gtk3
20904N/ABuildRequires: library/gnome/gnome-component
20904N/ABuildRequires: image/library/librsvg
20904N/ABuildRequires: gnome/gnome-audio
20904N/ABuildRequires: image/library/libexif
20904N/ABuildRequires: library/popt
20904N/ABuildRequires: library/gnome/gnome-libs
20904N/ABuildRequires: library/gnome/gnome-vfs
20904N/ABuildRequires: gnome/config/gconf
20904N/ABuildRequires: gnome/gnome-panel
20904N/ABuildRequires: library/libunique
20904N/ABuildRequires: developer/documentation-tool/gtk-doc
20904N/ABuildRequires: library/gnome/gnome-keyring
20904N/ARequires: gnome/gnome-audio
20904N/ARequires: library/gnome/gnome-component
20904N/ARequires: library/popt
20904N/ARequires: image/library/librsvg
20857N/ABuildRequires: runtime/perl-512
20904N/ARequires: compress/bzip2
20904N/ARequires: library/zlib
20904N/ARequires: service/gnome/desktop-cache
20904N/ARequires: system/library/iconv/utf-8
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
10139N/A
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ARequires: %{name}
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%nautilus.prep -d %name-%version
10139N/A%open_terminal.prep -d %name-%version
10139N/A
10139N/A%if %with_hal
10139N/A%gmount.prep -d %name-%version
10139N/A%endif
10139N/Acd %{_builddir}/%name-%version
10139N/Agzcat %SOURCE0 | tar xf -
10139N/A
10139N/A%build
10139N/APKG_CONFIG_DISABLE_UNINSTALLED=
10139N/Aunset PKG_CONFIG_DISABLE_UNINSTALLED
10139N/A
18582N/Aexport PKG_CONFIG_PATH=../nautilus-%{nautilus.version}/libnautilus-extension:%{_pkg_config_path}
18256N/Aexport CFLAGS="%optflags -I%{_includedir} -DGNOME_DESKTOP_USE_UNSTABLE_API -I/usr/include/gnome-desktop-2.0"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="%_ldflags"
12216N/Aexport ACLOCAL_FLAGS="-I /usr/share/aclocal"
10139N/A
10139N/A%nautilus.build -d %name-%version
10139N/A%open_terminal.build -d %name-%version
10139N/A
10139N/A%if %with_hal
10139N/Aexport LDFLAGS="%_ldflags -L/usr/X11/lib -R/usr/X11/lib -lX11 -lresolv"
10139N/A%gmount.build -d %name-%version
10139N/A%endif
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%nautilus.install -d %name-%version
10139N/A%open_terminal.install -d %name-%version
10139N/A
10139N/A%if %with_hal
10139N/A%gmount.install -d %name-%version
10139N/A%endif
10139N/A
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
20785N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
20785N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
20785N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
16307N/A%restart_fmri desktop-mime-cache mime-types-cache gconf-cache
10139N/A
10139N/A%postun
16307N/A%restart_fmri desktop-mime-cache mime-types-cache
10139N/A
10139N/A%files
14278N/A%doc gnome-mount-%{gmount.version}/AUTHORS gnome-mount-%{gmount.version}/README
14278N/A%doc(bzip2) gnome-mount-%{gmount.version}/COPYING
14278N/A%doc(bzip2) gnome-mount-%{gmount.version}/NEWS
14278N/A%doc(bzip2) gnome-mount-%{gmount.version}/ChangeLog
14278N/A%doc nautilus-%{nautilus.version}/README
14278N/A%doc nautilus-%{nautilus.version}/AUTHORS
14278N/A%doc nautilus-%{nautilus.version}/MAINTAINERS
14278N/A%doc(bzip2) nautilus-%{nautilus.version}/COPYING
14278N/A%doc(bzip2) nautilus-%{nautilus.version}/NEWS
14278N/A%doc(bzip2) nautilus-%{nautilus.version}/ChangeLog
14278N/A%doc nautilus-open-terminal-%{open_terminal.version}/AUTHORS
14278N/A%doc nautilus-open-terminal-%{open_terminal.version}/README
14278N/A%doc(bzip2) nautilus-open-terminal-%{open_terminal.version}/COPYING
14278N/A%doc(bzip2) nautilus-open-terminal-%{open_terminal.version}/NEWS
14278N/A%doc(bzip2) nautilus-open-terminal-%{open_terminal.version}/ChangeLog
14278N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
20785N/A%{_libdir}/nautilus/extensions-3.0/*.so
10139N/A%{_libdir}/lib*.so*
17141N/A%{_libdir}/nautilus-convert-metadata
20785N/A%{_libdir}/girepository-1.0
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%{_datadir}/applications/*
10139N/A%if %with_hal
10139N/A%dir %attr (0755, root, other) %{_datadir}/gnome-mount
10139N/A%{_datadir}/gnome-mount/*
10139N/A%endif
20785N/A%{_datadir}/glib-2.0
13330N/A%{_datadir}/gtk-doc
10139N/A%dir %attr (-, root, other) %{_datadir}/icons
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
10139N/A%{_datadir}/icons/hicolor/16x16/apps/nautilus.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
10139N/A%{_datadir}/icons/hicolor/22x22/apps/nautilus.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
10139N/A%{_datadir}/icons/hicolor/24x24/apps/nautilus.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
10139N/A%{_datadir}/icons/hicolor/32x32/apps/nautilus.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
20785N/A%{_datadir}/GConf
20785N/A%{_datadir}/dbus-1
20785N/A%{_datadir}/gir-1.0
10139N/A%{_datadir}/icons/hicolor/scalable/apps/nautilus.svg
10139N/A%{_datadir}/nautilus
17625N/A%dir %attr (0755, root, root) %{_datadir}/mime
17625N/A%dir %attr (0755, root, root) %{_datadir}/mime/packages
17625N/A%{_datadir}/mime/packages/*
10139N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
10139N/A
10139N/A%files root
10522N/A%defattr (-, root, sys)
10139N/A%attr (0755, root, sys) %dir %{_sysconfdir}
12512N/A%{_sysconfdir}/gconf/schemas/nautilus-open-terminal.schemas
10139N/A%if %with_hal
10139N/A%{_sysconfdir}/gconf/schemas/gnome-mount.schemas
10139N/A%endif
20785N/A%{_sysconfdir}/xdg
10139N/A
10139N/A%files devel
10522N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%attr (-, root, other) %{_datadir}/locale
10139N/A
10139N/A%changelog
20904N/A* Fri May 11 2012 - brian.cameron@oracle.com
20904N/A- Fix packaging after bumping nautilus to 3.4.1. Fix Requires.
20785N/A* Tue Jul 12 2011 - brian.cameron@oracle.com
20785N/A- Fix packaging for nautilus 3.1.3 and nautilus-open-terminal 0.19 releases.
19094N/A* Wed Nov 10 2010 - padraig.obriain@oracle.com
19094N/A- Add license tag.
18850N/A* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
18850N/A- Updated BuildRequires to fit SourceJuicer.
18582N/A* Mon Apr 12 2010 - padraig.obriain@sun.com
18582N/A- Remove build eel
17967N/A* Mon Dec 21 2009 - ghee.teo@sun.com
17967N/A- Remove SUNWgnome-print dependency.
17625N/A* Wed Oct 28 2009 - jedy.wang@sun.com
17625N/A- Update mime directory attribute to fix install problem.
17618N/A* Tue Oct 27 2009 - jedy.wang@sun.com
17618N/A- Ship mime files.
16307N/A* Fri Apr 3 2009 - laca@sun.com
16307N/A- use desktop-cache instead of postrun
16204N/A* Thu Mar 19 2009 - jeff.cai@sun.com
16204N/A- Remove gnome-volume-manager since it is obsolete in GNOME 2.26.
15796N/A* Tue Feb 10 2009 - halton.huo@sun.com
15796N/A- Add BuildRequires: SUNWlibunique-devel, Requires: SUNWlibunique
15798N/A- Add Requires: SUNWzfsr to fix issue #1 for CR6753371
15628N/A* Thu Jan 08 2009 - christian.kelly@sun.com
15628N/A- Add dependency on libunique.
14278N/A* Thu Sep 11 2008 - padraig.obriain@sun.com
14278N/A- Add %doc to %files for copyright
13330N/A* Wed Jun 04 2008 - damien.carbery@sun.com
13330N/A- Update %files (add %{_datadir}/gtk-doc).
12982N/A* Thu May 01 2008 - damien.carbery@sun.com
12982N/A- Update %files (remove %{_datadir}/gnome and add %{_sysconfdir}/xdg) after
12982N/A bumping gnome-volume-manager.
12512N/A* Fri Feb 29 2008 - damien.carbery@sun.com
12512N/A- Add nautilus-open-terminal.schemas to %files and %preun root.
12295N/A* Tue Jan 29 2008 - damien.carbery@sun.com
12295N/A- Add -DGNOME_DESKTOP_USE_UNSTABLE_API to CFLAGS to get it to build.
12216N/A* Thu Jan 17 2008 - damien.carbery@sun.com
12216N/A- Set ACLOCAL_FLAGS to pick up the modified intltool.m4.
12179N/A* Fri Jan 11 2008 - padraig.obriain@sun.com
12179N/A- Change extensions directory to extensions-2.0
12112N/A* Thu Jan 3 2008 - laca@sun.com
12112N/A- use gconf-install.script instead of an inline script
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- delete Nevada X dep
11193N/A* Wed Sep 05 2007 - damien.carbery@sun.com
11193N/A- Remove references to SUNWgnome-a11y-base-libs as its contents have been
11193N/A moved to SUNWgnome-base-libs.
10522N/A* Tue Apr 24 2007 - laca@sun.com
10522N/A- s/0755/-/ in defattr so that files are not made all executable
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Update %files for new graphics files.
10139N/A* Fri Oct 20 2006 - damien.carbery@sun.com
10139N/A- Remove SUNWhalh BuildRequires because header files are in SUNWhea in snv_51.
10139N/A* Mon Sep 18 2006 - Brian.Cameron@sun.com
10139N/A- Add SUNWhalh BuildRequires.
10139N/A* Fri Sep 01 2006 - Matt.Keenan@sun.com
10139N/A- New Manpage tarball
10139N/A* Mon Aug 14 2006 - damien.carbery@sun.com
10139N/A- Add Build/Requires SUNWhal after check-deps.pl run.
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- delete some unnecessary env variables
10139N/A* Thu Jul 25 2006 - brian.cameron@sun.com
10139N/A- Add gnome-volume-manager and gnome-mount for HAL integration.
10139N/A* Fri Jul 14 2006 - laca@sun.com
10139N/A- update %post/%postun/etc scripts to support diskless client setup,
10139N/A part of 6448317
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- update postrun scripts
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Thu Jun 1 2006 - laca@sun.com
10139N/A- use post/preun scripts to install schemas into the merged gconf files
10139N/A* Wed May 10 2006 - laca@sun.com
10139N/A- merge -share pkg(s) into the base pkg(s)
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Mon Jan 09 2006 - damien.carbery@sun.com
10139N/A- Delete mime dir structure.
10139N/A* Sat Dec 3 2005 - laca@sun.com
10139N/A- add %post script that runs update-desktop-database
10139N/A* Thu Jul 28 2005 - damien.carbery@sun.com
10139N/A- Add SUNWlibrsvg-devel build dependency. Add SUNWlibrsvg runtime dependency.
10139N/A* Thu Jun 02 2005 - brian.cameron
10139N/A- Bumped to 2.10, fixed packaging.
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Thu Sep 09 2004 - matt.keenan@sun.com
10139N/A- Added nautlius-file-management-properties.1 manpage
10139N/A* Mon Aug 23 2004 - laca@sun.com
10139N/A- s/SUNWpl5u/SUNWperl584usr/
10139N/A* Wed Aug 18 2004 - damien.carbery@sun.com
10139N/A- Change manpage perms for Solaris integration.
10139N/A* Tue Jul 27 2004 - damien.carbery@sun.com
10139N/A- Add SUNWgnome-component-devel as BuildRequires, for ORBit-2.0.
10139N/A* Sat Jun 26 2004 - shirley.woo@sun.com
10139N/A- Changed install location to /usr/...
10139N/A* Mon Jun 07 2004 - brian.cameron@sun.com
10139N/A- Added SUNWlibexif dependency, then removed it since it is alrady
10139N/A a dependency of SUNWgnome-libs.
10139N/A* Wed Jun 02 2004 - takao.fujiwara@sun.com
10139N/A- Added %{_datadir}/locale to install l10n messages
10139N/A* Thu May 20 2004 - brian.cameron@sun.com
10139N/A- Added man page to share package.
10139N/A* Thu May 13 2004 - brian.cameron@sun.com
10139N/A- Removed %{_libdir}/nautilus-*-helper from packages since Glynn
10139N/A removed these files that were added via ext-sources on May 5th.
10139N/A* Fri Apr 30 2004 - niall.power@sun.com
10139N/A- adjust %files for new nautilus version
10139N/A* Fri Mar 26 2004 - laca@sun.com
10139N/A- fix %files for libexecdir change
10139N/A* Wed Mar 24 2004 - brian.cameron@sun.com
10139N/A- Added SGML man page integration
10139N/A* Mon Mar 01 2004 - laca@sun.com
10139N/A- remove dependencies on SUNWgnome-libs-root and -share
10139N/A* Thu Feb 26 2004 - niall.power@sun.com
10139N/A- remove clashing (and empty gconf.xml files) after schema installation
10139N/A- add "-R%{_libdir}" to LDFLAGS
10139N/A- define PERL5LIB for XML::Parser
10139N/A- add a defattr for %package devel
10139N/A* Mon Feb 23 2004 - niall.power@sun.com
10139N/A- install gconf schemas at the end of the install stage
10139N/A* Wed Feb 18 2004 - niall.power@sun.com
10139N/A- removed gnome-desktop as it's provided by the panel pkgs now.
10139N/A- removed rsvg man pages from file maps + tidy up
10139N/A- removed unnecessary exported CFLAGS
10139N/A* Wed Feb 18 2004 - laca@sun.com
10139N/A- moved librsvg to SUNWgnome-libs as it is required by other modules as well
10139N/A* Mon Feb 16 2004 - niall.power@sun.com
10139N/A- initial spec file created
16401N/A