17711N/A#
17711N/A# spec file for package: eog-plugins
17711N/A#
17711N/A# includes module(s): eog-plugins
17711N/A#
17711N/A# Copyright 2010 Sun Microsystems, Inc.
17711N/A# This file and all modifications and additions to the pristine
17711N/A# package are under the same license as the package itself.
17711N/A#
17711N/A%define owner jouby
17711N/A#
17711N/A%include Solaris.inc
17711N/A
17711N/A%{?!pythonver:%define pythonver 2.6}
17711N/A%use eog_plugins = eog-plugins.spec
17711N/A
17711N/AName: SUNWgnome-eog-plugins
18688N/AIPS_package_name: image/viewer/eog/eog-plugins
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Graphics and Imaging
17711N/ASummary: A collection of extra eog plugins
17711N/AVersion: %{eog_plugins.version}
19112N/ASUNW_Copyright: %{name}.copyright
17711N/ALicense: GPL v2
17711N/ASUNW_BaseDir: %{_basedir}
17711N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17711N/A
17711N/A%include default-depend.inc
19142N/A%include desktop-incorporation.inc
17711N/ARequires: SUNWgnome-img-viewer
17711N/ARequires: SUNWlibchamplain
17711N/ARequires: SUNWgnome-python26
17711N/ARequires: SUNWpygtk2-26
17711N/ARequires: SUNWglib2
19126N/ARequires: SUNWPython26
17711N/A
19126N/ABuildRequires: SUNWlibexif
17711N/ABuildRequires: SUNWgnome-img-viewer-devel
19142N/ABuildRequires: SUNWgnome-common-devel
17711N/A
17711N/A%description
17711N/Aeog-plugins is a collection of plugins for use with the Eye of GNOME Image Viewer.
17711N/AThe included plugins provide a map view for where the picture was taken,
17711N/Adisplay of Exif information, Zoom to fit, etc.
17711N/A
17711N/A#%if %build_l10n
17711N/A#%package l10n
17711N/A#Summary: %{summary} - l10n files
17711N/A#SUNW_BaseDir: %{_basedir}
17711N/A#%include default-depend.inc
17711N/A#%include gnome-incorporation.inc
17711N/A#Requires: %{name}
17711N/A#%endif
17711N/A
17711N/A%prep
17711N/Arm -rf %name-%version
17711N/Amkdir %name-%version
17711N/A%eog_plugins.prep -d %name-%version
17711N/Acd %{_builddir}/%name-%version
17711N/A
17711N/A
17711N/A%build
17711N/Aexport PYTHON=/usr/bin/python%{pythonver}
17711N/A%eog_plugins.build -d %name-%version
17711N/A
17711N/A%install
17711N/Arm -rf $RPM_BUILD_ROOT
17711N/A%eog_plugins.install -d %name-%version
17711N/A
17711N/Afind $RPM_BUILD_ROOT -name "*.pyc" -exec rm {} \;
17711N/Afind $RPM_BUILD_ROOT -name "*.pyo" -exec rm {} \;
17711N/A
17711N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}(eog_plugins):$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
17711N/A
17901N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
17742N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
17742N/A
17805N/A%clean
17805N/Arm -rf $RPM_BUILD_ROOT
17805N/A
17711N/A%post
17711N/A%restart_fmri desktop-mime-cache gconf-cache
17711N/A
17711N/A%postun
17711N/A%restart_fmri desktop-mime-cache
17711N/A
17742N/A%files
17711N/A%defattr (-, root, bin)
17711N/A%defattr (-, root, sys)
17711N/A%dir %attr (0755, root, bin) %{_libdir}
17711N/A%dir %attr (0755, root, bin) %{_libdir}/eog
17711N/A%dir %attr (0755, root, bin) %{_libdir}/eog/plugins
17711N/A/usr/lib/eog/plugins/*.py
17711N/A/usr/lib/eog/plugins/*.eog-plugin
17711N/A/usr/lib/eog/plugins/lib*.so
17742N/A/usr/lib/eog/plugins/exif-display/*.ui
17742N/A%dir %attr (0755, root, sys) %{_datadir}
17742N/A%dir %attr (0755, root, other) %{_datadir}/locale
17805N/A%dir %attr (0755, root, other) %{_datadir}/locale/*
17805N/A%dir %attr (0755, root, other) %{_datadir}/locale/*/*
19216N/A/usr/share/locale/*/LC_MESSAGES/eog-plugins.mo
%doc -d eog-plugins-%{eog_plugins.version} AUTHORS NEWS README
%doc(bzip2) -d eog-plugins-%{eog_plugins.version} ChangeLog COPYING
%dir %attr (0755, root, other) %{_datadir}/doc
%changelog
* Wen Mar 31 2010 - yuntong.jin@sun.com
- Fix files attr
* Mon Mar 22 2010 - christian.kelly@sun.com
- Grr, typo in libchamplain dep.
* Mon Mar 22 2010 - christian.kelly@sun.com
- s/Requires: SUNWpython26/Requires: SUNWPython26/
* Fri Jan 29 2010 - yuntong.jin@sun.com
- Init