10139N/A#
10139N/A# spec file for package SUNWgnome-common-devel
10139N/A#
10139N/A# includes module(s): pkgconfig, intltool, gtk-doc, gnome-common
10139N/A#
12894N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner laca
10139N/A#
10139N/A%include Solaris.inc
13561N/A%use pkgconfig = pkg-config.spec
10139N/A%use gcommon = gnome-common.spec
10139N/A%use gettext = gettext.spec
10139N/A%use intltool = intltool.spec
10139N/A
10139N/AName: SUNWgnome-common-devel
18688N/AIPS_package_name: developer/gnome/gettext
18688N/AMeta(info.classification): %{classification_prefix}:Development/GNOME and GTK+
10139N/ASummary: GNOME common development tools
10139N/AVersion: %{default_pkg_version}
13561N/ASource: %{name}-manpages-0.1.tar.gz
10139N/ASUNW_BaseDir: %{_basedir}
12894N/ASUNW_Copyright: %{name}.copyright
19140N/ALicense: %{pkgconfig.license}
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
20857N/ABuildRequires: runtime/perl-512
20857N/ARequires: library/popt
10139N/ARequires: SUNWperl-xml-parser
10139N/ARequires: SUNWopenjade
19142N/ARequires: SUNWgnome-xml-share
10139N/ARequires: SUNWlxsl
13437N/ABuildRequires: SUNWlibpopt-devel
10139N/A
10139N/A%prep
13561N/Arm -rf %name-%version
13561N/Amkdir %name-%version
13561N/A
13561N/A%pkgconfig.prep -d %name-%version
10139N/A%gcommon.prep -d %name-%version
10139N/A%gettext.prep -d %name-%version
10139N/A%intltool.prep -d %name-%version
10139N/Acd %{_builddir}/%name-%version
13561N/Agzcat %SOURCE0 | tar xf -
10139N/A
10139N/A%build
13561N/A%pkgconfig.build -d %name-%version
13561N/A
13561N/A# gnome-common required pkg-config.
13561N/Aexport PATH=%{_builddir}/%name-%version/%{pkgconfig.name}-%{pkgconfig.version}:$PATH
10139N/Aexport PERL=/usr/perl5/bin/perl
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A
10139N/Acd %{_builddir}
10139N/A
10139N/A%gcommon.build -d %name-%version
10139N/A%if %cc_is_gcc
10139N/A%else
10139N/Aexport CXX="${CXX} -norunpath"
10139N/A%endif
10139N/Aexport CXXFLAGS="%{cxx_optflags}"
10139N/A%gettext.build -d %name-%version
10139N/Aexport INTLTOOL_XGETTEXT="%{_libdir}/intltool/gettext-tools/xgettext"
10139N/Aexport INTLTOOL_MSGMERGE="%{_libdir}/intltool/gettext-tools/msgmerge"
10139N/A%intltool.build -d %name-%version
10139N/A
10139N/A%install
13561N/Arm -rf $RPM_BUILD_ROOT
10139N/A
13561N/A%pkgconfig.install -d %name-%version
10139N/A%gcommon.install -d %name-%version
10139N/A%gettext.install -d %name-%version
10139N/A%intltool.install -d %name-%version
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A# Normally we build this package before we build scrollkeeper, but
10139N/A# remove any scrollkeeper files if user happens to rebuild this
10139N/A# package after scrollkeeper is already on the system.
10139N/A#
10139N/Arm -rf $RPM_BUILD_ROOT%{_prefix}/var
10139N/A
10139N/A# Remove /usr/share/info/dir, it's a generated file and shared by multiple
10139N/A# packages
10147N/Arm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
10139N/A
18921N/A# remove duplicate of that from sfw doo#15257
18921N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/doc/gettext
18952N/Arm -f $RPM_BUILD_ROOT%{_datadir}/info/gettext.info
18921N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%{_bindir}/*
10139N/A%{_libdir}/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/aclocal
10139N/A%{_datadir}/aclocal/*
10139N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A%{_datadir}/doc/*
10139N/A%{_datadir}/gnome-common
10139N/A%{_datadir}/info
10139N/A%{_datadir}/intltool
10139N/A%{_mandir}/*/*
10139N/A
10139N/A%changelog
17170N/A* Fri Aug 28 2009 - laca@sun.com
17170N/A- remove Python dependencies as they were only needed by gtk-doc
15612N/A* Wed Jan 07 2008 - christian.kelly@sun.com
15612N/A- Moved gtk-doc out into it's own spec because of circular dependency.
15469N/A* Fri Dec 5 2008 - laca@sun.com
15469N/A- update files
13561N/A* Tue Jul 15 2008 - damien.carbery@sun.com
13561N/A- Remove pkg-config code, replacing it with %use.
13437N/A* Wed Jun 18 2008 - damien.carbery@sun.com
13437N/A- Add Build/Requires SUNWPython/-devel because /usr/bin/gtkdoc-depscan is a
13437N/A python script.
12318N/A* Mon Jan 31 2008 - brian.cameron@sun.com
12318N/A- Bump pkg-config to 0.23.
12054N/A* Mon Dec 10 2007 - brian.cameron@sun.com
12054N/A- Bump pkg-config to 0.22.
10139N/A* Fri Feb 16 2007 - damien.carbery@sun.com
10139N/A- Update %files because gtk-doc xml files moved from %{_datadir}/gnome/help to
10139N/A %{_datadir}/doc with the bumping of gtk-doc to 1.8.
10139N/A* Thu Jan 11 2007 - damien.carbery@sun.com
10139N/A- Bump pkg-config to 0.21. Remove upstream patch, pkgconfig-01-wall.diff.
10139N/A Rename rest.
10139N/A* Fri Sep 15 2006 - Brian.Cameron@sun.com
10139N/A- Install gtk-doc documentation and call pkg-config configure script with
10139N/A --mandir set properly.
10139N/A* Fri Sep 01 2006 - Matt.Keenan@sun.com
10139N/A- New Manpage tarball
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- set PERL to /usr/perl5/bin/perl as per CR6454456
10139N/A* Fri Jun 23 2006 - christopher.hanna@sun.com
10139N/A- removed man page intltool-unicodify
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Wed May 10 2006 - laca@sun.com
10139N/A- merge -share pkg(s) into the base pkg(s)
10139N/A* Tue May 02 2006 - damien.carbery@sun.com
10139N/A- Remove gnome and omf dirs from share package as they are no longer installed.
10139N/A- Remove 'rm -rf $RPM_BUILD_ROOT' as pkg-config already installed.
10139N/A* Tue Apr 11 2006 - damien.carbery@sun.com
10139N/A- Set ACLOCAL_FLAGS for gtk-doc to find a pkgconfig macro. Move pkgconfig dir.
10139N/A* Sun Feb 19 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Thu Jan 19 2006 - damien.carbery@sun.com
10139N/A- Bump pkg-config to 0.20.0, remove upstream patch (01-pkg.m4), add new patch
10139N/A (01-wall, bug #4888).
10139N/A* Tue Sep 13 2005 - brian.cameron@sun.com
10139N/A- Bump version to 2.12.
10139N/A* Thu Sep 08 2005 - brian.cameron@sun.com
10139N/A- Verified builds fine on Solaris, bump to 2.11.
10139N/A* Fri Sep 02 2005 - laca@sun.com
10139N/A- remove unpackaged files; fix to build with new pkgbuild
10139N/A* Wed Jul 07 2005 - laca@sun.com
10139N/A- backport pkg.m4 fix from 0.17.2
10139N/A* Wed Jul 06 2005 - laca@sun.com
10139N/A- downgrade pkgconfig to 0.16.0
10139N/A* Thu Oct 21 2004 - laca@sun.com
10139N/A- set PERL, fixes 5100958
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Mon Aug 23 2004 - laca@sun.com
10139N/A- s/SUNWpl5u/SUNWperl584usr/
10139N/A* Sat Jun 26 2004 shirley.woo@sun.com
10139N/A- Changed install location to /usr/...
10139N/A* Thu May 27 2004 - laca@sun.com
10139N/A- added %_libdir/pkgconfig
10139N/A* Wed May 19 2004 - brian.cameron@sun.com
10139N/A- Added missing man pages.
10139N/A* Wed Mar 24 2004 - brian.cameron@sun.com
10139N/A- Added SGML man page integration
10139N/A* Mon Mar 02 2004 - Laszlo.Peter@sun.com
10139N/A- add dependency on SUNWlxsl (libxslt)
10139N/A* Mon Jan 26 2004 - Laszlo.Peter@sun.com
10139N/A- initial version added to CVS
19225N/A
19542N/A