10139N/A#
10139N/A# spec file for package SUNWgnome-a11y-speech
10139N/A#
10139N/A# includes module(s): gnome-speech
10139N/A#
11314N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner liyuan
10139N/A#
10139N/A%include Solaris.inc
10139N/A
12926N/A%define build_dectalk %(test -f /usr/bin/say && echo 1 || echo 0)
12926N/A%define build_swift %(test -d /opt/swift && echo 1 || echo 0)
16858N/A%define option_with_java 0
10139N/A
10139N/A%use gnome_speech = gnome-speech.spec
10139N/A
10139N/AName: SUNWgnome-a11y-speech
19108N/ALicense: LGPL v2
18688N/AIPS_package_name: gnome/speech/gnome-speech
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
10139N/ASummary: GNOME text-to-speech engine
19975N/A# please change Version to %{gnome_speech.version} once its >= 0.5.11
19975N/AVersion: 0.5.11
13760N/ASource: %{name}-manpages-0.1.tar.gz
10139N/ASUNW_BaseDir: %{_basedir}
12718N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
10139N/ARequires: SUNWgnome-a11y-libs
10139N/ARequires: SUNWgnome-component
10139N/ABuildRequires: SUNWgnome-component-devel
10139N/A
10139N/A%package festival
18688N/AIPS_package_name: gnome/speech/gnome-speech/driver/gnome-speech-festival
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
10139N/ASummary: %{summary} - Festival Synthesis Driver
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ARequires: SUNWgnome-a11y-speech
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/A
19852N/A%if %option_with_java
10139N/A%package freetts
18688N/AIPS_package_name: gnome/speech/gnome-speech/driver/gnome-speech-freetts
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
10139N/ASummary: %{summary} - FreeTTS Synthesis Driver
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ARequires: SUNWgnome-a11y-speech
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
19852N/A%endif
10139N/A
10139N/A%if %build_dectalk
10139N/A%package dectalk
10139N/ASummary: %{summary} - Fonix DECtalk Synthesis Driver
10139N/ASUNW_BaseDir: %{_basedir}
12926N/ARequires: SUNWgnome-a11y-speech
12926N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
12926N/A%endif
12926N/A
12926N/A%package espeak
18688N/AIPS_package_name: gnome/speech/gnome-speech/driver/gnome-speech-espeak
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
12926N/ASummary: %{summary} - eSpeak Synthesis Driver
12926N/ASUNW_BaseDir: %{_basedir}
13940N/ARequires: SUNWespeak
10139N/ARequires: SUNWgnome-a11y-speech
13940N/ABuildRequires: SUNWespeak-devel
12926N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
12926N/A
12926N/A%if %build_swift
12926N/A%package swift
12926N/ASummary: %{summary} - Cepstral Swift Synthesis Driver
12926N/ASUNW_BaseDir: %{_basedir}
12926N/ARequires: SUNWgnome-a11y-speech
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/A%endif
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%gnome_speech.prep -d %name-%version
13760N/Acd %{_builddir}/%name-%version
13760N/Agzcat %SOURCE0 | tar xf -
10139N/A
10139N/A%build
10139N/Aexport PKG_CONFIG_PATH=%{_pkg_config_path}
10139N/Aexport MSGFMT="/usr/bin/msgfmt"
10139N/Aexport ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
10139N/Aif [ `uname -r` = 5.9 ]; then
10139N/Aexport CFLAGS="%optflags -I%{_includedir} -I/usr/j2se/include -I/usr/j2se/include/solaris"
10139N/Aelse
16967N/Aexport CFLAGS="%optflags -I%{_includedir} -I/usr/jdk/instances/jdk1.6.0/include -I/usr/jdk/instances/jdk1.6.0/include/solaris"
10139N/Afi
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LD_RUN_PATH="%{_libdir}"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A%gnome_speech.build -d %name-%version
10139N/A
10139N/A%install
10139N/A%gnome_speech.install -d %name-%version
10139N/A
13760N/A# install man page
13760N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
13760N/Acd %{_builddir}/%name-%version/sun-manpages
13760N/Amake install DESTDIR=$RPM_BUILD_ROOT
13760N/A
13760N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/test-speech
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/libgnomespeech.so*
10139N/A%{_libdir}/orbit-2.0/GNOME_Speech_module.*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
14396N/A%doc -d gnome-speech-%{gnome_speech.version} README AUTHORS
14396N/A%doc(bzip2) -d gnome-speech-%{gnome_speech.version} COPYING NEWS ChangeLog
14396N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A%{_datadir}/idl/gnome-speech-*/GNOME_Speech*.idl
13760N/A%dir %attr(0755, root, bin) %{_mandir}
13760N/A%dir %attr(0755, root, bin) %{_mandir}/*
13760N/A%{_mandir}/*/*
11314N/A%if %option_with_java
10139N/A%{_datadir}/jar/gnome-speech.jar
11314N/A%endif
10139N/A
10139N/A%files festival
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/festival-synthesis-driver
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
10139N/A
11314N/A%if %option_with_java
10139N/A%files freetts
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/freetts-synthesis-driver
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/libfreettsdriver.*
10139N/A%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_FreeTTS.server
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%{_datadir}/jar/freetts-synthesis-driver.jar
10139N/A%{_datadir}/gnome-speech/drivers/freetts/user_addenda.txt
11314N/A%endif
10139N/A
10139N/A%if %build_dectalk
10139N/A%files dectalk
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/dectalk-synthesis-driver
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Dectalk.server
10139N/A%endif
10139N/A
12926N/A%files espeak
12926N/A%defattr (-, root, bin)
12926N/A%dir %attr (0755, root, bin) %{_bindir}
12926N/A%{_bindir}/espeak-synthesis-driver
12926N/A%dir %attr (0755, root, bin) %{_libdir}
12926N/A%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
12926N/A
12926N/A%if %build_swift
12926N/A%files swift
12926N/A%defattr (-, root, bin)
12926N/A%dir %attr (0755, root, bin) %{_bindir}
12926N/A%{_bindir}/swift-synthesis-driver
12926N/A%dir %attr (0755, root, bin) %{_libdir}
12926N/A%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Swift.server
12926N/A%endif
12926N/A
10139N/A%files devel
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/gnome-speech-*/gnome-speech/*.h
10139N/A
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A
10139N/A%changelog
16967N/A* Fri Aug 07 2009 - li.yuan@sun.com
16967N/A- Change Java version to 1.6.0 to avoid build error on OpenSolaris.
16858N/A* Fri Jul 24 2009 - li.yuan@sun.com
16858N/A- Disable java since java-access-bridge has been moved out.
14396N/A* Thu Sep 18 2008 - li.yuan@sun.com
14396N/A- Added %doc to %files for copyright.
13940N/A* Wed Aug 20 2008 - william.walker@sun.com
13943N/A- Require SUNWespeak.spec so it will be built prior to
13943N/A SUNWgnome-a11y-speech.
13943N/A* Wed Aug 20 2008 - william.walker@sun.com
13940N/A- Migrate SFEespeak.spec to SUNWespeak.spec
13760N/A* Tue Aug 05 2008 - li-yan.zhang@sun.com
13760N/A- Add manpages.
12926N/A* Thu Apr 21 2008 - william.walker@sun.com
12926N/A- Add new optional espeak and swift packages. Also change the way
12926N/A the DECtalk package was created since the DECtalk folks have
12926N/A different ways of shipping/installing their product.
12718N/A* Mon Mar 31 2008 - li.yuan@sun.com
12718N/A- Add copyright file
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- disable packaging java stuff if the --without-java option is used
10139N/A* Thu Jul 13 2006 - william.walker@sun.com
10139N/A- Add new packaging scheme
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Tue May 09 2006 - laca@sun.com
10139N/A- merge -share pkg(s) into the base pkg(s)
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Wed Sep 22 2004 - damien.carbery@sun.com
10139N/A- Correct JDK path in CFLAGS so jni.h can be found.
10139N/A* Fri Jul 23 2004 - damien.carbery@sun.com
10139N/A- Move freetts to SUNWgnome-a11y-libs.
10139N/A* Tue Jun 22 2004 - shirley.woo@sun.com
10139N/A- changed install location to /usr/lib and /usr/bin
10139N/A* Thu Mar 11 2004 - damien.carbery@sun.com
10139N/A- Add jar files that come from freetts module.
10139N/A* Mon Mar 02 2004 - laca@sun.com
10139N/A- add LD_RUN_PATH since -R{%_libdir} doesn't seem to work
10139N/A* Mon Mar 01 2004 - laca@sun.com
10139N/A- add share, devel subpkgs
19212N/A
19529N/A