SUNWgnome-a11y-dasher.spec revision 19206
12248N/A#
12251N/A# spec file for package SUNWgnome-a11y-dasher
12248N/A#
12248N/A# includes module(s): dasher
12248N/A#
12248N/A# Copyright 2009 Sun Microsystems, Inc.
12248N/A# This file and all modifications and additions to the pristine
12248N/A# package are under the same license as the package itself.
12248N/A#
12248N/A%define owner yippi
12248N/A#
12248N/A%include Solaris.inc
12248N/A
12248N/A%use dasher = dasher.spec
12248N/A
12248N/AName: SUNWgnome-a11y-dasher
12248N/AIPS_package_name: gnome/accessibility/dasher
12248N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
12248N/ASummary: Predictive text entry system
12248N/AVersion: %{dasher.version}
12248N/ASource: %{name}-manpages-0.1.tar.gz
12248N/ASUNW_BaseDir: %{_prefix}
12248N/ASUNW_Copyright: %{name}.copyright
12248N/ALicense: %{dasher.license}
12248N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12248N/A%include default-depend.inc
12248N/A%include gnome-consolidation.inc
12248N/ABuildRequires: SUNWlibglade-devel
12248N/ABuildRequires: SUNWgnome-libs-devel
12248N/ABuildRequires: SUNWgnome-a11y-libs-devel
12248N/ABuildRequires: SUNWgnome-a11y-speech-devel
12248N/ABuildRequires: SUNWgnome-component-devel
12248N/ABuildRequires: SUNWgnome-config-devel
12248N/ABuildRequires: SUNWgnome-vfs-devel
12248N/ABuildRequires: SUNWlibpopt-devel
12251N/ABuildRequires: SUNWgnome-doc-utils
12251N/ABuildRequires: SUNWgtk-doc
12254N/ARequires: SUNWlibglade
12254N/ARequires: SUNWlexpt
12248N/ARequires: SUNWgnome-a11y-libs
12248N/ARequires: SUNWgnome-a11y-speech
12248N/ARequires: SUNWgnome-libs
12248N/ARequires: SUNWgnome-component
12248N/ARequires: SUNWgnome-config
12248N/ARequires: SUNWgnome-vfs
12248N/ARequires: SUNWlibpopt
12248N/ARequires: SUNWlibC
12248N/ARequires: SUNWlibms
12248N/ARequires: SUNWdesktop-cache
12248N/ARequires: SUNWgnome-keyring
12248N/ARequires: SUNWlibgnome-keyring
12248N/ARequires: %{name}-root
12248N/A
12248N/A%package root
12248N/ASummary: %{summary} - / filesystem
12248N/ASUNW_BaseDir: /
12248N/A%include default-depend.inc
12248N/A%include gnome-consolidation.inc
12248N/A
12248N/A%if %build_l10n
12248N/A%package l10n
12248N/AIPS_package_name: gnome/accessibility/dasher/l10n
12248N/ASummary: %{summary} - l10n files
12248N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_gnome_il10n_basedir}
12248N/A%include default-depend.inc
12248N/A%include gnome-consolidation.inc
12248N/ARequires: %{name}
12248N/A%endif
12248N/A
12248N/A%prep
12248N/Arm -rf %name-%version
12248N/Amkdir %name-%version
12248N/A%dasher.prep -d %name-%version
12248N/Acd %{_builddir}/%name-%version
12248N/Agzcat %SOURCE0 | tar xf -
12248N/A
12248N/A%build
12248N/Aexport PKG_CONFIG_PATH=%{_pkg_config_path}
12248N/Aexport CFLAGS="%optflags -I/usr/sfw/include"
12248N/Aexport CPPFLAGS="-I/usr/sfw/include"
12248N/Aexport CXXFLAGS="%cxx_optflags -staticlib=stlport4"
12248N/Aexport RPM_OPT_FLAGS="$CFLAGS"
12248N/Aexport LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"
12248N/A%dasher.build -d %name-%version
12248N/A
12248N/A%install
12248N/A%dasher.install -d %name-%version
12248N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
12248N/Acd %{_builddir}/%name-%version/sun-manpages
12248N/Amake install DESTDIR=$RPM_BUILD_ROOT
12248N/A
12248N/A%if %build_l10n
12248N/A%else
12248N/A# REMOVE l10n FILES
12248N/Arm -r $RPM_BUILD_ROOT%{_datadir}/locale
12248N/A%endif
12248N/Arm -rf $RPM_BUILD_ROOT/var
12248N/A
12248N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):supported" $RPM_BUILD_ROOT}
12248N/A
12248N/A%clean
12248N/Arm -rf $RPM_BUILD_ROOT
12248N/A
12248N/A%post
12248N/A%restart_fmri desktop-mime-cache gconf-cache
12248N/A
12248N/A%postun
12251N/A%restart_fmri desktop-mime-cache
12248N/A
12248N/A%files
12248N/A%defattr (-, root, bin)
12248N/A%dir %attr (0755, root, bin) %{_bindir}
12248N/A%{_bindir}/*
12248N/A%dir %attr (0755, root, sys) %{_datadir}
12248N/A%dir %attr (0755, root, other) %{_datadir}/applications
12248N/A%{_datadir}/applications/*
12248N/A%{_datadir}/dasher
12248N/A%dir %attr (0755, root, other) %{_datadir}/gnome
12248N/A%{_datadir}/gnome/help
12248N/A%attr (-, root, other) %{_datadir}/icons
12248N/A%doc -d dasher-%{dasher.version} AUTHORS README
12248N/A%doc(bzip2) -d dasher-%{dasher.version} COPYING NEWS
12248N/A%doc(bzip2) -d dasher-%{dasher.version} ChangeLog po/ChangeLog
12248N/A%doc(bzip2) -d dasher-%{dasher.version} Data/Help/Gnome/ChangeLog
12248N/A%dir %attr (0755, root, other) %{_datadir}/doc
12248N/A%dir %attr (0755, root, bin) %{_datadir}/man
12248N/A%dir %attr (0755, root, bin) %{_datadir}/man/man1
12248N/A%{_datadir}/man/man1/*
12248N/A%{_datadir}/omf
12248N/A
12248N/A%files root
12248N/A%defattr (-, root, sys)
12248N/A%attr (0755, root, sys) %dir %{_sysconfdir}
12248N/A%{_sysconfdir}/gconf/schemas/dasher.schemas
12248N/A
12248N/A%if %build_l10n
12248N/A%files l10n
12248N/A%defattr (-, root, bin)
12248N/A%dir %attr (0755, root, sys) %{_datadir}
12248N/A%attr (-, root, other) %{_datadir}/locale
12248N/A%endif
12248N/A
12248N/A%changelog
12248N/A* Fri Apr 3 2009 - laca@sun.com
12248N/A- use desktop-cache instead of postrun
12248N/A* Fri Sep 11 2008 - brian.cameron@sun.com
12248N/A- Add new copyright files.
12248N/A* Wed Apr 02 2008 - brian.cameron@sun.com
12248N/A- Add SUNW_Copyright
12248N/A* Thu Jan 3 2008 - laca@sun.com
12248N/A- use gconf-install.script instead of an inline script
12248N/A* Fri Sep 28 2007 - laca@sun.com
12248N/A- delete Nevada X deps
12248N/A- delete some unneeded env vars
12248N/A* Sat Aug 18 2007 - damien.carbery@sun.com
12248N/A- Add -f to rm call to delete /var in %install.
12248N/A* Wed May 16 2007 - damien.carbery@sun.com
12248N/A- Set CPPFLAGS in %build so that expat.h under /usr/sfw/include can be found.
12248N/A* Tue Apr 24 2007 - laca@sun.com
12248N/A- s/0755/-/ in defattr so that files are not made all executable
12248N/A* Thu Jan 04 2007 - damien.carbery@sun.com
12248N/A- Remove '-f' from rm calls so that changes that require spec file changes are
12248N/A seen quickly.
12248N/A* Wed Dec 06 2006 - damien.carbery@sun.com
12248N/A- Add root package for dasher.schemas, and %post/%preun scripts to accompany
12248N/A the new package.
12248N/A* Mon Aug 28 2006 - brian.cameron@sun.com
12248N/A- install the NROFF manpage until we convert it to SGML.
12248N/A* Sat Aug 12 2006 - laca@sun.com
12248N/A- change datadir/icons permissions back to root:other since it's a stable
12248N/A interface and wasn't supposed to be changed
12248N/A* Thu Jul 27 2006 - damien.carbery@sun.com
12248N/A- Delete scrollkeeper files before packaging.
12248N/A* Fri Jul 14 2006 - laca@sun.com
12248N/A- update %post/%postun/etc scripts to support diskless client setup,
12248N/A part of 6448317
12248N/A* Thu Jun 29 2006 - laca@sun.com
12248N/A- update postrun scripts
12248N/A* Fri Jun 23 2006 - brian.cameron@sun.com
12248N/A- Remove '-library=stlport' from CXXFLAGS so it the library is not dynamically
12248N/A linked.
12248N/A* Sun Jun 11 2006 - laca@sun.com
12248N/A- change group from other to bin/sys
12248N/A* Thu May 04 2006 - laca@sun.com
12248N/A- merge -share pkg(s) into the base pkg(s)
12248N/A* Thu Feb 23 2006 - damien.carbery@sun.com
12248N/A- Update Build/Requires after running check-deps.pl script.
12248N/A* Tue Feb 14 2006 - damien.carbery@sun.com
12248N/A- Set CXXFLAGS to find stlport4.
12248N/A* Sat Dec 3 2005 - laca@sun.com
12248N/A- add %post script that runs update-desktop-database
12248N/A* Fri Sep 30 2005 - brian.cameron@sun.com
12248N/A- Correct packaging.
12248N/A* Tue Sep 20 2005 - laca@sun.com
12248N/A- add /usr/sfw/ to LDFLAGS and CFLAGS
12248N/A- add expat dependencies
12248N/A* Tue Sep 20 2005 - glynn.foster@sun.com
12248N/A- Initial SUNWgnome-a11y-dasher package
12248N/A
12248N/A
12248N/A