10139N/A# spec file for package SUNWevolution
10139N/A#
10139N/A# includes module(s): evolution
10139N/A#
16307N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner jefftsai
10139N/A#
10139N/A%include Solaris.inc
10139N/A
10139N/A%define with_hal %(pkginfo -q SUNWhal && echo 1 || echo 0)
10139N/A
10139N/A%use evolution = evolution.spec
10139N/A%define with_pilot_link 1
10139N/A
10139N/AName: SUNWevolution
19093N/ALicense: GPL v2, LGPL v2.1, FDL v1.1
18688N/AIPS_package_name: mail/evolution
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Internet
10139N/ASummary: Evolution Email and Calendar
19013N/AVersion: %{evolution.version}
10139N/ASUNW_Category: EVO25,%{default_category}
10139N/ASUNW_BaseDir: %{_basedir}
12745N/ASUNW_Copyright:%{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/ASource1: idnkit.pc
10139N/ASource2: %{name}-manpages-0.1.tar.gz
16401N/ARequires: SUNWlibgnomecanvas
10139N/ARequires: SUNWevolution-root
10139N/ARequires: SUNWevolution-libs
20829N/ARequires: library/security/nss
10139N/ARequires: SUNWidnl
10139N/ARequires: SUNWevolution-data-server
20857N/ABuildRequires: runtime/perl-512
10139N/ARequires: SUNWgnome-component
10139N/ARequires: SUNWgnome-config
10139N/ARequires: SUNWgnome-libs
10139N/ARequires: SUNWgnome-vfs
10139N/ARequires: SUNWlibpopt
10139N/ARequires: SUNWlxml
10139N/ARequires: SUNWlibms
10139N/ARequires: SUNWlibgcrypt
10139N/ARequires: SUNWkrbu
10139N/ARequires: SUNWgss
18187N/ARequires: SUNWlibgnome-keyring
10139N/A#FIXME: put this back when dbus ARC case done
10139N/A#Requires: SUNWdbus
10139N/ARequires: SUNWevolution-data-server
10139N/ARequires: SUNWgnutls
10139N/ARequires: SUNWlibgcrypt
10139N/ARequires: SUNWlibgpg-error
10139N/ARequires: SUNWzlib
16307N/ARequires: SUNWdesktop-cache
20829N/ARequires: library/nspr
11375N/ARequires: SUNWgnome-media
18799N/A#Requires: SUNWgtkimageview
10139N/A%{?with_pilot_link:Requires: SUNWpilot-link}
10139N/A%{?with_pilot_link:Requires: SUNWgnome-pilot}
16401N/ABuildRequires: SUNWlibgnomecanvas-devel
10139N/ABuildRequires: SUNWidnd
10139N/ABuildRequires: SUNWevolution-data-server-devel
10139N/ABuildRequires: SUNWgnome-component-devel
10139N/ABuildRequires: SUNWgnome-config-devel
10139N/ABuildRequires: SUNWgnome-libs-devel
10139N/ABuildRequires: SUNWgnome-vfs-devel
10139N/ABuildRequires: SUNWlibpopt-devel
10139N/ABuildRequires: SUNWlxml
10139N/ABuildRequires: SUNWlibms
10139N/ABuildRequires: SUNWlibgcrypt-devel
11375N/ABuildRequires: SUNWgnome-media-devel
18187N/ABuildRequires: SUNWlibgnome-keyring-devel
18799N/A#BuildRequires: SUNWgtkimageview
18634N/ABuildRequires: SUNWiconv-unicode
18850N/ABuildRequires: SUNWgnome-doc-utils
18850N/ABuildRequires: SUNWlibunique
18850N/ABuildRequires: SUNWgnome-icon-theme
18850N/ABuildRequires: SUNWuiu8
18850N/ABuildRequires: SUNWlibgweather
18850N/ABuildRequires: SUNWevolution-data-server
18850N/A
10139N/A%if %with_hal
10139N/ABuildRequires: SUNWhal
10139N/A%endif
10139N/A%{?with_pilot_link:BuildRequires: SUNWpilot-link-devel}
10139N/A%{?with_pilot_link:BuildRequires: SUNWgnome-pilot}
10139N/A%{?with_pilot_link:BuildRequires: SUNWgnome-pilot-devel}
10139N/A
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ARequires: %{name}
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/A
10139N/A%package devel
10139N/ASummary: %{summary} - development files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
10139N/ARequires: SUNWevolution
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir -p %name-%version
10139N/A%evolution.prep -d %name-%version
10139N/Acd %{_builddir}/%name-%version
10139N/Agzcat %SOURCE2 | tar xf -
10139N/Acd %{_builddir}/%name-%version/evolution-%{evolution.version}
10139N/A
10139N/Acd ..
10139N/Acp %SOURCE1 %{_builddir}/%name-%version/evolution-%{evolution.version}
10139N/A
10139N/A%build
17985N/Aexport LDFLAGS="%_ldflags -L%{_libdir} -R%{_libdir} -R`pkg-config --variable=libdir nss` -R`pkg-config --variable=libdir nspr`"
11837N/Aexport CFLAGS="%optflags"
11837N/A%if %option_with_gnu_iconv
11837N/Aexport CFLAGS="$CFLAGS -I/usr/gnu/include -L/usr/gnu/lib -R/usr/gnu/lib"
11837N/A%endif
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10535N/Aexport PERL=/usr/perl5/bin/perl
10139N/Aexport PKG_CONFIG_PATH=%{_pkg_config_path}:%{_builddir}/%name-%version/evolution-%{evolution.version}
10139N/A%evolution.build -d %name-%version
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A%evolution.install -d %name-%version
10139N/A
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%name-%version/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
14067N/A# Remove bogofilter junk plugin since bogofilter is not available on Solaris.
14067N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/evolution/%{evolution.major_version}/plugins/*bogo*
14067N/Arm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/bogo-junk-plugin.schemas
14067N/A
10139N/A# Delete scrollkeeper files
10139N/Arm -rf $RPM_BUILD_ROOT/var
10139N/A
10139N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/Arm -rf ${RPM_BUILD_ROOT}DISABLE
10139N/A
13890N/A# replace the old scripts with script files
10139N/A%post
16307N/A%restart_fmri gconf-cache desktop-mime-cache icon-cache
10139N/A
10139N/A%postun
16307N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A%files
14341N/A
14341N/A%doc -d evolution-%{evolution.version} AUTHORS README
14341N/A%doc(bzip2) -d evolution-%{evolution.version} ChangeLog ChangeLog.pre-1-4
15221N/A%doc(bzip2) -d evolution-%{evolution.version} COPYING COPYING.LGPL2 COPYING-DOCS
14341N/A%doc(bzip2) -d evolution-%{evolution.version} NEWS NEWS-1.0
14341N/A%dir %attr (0755, root, other) %{_datadir}/doc
14341N/A
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%{_libdir}/evolution/%{evolution.major_version}/*.so*
17866N/A%{_libdir}/evolution/%{evolution.major_version}/modules/*
10139N/A%{?with_pilot_link:%{_libdir}/evolution/%{evolution.major_version}/conduits/*.so}
10139N/A%{_libdir}/evolution/%{evolution.major_version}/plugins/*
10139N/A%{_libexecdir}/evolution/%{evolution.major_version}/csv2vcard
10139N/A%{_libexecdir}/evolution/%{evolution.major_version}/evolution-addressbook-clean
10139N/A%{_libexecdir}/evolution/%{evolution.major_version}/evolution-addressbook-export
18725N/A%{_libexecdir}/evolution/%{evolution.major_version}/evolution-alarm-notify
12229N/A%{_libexecdir}/evolution/%{evolution.major_version}/evolution-backup
10139N/A%{_libexecdir}/evolution/%{evolution.major_version}/killev
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%{_datadir}/evolution
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%{_datadir}/applications/*
10139N/A%dir %attr (0755, root, other) %{_datadir}/mime-info
10139N/A%{_datadir}/mime-info/*
10139N/A%{?with_pilot_link:%attr (0755, root, bin) %{_datadir}/gnome-pilot}
10139N/A%dir %attr (-, root, other) %{_datadir}/icons
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
13890N/A%{_datadir}/icons/hicolor/16x16/apps/evolution*.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
13890N/A%{_datadir}/icons/hicolor/22x22/apps/evolution*.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
13890N/A%{_datadir}/icons/hicolor/24x24/apps/evolution*.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
13890N/A%{_datadir}/icons/hicolor/32x32/apps/evolution*.png
10648N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
10648N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
10648N/A%{_datadir}/icons/hicolor/48x48/apps/*.png
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
10139N/A%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
10139N/A%{_datadir}/icons/hicolor/scalable/apps/evolution.svg
10139N/A
10139N/A%dir %attr (0755, root, other) %{_datadir}/gnome
10139N/A%{_datadir}/gnome/help/evolution*/C
10139N/A%{_datadir}/omf/evolution/evolution*C.omf
10139N/A%dir %attr(0755, root, bin) %{_mandir}
10139N/A%dir %attr(0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
10139N/A
17866N/A%dir %attr (0755, root, bin) %{_datadir}/gtk-doc
17866N/A%{_datadir}/gtk-doc/*
17866N/A
10139N/A%files l10n
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%attr (-, root, other) %{_datadir}/locale
10139N/A%{_datadir}/omf/evolution/evolution-[a-z][a-z].omf
10295N/A%{_datadir}/omf/evolution/evolution-[a-z][a-z]_[A-Z][A-Z].omf
10139N/A%dir %attr (0755, root, other) %{_datadir}/gnome
10139N/A%{_datadir}/gnome/help/evolution/[a-z][a-z]
10295N/A%{_datadir}/gnome/help/evolution/[a-z][a-z]_[A-Z][A-Z]
10139N/A
10139N/A%files devel
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A
10139N/A%files root
10522N/A%defattr (-, root, sys)
10139N/A%attr (0755, root, sys) %dir %{_sysconfdir}
13357N/A%{_sysconfdir}/gconf/schemas/apps_evolution_email_custom_header.schemas
10745N/A%{_sysconfdir}/gconf/schemas/apps-evolution-mail-prompts-checkdefault.schemas
10745N/A%{_sysconfdir}/gconf/schemas/apps_evolution_addressbook.schemas
11122N/A%{_sysconfdir}/gconf/schemas/apps-evolution-attachment-reminder.schemas
10745N/A%{_sysconfdir}/gconf/schemas/apps-evolution-mail-notification.schemas
10745N/A%{_sysconfdir}/gconf/schemas/apps_evolution_calendar.schemas
10745N/A%{_sysconfdir}/gconf/schemas/apps_evolution_shell.schemas
10745N/A%{_sysconfdir}/gconf/schemas/evolution-mail.schemas
13644N/A%{_sysconfdir}/gconf/schemas/apps-evolution-template-placeholders.schemas
17866N/A%attr (0755, root, sys) %dir %{_sysconfdir}/xdg
17866N/A%attr (0755, root, sys) %dir %{_sysconfdir}/xdg/autostart
17866N/A%{_sysconfdir}/xdg/autostart/*
10139N/A
10139N/A%changelog
18850N/A* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
18850N/A- Updated BuildRequires to fit SourceJuicer.
18799N/A* Thu May 27 - jeff.cai@sun.com
18799N/A- Comment the dependency on SUNWgtkimageview
18634N/A* Tue Apr 20 - christian.kelly@oracle.com
18634N/A- Correct typo from previous commit!
18614N/A* Tue Mar 19 - jeff.cai@sun.com
18614N/A- Add dependency on SUNWiconv-unicode
18278N/A* Wed Feb 10 - jedy.wang@sun.com
18278N/A- Add dependency on SUNWgtkimageview.
18187N/A* Tue Jan 26 - jeff.cai@sun.com
18187N/A- Add dependency on SUNWlibgnome-keyring
17989N/A* Wed Dec 23 - jedy.wang@sun.com
17989N/A- Use default ld.
17985N/A* Wed Dec 23 2009 - jedy.wang@sun.com
17985N/A- Moves ldfalgs from evolution.spec.
17967N/A* Mon Dec 21 2009 - ghee.teo@sun.com
17967N/A- Remove SUNWgnome-print dependency.
17286N/A* Fri Sep 11 2009 - jedy.wang@sun.com
17286N/A- Remove SUNWmlib dependency.
16307N/A* Fri Apr 3 2009 - laca@sun.com
16307N/A- use desktop-cache instead of postrun
15221N/A* Thu Oct 16 2008 - jeff.cai@sun.com
15221N/A- Update copyright, add file COPYING.LGPL2.
14341N/A* Tue Sep 16 2008 - jeff.cai@sun.com
14341N/A- Add copyright.
14067N/A* Fri Aug 29 2008 - jeff.cai@sun.com
14067N/A- Remove bogofilter plugin.
13644N/A* Wed Jul 23 2008 - jeff.cai@sun.com
13644N/A- Add apps-evolution-template-placeholders.schemas to %files root and %preun root.
13357N/A* Fri Jun 05 2008 - damien.carbery@sun.com
13357N/A- Add apps_evolution_email_custom_header.schemas to %files root and %preun root.
12745N/A* Wed Apr 02 2008 - jeff.cai@sun.com
12745N/A- Add copyright file.
12229N/A* Fri Jan 18 2008 - damien.carbery@sun.com
12229N/A- Add evolution-backup to %files.
12112N/A* Thu Jan 3 2008 - laca@sun.com
12112N/A- use gconf-install.script instead of an inline script
11859N/A* Mon Nov 5 2007 - jeff.cai@sun.com
11859N/A- Use system ldflag to enable -Bdirect
11830N/A* Wed Oct 31 2006 - damien.carbery@sun.com
11837N/A- Put the /usr/gnu references inside '%if %option_with_gnu_iconv' test.
11837N/A* Wed Oct 31 2006 - damien.carbery@sun.com
11830N/A- Remove %{_libexecdir}/evolution/%{evolution.major_version}/evolution-backup
11830N/A as it is not in the 2.21.1 tarball.
11426N/A* Mon Oct 22 2006 - damien.carbery@sun.com
11426N/A- Add %{_libexecdir}/evolution/%{evolution.major_version}/evolution-backup to
11426N/A %files for evolution 2.12.1 tarball.
11375N/A* Wed Oct 10 2006 - damien.carbery@sun.com
11375N/A- Update Build/Requires after running check-deps.pl script.
11346N/A* Thu Oct 4 2007 - laca@sun.com
11350N/A- add %arch_ldadd to LDFLAGS so that the GNU libiconv flags are used
11346N/A- delete -I %{_includedir} from CFLAGS -- breaks the indiana build because
11358N/A the wrong iconv.h is picked up; otherwise it's useless; add /usr/gnu stuff
11358N/A instead
11122N/A* Tue Aug 28 2007 - damien.carbery@sun.com
11122N/A- Add a new schemas files to %files and remove version number from another.
10920N/A* Wed Jul 11 2007 - damien.carbery@sun.com
10920N/A- Add a new schemas file to %files.
10745N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10745N/A- Add new schema file and remove Evolution version number from muliple files.
10648N/A* Tue May 15 2007 - damien.carbery@sun.com
10648N/A- Add %{_datadir}/icons/hicolor/48x48 dir to %files for new tarball.
10615N/A* Thu May 10 2007 - damien.carbery@sun.com
10615N/A- Add bogo-junk-plugin-2.12.schemas to %files.
10535N/A* Thu Apr 26 2007 - laca@sun.com
10535N/A- set PERL to /usr/perl5/bin/perl
10522N/A* Tue Apr 24 2007 - laca@sun.com
10522N/A- s/0755/-/ in defattr so that files are not made all executable
10316N/A* Fri Mar 16 2007 - damien.carbery@sun.com
10316N/A- Correct code that removes l10n files.
10295N/A* Wed Mar 14 2007 - damien.carbery@sun.com
10316N/A- Add en_GB files to l10n package.
10139N/A* Tue Feb 27 2007 - simon.zheng@sun.com
10139N/A- Move evolution icons from /usr/share/pixmaps to /usr/share/icons/hicolor
10139N/A* Thu Jan 04 2007 - jijun.yu@sun.com
10139N/A- Its dependencies-gnome-pilot and pilot-link are upgraded to new version
10139N/A* Tue Dec 12 2006 - damien.carbery@sun.com
10139N/A- Fix %build_l10n section in %install to remove the files when necessary.
10139N/A* Wed Dec 06 2006 - damien.carbery@sun.com
10139N/A- Remove scrollkeeper files during %install. Add l10n files to l10n pkg.
10139N/A* Wed Nov 29 2006 - damien.carbery@sun.com
10139N/A- Revert version to %{default_pkg_version} as this module has been integrated
10139N/A to Nevada with this version. Using the base module's version number (2.8.x)
10139N/A is lower than 2.16.x and will cause an integration error.
10139N/A* Mon Nov 27 2006 - jeff.cai@sun.com
10139N/A- Use evolution's version information to replace default one.
10139N/A* Mon Oct 23 2006 - irene.huang@sun.com
10139N/A- Moved all patches to ../patches/
10139N/A* Fri Oct 20 2006 - damien.carbery@sun.com
10139N/A- Remove SUNWhalh BuildRequires because header files are in SUNWhea in snv_51.
10139N/A* Wed Oct 18 2006 - damien.carbery@sun.com
10139N/A- Use %{evolution.major_version} instead of hard coded version number.
10139N/A* Tue Oct 17 2006 - Jeff.Cai@sun.com
10139N/A- Remove patch patches/evolution-03-mail-rlimit.diff
10139N/A* Mon Sep 18 2006 - Brian.Cameron@sun.com
10139N/A- Add SUNWhalh BuildRequires.
10139N/A* Fri Sep 01 2006 - Matt.Keenan@sun.com
10139N/A- New Manpage tarball
10139N/A* Mon Aug 14 2006 - damien.carbery@sun.com
10139N/A- Add Build/Requires SUNWhal after check-deps.pl run.
10139N/A* Sat Aug 12 2006 - laca@sun.com
10139N/A- delete some unnecessary env variables
10139N/A* Tue Aug 07 2006 - jeff.cai@sun.com
10139N/A- add patch evolution-03-mail-rlimit.diff to resolve stoping updating review
10139N/A page.
10139N/A* Tue Jul 25 2006 - jeff.cai@sun.com
10139N/A- Reorder patches
10139N/A* Fri Jul 21 2006 - jeff.cai@sun.com
10139N/A- Bump to 2.7.4
10139N/A Remove patch evolution-01-solaris-ldap.diff.
10139N/A* Thu Jul 20 2006 - irene.huang@sun.com
10139N/A- remove manpage evolution-addressbook-export.1
10139N/A* Fri Jul 14 2006 - laca@sun.com
10139N/A- update %post/%postun/etc scripts to support diskless client setup,
10139N/A part of 6448317
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- update postrun scripts
10139N/A* Fri Jun 23 2006 - Christopher.Hanna@sun.com
10139N/A- Added manpange for evolution-addressbook-export because it
10139N/A is still in /usr/bin and so should still have a manpage.
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Sun May 28 2006 - irene.huang@sun.com
10139N/A- Add patch evolution-03-kerberos.diff, add package requirement of
10139N/A SUNWkrbu and SUNWgss.
10139N/A* Fri May 26 2006 - irene.huang@sun.com
10139N/A- Remove manpanges for evolution-addressbook-export and
10139N/A evolution-addressbook-import.
10139N/A* Thu May 25 2006 - laca@sun.com
10139N/A- use post/preun scripts to install schemas into the merged gconf files
10139N/A* Fri May 12 2006 - damien.carbery@sun.com
10139N/A- Update dir perms for omf/evolution to correct WOS integration error.
10139N/A* Fri May 12 2006 - damien.carbery@sun.com
10139N/A- Small update to dependency list after check-deps.pl run.
10139N/A* Thu May 11 2006 - halton.huo@sun.com
10139N/A- Merge -share pkg(s) into the base pkg(s).
10139N/A* Wed Apr 26 2006 - halton.huo@sun.com
10139N/A- Use JES's NSS/NSPR(/usr/lib/mps) instead of that provided by
10139N/A mozilla or firefox, to fix bug #6418049.
10139N/A* Tue Apr 04 2006 - halton.huo@sun.com
10139N/A- Alter remove .a/.la filepkginfo s part into linux spec.
10139N/A* Thu Mar 30 2006 - halton.huo@sun.com
10139N/A- Remove all *.a/*.la files.
10139N/A* Thu Feb 23 2006 - damien.carbery@sun.com
10139N/A- Use default pkg version to match other pkgs; add EVO25 to default category.
10139N/A* Thu Feb 16 2006 - damien.carbery@sun.com
10139N/A- Update Build/Requires after running check-deps.pl script.
10139N/A* Mon Jan 23 2006 - Irene.Huang@sun.com
10139N/A- Move patch evolution-caldav-startup-fail.diff
10139N/A to ../../patches.
10139N/A* Mon Jan 23 2006 - Irene.Huang@sun.com
10139N/A- Add patch evolution-caldav-startup-fail.diff.
10139N/A* Tue Jan 10 2006 - halton.huo@sun.com
10139N/A- Enable pilot-conduits option.
10139N/A* Wed Jan 04 2006 - halton.huo@sun.com
10139N/A- Add all files under plugins.
10139N/A* Wed Dec 21 2005 - halton.huo@sun.com
10139N/A- Change major_verion from 2.4 to 2.6.
10139N/A* Tue Dec 6 2005 - laca@sun.com
10139N/A- disable -Bdirect as due to symbol clashes
10139N/A* Sat Dec 3 2005 - laca@sun.com
10139N/A- add %post script that runs update-desktop-database
10139N/A* Tue Nov 29 2005 - laca@sun.com
10139N/A- remove javahelp stuff
10139N/A* Fri Oct 21 2005 - halton.huo@sun.com
10139N/A- Disable gnome_pilot_link.
10139N/A* Mon Oct 10 2005 - halton.huo@sun.com
10139N/A- Change build require from mozilla to firefox.
10139N/A- Move upstreamed patch evolution-02-solaris-kerberos.diff.
10139N/A- Add patch evolution-02-solaris-sed.diff.
10139N/A* Thu Sep 15 2005 - halton.huo@sun.com
10139N/A- Remove define krb5_prefix and related.
10139N/A- Add patch evolution-02-solaris-kerberos.diff to disable krb5.
10139N/A- Change changelog more readable.
10139N/A* Thu Sep 8 2005 - halton.huo@sun.com
10139N/A- Add krb5_prefix define.
10139N/A- Add "-L%{krb5_prefix}/lib -R%{krb5_prefix}/lib" to LDFLAGS.
10139N/A- Add "-I%{krb5_prefix}/include" to CFLAGS.
10139N/A* Tue Sep 7 2005 - halton.huo@sun.com
10139N/A- Remove "-L/usr/sfw/lib -R/usr/sfw/lib" from LDFLAGS, remove
10139N/A "-I/usr/sfw/include" from CFLAGS and remove LD_LIBRARY_PATH=/usr/sfw/lib,
10139N/A because current gnome-pilot-link packages are deployed on /usr not /usr/sfw.
10139N/A* Tue Sep 6 2005 - halton.huo@sun.com
10139N/A- Change SUNWevolution package files defination.
10139N/A- Add patch evolution-01-solaris-ldap.diff
10139N/A* Wed Aug 31 2005 - halton.huo@sun.com
10139N/A- Change SUNW_Category for open solaris.
10139N/A- Remove DB3 since now is included in evolution-data-server.
10139N/A- Remove obsoleted patch evolution-01-solaris-compile.diff
10139N/A- Added "-L/usr/sfw/lib -R /usr/sfw/lib" to LDFLAGS to use pilot-link
10139N/A- Added "-I/usr/sfw/include" to CFLAGS to use pilot-link
10139N/A- Added "LD_LIBRARY_PATH=/usr/sfw/lib" to pass use pilot-link check
10139N/A* Tue Jul 19 2005 - damien.carbery@sun.com
10139N/A- Enable gnome-pilot-link.
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Fri Oct 1 2004 - damien.carbery@sun.com
10139N/A- Add option to enable/disable gnome-pilot-link.
10139N/A* Fri Jul 23 2004 laca@sun.com
10139N/A- use evolution-copyright.txt as copyright notice
10139N/A* Tue Jul 20 2004 - brian.cameron@sun.com
10139N/A- Added man pages.
10139N/A* Tue Jun 29 2004 - shirley.woo@sun.com
10139N/A- Added "-L%{moz_prefix}/lib/mozilla -R%{moz_prefix}/lib/mozilla" to LDFLAGS
10139N/A so mozilla libraries can be found
10139N/A* Mon Jun 28 2004 - shirley.woo@sun.com
10139N/A- Changed install location to /usr/... so need to use moz-prefix for nss/nspr
10139N/A since install location of mozilla is different for Linux and Solaris
10139N/A* Sat Jun 26 2004 shirley.woo@sun.com
10139N/A- Changed install location to /usr/...
10139N/A* Wed Jun 2 2004 - takao.fujiwara@sun.com
10139N/A- Added %{_datadir}/locale to install l10n messages
10139N/A* Tue May 25 2004 - <laca@sun.com>
10139N/A- add SUNWdtbas dep
10139N/A* Fri May 14 2004 - <laca@sun.com>
10139N/A- add idnkit dependencies
10139N/A* Sun May 02 2004 - <laca@sun.com>
10139N/A- add the source directory to the end of PKG_CONFIG_PATH so that idnkit.pc
10139N/A is picked up from here on Solaris (bad, bad hack...)
10139N/A* Tue Apr 20 2004 - <laca@sun.com>
10139N/A- add SUNWgnome-pilot-link dependency
10139N/A- fix libexec stuff
10139N/A* Fri Apr 16 2004 - <laca@sun.com>
10139N/A- remove static libs
10139N/A* Thu Mar 11 2004 - <laca@sun.com>
10139N/A- initial version created
16401N/A
19193N/A
19510N/A