SUNWespeak.spec revision 19870
10139N/A#
10139N/A# spec file for package SUNWespeak
12161N/A#
12161N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
17185N/A# package are under the same license as the package itself.
10139N/A#
17181N/A%define owner liyuan
17181N/A%define OSR 8874:1.37
17181N/A
10139N/A%include Solaris.inc
19069N/A
10139N/A%define src_name espeak
10139N/A%define src_url http://downloads.sourceforge.net/%{src_name}
15291N/A%define tarball_version 1.44.05
18616N/A
10139N/AName: SUNWespeak
10139N/AIPS_package_name: library/speech/espeak
10139N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
10139N/ASummary: eSpeak - compact open source software speech synthesizer
10315N/AVersion: 1.41.1
10139N/AVendor: espeak.sourceforge.net
10139N/ALicense: GPL v3
10139N/ASource: %{src_url}/%{src_name}-%{tarball_version}-source.zip
10139N/ASource1: %{name}-manpages-0.1.tar.gz
10139N/A# date:2008-08-15 owner:ww36193 type:bug
10139N/APatch1: espeak-01-makefile.diff
10139N/A# date:2010-10-27 owner:yippi type:bug
10139N/APatch2: espeak-02-samplerate.diff
10139N/A# date:2010-12-28 owner:liyuan type:bug
10139N/APatch3: espeak-03-Wall.diff
10139N/ASUNW_BaseDir: %{_basedir}
12754N/ASUNW_Copyright: %{name}.copyright
10139N/ABuildRoot: %{_tmppath}/%{name}-%{tarball_version}-build
10139N/A
10374N/A%include default-depend.inc
10374N/A%include gnome-consolidation.inc
10374N/ABuildRequires: SUNWaudh
10374N/ABuildRequires: SUNWunzip
10374N/ABuildRequires: SUNWgcc
10374N/ARequires: SUNWlibC
10374N/ARequires: SUNWlibmsr
10374N/A
10374N/A%package devel
10374N/ASummary: %{summary} - development files
10374N/ASUNW_BaseDir: %{_basedir}
11330N/A%include default-depend.inc
11330N/A%include gnome-consolidation.inc
11330N/ARequires: %name
10374N/A
10374N/A%prep
10374N/A%setup -q -n %{src_name}-%{tarball_version}-source
10374N/A%patch1 -p1
10374N/A%patch2 -p1
10374N/A%patch3 -p1
10374N/Agzcat %SOURCE1 | tar xf -
10374N/A
10374N/A%build
10374N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
11331N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
11331N/A%ifarch sparc
10139N/A%define endian_macro "-DBYTE_ORDER=BIG_ENDIAN"
10139N/Acd platforms/big_endian
10139N/Amake -j$CPUS CFLAGS="%{endian_macro}"
10139N/A./espeak-phoneme-data ../../espeak-data ../../espeak-data
10139N/Acd ../..
10139N/A%else
10139N/A%define endian_macro ""
10139N/A%endif
10139N/Acd src
10139N/Amake -j$CPUS EXTRA_LIBS=-lm AUDIO=sada CXXFLAGS="-O2 %{endian_macro}"
10139N/Amake install EXTRA_LIBS=-lm AUDIO=sada DESTDIR=$RPM_BUILD_ROOT CXXFLAGS="-O2 %{endian_macro}"
10139N/Arm $RPM_BUILD_ROOT/%{_libdir}/lib*.a
10139N/A
10139N/A%install
10139N/A#Install manpages
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/Acd %{_builddir}/%src_name-%tarball_version-source/sun-manpages
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
19069N/A%defattr (-, root, bin)
19069N/A%dir %attr (0755, root, bin) %{_bindir}
19069N/A%{_bindir}/*
18819N/A%dir %attr (0755, root, bin) %{_libdir}
18819N/A%{_libdir}/lib*.so*
15709N/A%dir %attr (0755, root, sys) %{_datadir}
15709N/A%{_datadir}/*
15291N/A
15291N/A%files devel
15291N/A%defattr (-, root, bin)
13355N/A%{_includedir}
11330N/A
11330N/A%changelog
10374N/A* Tue Nov 09 2010 - lee.yuan@oracle.com
10374N/A- Fix build error on sparc.
10315N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
10315N/A- Bump to 1.44.05.
10139N/A* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
10139N/A- Updated BuildRequires to fit SourceJuicer.
10139N/A* Wed Sep 23 2009 - william.walker@sun.com
10139N/A- Add patch to fix yet another hang - sourceforge:2860912 bugzilla:595336
10139N/A This should be fixed in 1.41.03 when it is released, so the patch can be
10139N/A removed when upreving to 1.41.03.
* Tue Aug 28 2009 - william.walker@sun.com
- Bump to 1.41.01. This resolves bgo#580389 - Orca hangs
when clicking "Ok" or "Apply" button in Orca Preference dialog
and doo#10858 - eSpeak_Synchronize hangs Orca
* Fri Aug 21 2009 - li.yuan@sun.com
- Change owner to liyuan.
* Mon Aug 17 2009 - william.walker@sun.com
- Add Vendor and License
* Tue Jul 28 2009 - christian.kelly@sun.com
- Bump to 1.40.02.
* Mon May 04 2009 - brian.cameron@sun.com
- Bump to 1.40.
* Tue Feb 10 2009 - halton.huo@sun.com
- Add dependency on SUNWlibC and SUNWlibmsr, CR #6755918
* Fri Sep 19 2008 - Willie Walker
- Add BuildRequires: SUNWaudh
* Mon Sep 02 2008 - Harry Lu
- Add bug ID for espeak-02-endian.diff
* Fri Aug 29 2008 - Willie Walker
- Fix SPARC build endian-ness
* Thu Aug 21 2008 - Dermot McCluskey
- added manpages and file header
* Wed Aug 20 2008 - Willie Walker
- Migrate to JDS (SFEespeak.spec to SUNWespeak.spec)
* Tue Aug 12 2008 - Willie Walker
- Port to SunStudio (thanks Brian Cameron!)
* Tue Apr 15 2008 - Willie Walker
- Upgrade to version 1.37 which contains direct SADA support and eliminates
all PulseAudio and other dependencies.
* Tue Jan 29 2008 - Willie Walker
- Initial spec