SUNWespeak.spec revision 19067
19082N/A#
19082N/A# spec file for package SUNWespeak
19082N/A#
20903N/A# Copyright (c) 2008 Sun Microsystems, Inc.
19082N/A# This file and all modifications and additions to the pristine
19082N/A# package are under the same license as the package itself.
19082N/A#
19082N/A%define owner liyuan
19082N/A%define OSR 8874:1.37
19082N/A
19082N/A%include Solaris.inc
19082N/A
19082N/A%define src_name espeak
20903N/A%define src_url http://downloads.sourceforge.net/%{src_name}
19082N/A%define tarball_version 1.44.05
19082N/A
19082N/AName: SUNWespeak
19082N/AIPS_package_name: library/speech/espeak
20903N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
19082N/ASummary: eSpeak - compact open source software speech synthesizer
19082N/AVersion: 1.41.1
19082N/AVendor: espeak.sourceforge.net
19082N/ALicense: GPL v3
19082N/ASource: %{src_url}/%{src_name}-%{tarball_version}-source.zip
19082N/ASource1: %{name}-manpages-0.1.tar.gz
19082N/A# date:2008-08-15 owner:ww36193 type:bug
19082N/APatch1: espeak-01-makefile.diff
19082N/A# date:2010-10-27 owner:yippi type:bug
19082N/APatch2: espeak-02-samplerate.diff
19082N/ASUNW_BaseDir: %{_basedir}
19082N/ASUNW_Copyright: %{name}.copyright
19082N/ABuildRoot: %{_tmppath}/%{name}-%{tarball_version}-build
19082N/A
19082N/A%include default-depend.inc
19082N/ABuildRequires: SUNWaudh
19082N/ABuildRequires: SUNWunzip
19082N/ABuildRequires: SUNWgcc
19082N/ARequires: SUNWlibC
19082N/ARequires: SUNWlibmsr
19082N/A
19082N/A%package devel
19082N/ASummary: %{summary} - development files
19082N/ASUNW_BaseDir: %{_basedir}
19082N/A%include default-depend.inc
19082N/ARequires: %name
19082N/A
19082N/A%prep
19082N/A%setup -q -n %{src_name}-%{tarball_version}-source
19082N/A%patch1 -p1
19082N/A%patch2 -p1
19082N/Agzcat %SOURCE1 | tar xf -
19082N/A
19082N/A%build
19082N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
19082N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
19082N/A CPUS=1
19082N/Afi
19082N/A%ifarch sparc
19082N/A%define endian_macro "-DBYTE_ORDER=BIG_ENDIAN"
19082N/Acd platforms/big_endian
19082N/Amake -j$CPUS CFLAGS="%{endian_macro}"
19082N/A./espeak-phoneme-data ../../espeak-data ../../espeak-data ../../espeak-data/phondata-manifest
19082N/Acd ../..
19082N/A%else
19082N/A%define endian_macro ""
19082N/A%endif
19082N/Acd src
19082N/Amake -j$CPUS EXTRA_LIBS=-lm AUDIO=sada CXXFLAGS="-O2 %{endian_macro}"
19082N/Amake install EXTRA_LIBS=-lm AUDIO=sada DESTDIR=$RPM_BUILD_ROOT CXXFLAGS="-O2 %{endian_macro}"
19082N/Arm $RPM_BUILD_ROOT/%{_libdir}/lib*.a
19082N/A
19082N/A%install
19082N/A#Install manpages
19082N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
19082N/Acd %{_builddir}/%src_name-%tarball_version-source/sun-manpages
19082N/Amake install DESTDIR=$RPM_BUILD_ROOT
19082N/A
19082N/A
19082N/A%clean
19082N/Arm -rf $RPM_BUILD_ROOT
19082N/A
19082N/A%files
19082N/A%defattr (-, root, bin)
19082N/A%dir %attr (0755, root, bin) %{_bindir}
19082N/A%{_bindir}/*
19082N/A%dir %attr (0755, root, bin) %{_libdir}
19082N/A%{_libdir}/lib*.so*
19082N/A%dir %attr (0755, root, sys) %{_datadir}
19082N/A%{_datadir}/*
19082N/A
19082N/A%files devel
19082N/A%defattr (-, root, bin)
20903N/A%{_includedir}
20903N/A
20783N/A%changelog
20783N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
19082N/A- Bump to 1.44.05.
19082N/A* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
- Updated BuildRequires to fit SourceJuicer.
* Wed Sep 23 2009 - william.walker@sun.com
- Add patch to fix yet another hang - sourceforge:2860912 bugzilla:595336
This should be fixed in 1.41.03 when it is released, so the patch can be
removed when upreving to 1.41.03.
* Tue Aug 28 2009 - william.walker@sun.com
- Bump to 1.41.01. This resolves bgo#580389 - Orca hangs
when clicking "Ok" or "Apply" button in Orca Preference dialog
and doo#10858 - eSpeak_Synchronize hangs Orca
* Fri Aug 21 2009 - li.yuan@sun.com
- Change owner to liyuan.
* Mon Aug 17 2009 - william.walker@sun.com
- Add Vendor and License
* Tue Jul 28 2009 - christian.kelly@sun.com
- Bump to 1.40.02.
* Mon May 04 2009 - brian.cameron@sun.com
- Bump to 1.40.
* Tue Feb 10 2009 - halton.huo@sun.com
- Add dependency on SUNWlibC and SUNWlibmsr, CR #6755918
* Fri Sep 19 2008 - Willie Walker
- Add BuildRequires: SUNWaudh
* Mon Sep 02 2008 - Harry Lu
- Add bug ID for espeak-02-endian.diff
* Fri Aug 29 2008 - Willie Walker
- Fix SPARC build endian-ness
* Thu Aug 21 2008 - Dermot McCluskey
- added manpages and file header
* Wed Aug 20 2008 - Willie Walker
- Migrate to JDS (SFEespeak.spec to SUNWespeak.spec)
* Tue Aug 12 2008 - Willie Walker
- Port to SunStudio (thanks Brian Cameron!)
* Tue Apr 15 2008 - Willie Walker
- Upgrade to version 1.37 which contains direct SADA support and eliminates
all PulseAudio and other dependencies.
* Tue Jan 29 2008 - Willie Walker
- Initial spec