13980N/A#
13980N/A# spec file for package SUNWespeak
13980N/A#
20885N/A# Copyright (c) 2008, 2012, Oracle and/or its affiliates. All rights reserved.
13980N/A# This file and all modifications and additions to the pristine
13980N/A# package are under the same license as the package itself.
13980N/A#
17185N/A%define owner liyuan
18644N/A%define OSR 8874:1.37
13980N/A
13940N/A%include Solaris.inc
13940N/A
13940N/A%define src_name espeak
13940N/A%define src_url http://downloads.sourceforge.net/%{src_name}
19904N/A# remember to update the Version tag but make sure it's IPS compliant,
19904N/A# so no leading 0-s allowed. 1.44.05 should be 1.44.0.5
20904N/A%define tarball_version 1.46.02
13940N/A
13940N/AName: SUNWespeak
18688N/AIPS_package_name: library/speech/espeak
18688N/AMeta(info.classification): %{classification_prefix}:Applications/Universal Access
13940N/ASummary: eSpeak - compact open source software speech synthesizer
20916N/AVersion: 1.46.0.2
17051N/ALicense: GPL v3
18850N/ASource: %{src_url}/%{src_name}-%{tarball_version}-source.zip
13980N/ASource1: %{name}-manpages-0.1.tar.gz
14072N/A# date:2008-08-15 owner:ww36193 type:bug
13940N/APatch1: espeak-01-makefile.diff
19870N/A# date:2010-12-28 owner:liyuan type:bug
20904N/APatch2: espeak-02-Wall.diff
13940N/ASUNW_BaseDir: %{_basedir}
13940N/ASUNW_Copyright: %{name}.copyright
18850N/ABuildRoot: %{_tmppath}/%{name}-%{tarball_version}-build
15802N/A
13940N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
20885N/A
20901N/ARequires: SUNWgccruntime
20901N/ABuildRequires: SUNWgcc
20885N/ABuildRequires: compress/unzip
20885N/ABuildRequires: system/header
20901N/ABuildRequires: library/audio/pulseaudio
20901N/ABuildRequires: library/gc
20901N/ABuildRequires: library/json-c
20901N/ABuildRequires: library/libsndfile
20901N/A
20901N/ABuildRequires: system/library/c++-runtime
20901N/ABuildRequires: system/library/math
13940N/A
13940N/A%package devel
13940N/ASummary: %{summary} - development files
13940N/ASUNW_BaseDir: %{_basedir}
13940N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
13940N/ARequires: %name
13940N/A
13940N/A%prep
18850N/A%setup -q -n %{src_name}-%{tarball_version}-source
13940N/A%patch1 -p1
17374N/A%patch2 -p1
13980N/Agzcat %SOURCE1 | tar xf -
13940N/A
13940N/A%build
13940N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
13940N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
13940N/A CPUS=1
13940N/Afi
14072N/A%ifarch sparc
14072N/A%define endian_macro "-DBYTE_ORDER=BIG_ENDIAN"
14072N/Acd platforms/big_endian
14072N/Amake -j$CPUS CFLAGS="%{endian_macro}"
19086N/A./espeak-phoneme-data ../../espeak-data ../../espeak-data
14072N/Acd ../..
14072N/A%else
14072N/A%define endian_macro ""
14072N/A%endif
13940N/Acd src
20841N/Amake -j$CPUS EXTRA_LIBS=-lm AUDIO=pulseaudio CXXFLAGS="-norunpath -O2 %{endian_macro}"
20841N/Amake install EXTRA_LIBS=-lm AUDIO=pulseaudio DESTDIR=$RPM_BUILD_ROOT CXXFLAGS="-norunpath -O2 %{endian_macro}"
13940N/Arm $RPM_BUILD_ROOT/%{_libdir}/lib*.a
13940N/A
13980N/A%install
13980N/A#Install manpages
13980N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
18850N/Acd %{_builddir}/%src_name-%tarball_version-source/sun-manpages
13980N/Amake install DESTDIR=$RPM_BUILD_ROOT
13980N/A
13980N/A
13940N/A%clean
13940N/Arm -rf $RPM_BUILD_ROOT
13940N/A
13940N/A%files
13940N/A%defattr (-, root, bin)
13940N/A%dir %attr (0755, root, bin) %{_bindir}
13940N/A%{_bindir}/*
13940N/A%dir %attr (0755, root, bin) %{_libdir}
13940N/A%{_libdir}/lib*.so*
13940N/A%dir %attr (0755, root, sys) %{_datadir}
13940N/A%{_datadir}/*
13940N/A
13940N/A%files devel
13940N/A%defattr (-, root, bin)
13940N/A%{_includedir}
13940N/A
13940N/A%changelog
20904N/A* Fri May 04 2012 - brian.cameron@oracle.com
20904N/A- Bump to 1.46.02.
20841N/A* Tue Oct 04 2011 - brian.cameron@oracle.com
20841N/A- Bump to 1.45.05.
20814N/A* Tue Jul 26 2011 - dave.lin@oracle.com
20814N/A- Added '-norunpath' in CXXFLAGS to fix 6754651.
19901N/A* Thu Dec 30 2010 - brian.cameron@oracle.com
19901N/A- The Version was not the same as tarball_version. Corrected so they are now
19901N/A both 1.44.05.
19086N/A* Tue Nov 09 2010 - lee.yuan@oracle.com
19086N/A- Fix build error on sparc.
19067N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
19067N/A- Bump to 1.44.05.
18850N/A* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
18850N/A- Updated BuildRequires to fit SourceJuicer.
17374N/A* Wed Sep 23 2009 - william.walker@sun.com
17374N/A- Add patch to fix yet another hang - sourceforge:2860912 bugzilla:595336
17374N/A This should be fixed in 1.41.03 when it is released, so the patch can be
17374N/A removed when upreving to 1.41.03.
17104N/A* Tue Aug 28 2009 - william.walker@sun.com
17104N/A- Bump to 1.41.01. This resolves bgo#580389 - Orca hangs
17104N/A when clicking "Ok" or "Apply" button in Orca Preference dialog
17104N/A and doo#10858 - eSpeak_Synchronize hangs Orca
17075N/A* Fri Aug 21 2009 - li.yuan@sun.com
17075N/A- Change owner to liyuan.
17051N/A* Mon Aug 17 2009 - william.walker@sun.com
17051N/A- Add Vendor and License
16904N/A* Tue Jul 28 2009 - christian.kelly@sun.com
16904N/A- Bump to 1.40.02.
16466N/A* Mon May 04 2009 - brian.cameron@sun.com
16466N/A- Bump to 1.40.
15802N/A* Tue Feb 10 2009 - halton.huo@sun.com
15802N/A- Add dependency on SUNWlibC and SUNWlibmsr, CR #6755918
14419N/A* Fri Sep 19 2008 - Willie Walker
14419N/A- Add BuildRequires: SUNWaudh
14091N/A* Mon Sep 02 2008 - Harry Lu
14091N/A- Add bug ID for espeak-02-endian.diff
14072N/A* Fri Aug 29 2008 - Willie Walker
14072N/A- Fix SPARC build endian-ness
13980N/A* Thu Aug 21 2008 - Dermot McCluskey
13980N/A- added manpages and file header
13940N/A* Wed Aug 20 2008 - Willie Walker
13940N/A- Migrate to JDS (SFEespeak.spec to SUNWespeak.spec)
13940N/A* Tue Aug 12 2008 - Willie Walker
13940N/A- Port to SunStudio (thanks Brian Cameron!)
13940N/A* Tue Apr 15 2008 - Willie Walker
13940N/A- Upgrade to version 1.37 which contains direct SADA support and eliminates
13940N/A all PulseAudio and other dependencies.
13940N/A* Tue Jan 29 2008 - Willie Walker
13940N/A- Initial spec
19187N/A
19504N/A