SUNWdia.spec revision 19181
18861N/A#
18861N/A# spec file for package SUNWdia
18861N/A#
18861N/A# includes module(s): dia
18861N/A#
18861N/A# Copyright 2008 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A%define owner jerrytan
18861N/A#
18861N/A%include Solaris.inc
18861N/A%use dia = dia.spec
18861N/A
18861N/AName: SUNWdia
18861N/AIPS_package_name: editor/diagram/dia
18861N/AMeta(info.classification): %{classification_prefix}:Applications/Graphics and Imaging
18861N/ASummary: Dia Diagram Editor
18861N/ASource: %{name}-manpages-0.1.tar.gz
18861N/AVersion: %{dia.version}
18861N/ASUNW_BaseDir: %{_basedir}
19109N/ASUNW_Copyright: %{name}.copyright
18861N/ALicense: %{dia.license}
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/A
18861N/A%include default-depend.inc
18861N/A%include gnome-consolidation.inc
18861N/ARequires: SUNWlibart
18861N/ARequires: SUNWgtk2
18861N/ARequires: SUNWgnome-libs
18861N/ARequires: SUNWgccruntime
18861N/ABuildRequires: SUNWlibgnome-keyring
18861N/ABuildRequires: SUNWgtk2-devel
18861N/ABuildRequires: SUNWgccruntime
18861N/A
18861N/A%if %build_l10n
18861N/A%package l10n
18861N/AIPS_package_name: editor/diagram/dia/l10n
18861N/ASummary: %{summary} - l10n files
18861N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_gnome_il10n_basedir}
18861N/A%include default-depend.inc
18861N/A%include gnome-consolidation.inc
18861N/ARequires: %{name}
18861N/A%endif
18861N/A
18861N/A%prep
18861N/Arm -rf %name-%version
18861N/Amkdir -p %name-%version
18861N/A%dia.prep -d %name-%version
18861N/Acd %{_builddir}/%name-%version
18861N/Agzcat %SOURCE0 | tar xf -
18861N/A
18861N/A%build
18861N/A%dia.build -d %name-%version
18861N/A
18861N/A%install
18861N/A%dia.install -d %name-%version
18861N/A
18861N/Arm -r $RPM_BUILD_ROOT%{_mandir}
18861N/Acd %{_builddir}/%name-%version/sun-manpages
18861N/Amake install DESTDIR=$RPM_BUILD_ROOT
18861N/A
18861N/A%if %build_l10n
18861N/A%else
18861N/A# REMOVE l10n FILES
18861N/A#FIXME: really need to fix this stuff up
18861N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
18861N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/dia/eu
18861N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/dia/[a-d]*
18861N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/dia/[f-z]*
18861N/A%endif
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%dir %attr (-, root, other) %{_datadir}/icons
%dir %attr (-, root, other) %{_datadir}/icons/hicolor
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
%{_datadir}/icons/hicolor/16x16/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
%{_datadir}/icons/hicolor/22x22/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
%{_datadir}/icons/hicolor/24x24/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
%{_datadir}/icons/hicolor/32x32/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
%{_datadir}/icons/hicolor/48x48/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
%{_datadir}/icons/hicolor/scalable/apps/dia.svg
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/dia/C
%{_datadir}/gnome/help/dia/en
%{_datadir}/man/*
%dir %attr (0755, root, other) %{_datadir}/mime-info
%{_datadir}/mime-info/*
%{_datadir}/omf/*
%dir %attr (0755, root, other) %{_datadir}/dia
%{_datadir}/dia/*
%doc -d dia-%{dia.version} AUTHORS README
%doc(bzip2) -d dia-%{dia.version} COPYING ChangeLog NEWS po/ChangeLog
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/dia/*
%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/dia/eu
# Comment this line out since no [a-d]* locale at this point
#%{_datadir}/gnome/help/dia/[a-d]*
%{_datadir}/gnome/help/dia/[f-z]*
%endif
%changelog
* Mon Jan 25 2010 - jerry.tan@sun.com
- bump to 0.97.1
* Wed Oct 22 2008 - matt.keenan@sun.com
- Created