SUNWdbus.spec revision 19099
18861N/A#
18861N/A# spec file for package SUNWdbus
18861N/A#
18861N/A# includes module(s): dbus
18861N/A#
18861N/A# Copyright 2007 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A%define owner yippi
18861N/A#
18861N/A
18861N/A%include Solaris.inc
18861N/A
18861N/A%ifarch amd64 sparcv9
18861N/A%include arch64.inc
18861N/A%define _libexecdir %{_basedir}/lib
18861N/A%use dbus_64 = dbus.spec
18861N/A%endif
18861N/A
18861N/A%include base.inc
18861N/A%use dbus = dbus.spec
18861N/A
18861N/AName: SUNWdbus
18861N/AIPS_package_name: system/library/dbus
18861N/AMeta(info.classification): %{classification_prefix}:System/Services
18862N/ASummary: Simple IPC library based on messages
18861N/AVersion: %{dbus.version}
18861N/ASource: %{name}-manpages-0.1.tar.gz
18861N/ASUNW_BaseDir: %{_basedir}
18861N/ASUNW_Copyright: %{name}.copyright
18861N/ALicense: %{dbus.license}
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ASource1: dbus.xml
18861N/ASource2: svc-dbus
18861N/ASource3: 0070.dbus
18861N/A%include default-depend.inc
18861N/ARequires: SUNWxwrtl
18861N/ARequires: SUNWdbus-libs
18861N/ARequires: SUNWdbus-root
18861N/ARequires: SUNWlxml
18861N/ARequires: SUNWlexpt
18861N/ARequires: SUNWPython26-extra
18993N/ABuildRequires: SUNWlxml
18993N/ABuildRequires: SUNWPython26-extra
18861N/A
18861N/A%package devel
18861N/ASummary: %{summary} - development files
18861N/ASUNW_BaseDir: %{_basedir}
18861N/A%include default-depend.inc
18861N/A
18861N/A%package libs
18861N/AIPS_package_name: system/library/libdbus
18861N/AMeta(info.classification): %{classification_prefix}:System/Libraries
18861N/ASummary: %{summary} - client libraries
18861N/ASUNW_BaseDir: %{_basedir}
18861N/A%include default-depend.inc
18861N/ABuildRequires: SUNWdbus-devel
18861N/A
18861N/A%package root
18993N/ASummary: %{summary} - / filesystem
18993N/ASUNW_BaseDir: /
18993N/A%include default-depend.inc
18993N/A
18861N/A%prep
18861N/Arm -rf %name-%version
18861N/Amkdir %name-%version
18861N/A
18861N/A%ifarch amd64 sparcv9
18861N/Amkdir %name-%version/%_arch64
18861N/A%dbus_64.prep -d %name-%version/%_arch64
18861N/A%endif
18861N/A
18861N/Amkdir %name-%version/%{base_arch}
18861N/A%dbus.prep -d %name-%version/%{base_arch}
18861N/A
18861N/Acd %{_builddir}/%name-%version
18861N/Agzcat %SOURCE0 | tar xf -
18861N/A
18861N/A%build
18861N/A# Put /usr/ccs/lib first in the PATH so that cpp is picked up from there
18861N/A# note: I didn't put /usr/lib in the PATH because there's too much other
18861N/A# stuff in there
18861N/A#
18861N/Aexport PATH=/usr/ccs/lib:$PATH
18861N/A%ifarch amd64 sparcv9
18861N/A%dbus_64.build -d %name-%version/%_arch64
18861N/A%endif
18861N/A
18861N/A%dbus.build -d %name-%version/%{base_arch}
18861N/A
18861N/A%install
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%ifarch amd64 sparcv9
18861N/A%dbus_64.install -d %name-%version/%_arch64
18861N/A%endif
18861N/A
18861N/A%dbus.install -d %name-%version/%{base_arch}
18861N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
18861N/Acd %{_builddir}/%name-%version/sun-manpages
18861N/Amake install DESTDIR=$RPM_BUILD_ROOT
18861N/A
18861N/A%ifarch amd64 sparcv9
18861N/Acd $RPM_BUILD_ROOT%{_bindir}/%{_arch64}
18861N/Arm dbus-launch dbus-monitor dbus-cleanup-sockets dbus-send dbus-uuidgen
18861N/Acd ..
18861N/Armdir %{_arch64}
18861N/A%endif
18861N/A
18861N/A# The /var/run directory should not be included with the packages.
18861N/A# D-Bus will create it at run-time.
18861N/A#
18861N/Armdir $RPM_BUILD_ROOT/var/run/dbus
18861N/Armdir $RPM_BUILD_ROOT/var/run
18861N/A
18861N/A# Add SMF integration files.
18861N/A#
18861N/Amkdir -p $RPM_BUILD_ROOT/var/svc/manifest/system
18861N/Achmod -R 755 $RPM_BUILD_ROOT/var/svc
18861N/Acp %SOURCE1 $RPM_BUILD_ROOT/var/svc/manifest/system/
18861N/Amkdir -p $RPM_BUILD_ROOT/lib/svc/method
18861N/Achmod -R 755 $RPM_BUILD_ROOT/lib
18861N/Acp %SOURCE2 $RPM_BUILD_ROOT/lib/svc/method/
18861N/A
18861N/A# Add in dbus session launching for gdm
18861N/A#
18861N/Ainstall --mode=0755 -d $RPM_BUILD_ROOT/%{_sysconfdir}
18861N/Ainstall --mode=0755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/X11
18861N/Ainstall --mode=0755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/X11/xinit
18861N/Ainstall --mode=0755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/X11/xinit/xinitrc.d
18861N/Ainstall --mode=0755 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/X11/xinit/xinitrc.d/0070.dbus
18861N/A
18861N/Amkdir -p $RPM_BUILD_ROOT/etc/security
18861N/Aecho 'solaris.smf.manage.dbus:::Manage D-BUS Service States::help=SmfDBUSStates.html' > $RPM_BUILD_ROOT/etc/security/auth_attr
18861N/Aecho 'D-BUS Management:::Manage D-BUS:auths=solaris.smf.manage.dbus;help=RtDBUSMngmnt.html' > $RPM_BUILD_ROOT/etc/security/prof_attr
18861N/A
18861N/A%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%if %(test -f /usr/sadm/install/scripts/i.manifest && echo 0 || echo 1)
18861N/A%iclass manifest -f i.manifest
18861N/A%endif
18861N/A
18861N/A%pre root
18861N/A#!/bin/sh
18861N/A#
18861N/A# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
18861N/A# Use is subject to license terms.
18861N/A#
18861N/A
18861N/A# Presence of this temp file will tell postinstall script
18861N/A# that the dbus service is already installed, in which case
18861N/A# the current service state will be preserved, be it enabled
18861N/A# or disabled.
18861N/Arm -f $PKG_INSTALL_ROOT/var/dbus_installed.tmp > /dev/null 2>&1
18861N/A
18861N/Aif [ -f $PKG_INSTALL_ROOT/var/svc/manifest/system/dbus.xml ]; then
18861N/A touch $PKG_INSTALL_ROOT/var/dbus_installed.tmp
18861N/Afi
18861N/A
18861N/Aexit 0
18861N/A
18861N/A%post root
18861N/A#!/bin/sh
18861N/A#
18861N/A# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
18861N/A# Use is subject to license terms.
18861N/A#
18861N/A
18861N/A# Preinstall script will create this file if dbus service was already
18861N/A# installed, in which case we preserve current service state,
18861N/A# be it enabled or disabled.
18861N/Aif [ -f $PKG_INSTALL_ROOT/var/dbus_installed.tmp ]; then
18861N/A rm -f $PKG_INSTALL_ROOT/var/dbus_installed.tmp
18861N/Aelse
18861N/A # enable dbus:
18861N/A # - PKG_INSTALL_ROOT is / or empty when installing onto a live system
18861N/A # and we can invoke svcadm directly;
18861N/A # - otherwise it's upgrade, so we append to the upgrade script
18861N/A if [ "${PKG_INSTALL_ROOT:-/}" = "/" ]; then
18861N/A if [ `/sbin/zonename` = global ]; then
18861N/A /usr/sbin/svcadm enable svc:/system/dbus:default
18861N/A fi
18861N/A else
18861N/A cat >> ${PKG_INSTALL_ROOT}/var/svc/profile/upgrade <<-EOF
18861N/A if [ \`/sbin/zonename\` = global ]; then
18861N/A /usr/sbin/svcadm enable svc:/system/dbus:default
18861N/A fi
18861N/AEOF
18861N/A fi
18861N/Afi
18861N/A
18861N/Aexit 0
18861N/A
18861N/A%files
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755, root, bin) %{_bindir}
18861N/A%{_bindir}/*
18861N/A%{_libexecdir}/dbus-1
18861N/A%{_libexecdir}/dbus-daemon
18861N/A%dir %attr (0755, root, sys) %{_datadir}
18861N/A%{_datadir}/dbus-1
18861N/A%doc -d %{base_arch}/dbus-%{dbus.version} AUTHORS README
18861N/A%doc(bzip2) -d %{base_arch}/dbus-%{dbus.version} ChangeLog ChangeLog.pre-1-0
18861N/A%doc(bzip2) -d %{base_arch}/dbus-%{dbus.version} ChangeLog.pre-1-2
18861N/A%doc(bzip2) -d %{base_arch}/dbus-%{dbus.version} COPYING NEWS
18861N/A%doc(bzip2) -d %{base_arch}/dbus-%{dbus.version} NEWS.pre-1-0 NEWS.pre-1-2
18861N/A%dir %attr (0755, root, other) %{_datadir}/doc
18861N/A%dir %attr(0755, root, bin) %{_mandir}
18861N/A%dir %attr(0755, root, bin) %{_mandir}/man1
18861N/A%dir %attr(0755, root, bin) %{_mandir}/man3
18861N/A%{_mandir}/man1/*
18861N/A%{_mandir}/man3/*
18861N/A
18861N/A%files -n SUNWdbus-libs
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/libdbus*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%{_libdir}/%{_arch64}/libdbus*
%endif
%files root
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_sysconfdir}
%config %{_sysconfdir}/dbus-1
%dir %attr (0755, root, sys) %{_sysconfdir}/X11
%dir %attr (0755, root, sys) %{_sysconfdir}/X11/xinit
%dir %attr (0755, root, sys) %{_sysconfdir}/X11/xinit/xinitrc.d
%{_sysconfdir}/X11/xinit/xinitrc.d/0070.dbus
%dir %attr (0755, root, sys) %{_localstatedir}
%dir %attr (0755, root, other) %{_localstatedir}/lib
%attr (0755, root, root) %{_localstatedir}/lib/dbus
%dir %attr (0755, root, sys) /var/svc
%dir %attr (0755, root, sys) /var/svc/manifest
%dir %attr (0755, root, sys) /var/svc/manifest/system
%class(manifest) %attr (0444, root, sys) /var/svc/manifest/system/dbus.xml
%attr (0555, root, bin) /lib/svc/method/svc-dbus
%dir %attr (0755, root, sys) /etc/security
%config %class (rbac) %attr (0644, root, sys) /etc/security/auth_attr
%config %class (rbac) %attr (0644, root, sys) /etc/security/prof_attr
%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%{_libdir}/dbus*/include
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}/dbus-1.0
%{_libdir}/%{_arch64}/pkgconfig/*.pc
%{_libdir}/%{_arch64}/dbus-1.0/*
%endif
%changelog
* Tue Jun 08 2010 - Michal.Pryc@Oracle.Com
- Updated BuildRequires to fit SourceJuicer.
* Mon Mar 02 2009 - dave.lin@sun.com
- Add man/man3.
* Thu Feb 05 2009 - brian.cameron@sun.com
- Do not package /var/run files. Fixes bug #6799059.
* Wed Feb 04 2009 - takao.fujiwara@sun.com
- Renamed 0005.dbus to 0070.dbus.
* Thu Oct 02 2008 - ghee.teo@sun.com
- Add /etc/X11/xinit/xinitrc.d/0005.dbus to fix 6755007 so that gdm can launch
dbus session for the user. This can be used for both gdm on nevada and
OpenSolaris.
* Sun Sep 14 2008 - brian.cameron@sun.com
- Add new copyright files.
* Tue Sep 02 2008 - brian.cameron@sun.com
- Place the library in a separate package, so that people who just
want to write their own D-Bus services don't need to depend on the
daemon.
* Wed Aug 20 2008 - brian.cameron@sun.com
- Move dbus-daemon.3 manpage to dbus-daemon.1 manpage.
* Thu Mar 27 2008 - brian.cameron@sun.com
- Add SUNW_Copyright.
* Wed Mar 19 2008 - brian.cameron@sun.com
- Remove the symlinks that point from /usr/lib/libdbus-1.so.2 to
/usr/lib/libdbus-1.so.3. Now that ON updated their build machines to use the
new D-Bus library, the symlinks are no longer needed.
* Fri Jan 11 2008 - damien.carbery@sun.com
- Fix amd64/sparcv9 symlink to point to libdbus-1.so.3 (2nd half of Brian's
change on Aug 6. Fixes 6624762.
* Tue Nov 20 2007 - brian.cameron@sun.com
- Add dbus manpages.
* Mon Oct 8 2007 - damien.carbery@sun.com
- Remove %{_libdir}/dbus-1 line from base package as it only contains a header
file and is duplicated in the devel package. Fixes 6613798.
* Mon Oct 1 2007 - laca@sun.com
- change 64-bit libexecdir to /usr/lib
* Mon Oct 1 2007 - damien.carbery@sun.com
- Fix %files, adding %{_libdir}/%{_arch64}/dbus-1.
* Sun Sep 30 2007 - laca@sun.com
- fix %install
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
- delete SUNWxwrtl dep
* Mon Aug 06 2007 - brian.cameron@sun.com
- Fix packaging after bumping to 1.1.2. Also fix the symlink so we
link to libdbus-1.so.3 rather than libdbus-1.so.3.# so we don't have
to update the link each time we upgrade the D-Bus library.
* Sun Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Fri Dec 15 2006 - damien.carbery@sun.com
- Create symlink to support hal which was built with an older version of dbus.
* Mon Nov 27 2006 - brian.cameron@sun.com
- Update to 1.0.1.
* Fri Nov 24 2006 - damien.carbery@sun.com
- Update %files - remove python dir, add %{_localstatedir}/lib/dbus.
* Mon Sep 18 2006 - laca@sun.com
- revert to normal optimisation flags, the build problems were caused by
ld(1) bug 6467925
- change /var/run/dbus permissions to root:root, fixes 6460949
* Mon Aug 28 2006 - damien.carbery@sun.com
- Use '-xO2' optimization (not -xO4) as the latter causes seg faults in build.
* Fri Aug 25 2006 - padraig.obriain@sun.com
- Use c99 compiler
* Fri Jul 28 2006 - laca@sun.com
- add pre and post scripts for enabling the dbus svc upon installation
but leaving it as is upon upgrade (Artem Kachitchkine, David Bustos)
* Fri Jul 21 2006 - laca@sun.com
- Add dbus RBAC entries to auth_attr and prof_attr
* Mon May 08 2006 - damien.carbery@sun.com
- Add Build/Requires dependency on SUNWPython-extra (for Pyrex) so that python
bindings are built.
* Tue May 02 2006 - laca@sun.com
- add SMF support (from Artem Kachitchkine)
* Fri Feb 17 2006 - damien.carbery@sun.com
- Update Build/Requires after running check-deps.pl script.
* Tue Oct 25 2005 - damien.carbery@sun.com
- Add the include dir under _libdir.
* Fri Oct 21 2005 - damien.carbery@sun.com
- Initial spec file created.