SUNWcompiz-fusion-extra.spec revision 18861
10139N/A#
10139N/A# spec file for package SUNWcompiz-fusion-extra.spec
10139N/A#
10139N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner erwannc
10139N/A#
10139N/A
10139N/A%include Solaris.inc
10139N/A
10139N/A%define OSR 8297:1.6.2
10592N/A
10139N/A%define src_name compiz-plugins-extra
10139N/A
10139N/AName: SUNWcompiz-fusion-extra
10139N/AIPS_package_name: desktop/compiz/plugin/compiz-fusion-extra
10595N/AMeta(info.classification): %{classification_prefix}:Applications/Plug-ins and Run-times
10287N/ASummary: extra effects plugins for compiz
10139N/ALicense: GPL v2
10139N/AVendor: compiz-fusion.org
10139N/AVersion: 0.8.4
10139N/ASource: http://releases.compiz.org/%{version}/%{src_name}-%{version}.tar.bz2
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A%endif
10139N/APatch1: compiz-fusion-extra-01-solaris-port.diff
10139N/APatch2: compiz-fusion-extra-02-indiana-branding.diff
10139N/APatch3: compiz-fusion-extra-03-compvector.diff
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Copyright: %{name}.copyright
10139N/A
10139N/A%ifnarch sparc
10139N/A# these packages are only avavilable on x86
10139N/A# =========================================
10139N/A
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A%include default-depend.inc
10139N/ABuildRequires: SUNWcompiz-bcop
10139N/ABuildRequires: SUNWcompiz-devel
10139N/ABuildRequires: SUNWcompiz-fusion-main-devel
10139N/ABuildRequires: SUNWxorg-mesa
10139N/ARequires: SUNWcompiz
10139N/A# the base pkg should depend on the -root subpkg, if there is one:
10139N/ARequires: %{name}-root
10139N/ARequires: SUNWdesktop-cache
10139N/A
10139N/A%package root
10139N/ASummary: %{summary} - / filesystem
10139N/ASUNW_BaseDir: /
10139N/A%include default-depend.inc
10139N/A
10139N/A
10139N/A%package devel
10139N/ASummary: %summary - developer files
10139N/AsUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/ARequires: %name
10139N/A
10139N/A
10139N/A%if %build_l10n
10139N/A%package l10n
10139N/ASummary: %{summary} - l10n files
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/ARequires: %{name}
10139N/A%endif
10139N/A
10139N/A%prep
10139N/A%setup -q -n %{src_name}-%version
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A# Ensure option code is regenerated by bcop XSLT
10139N/Afind . -name '*_options.c' -o -name '*_options.h' -exec rm -f {} \;
10139N/A
10139N/A%build
10139N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aintltoolize --copy --force --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Arm -f ltmain.sh
10139N/Alibtoolize --force
10592N/Aaclocal
10592N/Aautoheader
10592N/Aautomake -a -c -f
10476N/Aautoconf
10476N/A
10476N/Aexport CFLAGS="%optflags"
10287N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10287N/Aexport LDFLAGS="%{_ldflags}"
10287N/Aexport MSGFMT="/usr/bin/msgfmt"
10287N/A
10285N/A./configure --prefix=%{_prefix} \
10285N/A --bindir=%{_bindir} \
10285N/A --sysconfdir=%{_sysconfdir} \
10179N/A --includedir=%{_includedir} \
10179N/A --mandir=%{_mandir} \
10179N/A --libdir=%{_libdir} \
10139N/A --enable-schemas
10139N/A
10139N/Amake -j$CPUS
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/compiz/*.a
10139N/A#
10139N/A# when not building -l10n packages, remove anything l10n related from
10139N/A# $RPM_BUILD_ROOT
10139N/A#
10139N/A%if %build_l10n
10139N/A%else
10139N/A# REMOVE l10n FILES
10139N/Arm -r $RPM_BUILD_ROOT%{_datadir}/locale
10139N/A%endif
10139N/A
10139N/A%post
10139N/A%restart_fmri gconf-cache
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, bin) %{_libdir}/compiz
10139N/A%{_libdir}/compiz/*
10139N/A%dir %attr(0755, root, sys) %{_datadir}
10139N/A%dir %attr(0755, root, other) %{_datadir}/compiz
10139N/A%{_datadir}/compiz/*
10139N/A%doc AUTHORS po/ChangeLog
10139N/A%doc(bzip2) COPYING
10139N/A%dir %attr (0755, root, other) %{_datadir}/doc
10139N/A
10139N/A%files root
10139N/A%defattr (0755, root, sys)
10139N/A%attr (0755, root, sys) %dir %{_sysconfdir}
10139N/A%{_sysconfdir}/*
10139N/A
10139N/A%files devel
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755,root,other) %{_libdir}/pkgconfig
10139N/A%{_libdir}/pkgconfig/*
10139N/A%dir %attr (0755, root, bin) %{_includedir}
10139N/A%{_includedir}/*
10139N/A
10139N/A%if %build_l10n
10139N/A%files l10n
10139N/A%defattr (-, root, other)
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%{_datadir}/locale
10139N/A%endif
10139N/A
10139N/A# endif for "ifnarch sparc"
10139N/A%endif
10139N/A
10139N/A%changelog
10139N/A* Tue Jan 12 2010 - dave.lin@sun.com
10139N/A- Remove OpenGL check, use 'BuildRequires: SUNWxorg-mesa' instread.
10139N/A* Fri Apr 3 2009 - laca@sun.com
10139N/A- use desktop-cache instead of postrun
10139N/A* Wed Apr 01 2009 - dave.lin@sun.com
10139N/A- mandatorily apply patch 03-indiana-branding.diff for both Nv & OS
10139N/A in order to lessen the difference between Nv & OS.
10139N/A* Wed Sep 16 2008 - matt.keenn@sun.com
10139N/A- Update copyright
10139N/A* Mon Apr 07 damien.carbery@sun.com
10139N/A- Break the build if the openGL headers and libraries are not present on the
10139N/A machine.
10139N/A* Wed Mar 26 2008 - dave.lin@sun.com
10139N/A- change to not build this component on SPARC
10139N/A* Thu Mar 20 2008 - takao.fujiwara@sun.com
10139N/A- Add compiz-fusion-extra-02-po.diff for ar, es, hu, ko, pt_BR and ru.
10139N/A* Sun Mar 09 2008 - erwann@sun.com
10139N/A- add standard gconf script
10139N/A* Wed Feb 20 2008 - damien.carbery@sun.com
10139N/A- Fix l10n build.
10139N/A* Wed Feb 13 2008 - erwann@sun.com
10139N/A- moved to SFO
10139N/A* Mon Oct 29 2007 - trisk@acm.jhu.edu
10139N/A- Bump to 0.6.0
10139N/A* Fri Sep 07 2007 - trisk@acm.jhu.edu
10139N/A- Fix rules
10139N/A* Wed Aug 29 2007 - erwann@sun.com
10139N/A- Initial spec
10139N/A