18861N/A#
18861N/A# spec file for package SUNWcompiz-fusion-extra.spec
18861N/A#
18861N/A# Copyright 2009 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A%define owner erwannc
18861N/A#
18861N/A
18861N/A%include Solaris.inc
18861N/A
18861N/A%define OSR 8297:1.6.2
18861N/A
18861N/A%define src_name compiz-plugins-extra
18861N/A
18861N/AName: SUNWcompiz-fusion-extra
18861N/AIPS_package_name: desktop/compiz/plugin/compiz-fusion-extra
18861N/AMeta(info.classification): %{classification_prefix}:Applications/Plug-ins and Run-times
18861N/ASummary: extra effects plugins for compiz
18861N/ALicense: GPL v2
18861N/AVersion: 0.8.4
18861N/ASource: http://releases.compiz.org/%{version}/%{src_name}-%{version}.tar.bz2
18861N/ASource1: l10n-configure.sh
18861N/APatch1: compiz-fusion-extra-01-solaris-port.diff
18861N/APatch2: compiz-fusion-extra-02-indiana-branding.diff
18861N/APatch3: compiz-fusion-extra-03-compvector.diff
18861N/ASUNW_BaseDir: %{_basedir}
18861N/ASUNW_Copyright: %{name}.copyright
20857N/ABuildRequires: consolidation/desktop/gnome-incorporation
18861N/A
18861N/A%ifnarch sparc
18861N/A# these packages are only avavilable on x86
18861N/A# =========================================
18861N/A
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
18861N/ABuildRequires: SUNWcompiz-bcop
18861N/ABuildRequires: SUNWcompiz-devel
18861N/ABuildRequires: SUNWcompiz-fusion-main-devel
18861N/ABuildRequires: SUNWxorg-mesa
18861N/ARequires: SUNWcompiz
18861N/A# the base pkg should depend on the -root subpkg, if there is one:
18861N/ARequires: %{name}-root
18861N/ARequires: SUNWdesktop-cache
18861N/A
18861N/A%package root
18861N/ASummary: %{summary} - / filesystem
18861N/ASUNW_BaseDir: /
18861N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
18861N/A
18861N/A%package devel
18861N/ASummary: %summary - developer files
18861N/AsUNW_BaseDir: %{_basedir}
18861N/A%include default-depend.inc
20857N/A%include desktop-incorporation.inc
18861N/ARequires: %name
18861N/A
18861N/A
18861N/A%package l10n
18861N/ASummary: %{summary} - l10n files
18861N/ARequires: %{name}
18861N/A
18861N/A%prep
18861N/A%setup -q -n %{src_name}-%version
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/A%patch3 -p1
18861N/A# Ensure option code is regenerated by bcop XSLT
18861N/Afind . -name '*_options.c' -o -name '*_options.h' -exec rm -f {} \;
18861N/A
18861N/A%build
18861N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Aintltoolize --copy --force --automake
18861N/A
18861N/Abash -x %SOURCE1 --enable-copyright
18861N/A
18861N/Arm -f ltmain.sh
18861N/Alibtoolize --force
18861N/Aaclocal
18861N/Aautoheader
18861N/Aautomake -a -c -f
18861N/Aautoconf
18861N/A
18861N/Aexport CFLAGS="%optflags"
18861N/Aexport RPM_OPT_FLAGS="$CFLAGS"
18861N/Aexport LDFLAGS="%{_ldflags}"
18861N/Aexport MSGFMT="/usr/bin/msgfmt"
18861N/A
18861N/A./configure --prefix=%{_prefix} \
18861N/A --bindir=%{_bindir} \
18861N/A --sysconfdir=%{_sysconfdir} \
18861N/A --includedir=%{_includedir} \
18861N/A --mandir=%{_mandir} \
18861N/A --libdir=%{_libdir} \
18861N/A --enable-schemas
18861N/A
18861N/Amake -j$CPUS
18861N/A
18861N/A%install
18861N/Amake install DESTDIR=$RPM_BUILD_ROOT
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/compiz/*.a
18861N/A
18861N/A%post
18861N/A%restart_fmri gconf-cache
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%files
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755, root, bin) %{_libdir}
18861N/A%dir %attr (0755, root, bin) %{_libdir}/compiz
18861N/A%{_libdir}/compiz/*
18861N/A%dir %attr(0755, root, sys) %{_datadir}
18861N/A%dir %attr(0755, root, other) %{_datadir}/compiz
18861N/A%{_datadir}/compiz/*
18861N/A%doc AUTHORS po/ChangeLog
18861N/A%doc(bzip2) COPYING
18861N/A%dir %attr (0755, root, other) %{_datadir}/doc
18861N/A
18861N/A%files root
18861N/A%defattr (0755, root, sys)
18861N/A%attr (0755, root, sys) %dir %{_sysconfdir}
18861N/A%{_sysconfdir}/*
18861N/A
18861N/A%files devel
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755,root,other) %{_libdir}/pkgconfig
18861N/A%{_libdir}/pkgconfig/*
18861N/A%dir %attr (0755, root, bin) %{_includedir}
18861N/A%{_includedir}/*
18861N/A
18861N/A%files l10n
18861N/A%defattr (-, root, other)
18861N/A%dir %attr (0755, root, sys) %{_datadir}
18861N/A%{_datadir}/locale
18861N/A
18861N/A# endif for "ifnarch sparc"
18861N/A%endif
18861N/A
18861N/A%changelog
18861N/A* Tue Jan 12 2010 - dave.lin@sun.com
18861N/A- Remove OpenGL check, use 'BuildRequires: SUNWxorg-mesa' instread.
18861N/A* Fri Apr 3 2009 - laca@sun.com
18861N/A- use desktop-cache instead of postrun
18861N/A* Wed Apr 01 2009 - dave.lin@sun.com
18861N/A- mandatorily apply patch 03-indiana-branding.diff for both Nv & OS
18861N/A in order to lessen the difference between Nv & OS.
18861N/A* Wed Sep 16 2008 - matt.keenn@sun.com
18861N/A- Update copyright
18861N/A* Mon Apr 07 damien.carbery@sun.com
18861N/A- Break the build if the openGL headers and libraries are not present on the
18861N/A machine.
18861N/A* Wed Mar 26 2008 - dave.lin@sun.com
18861N/A- change to not build this component on SPARC
18861N/A* Thu Mar 20 2008 - takao.fujiwara@sun.com
18861N/A- Add compiz-fusion-extra-02-po.diff for ar, es, hu, ko, pt_BR and ru.
18861N/A* Sun Mar 09 2008 - erwann@sun.com
18861N/A- add standard gconf script
18861N/A* Wed Feb 20 2008 - damien.carbery@sun.com
18861N/A- Fix l10n build.
18861N/A* Wed Feb 13 2008 - erwann@sun.com
18861N/A- moved to SFO
18861N/A* Mon Oct 29 2007 - trisk@acm.jhu.edu
18861N/A- Bump to 0.6.0
18861N/A* Fri Sep 07 2007 - trisk@acm.jhu.edu
18861N/A- Fix rules
18861N/A* Wed Aug 29 2007 - erwann@sun.com
18861N/A- Initial spec
19165N/A
19482N/A