18861N/A#
18861N/A# spec file for package SUNWcompiz-bcop
18861N/A#
18861N/A# Copyright 2006 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A%define owner erwannc
18861N/A#
18861N/A
18861N/A####################################################################
18861N/A# beryl compiz XML option parser
18861N/A####################################################################
18861N/A
18861N/A%include Solaris.inc
18861N/A
18861N/A%define OSR 8297:1.6.2
18861N/A
18861N/A%define src_name compiz-bcop
18861N/A
18861N/AName: SUNWcompiz-bcop
18861N/ASummary: beryl compiz XML option parser
18861N/ALicense: GPL v2
18861N/AVersion: 0.8.4
18861N/ASource: http://releases.compiz.org/%{version}/%{src_name}-%{version}.tar.bz2
18861N/APatch1: compiz-bcop-01-solaris-port.diff
18861N/ASUNW_BaseDir: %{_basedir}
18861N/ASUNW_Copyright: %{name}.copyright
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ARequires: SUNWgnugetopt
18861N/ARequires: SUNWlxsl
18861N/ARequires: SUNWbash
18861N/ABuildRequires: SUNWgnugetopt
18861N/ABuildRequires: SUNWgnome-common-devel
18861N/ABuildRequires: SUNWlxsl-devel
18861N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
18861N/A
18861N/A%prep
18861N/A%setup -q -n %{src_name}-%version
18861N/A%patch1 -p1
18861N/A
18861N/A%build
18861N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Aaclocal
18861N/Aautoheader
18861N/Aautomake -a -c -f
18861N/Aautoconf
18861N/A
18861N/Aexport CFLAGS="%optflags"
18861N/Aexport RPM_OPT_FLAGS="$CFLAGS"
18861N/Aexport LDFLAGS="%{_ldflags}"
18861N/Aexport MSGFMT="/usr/bin/msgfmt"
18861N/A
18861N/A./configure --prefix=%{_prefix} \
18861N/A --bindir=%{_bindir} \
18861N/A --sysconfdir=%{_sysconfdir} \
18861N/A --includedir=%{_includedir} \
18861N/A --mandir=%{_mandir} \
18861N/A --libdir=%{_libdir} \
18861N/A --with-getopt=/usr/gnu/bin/getopt
18861N/A
18861N/Amake -j$CPUS
18861N/A
18861N/A%install
18861N/Amake install DESTDIR=$RPM_BUILD_ROOT
18861N/A
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%files
18861N/A%defattr (-, root, bin)
18861N/A%dir %attr (0755, root, bin) %{_bindir}
18861N/A%{_bindir}/*
18861N/A%dir %attr (0755, root, bin) %{_libdir}
18861N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
18861N/A%{_libdir}/pkgconfig/*
18861N/A%dir %attr(0755, root, sys) %{_datadir}
19853N/A%{_datadir}/bcop
18861N/A%doc(bzip2) COPYING
18861N/A%dir %attr (0755, root, other) %{_datadir}/doc
18861N/A
18861N/A%changelog
18861N/A* Wed Sep 17 2008 - matt.keenn@sun.com
18861N/A- Update copyright
18861N/A* Wed Jun 18 2008 - damien.carbery@sun.com
18861N/A- Add Requires SUNWbash as /usr/bin/bcop is a bash script.
18861N/A* Tue May 27 2008 - damien.carbery@sun.com
18861N/A- Add BuildRequires SUNWgnome-common-devel and Build/Requires SUNWlxsl/-devel
18861N/A to prevent build error.
18861N/A* Wed Feb 13 2008 - erwann@sun.com
18861N/A- remove SFE deps and added to SFO
18861N/A* Mon Oct 29 2007 - trisk@acm.jhu.edu
18861N/A- Bump to 0.6.0
18861N/A* Sat Sep 08 2007 - trisk@acm.jhu.edu
18861N/A- Change XSLT for plugins
18861N/A* Fri Aug 31 2007 - trisk@acm.jhu.edu
18861N/A- Fix dir attributes
18861N/A* Tue Aug 28 2007 - erwann@sun.com
18861N/A- init spec for the new package format
19164N/A
19481N/A