20841N/A#
20841N/A# spec file for package SUNWcogl
20841N/A#
20841N/A# includes module(s): cogl
20841N/A#
20903N/A# Copyright (c) 2011, 2012, Oracle and/or its affiliates. All rights reserved.
20841N/A# This file and all modifications and additions to the pristine
20841N/A# package are under the same license as the package itself.
20841N/A#
20841N/A%define owner yippi
20841N/A#
20841N/A%include Solaris.inc
20841N/A
20841N/AName: SUNWcogl
20841N/AIPS_package_name: library/cogl
20841N/AMeta(info.classification): %{classification_prefix}:Desktop (GNOME)/Libraries
20841N/ASummary: Drawing library for use with 3D graphics hardware.
22050N/AVersion: 1.10.4
20841N/ALicense: LGPL v2.1
20903N/ASource: http://ftp.gnome.org/pub/GNOME/sources/cogl/1.10/cogl-%{version}.tar.xz
20841N/A# date:2011-10-04 owner:yippi type:bug
20841N/APatch1: cogl-01-makefile.diff
20841N/AUrl: http://www.clutter-project.org/
20841N/ASUNW_BaseDir: %{_basedir}
20841N/ASUNW_Copyright: %{name}.copyright
20841N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20841N/A
20841N/A%include default-depend.inc
20862N/A%include gnome-incorporation.inc
20841N/A
20841N/A%if %{!?_without_gtk_doc:1}%{?_without_gtk_doc:0}
20841N/ABuildRequires: SUNWgnome-common-devel
20841N/ABuildRequires: SUNWgtk-doc
20841N/A%endif
20841N/ARequires: SUNWxorg-mesa
20841N/ARequires: SUNWglib2
20841N/ARequires: SUNWgdk-pixbuf
20841N/ARequires: SUNWcairo
20841N/ARequires: SUNWpango
20841N/ABuildRequires: SUNWgobject-introspection-devel
20841N/ABuildRequires: SUNWglib2-devel
20841N/ABuildRequires: SUNWgdk-pixbuf-devel
20841N/ABuildRequires: SUNWcairo-devel
20841N/ABuildRequires: SUNWpango-devel
20841N/ABuildRequires: SUNWuiu8
20841N/ABuildRequires: SUNWxwinc
20841N/ABuildRequires: SUNWxorg-headers
20841N/ABuildRequires: SUNWxorg-mesa
20841N/A
20841N/A%package devel
20841N/ASummary: %{summary} - development files
20841N/ASUNW_BaseDir: %{_basedir}
20841N/A%include default-depend.inc
20862N/A%include gnome-incorporation.inc
20841N/ARequires: %name
20841N/ARequires: SUNWglib2
20841N/A
20841N/A%package l10n
20841N/ASummary: %{summary} - l10n files
20841N/ARequires: %{name}
20841N/A
20841N/A%prep
20841N/A%setup -q -n cogl-%version
20841N/A%patch1 -p1
20841N/A
20841N/A%build
20841N/A
20841N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20841N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20841N/A CPUS=1
20841N/Afi
20841N/A
20903N/A# This is needed for the gobject-introspection compile to find libdrm.
20903N/Aexport LD_LIBRARY_PATH=/usr/lib/xorg
20903N/A
20841N/Aexport CFLAGS="%optflags"
20841N/Aexport LDFLAGS="%{_ldflags}"
20841N/A
20862N/A# This is needed for the gobject-introspection compile to find libdrm and
20862N/A# libplds4.
20862N/Aexport LD_LIBRARY_PATH="/usr/lib/xorg:/usr/lib/mps"
20841N/A
20903N/Aaclocal-1.11 $ACLOCAL_FLAGS -I ./build/autotools
20903N/Aautoheader
20903N/Aautomake-1.11 -a -c -f
20903N/Aautoconf
20841N/A./configure --prefix=%{_prefix} \
20841N/A --bindir=%{_bindir} \
20841N/A --libdir=%{_libdir} \
20841N/A --includedir=%{_includedir} \
20841N/A --mandir=%{_mandir} \
20841N/A %{gtk_doc_option} \
20841N/A --disable-static
20841N/A
20841N/Agmake -j $CPUS
20841N/A
20841N/A%install
20841N/Arm -rf $RPM_BUILD_ROOT
20841N/Agmake install DESTDIR=$RPM_BUILD_ROOT
20841N/Arm -f $RPM_BUILD_ROOT%{_libdir}/lib*.*a
20841N/A
20903N/A# Remove empty directory.
20903N/Armdir $RPM_BUILD_ROOT%{_bindir}
20903N/A
20841N/A%if %{!?_without_gtk_doc:0}%{?_without_gtk_doc:1}
20841N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
20841N/A%endif
20841N/A
20841N/A%if %build_l10n
20841N/A%else
20841N/A# REMOVE l10n FILES
20841N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
20841N/A%endif
20841N/A
20841N/A%clean
20841N/Arm -rf $RPM_BUILD_ROOT
20841N/A
20841N/A%files
20841N/A%defattr (-, root, bin)
20841N/A%doc COPYING ChangeLog NEWS README
20841N/A%dir %attr (0755, root, bin) %{_libdir}
20841N/A%{_libdir}/lib*.so*
20841N/A%{_libdir}/girepository-1.0
20841N/A%dir %attr (0755, root, sys) %{_datadir}
20903N/A%{_datadir}/cogl
20841N/A%{_datadir}/gir-1.0
20841N/A%dir %attr (0755, root, other) %{_docdir}
20841N/A
20841N/A%files devel
20841N/A%defattr (-, root, bin)
20841N/A%dir %attr (0755, root, bin) %dir %{_includedir}
20841N/A%{_includedir}/*
20841N/A%dir %attr (0755, root, other) %{_libdir}/pkgconfig
20841N/A%{_libdir}/pkgconfig/*
20841N/A%if %{!?_without_gtk_doc:1}%{?_without_gtk_doc:0}
20841N/A%dir %attr (0755, root, sys) %{_datadir}
20841N/A%{_datadir}/gtk-doc
20841N/A%endif
20841N/A
20841N/A%if %build_l10n
20841N/A%files l10n
20841N/A%defattr (-, root, bin)
20841N/A%dir %attr (0755, root, sys) %{_datadir}
20841N/A%attr (-, root, other) %{_datadir}/locale
20841N/A%endif
20841N/A
20841N/A%changelog
22050N/A* Sat Sep 15 2012 - Brian Cameron <brian.cameron@oracle.com>
22050N/A- Bump to 1.10.4.
20903N/A* Wed May 02 2012 - Brian Cameron <brian.cameron@oracle.com>
20903N/A- Bump to 1.10.2.
20862N/A* Wed Oct 19 2011 - Brian Cameron <brian.cameron@oracle.com>
20862N/A- Bump to 1.8.2.
20841N/A* Tue Oct 04 2011 - Brian Cameron <brian.cameron@oracle.com>
20841N/A- Initial spec file with version 1.8.0.