SUNWccsm.spec revision 19126
17090N/A#
17090N/A# spec file for package SUNWccsm
17090N/A####################################################################
17090N/A# compizconfig-settings-manager(ccsm): A fully featured Python/GTK
17090N/A# based settings manager for the CompizConfig system.
17090N/A####################################################################
17090N/A#
17185N/A# Copyright 2009 Sun Microsystems, Inc.
17090N/A# This file and all modifications and additions to the pristine
17090N/A# package are under the same license as the package itself.
17090N/A#
17090N/A%define owner erwannc
17090N/A
17090N/A%include Solaris.inc
17090N/A
17090N/A%define OSR 8297:1.6.2
17090N/A
17090N/A%define src_name ccsm
17090N/A
17090N/AName: SUNWccsm
17090N/AIPS_package_name: desktop/compiz/ccsm
17162N/AMeta(info.classification): %{classification_prefix}:Applications/Graphics and Imaging
17090N/ASummary: ccsm settings manager for the CompizConfig system
17162N/ALicense: GPL v2
17162N/AVendor: compiz-fusion.org
17162N/AVersion: 0.8.2
17171N/ASource: http://releases.compiz-fusion.org/%{version}/%{src_name}-%{version}.tar.bz2
17162N/A# owner:jedy date:2008-08-11 type:branding
17175N/APatch1: ccsm-01-desktop.diff
17175N/ASUNW_BaseDir: %{_basedir}
17090N/ASUNW_Copyright: %{name}.copyright
17090N/A
17090N/A%ifnarch sparc
17090N/A# these packages are only avavilable on x86
17090N/A# =========================================
17090N/A
17090N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17090N/A%include default-depend.inc
17090N/A# add build and runtime dependencies here:
17090N/ABuildRequires: SUNWgnome-python26-libs-devel
17090N/ABuildRequires: SUNWPython26
17090N/ABuildRequires: SUNWpython26-setuptools
17090N/ABuildRequires: SUNWcompizconfig-python
17090N/ABuildRequires: SUNWlibsexy
17090N/ARequires: SUNWdbus-python26
17090N/ARequires: SUNWgnome-python26-libs
17090N/ARequires: SUNWPython26
17090N/ARequires: SUNWcompizconfig-python
17090N/ARequires: SUNWlibsexy
17090N/ARequires: SUNWdesktop-cache
17090N/A%include default-depend.inc
17090N/A
17090N/A%define pythonver 2.6
17090N/A
17090N/A%if %build_l10n
17090N/A%package l10n
17090N/AIPS_package_name: desktop/compiz/ccsm/l10n
17090N/ASummary: %{summary} - l10n files
17090N/ASUNW_BaseDir(relocate_from:%{_prefix}): %{_dto_il10n_basedir}
17090N/A%include default-depend.inc
17090N/ARequires: %{name}
17090N/A%endif
17090N/A
17090N/A%prep
17162N/A%setup -q -n %{src_name}-%version
17175N/A%patch1 -p1
17090N/A
17090N/A%build
17090N/Apython%{pythonver} setup.py build --prefix=%{_prefix}
17090N/A
17090N/A%install
17090N/Arm -rf $RPM_BUILD_ROOT
17090N/Apython%{pythonver} setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT
17090N/A
17090N/A# move to vendor-packages
17090N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
17090N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
17090N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
17090N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages
17090N/A
17175N/A#
17090N/A# when not building -l10n packages, remove anything l10n related from
17090N/A# $RPM_BUILD_ROOT
17090N/A#
17090N/A%if %build_l10n
17090N/A%else
17090N/A# REMOVE l10n FILES
17090N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
17175N/A%endif
17175N/A
17175N/A%post
17175N/A%restart_fmri desktop-mime-cache mime-types-cache
17175N/A
17090N/A%postun
17090N/A%restart_fmri desktop-mime-cache mime-types-cache
17175N/A
17090N/A%clean
17090N/Arm -rf $RPM_BUILD_ROOT
17090N/A
17090N/A%files
17090N/A%defattr (-, root, bin)
17090N/A%dir %attr (0755, root, bin) %{_bindir}
17090N/A%{_bindir}/*
17090N/A%dir %attr (0755, root, bin) %{_libdir}
17090N/A%{_libdir}/python%{pythonver}/vendor-packages
17090N/A%dir %attr(0755, root, sys) %{_datadir}
17090N/A%dir %attr (0755, root, other) %{_datadir}/ccsm
17090N/A%{_datadir}/ccsm/*
17090N/A%dir %attr (0755, root, other) %{_datadir}/applications
17090N/A%{_datadir}/applications/ccsm.desktop
17090N/A%attr (0755, root, other) %{_datadir}/icons
17090N/A#
17090N/A# The files included here should match the ones removed in %install
17090N/A#
17090N/A%if %build_l10n
17090N/A%files l10n
17090N/A%defattr (-, root, other)
17090N/A%dir %attr (0755, root, sys) %{_datadir}
17090N/A%{_datadir}/locale/*
17090N/A%endif
17090N/A
17090N/A# endif for "ifnarch sparc"
17090N/A%endif
17090N/A
17090N/A%changelog
17090N/A* Thu Aug 13 2009 - christian.kelly@sun.com
17090N/A- Bump to 0.8.2.
17090N/A* Fri Apr 3 2009 - laca@sun.com
17090N/A- use desktop-cache instead of postrun
17090N/A* Mon Aug 11 2008 - jedy.wang@sun.com
17090N/A- Add 02-desktop.diff to hide the menu enty form the menu because it has
17090N/A been integrated into gnome-appearance-properties.
17090N/A* Tue Jun 01 2008 - damien.carbery@sun.com
17090N/A- Fix perms in %files.
17090N/A* Wed Mar 26 2008 - dave.lin@sun.com
17090N/A- change to not build this component on SPARC
17090N/A* Fri Feb 22 2008 - takao.fujiwara@sun.com
17090N/A- Add ccsm-01-po.diff to add cs.po, es.po, hu.po, ja.po, ko.po from HEAD.
17090N/A* Wed Feb 13 2008 - erwann@sun.com
17090N/A- Moved to SFO
17090N/A* Wed Nov 14 2007 - daymobrew@users.sourceforge.net
17175N/A- Add l10n package.
17175N/A* Mon Oct 29 2007 - trisk@acm.jhu.edu
17162N/A- Bump to 0.6.0
17162N/A* Sat Sep 08 2007 - trisk@acm.jhu.edu
17090N/A- Correct rules, remove -root, fix Python library location
17090N/A* Fri Aug 14 2007 - erwann@sun.com
- Initial spec